Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xdm crash at boot
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
botsyndicate1
n00b
n00b


Joined: 30 May 2015
Posts: 3

PostPosted: Sat May 30, 2015 2:34 pm    Post subject: xdm crash at boot Reply with quote

So, I'm really new to this. I know you're probably all like, "Well, beat it, kid, this is a man's os!" However, I think I'm close to a gui (though I really don't know what I'm doing lol, i just followed a youtube tutorial). xdm keeps crashing at boot. I login via bash and interact with the os via bash. Not running in a vm. I've emerged x11-base/xorg-x11 and x11-base/xorg-drivers, and xdm has been set as a default runlevel programme. However, i didnt really complete the xorg merging until after i set xdm as a default. Help? 8O
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13867

PostPosted: Sat May 30, 2015 3:10 pm    Post subject: Reply with quote

If you ignore xdm, log in as a normal user on a text console, and start the X server, does it work? If yes, then the problem is specific to XDM and we can debug that (or abandon it and rely on text logins). If no, then you have a fundamental problem with getting the X server going, and xdm might work once the X server is fixed. Either way, please post the output of emerge --info --verbose x11-base/xorg-x11 x11-base/xorg-drivers, your video card, and your Xorg log file (usually at /var/log/Xorg.0.log).
Back to top
View user's profile Send private message
botsyndicate1
n00b
n00b


Joined: 30 May 2015
Posts: 3

PostPosted: Sat May 30, 2015 4:41 pm    Post subject: Reply with quote

Hu wrote:
If you ignore xdm, log in as a normal user on a text console, and start the X server, does it work? If yes, then the problem is specific to XDM and we can debug that (or abandon it and rely on text logins). If no, then you have a fundamental problem with getting the X server going, and xdm might work once the X server is fixed. Either way, please post the output of emerge --info --verbose x11-base/xorg-x11 x11-base/xorg-drivers, your video card, and your Xorg log file (usually at /var/log/Xorg.0.log).



how would i launch the x server?
currently plugged into my 3770k via dvi, so intel hd 4000 gpu, but i have a gtx660 that i think is dead (why i am not using it--no output)
here is the log--

here are the warnings and errors in the order they appear (ommitting (II), (==), (--), (**)):
(WW) Warning, couldn't open module intel
(EE) Failed to load module "intel" (module does not exist, 0)
(WW) Warning, couldn't open module modesetting
(EE) Failed to load module "modesetting" (module does not exist, 0)
(WW) Warning, couldn't open module fbdev
(EE) Failed to load module "fbdev" (module does not exist, 0)
(WW) Warning, couldn't open module vesa
(EE) Failed to load module "vesa" (module does not exist, 0)
(EE) No drivers available.
(EE) Fatal server error:
(EE) no screens found(EE)
(EE)
thats it. i tried to keep it as authentic as possible. yes, thats a blank ee




ALSO
heres the output for the emerge --info bit:
imgur.com/0EeJGmZ
Back to top
View user's profile Send private message
Hieronymus Bosch
Tux's lil' helper
Tux's lil' helper


Joined: 29 Jan 2015
Posts: 75
Location: 31°45′33.14″N 106°29′24.63″W

PostPosted: Sat May 30, 2015 6:55 pm    Post subject: Reply with quote

Try updating videocard drivers and type this in /etc/portage/make.conf

VIDEOS_CARDS="intel vesa vga radeon"
_________________
Details fueled any investigation ...
Back to top
View user's profile Send private message
botsyndicate1
n00b
n00b


Joined: 30 May 2015
Posts: 3

PostPosted: Sat May 30, 2015 10:34 pm    Post subject: Reply with quote

Hu wrote:
If you ignore xdm, log in as a normal user on a text console, and start the X server, does it work? If yes, then the problem is specific to XDM and we can debug that (or abandon it and rely on text logins). If no, then you have a fundamental problem with getting the X server going, and xdm might work once the X server is fixed. Either way, please post the output of emerge --info --verbose x11-base/xorg-x11 x11-base/xorg-drivers, your video card, and your Xorg log file (usually at /var/log/Xorg.0.log).


well, i tried logging in as a user to startx

it failed. what do?
Back to top
View user's profile Send private message
e3k
Guru
Guru


Joined: 01 Oct 2007
Posts: 363
Location: Inner Space

PostPosted: Wed Jul 08, 2015 8:51 pm    Post subject: Reply with quote

botsyndicate1 wrote:
Hu wrote:
If you ignore xdm, log in as a normal user on a text console, and start the X server, does it work? If yes, then the problem is specific to XDM and we can debug that (or abandon it and rely on text logins). If no, then you have a fundamental problem with getting the X server going, and xdm might work once the X server is fixed. Either way, please post the output of emerge --info --verbose x11-base/xorg-x11 x11-base/xorg-drivers, your video card, and your Xorg log file (usually at /var/log/Xorg.0.log).


well, i tried logging in as a user to startx

it failed. what do?


in xorg.conf you probably asked for intel (or not. some systems work now without /etc/X11/xorg.conf) but the module was not found. you have to install the intel module to make it work:
do what Hieronymus Bosch told you about /etc/portage/make.conf and run: emerge --ask --changed-use --deep @world

or read this guide and try it yourself: https://wiki.gentoo.org/wiki/Intel provided that you really have an intel graphics card.
_________________
((O.o))
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Thu Jul 09, 2015 4:35 am    Post subject: Reply with quote

boot to the command line, run
Code:
emerge wgetpaste
wgetpaste -t /var/log/Xorg.0.log
wgetpaste -t /usr/src/linux/.config
lspci -k | wgetpaste -t
emerge -pv xorg-server $(qlist -IC x11-drivers) | wgetpaste -t
post the url's returned
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum