Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] systemd-udevd crash at boot after world update
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
arom
n00b
n00b


Joined: 27 Aug 2011
Posts: 9
Location: Italy

PostPosted: Tue Jun 02, 2015 2:14 am    Post subject: [SOLVED] systemd-udevd crash at boot after world update Reply with quote

hi all,
i'm having a very weird issue with my laptop after the last world update. At boot, when systemd tries to mount non-root partitions (/home and /usr/portage which is reiserfs), it hangs for 90sec and then drops me to emergency console. journalctl shows these error messages:

Code:

May 31 19:14:21 ultra kernel: traps: systemd-udevd[163] trap invalid opcode ip:7f782f19d93a sp:7fff1cc67a38 error:0
May 31 19:14:21 ultra kernel: traps: systemd-udevd[150] trap invalid opcode ip:7f782f19d93a sp:7fff1cc67a38 error:0 in libpthread-2.20.so[7f782f192000+16000]
May 31 19:14:21 ultra kernel: traps: systemd-udevd[151] trap invalid opcode ip:7f782f19d93a sp:7fff1cc67a38 error:0 in libpthread-2.20.so[7f782f192000+16000]
May 31 19:14:21 ultra kernel:  in libpthread-2.20.so[7f782f192000+16000]
May 31 19:14:21 ultra kernel: traps: systemd-udevd[149] trap invalid opcode ip:7f782f19d93a sp:7fff1cc69b98 error:0 in libpthread-2.20.so[7f782f192000+16000]
May 31 19:14:21 ultra systemd[1]: Unit systemd-udevd.service entered failed state.
May 31 19:14:21 ultra systemd[1]: systemd-udevd.service failed.


and:

Code:

May 31 19:15:46 ultra systemd[1]: Job dev-sda7.device/start timed out.
May 31 19:15:46 ultra systemd[1]: Timed out waiting for device dev-sda7.device.
-- Subject: Unit dev-sda7.device has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit dev-sda7.device has failed.
--
-- The result is timeout.
May 31 19:15:46 ultra systemd[1]: Dependency failed for /home.
-- Subject: Unit home.mount has failed


On the console, if i try to mount -a or mount individual partitions, i get no errors but the mountpoints remain empty. If i then try to unmount them, i get "not mounted". Now, if i do:

Code:

# mkdir /home2
# mount /dev/sda7 /home2


it works just fine and i can access my data under /home2 !
This way i managed to access portage again; i made /usr/portage a symlink to /usr/portage2 and used that as mountpoint. Then i've re-emerged both glibc and systemd, but no luck. I have also tried emerging with different CFLAGS (-march=core2 -mno-rtm -mno-hle), but nothing changes.
I was already using gcc-4.8.4 as recommended in the news.

What's wrong? please help :_(


Here's the output of emerge --info :

Code:

Portage 2.2.18 (python 3.3.5-final-0, default/linux/amd64/13.0/desktop/gnome/systemd, gcc-4.8.4, glibc-2.20-r2, 3.18.11-gentoo x86_64)
=================================================================
System uname: Linux-3.18.11-gentoo-x86_64-Intel-R-_Core-TM-_i7-4600U_CPU_@_2.10GHz-with-gentoo-2.2
KiB Mem:     7821576 total,   6921416 free
KiB Swap:   16777212 total,  16777212 free
Timestamp of repository gentoo: Thu, 28 May 2015 19:15:01 +0000
sh bash 4.3_p33-r2
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.3_p33-r2::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.9-r1::gentoo, 3.3.5-r1::gentoo, 3.4.1::gentoo
dev-util/cmake:           2.8.12.2-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.13.11::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.13.4::gentoo, 1.14.1::gentoo
sys-devel/binutils:       2.24-r3::gentoo
sys-devel/gcc:            4.8.4::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 3.18::gentoo (virtual/os-headers)
sys-libs/glibc:           2.20-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.at.gentoo.org/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -mno-rtm -mno-hle"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -mno-rtm -mno-hle"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask-write --keep-going"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://gentoo.imj.fr/pub/gentoo/ rsync://mirror.leaseweb.com/gentoo/ ftp://tux.rainside.sk/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo http://tux.rainside.sk/gentoo/"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli colord cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gdbm gif glamor gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv introspection ipv6 jack jpeg ladspa lame lcms ldap libnotify libsecret mad mmx mmxext mng modules mp3 mp4 mpeg multilib nautilus ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pulseaudio qt3support readline sdl session sound spell sse sse2 ssl ssse3 startup-notification svg systemd tcpd tiff tracker truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.3"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

_________________
arom


Last edited by arom on Tue Jun 02, 2015 4:19 pm; edited 1 time in total
Back to top
View user's profile Send private message
arom
n00b
n00b


Joined: 27 Aug 2011
Posts: 9
Location: Italy

PostPosted: Tue Jun 02, 2015 3:09 pm    Post subject: Reply with quote

I managed to make my system boot again. The problem was caused by the latest Intel microcode. The world update i did last friday brought in =sys-apps/microcode-data-20150121 which has been marked as stable.

This microcode update fixes a bug on some Haswell CPUs, by basically disabling some processor features, that are needed by libpthread:

http://www.odi.ch/weblog/posting.php?posting=690

Unfortunately, the solution proposed by the above blogpost (using gcc-4.8.4) did not work for me. I had already switched to 4.8.4 before my world update, as this was requested by the glibc ebuild.
I also tried to force -mno-rtm -mno-hle in my CFLAGS and reemerge glibc, but nothing changed (maybe the glibc build overrides those flags?).

Finally, i added =sys-apps/microcode-data-20150121 to package.mask, reverted back to 20140430, and suddenly my machine got back to life. I think i'll stick to my buggy old (but booting) cpu for some more... :-)

Anyway, i think microcode-data shouldn't be marked as stable, or at least there should be some warning in the news or the emerge notes. I'll try to file a bug about this.

Edit: nevermind, there's already an open bug: https://bugs.gentoo.org/show_bug.cgi?id=528712
Unfortunately it was very hard to find if you don't specifically search for a microcode issue :_(
_________________
arom
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum