Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Incorrect dependency on dev-libs/libgcrypt ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
hurvajs77
n00b
n00b


Joined: 05 Apr 2010
Posts: 56

PostPosted: Fri Jun 05, 2015 9:27 pm    Post subject: Incorrect dependency on dev-libs/libgcrypt ? Reply with quote

Hi all,
I've a problem with new Gentoo installation. Core system from minimal CD installed sucessfully, but now when try rebuild all system, got this:
Code:
zeryk etc # cave resolve installed-packages
I encountered the following errors:

!   dev-libs/libgcrypt
    Reasons: target (installed-packages::installed), app-crypt/gnupg-2.1.4:0::gentoo, dev-libs/libxslt-1.1.28-r4:0::installed, 3 more
    Unsuitable candidates:
      * dev-libs/libgcrypt-1.4.4:0::layman (in ::embedded-cross)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet >=dev-libs/libgcrypt-1.5.3:0/11=, use existing if possible, installing to / from restarted because of dev-libs/libxslt-1.1.28-r4:0::installed
        Did not meet >=dev-libs/libgcrypt-1.5.3:0/11=[abi_x86_64(-)], use existing if possible, installing to / from dev-libs/libxslt-1.1.28-r4:0::installed
        Did not meet >=dev-libs/libgcrypt-1.5.3:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?], use existing if possible, installing to / from net-print/cups-2.0.2-r1:0::gentoo
        Did not meet >=dev-libs/libgcrypt-1.6.2, use existing if possible, installing to / from app-crypt/gnupg-2.1.4:0::gentoo
      * dev-libs/libgcrypt-1.4.5:0::layman (in ::embedded-cross)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet >=dev-libs/libgcrypt-1.5.3:0/11=, use existing if possible, installing to / from restarted because of dev-libs/libxslt-1.1.28-r4:0::installed
        Did not meet >=dev-libs/libgcrypt-1.5.3:0/11=[abi_x86_64(-)], use existing if possible, installing to / from dev-libs/libxslt-1.1.28-r4:0::installed
        Did not meet >=dev-libs/libgcrypt-1.5.3:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?], use existing if possible, installing to / from net-print/cups-2.0.2-r1:0::gentoo
        Did not meet >=dev-libs/libgcrypt-1.6.2, use existing if possible, installing to / from app-crypt/gnupg-2.1.4:0::gentoo
      * dev-libs/libgcrypt-1.5.4:0::gentoo
        Did not meet >=dev-libs/libgcrypt-1.6.2, use existing if possible, installing to / from app-crypt/gnupg-2.1.4:0::gentoo
      * dev-libs/libgcrypt-1.5.4-r1:0::gentoo
        Did not meet >=dev-libs/libgcrypt-1.6.2, use existing if possible, installing to / from app-crypt/gnupg-2.1.4:0::gentoo
      * dev-libs/libgcrypt-1.6.1-r2:0::gentoo
        Did not meet >=dev-libs/libgcrypt-1.5.3:0/11=, use existing if possible, installing to / from restarted because of dev-libs/libxslt-1.1.28-r4:0::installed
        Did not meet >=dev-libs/libgcrypt-1.5.3:0/11=[abi_x86_64(-)], use existing if possible, installing to / from dev-libs/libxslt-1.1.28-r4:0::installed
        Did not meet >=dev-libs/libgcrypt-1.6.2, use existing if possible, installing to / from app-crypt/gnupg-2.1.4:0::gentoo
      * dev-libs/libgcrypt-1.6.2:0::gentoo
        Did not meet >=dev-libs/libgcrypt-1.5.3:0/11=, use existing if possible, installing to / from restarted because of dev-libs/libxslt-1.1.28-r4:0::installed
        Did not meet >=dev-libs/libgcrypt-1.5.3:0/11=[abi_x86_64(-)], use existing if possible, installing to / from dev-libs/libxslt-1.1.28-r4:0::installed
      * dev-libs/libgcrypt-1.6.3:0::gentoo
        Did not meet >=dev-libs/libgcrypt-1.5.3:0/11=, use existing if possible, installing to / from restarted because of dev-libs/libxslt-1.1.28-r4:0::installed
        Did not meet >=dev-libs/libgcrypt-1.5.3:0/11=[abi_x86_64(-)], use existing if possible, installing to / from dev-libs/libxslt-1.1.28-r4:0::installed
      * dev-libs/libgcrypt-9999:0::layman (in ::mva)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet >=dev-libs/libgcrypt-1.5.3:0/11=, use existing if possible, installing to / from restarted because of dev-libs/libxslt-1.1.28-r4:0::installed
        Did not meet >=dev-libs/libgcrypt-1.5.3:0/11=[abi_x86_64(-)], use existing if possible, installing to / from dev-libs/libxslt-1.1.28-r4:0::installed
        Did not meet >=dev-libs/libgcrypt-1.5.3:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?], use existing if possible, installing to / from net-print/cups-2.0.2-r1:0::gentoo
            Flag 'abi_x86_64' enabled if it is enabled for 'net-print/cups-2.0.2-r1:0::gentoo', assuming disabled if missing
      * dev-libs/libgcrypt-9999:0::layman (in ::emery)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet >=dev-libs/libgcrypt-1.5.3:0/11=[abi_x86_64(-)], use existing if possible, installing to / from dev-libs/libxslt-1.1.28-r4:0::installed
            Flag 'abi_x86_64' enabled, assuming disabled if missing
        Did not meet >=dev-libs/libgcrypt-1.5.3:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?], use existing if possible, installing to / from net-print/cups-2.0.2-r1:0::gentoo
            Flag 'abi_x86_64' enabled if it is enabled for 'net-print/cups-2.0.2-r1:0::gentoo', assuming disabled if missing
      * dev-libs/libgcrypt-9999:0::layman (in ::k_f)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet >=dev-libs/libgcrypt-1.5.3:0/11=, use existing if possible, installing to / from restarted because of dev-libs/libxslt-1.1.28-r4:0::installed
        Did not meet >=dev-libs/libgcrypt-1.5.3:0/11=[abi_x86_64(-)], use existing if possible, installing to / from dev-libs/libxslt-1.1.28-r4:0::installed
        Did not meet >=dev-libs/libgcrypt-1.5.3:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?], use existing if possible, installing to / from net-print/cups-2.0.2-r1:0::gentoo
            Flag 'abi_x86_64' enabled if it is enabled for 'net-print/cups-2.0.2-r1:0::gentoo', assuming disabled if missing

I cannot proceed without being permitted to do the following:

-n  dev-libs/nettle:0::gentoo (not the best version) 2.7.1-r4 to ::installed
    "Low-level cryptographic library"
    -doc gmp (-neon) -static-libs (-test) ABI_X86: -32 (64) (-x32) build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: net-libs/gnutls-3.3.15:0::gentoo
    Cannot proceed without: --permit-old-version

and my use.conf
Code:
*/* -gnome -qt3support -kipi -ldap X a52 aac acl acpi alsa berkdb bindist bluetooth branding bzip2 cairo cdr consolekit cracklib crypt dbus dri dts dvd dvdr encode exif fam flac gif gtk iconv ipv6 jpeg kde lcms libnotify mmx mmxext modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl pam pcre pdf phonon plasma png policykit qt4 readline sdl session spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xcomposite xinerama xml xscreensaver xv xvid zlib
*/* ALSA_CARDS: -* hda-intel
*/* CPU_FLAGS_X86: -* aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3
*/* GRUB_PLATFORMS: -* efi-64 pc
*/* INPUT_DEVICES: -* evdev
*/* LINGUAS: -* en
*/* VIDEO_CARDS: -* nvidia

dev-qt/* qt3support

net-misc/iputils -caps -filecaps

sys-apps/paludis search-index
sys-boot/grub -device-mapper efiemu
media-libs/phonon designer
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1428

PostPosted: Fri Jun 05, 2015 9:47 pm    Post subject: Reply with quote

What happens when you try this with the emerge command?

Code:
eselect package-manager set portage
emerge --sync
emerge -uDavN world

_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
hurvajs77
n00b
n00b


Joined: 05 Apr 2010
Posts: 56

PostPosted: Sun Jun 07, 2015 10:53 am    Post subject: Reply with quote

there isn't any error. I set up USE flags as on paludis and emerge can be executed.

I use long time paludis / cave, but I see that emerge is more better now, so I try use it again. Thanks for help :-)

Please, is some handbook for new emerge and setting up USE flags? I remember that global USE flags was in make.conf, local flags was in package.use. Now I see that package.use is folder with files.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum