Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GRUB2 is not loading after reboot
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
ptrkk
n00b
n00b


Joined: 11 Jun 2015
Posts: 2

PostPosted: Thu Jun 11, 2015 8:17 am    Post subject: GRUB2 is not loading after reboot Reply with quote

Hello,

I have installed Gentoo on my laptop, and installed grub according to instructions in the handbook. However, after first reboot grub menu did not appear and Windows 8 started as usual. Could you pleas direct me where could be the problem and how can I fix it?

Thanks in advance :)
Back to top
View user's profile Send private message
jbvideo
n00b
n00b


Joined: 29 Mar 2015
Posts: 31
Location: uk

PostPosted: Thu Jun 11, 2015 4:08 pm    Post subject: Re: GRUB2 is not loading after reboot Reply with quote

ptrkk wrote:
Hello,

I have installed Gentoo on my laptop, and installed grub according to instructions in the handbook. However, after first reboot grub menu did not appear and Windows 8 started as usual. Could you pleas direct me where could be the problem and how can I fix it?

Thanks in advance :)

Hi
Have a look / read in the link below, to see if it helps.
https://forums.gentoo.org/viewtopic-t-1017576.html
jb
Back to top
View user's profile Send private message
Barracuz
n00b
n00b


Joined: 17 Mar 2015
Posts: 17
Location: R.I., United States

PostPosted: Fri Jun 12, 2015 11:11 am    Post subject: Reply with quote

I'm pretty sure you did this but did you setup your bios/uefi to boot gentoo instead of windows?

Post the output of ls /boot
Back to top
View user's profile Send private message
ptrkk
n00b
n00b


Joined: 11 Jun 2015
Posts: 2

PostPosted: Fri Jun 12, 2015 11:22 am    Post subject: Reply with quote

@Barracuz,

I have UEFI in my laptop. Ho to set up UEFI boot to boot gentoo?


@jbvideo

I will post is as soon as I can :)
Back to top
View user's profile Send private message
Barracuz
n00b
n00b


Joined: 17 Mar 2015
Posts: 17
Location: R.I., United States

PostPosted: Tue Jun 16, 2015 12:39 pm    Post subject: Reply with quote

ptrkk wrote:
@Barracuz,

I have UEFI in my laptop. Ho to set up UEFI boot to boot gentoo?


@jbvideo

I will post is as soon as I can :)


Youll have to play with the boot options on the bios/uefi. For example disable the csm/legacy boot options and disable secure boot.
Back to top
View user's profile Send private message
MarioCorleone
Guru
Guru


Joined: 29 Jun 2003
Posts: 327

PostPosted: Tue Jun 16, 2015 12:45 pm    Post subject: Reply with quote

Yeah, I would switch from UEFI to legacy. In order to do so, you have to diable secureboot
_________________
-Mario
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum