Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
razer mouse and keyboard conflicting (Terminal, not X yet)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
JumboAg
Tux's lil' helper
Tux's lil' helper


Joined: 03 Mar 2007
Posts: 89
Location: Dallas, TX

PostPosted: Tue Jun 16, 2015 4:58 pm    Post subject: razer mouse and keyboard conflicting (Terminal, not X yet) Reply with quote

Independent of X-windows, I am having conflicts between my razer blackwidow keyboard and razer naga mouse. If I plug the mouse in, they keyboard goes nuts and then stops working altogether requiring a reboot. They system is NOT hanging, as I can still SSH into it. There appears to be a conflict between the mouse and keyboard. Already tried the scheduler thing. Tried disabling USB 3.0 altogether. No luck either way. Want to get it fixed before hopping into an X environment. Will revisit it in the xorg-conf afterwards if need be.



Here's what happens when I plug the mouse in.
Code:
[   62.412318] usb 1-1.3: new full-speed USB device number 5 using ehci-pci
[   62.500394] usb 1-1.3: New USB device found, idVendor=1532, idProduct=001f
[   62.500398] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[   62.500401] usb 1-1.3: Product: Razer Naga Epic
[   62.500403] usb 1-1.3: Manufacturer: Razer
[   62.501500] input: Razer Razer Naga Epic as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.3/1-1.3:1.0/0003:1532:001F.0007/input/input10
[   62.501609] hid-generic 0003:1532:001F.0007: input,hidraw6: USB HID v1.11 Mouse [Razer Razer Naga Epic] on usb-0000:00:1a.0-1.3/input0
[   62.502391] input: Razer Razer Naga Epic as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.3/1-1.3:1.1/0003:1532:001F.0008/input/input11
[   62.502476] hid-generic 0003:1532:001F.0008: input,hidraw7: USB HID v1.11 Keyboard [Razer Razer Naga Epic] on usb-0000:00:1a.0-1.3/input1
[   62.879530] usb 1-1.3: reset full-speed USB device number 5 using ehci-pci
[   63.147316] usbhid 1-1.3:1.0: can't add hid device: -32
[   63.147324] usbhid: probe of 1-1.3:1.0 failed with error -32
[   63.185666] usb 1-1.1: reset full-speed USB device number 3 using ehci-pci
[   63.269704] usb 1-1.1: device descriptor read/64, error -32
[   63.845916] usb 1-1.1: device not accepting address 3, error -32
[   63.919000] usb 1-1.1: reset full-speed USB device number 3 using ehci-pci
[   64.396183] usb 1-1.1: device not accepting address 3, error -32
[   64.469255] usb 1-1.1: reset full-speed USB device number 3 using ehci-pci
[   64.871395] usb 1-1.1: device not accepting address 3, error -32
[   64.944477] usb 1-1.1: reset full-speed USB device number 3 using ehci-pci
[   64.962240] usb 1-1.1: device firmware changed
[   64.962491] usb 1-1.1: USB disconnect, device number 3
[   65.031500] usb 1-1.3: reset full-speed USB device number 5 using ehci-pci
[   65.106555] usb 1-1.3: device descriptor read/64, error -32
[   65.283759] usb 1-1.3: device descriptor read/64, error -32
[   65.457861] usb 1-1.3: reset full-speed USB device number 5 using ehci-pci
[   65.933890] usb 1-1.3: device not accepting address 5, error -32
[   66.007111] usb 1-1.3: reset full-speed USB device number 5 using ehci-pci
[   66.409112] usb 1-1.3: device not accepting address 5, error -32
[   66.482327] usb 1-1.3: reset full-speed USB device number 5 using ehci-pci
[   66.696275] usb 1-1.3: device descriptor read/8, error -32
[   66.811329] usb 1-1.3: device descriptor read/8, error -32
[   66.988546] usb 1-1.1: new full-speed USB device number 6 using ehci-pci
[   67.454593] usb 1-1.1: device not accepting address 6, error -32
[   67.527783] usb 1-1.1: new full-speed USB device number 7 using ehci-pci
[   67.619301] usb 1-1.1: unable to read config index 0 descriptor/start: -32
[   67.619304] usb 1-1.1: chopping to 0 config(s)
[   67.621671] usb 1-1.1: string descriptor 0 read error: -32
[   67.621673] usb 1-1.1: New USB device found, idVendor=1532, idProduct=011a
[   67.621674] usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[   67.621753] usb 1-1.1: no configuration chosen from 0 choices
[   67.621925] usb 1-1.3: USB disconnect, device number 5
[   67.694862] usb 1-1.3: new full-speed USB device number 8 using ehci-pci
[   68.169925] usb 1-1.3: device not accepting address 8, error -32
[   68.243106] usb 1-1.3: new full-speed USB device number 9 using ehci-pci
[   68.329165] usb 1-1.3: device descriptor read/all, error -32
[   68.403179] usb 1-1.3: new full-speed USB device number 10 using ehci-pci
[   68.416061] usb 1-1.3: device descriptor read/8, error -32
[   68.529112] usb 1-1.3: device descriptor read/8, error -32
[   68.703324] usb 1-1.3: new full-speed USB device number 11 using ehci-pci
[   69.105355] usb 1-1.3: device not accepting address 11, error -32
[   69.105499] usb 1-1-port3: unable to enumerate USB device


Code:

[x@y:/usr/src/linux] $ grep -i USB .config
# CONFIG_USB_SWITCH_FSA9480 is not set
# CONFIG_USB_NET_DRIVERS is not set
# CONFIG_MOUSE_SYNAPTICS_USB is not set
# CONFIG_TABLET_USB_ACECAD is not set
# CONFIG_TABLET_USB_AIPTEK is not set
# CONFIG_TABLET_USB_GTCO is not set
# CONFIG_TABLET_USB_HANWANG is not set
# CONFIG_TABLET_USB_KBTAB is not set
# CONFIG_TOUCHSCREEN_USB_COMPOSITE is not set
# CONFIG_I2C_TINY_USB is not set
# USB-based Watchdog Cards
# CONFIG_USBPCWATCHDOG is not set
# CONFIG_MFD_RTSX_USB is not set
CONFIG_SND_USB=y
# CONFIG_SND_USB_AUDIO is not set
# CONFIG_SND_USB_UA101 is not set
# CONFIG_SND_USB_USX2Y is not set
# CONFIG_SND_USB_CAIAQ is not set
# CONFIG_SND_USB_US122L is not set
# CONFIG_SND_USB_6FIRE is not set
# CONFIG_SND_USB_HIFACE is not set
# USB HID support
CONFIG_USB_HID=y
CONFIG_USB_HIDDEV=y
CONFIG_USB_OHCI_LITTLE_ENDIAN=y
CONFIG_USB_SUPPORT=y
CONFIG_USB_COMMON=y
CONFIG_USB_ARCH_HAS_HCD=y
CONFIG_USB=y
CONFIG_USB_ANNOUNCE_NEW_DEVICES=y
# Miscellaneous USB options
CONFIG_USB_DEFAULT_PERSIST=y
# CONFIG_USB_DYNAMIC_MINORS is not set
# CONFIG_USB_OTG_WHITELIST is not set
# CONFIG_USB_OTG_FSM is not set
CONFIG_USB_MON=y
# CONFIG_USB_WUSB_CBAF is not set
# USB Host Controller Drivers
# CONFIG_USB_C67X00_HCD is not set
# CONFIG_USB_XHCI_HCD is not set
CONFIG_USB_EHCI_HCD=y
CONFIG_USB_EHCI_ROOT_HUB_TT=y
CONFIG_USB_EHCI_TT_NEWSCHED=y
CONFIG_USB_EHCI_PCI=y
# CONFIG_USB_EHCI_HCD_PLATFORM is not set
# CONFIG_USB_OXU210HP_HCD is not set
# CONFIG_USB_ISP116X_HCD is not set
# CONFIG_USB_ISP1760_HCD is not set
# CONFIG_USB_ISP1362_HCD is not set
# CONFIG_USB_FUSBH200_HCD is not set
# CONFIG_USB_FOTG210_HCD is not set
# CONFIG_USB_OHCI_HCD is not set
# CONFIG_USB_UHCI_HCD is not set
# CONFIG_USB_SL811_HCD is not set
# CONFIG_USB_R8A66597_HCD is not set
# CONFIG_USB_HCD_TEST_MODE is not set
# USB Device Class drivers
# CONFIG_USB_ACM is not set
CONFIG_USB_PRINTER=y
# CONFIG_USB_WDM is not set
# CONFIG_USB_TMC is not set
# NOTE: USB_STORAGE depends on SCSI but BLK_DEV_SD may
# also be needed; see USB_STORAGE Help for more info
CONFIG_USB_STORAGE=y
# CONFIG_USB_STORAGE_DEBUG is not set
# CONFIG_USB_STORAGE_REALTEK is not set
# CONFIG_USB_STORAGE_DATAFAB is not set
# CONFIG_USB_STORAGE_FREECOM is not set
# CONFIG_USB_STORAGE_ISD200 is not set
# CONFIG_USB_STORAGE_USBAT is not set
# CONFIG_USB_STORAGE_SDDR09 is not set
# CONFIG_USB_STORAGE_SDDR55 is not set
# CONFIG_USB_STORAGE_JUMPSHOT is not set
# CONFIG_USB_STORAGE_ALAUDA is not set
# CONFIG_USB_STORAGE_ONETOUCH is not set
# CONFIG_USB_STORAGE_KARMA is not set
# CONFIG_USB_STORAGE_CYPRESS_ATACB is not set
# CONFIG_USB_STORAGE_ENE_UB6250 is not set
# CONFIG_USB_UAS is not set
# USB Imaging devices
# CONFIG_USB_MDC800 is not set
# CONFIG_USB_MICROTEK is not set
# CONFIG_USBIP_CORE is not set
# CONFIG_USB_MUSB_HDRC is not set
# CONFIG_USB_DWC3 is not set
# CONFIG_USB_DWC2 is not set
# CONFIG_USB_CHIPIDEA is not set
# USB port drivers
# CONFIG_USB_SERIAL is not set
# USB Miscellaneous drivers
# CONFIG_USB_EMI62 is not set
# CONFIG_USB_EMI26 is not set
# CONFIG_USB_ADUTUX is not set
# CONFIG_USB_SEVSEG is not set
# CONFIG_USB_RIO500 is not set
# CONFIG_USB_LEGOTOWER is not set
# CONFIG_USB_LCD is not set
# CONFIG_USB_LED is not set
# CONFIG_USB_CYPRESS_CY7C63 is not set
# CONFIG_USB_CYTHERM is not set
# CONFIG_USB_IDMOUSE is not set
# CONFIG_USB_FTDI_ELAN is not set
# CONFIG_USB_APPLEDISPLAY is not set
# CONFIG_USB_SISUSBVGA is not set
# CONFIG_USB_LD is not set
# CONFIG_USB_TRANCEVIBRATOR is not set
# CONFIG_USB_IOWARRIOR is not set
# CONFIG_USB_TEST is not set
# CONFIG_USB_EHSET_TEST_FIXTURE is not set
# CONFIG_USB_ISIGHTFW is not set
# CONFIG_USB_YUREX is not set
# CONFIG_USB_EZUSB_FX2 is not set
# CONFIG_USB_HSIC_USB3503 is not set
# CONFIG_USB_LINK_LAYER_TEST is not set
# USB Physical Layer drivers
# CONFIG_USB_PHY is not set
# CONFIG_NOP_USB_XCEIV is not set
# CONFIG_USB_ISP1301 is not set
# CONFIG_USB_GADGET is not set
# CONFIG_USB_LED_TRIG is not set
# LED driver for blink(1) USB RGB LED is under Special HID drivers (HID_THINGM)
# CONFIG_BCM_KONA_USB2_PHY is not set
$
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 802

PostPosted: Tue Jun 16, 2015 5:11 pm    Post subject: Reply with quote

got the same stuff before Roccats, but never had problems with them
Back to top
View user's profile Send private message
JumboAg
Tux's lil' helper
Tux's lil' helper


Joined: 03 Mar 2007
Posts: 89
Location: Dallas, TX

PostPosted: Tue Jun 16, 2015 5:14 pm    Post subject: Reply with quote

I use the same machine for MMO's, not willing to give up the mechanical keyboard and bazillion button mouse. I actually did get this working once, at least in X-windows. Did reinstall recently and cant recall how I did it, nor can I get pre-X terminal level support up and running.
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 802

PostPosted: Tue Jun 16, 2015 5:50 pm    Post subject: Reply with quote

I moved to Roccat as it has native Linux support. Blackwidow is now in parent's PC. Naga is my work-trip mouse.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum