Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201503-11 ] OpenSSL
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2189

PostPosted: Wed Jun 17, 2015 4:26 pm    Post subject: [ GLSA 201503-11 ] OpenSSL Reply with quote

Gentoo Linux Security Advisory

Title: OpenSSL: Multiple vulnerabilities (GLSA 201503-11)
Severity: normal
Exploitable: remote
Date: March 19, 2015
Updated: June 06, 2015
Bug(s): #543552
ID: 201503-11

Synopsis

Multiple vulnerabilities have been found in OpenSSL that can result
in either Denial of Service or information disclosure.


Background

OpenSSL is an Open Source toolkit implementing the Secure Sockets Layer
(SSL v2/v3) and Transport Layer Security (TLS v1) as well as a general
purpose cryptography library.


Affected Packages

Package: dev-libs/openssl
Vulnerable: < 1.0.1l-r1
Unaffected: >= 1.0.1l-r1
Unaffected: >= 0.9.8z_p5 < 0.9.9
Unaffected: >= 0.9.8z_p6 < 0.9.9
Unaffected: >= 0.9.8z_p7 < 0.9.9
Unaffected: >= 0.9.8z_p8 < 0.9.9
Unaffected: >= 0.9.8z_p9 < 0.9.9
Unaffected: >= 0.9.8z_p10 < 0.9.9
Unaffected: >= 0.9.8z_p11 < 0.9.9
Unaffected: >= 0.9.8z_p12 < 0.9.9
Unaffected: >= 0.9.8z_p13 < 0.9.9
Unaffected: >= 0.9.8z_p14 < 0.9.9
Unaffected: >= 0.9.8z_p15 < 0.9.9
Architectures: All supported architectures


Description

Multiple vulnerabilities have been found in OpenSSL. Please review the
CVE identifiers and the upstream advisory referenced below for details:
  • RSA silently downgrades to EXPORT_RSA [Client] (Reclassified)
    (CVE-2015-0204)
  • Segmentation fault in ASN1_TYPE_cmp (CVE-2015-0286)
  • ASN.1 structure reuse memory corruption (CVE-2015-0287)
  • X509_to_X509_REQ NULL pointer deref (CVE-2015-0288)
  • PKCS7 NULL pointer dereferences (CVE-2015-0289)
  • Base64 decode (CVE-2015-0292)
  • DoS via reachable assert in SSLv2 servers (CVE-2015-0293)
  • Use After Free following d2i_ECPrivatekey error (CVE-2015-0209)
The following issues affect OpenSSL 1.0.2 only which is not part of the
supported Gentoo stable tree:
  • OpenSSL 1.0.2 ClientHello sigalgs DoS (CVE-2015-0291)
  • Multiblock corrupted pointer (CVE-2015-0290)
  • Segmentation fault in DTLSv1_listen (CVE-2015-0207)
  • Segmentation fault for invalid PSS parameters (CVE-2015-0208)
  • Empty CKE with client auth and DHE (CVE-2015-1787)
  • Handshake with unseeded PRNG (CVE-2015-0285)


Impact

A remote attacker can utilize multiple vectors to cause Denial of
Service or Information Disclosure.


Workaround

There is no known workaround at this time.

Resolution

All OpenSSL 1.0.1 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-libs/openssl-1.0.1l-r1"
   
All OpenSSL 0.9.8 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-libs/openssl-0.9.8z_p5-r1"
   
Packages which depend on the OpenSSL library need to be restarted for
the upgrade to take effect. Some packages may need to be recompiled.
Tools such as revdep-rebuild may assist in identifying some of these
packages.


References

CVE-2015-0204
CVE-2015-0207
CVE-2015-0208
CVE-2015-0209
CVE-2015-0285
CVE-2015-0287
CVE-2015-0288
CVE-2015-0289
CVE-2015-0290
CVE-2015-0291
CVE-2015-0292
CVE-2015-0293
CVE-2015-1787
OpenSSL Security
Advisory [19 Mar 2015]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum