Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Brightness adjustment not working kernel after kern
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
AndrewAmmerlaan
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jun 2014
Posts: 143
Location: Lent

PostPosted: Wed Jun 17, 2015 5:10 pm    Post subject: [SOLVED] Brightness adjustment not working kernel after kern Reply with quote

I just upgrade gentoo-sources from 3.18.12 to 4.0.5, after reboot I noticed that I can no longer adjust the brightness of my laptop-screen. The brightness keys (fn+f2, fn+f3) are no longer working, nor can I adjust brightness by clicking on the battery icon in the KDE taskbar, the slider just shows 0% and I can slide it but the shown value remaind 0% (while actual brightness is 100%). I am convinced this is due to the kernel upgrade, because I was able to adjust brightness before the reboot, nothing else changed. I used "make oldconfig" to update the config file. Kernel config is here: https://bpaste.net/show/116ba08e100a
_________________
OS: Gentoo KDE x86_64 (~amd64, 4.20.7-gentoo)
MB: MSI Z370-A PRO
CPU: Intel Core i7-8700K
GPU: NVIDIA GTX 1060 6GB & Intel UHD Graphics 630
SSD: Samsung 970 Pro 512GB
RAM: Crucial Ballistix 32GB DDR4-2400


Last edited by AndrewAmmerlaan on Sun Apr 10, 2016 2:40 pm; edited 1 time in total
Back to top
View user's profile Send private message
AndrewAmmerlaan
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jun 2014
Posts: 143
Location: Lent

PostPosted: Thu Jun 18, 2015 1:56 pm    Post subject: Reply with quote

I checked the files in /sys/class/backlight/radeon_bl0, output is shown below:
Code:
andrew@Andrew-Gentoo ~ $ ls /sys/class/backlight/radeon_bl0
actual_brightness  bl_power  brightness  device  max_brightness  power  subsystem  type  uevent
andrew@Andrew-Gentoo ~ $ cat /sys/class/backlight/radeon_bl0/actual_brightness
255
andrew@Andrew-Gentoo ~ $ cat /sys/class/backlight/radeon_bl0/bl_power
0
andrew@Andrew-Gentoo ~ $ cat /sys/class/backlight/radeon_bl0/brightness
255
andrew@Andrew-Gentoo ~ $ cat /sys/class/backlight/radeon_bl0/max_brightness
255
andrew@Andrew-Gentoo ~ $

I suspect 255 is the max brightness, which is also the current brightness, KDE however shows 0%, could it be that this is a bug KDE has with the new kernel version?
Any ideas how I might fix this?

EDIT: I edited the brightness file and this did change the brightness
EDIT2: the owner of the file 'brightness' and the other files is root, that can't be right, can it?
_________________
OS: Gentoo KDE x86_64 (~amd64, 4.20.7-gentoo)
MB: MSI Z370-A PRO
CPU: Intel Core i7-8700K
GPU: NVIDIA GTX 1060 6GB & Intel UHD Graphics 630
SSD: Samsung 970 Pro 512GB
RAM: Crucial Ballistix 32GB DDR4-2400
Back to top
View user's profile Send private message
AndrewAmmerlaan
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jun 2014
Posts: 143
Location: Lent

PostPosted: Mon Jun 22, 2015 2:49 pm    Post subject: Reply with quote

Still no replies, that usually means one of two things, either I asked a too simple question, or a very difficult one. I'm still unable to adjust brightness, and it is really annoying, I've ran out of ideas, so any suggestions would be very appreciated.
_________________
OS: Gentoo KDE x86_64 (~amd64, 4.20.7-gentoo)
MB: MSI Z370-A PRO
CPU: Intel Core i7-8700K
GPU: NVIDIA GTX 1060 6GB & Intel UHD Graphics 630
SSD: Samsung 970 Pro 512GB
RAM: Crucial Ballistix 32GB DDR4-2400


Last edited by AndrewAmmerlaan on Tue Jun 23, 2015 5:13 am; edited 1 time in total
Back to top
View user's profile Send private message
MarioCorleone
Guru
Guru


Joined: 29 Jun 2003
Posts: 327

PostPosted: Mon Jun 22, 2015 9:24 pm    Post subject: Reply with quote

Ive been in the same boat as you, so I too await a response
_________________
-Mario
Back to top
View user's profile Send private message
vasettoo
Tux's lil' helper
Tux's lil' helper


Joined: 11 Nov 2012
Posts: 77

PostPosted: Tue Jun 23, 2015 9:58 am    Post subject: Reply with quote

My Dell Latitude e5530 faced the same problem, but I managed to correct this by clean rebuild of the new stable kernel - removed any entries related to 4.0.5 kernel in /boot folder, cleaned the /usr/src/linux for 4.0.5 stuff, also cleared /lib/modules/ for the aforementioned kernel, after this I used genkernel with old config of 3.18.12 kernel, nothing changed in options, just rebuild with the new settings, rebuilded modules, reboot. Voilá! Everything works with backlight buttons. Steps to reproduce:
Code:
# rm -vi /boot/*4.0.5-gentoo
rm -frv /usr/src/linux-4.0.5-gentoo
rm -frv /lib/modules/4.0.5-gentoo
eselect kernel set linux-4.0.5-gentoo
genkernel --menuconfig --kernel-config=/etc/kernels/kernel-config-x86_64-3.18.12-gentoo all
emerge @module-rebuild
emerge @x11-module-rebuild
systemctl reboot

I just had to rename the generated kernel in /boot to bzImage as I'm using dual boot with M$ Windows and rEFInd needs it this way.
Good luck and hope it helps someone else!
Back to top
View user's profile Send private message
AndrewAmmerlaan
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jun 2014
Posts: 143
Location: Lent

PostPosted: Tue Jun 23, 2015 3:32 pm    Post subject: Reply with quote

I tried this:
Code:
root #cp .config /usr/src/kernel_config_bk
root #make distclean
root #mv /usr/src/kernel_config_bk .config

Which didn't work, I thought that would do the same thing but apparently not. I'll try your suggestion next, but I'm not using genkernel so I would have to change some commands.
_________________
OS: Gentoo KDE x86_64 (~amd64, 4.20.7-gentoo)
MB: MSI Z370-A PRO
CPU: Intel Core i7-8700K
GPU: NVIDIA GTX 1060 6GB & Intel UHD Graphics 630
SSD: Samsung 970 Pro 512GB
RAM: Crucial Ballistix 32GB DDR4-2400
Back to top
View user's profile Send private message
AndrewAmmerlaan
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jun 2014
Posts: 143
Location: Lent

PostPosted: Sat Jun 27, 2015 3:14 pm    Post subject: Reply with quote

vasettoo wrote:
My Dell Latitude e5530 faced the same problem, but I managed to correct this by clean rebuild of the new stable kernel - removed any entries related to 4.0.5 kernel in /boot folder, cleaned the /usr/src/linux for 4.0.5 stuff, also cleared /lib/modules/ for the aforementioned kernel, after this I used genkernel with old config of 3.18.12 kernel, nothing changed in options, just rebuild with the new settings, rebuilded modules, reboot. Voilá! Everything works with backlight buttons. Steps to reproduce:
Code:
# rm -vi /boot/*4.0.5-gentoo
rm -frv /usr/src/linux-4.0.5-gentoo
rm -frv /lib/modules/4.0.5-gentoo
eselect kernel set linux-4.0.5-gentoo
genkernel --menuconfig --kernel-config=/etc/kernels/kernel-config-x86_64-3.18.12-gentoo all
emerge @module-rebuild
emerge @x11-module-rebuild
systemctl reboot

I just had to rename the generated kernel in /boot to bzImage as I'm using dual boot with M$ Windows and rEFInd needs it this way.
Good luck and hope it helps someone else!

So the only difference is the config of 3.18.12, so there is something new in the 4.0.5 config that is causing this problem. I no longer have the old config, but I took al look at the new config and I can't find anything (obvious) that might cause the backlight to stop working.
_________________
OS: Gentoo KDE x86_64 (~amd64, 4.20.7-gentoo)
MB: MSI Z370-A PRO
CPU: Intel Core i7-8700K
GPU: NVIDIA GTX 1060 6GB & Intel UHD Graphics 630
SSD: Samsung 970 Pro 512GB
RAM: Crucial Ballistix 32GB DDR4-2400
Back to top
View user's profile Send private message
FroL_Onn
n00b
n00b


Joined: 20 Oct 2013
Posts: 55

PostPosted: Fri Aug 14, 2015 9:07 am    Post subject: Reply with quote

AndrewAmmerlaan wrote:

So the only difference is the config of 3.18.12, so there is something new in the 4.0.5 config that is causing this problem. I no longer have the old config, but I took al look at the new config and I can't find anything (obvious) that might cause the backlight to stop working.


Hello there!
Did you achieved any positive result?

I experience the same problem and don't know what to do!

Could this be some kind of security policy/KDE problem?
Back to top
View user's profile Send private message
AndrewAmmerlaan
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jun 2014
Posts: 143
Location: Lent

PostPosted: Fri Aug 14, 2015 5:19 pm    Post subject: Reply with quote

FroL_Onn wrote:
AndrewAmmerlaan wrote:

So the only difference is the config of 3.18.12, so there is something new in the 4.0.5 config that is causing this problem. I no longer have the old config, but I took al look at the new config and I can't find anything (obvious) that might cause the backlight to stop working.


Hello there!
Did you achieved any positive result?

I experience the same problem and don't know what to do!

Could this be some kind of security policy/KDE problem?


No sadly not, I have given up actually. I don't do that usually but this has beaten me :(
Unless I or someone else suddenly comes up with a brilliant solution, I just have to live without brightness adjustment, which isn't that bad once you get used to it.

I no longer think this is a KDE problem because I am also unable to adjust brightness with xrandr or xbacklight, so if it isn't the kernel it is maybe X or something, but I really don't know. :(
_________________
OS: Gentoo KDE x86_64 (~amd64, 4.20.7-gentoo)
MB: MSI Z370-A PRO
CPU: Intel Core i7-8700K
GPU: NVIDIA GTX 1060 6GB & Intel UHD Graphics 630
SSD: Samsung 970 Pro 512GB
RAM: Crucial Ballistix 32GB DDR4-2400
Back to top
View user's profile Send private message
FroL_Onn
n00b
n00b


Joined: 20 Oct 2013
Posts: 55

PostPosted: Fri Aug 14, 2015 5:39 pm    Post subject: Reply with quote

AndrewAmmerlaan wrote:
I no longer think this is a KDE problem because I am also unable to adjust brightness with xrandr or xbacklight, so if it isn't the kernel it is maybe X or something, but I really don't know. :(


I also don't think it is KDE problem as my fn+f2 and fn+f3 are not recognized by the system!
xev does not see them
and dmesg after pressing them give:
Code:
[ 4291.032234] atkbd serio0: Use 'setkeycodes e012 <keycode>' to make it known.
[ 4291.153672] atkbd serio0: Unknown key released (translated set 2, code 0x92 on isa0060/serio0).
[ 4291.153682] atkbd serio0: Use 'setkeycodes e012 <keycode>' to make it known.
[ 4291.302911] atkbd serio0: Unknown key pressed (translated set 2, code 0x97 on isa0060/serio0).
[ 4291.302921] atkbd serio0: Use 'setkeycodes e017 <keycode>' to make it known.
[ 4291.444176] atkbd serio0: Unknown key released (translated set 2, code 0x97 on isa0060/serio0).
[ 4291.444180] atkbd serio0: Use 'setkeycodes e017 <keycode>' to make it known.

Sadly I don't remember, when it started (not long ago).

But I still can use tray powerdevil icon (click it -> and use slider).
Besides,
Code:
xbacklight -set 70
works for me!

So do we have different problems, what do you think?

Help needed!)
Should we file a bug?
Back to top
View user's profile Send private message
AndrewAmmerlaan
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jun 2014
Posts: 143
Location: Lent

PostPosted: Fri Aug 14, 2015 5:46 pm    Post subject: Reply with quote

FroL_Onn wrote:
AndrewAmmerlaan wrote:
I no longer think this is a KDE problem because I am also unable to adjust brightness with xrandr or xbacklight, so if it isn't the kernel it is maybe X or something, but I really don't know. :(

I also don't think it is KDE problem as my fn+f2 and fn+f3 are not recognized by the system!
Sadly I don't remember, when it started (not long ago).

But I still can use tray powerdevil icon (click it -> and use slider).
Besides,
Code:
xbacklight -set 70
works for me!

So do we have different problems, what do you think?


I don't think fn f3 and fn f2 are supposed to be recognized by the kernel, I thought these were X or DE shortcuts, but I may be wrong, I also don't think are problems are related at all, since I can't adjust brightness at all (unless if I edit that file I mentioned earlier, but I think that's actually on the device itself or something like that) I think that on my system the kernel can't adjust the brightness and therefore X and KDE show it as impossible, I think this may be because the kernel tries to adjust the wrong file or it is actually disabled (though it was working before, and I didn't disable anything, weird :? ).
_________________
OS: Gentoo KDE x86_64 (~amd64, 4.20.7-gentoo)
MB: MSI Z370-A PRO
CPU: Intel Core i7-8700K
GPU: NVIDIA GTX 1060 6GB & Intel UHD Graphics 630
SSD: Samsung 970 Pro 512GB
RAM: Crucial Ballistix 32GB DDR4-2400
Back to top
View user's profile Send private message
FroL_Onn
n00b
n00b


Joined: 20 Oct 2013
Posts: 55

PostPosted: Fri Aug 14, 2015 6:45 pm    Post subject: Reply with quote

AndrewAmmerlaan wrote:

I don't think fn f3 and fn f2 are supposed to be recognized by the kernel, I thought these were X or DE shortcuts, but I may be wrong, I also don't think are problems are related at all

Well, I should say, fn+f8 (which is volumeDown in my case) is recognized by xev.
Ok, I will open new topic then!
Please write here if you find a solution or it heals itself, ok?
Back to top
View user's profile Send private message
AndrewAmmerlaan
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jun 2014
Posts: 143
Location: Lent

PostPosted: Sun Apr 10, 2016 2:39 pm    Post subject: Reply with quote

I finally fixed this (accidentally :D ), the solution is here: https://forums.gentoo.org/viewtopic-p-7904712.html#7904712
It acctually had nothing to do with the kernel, or ACPI. but with the fact that kde polkit starts after kded, https://bugs.kde.org/show_bug.cgi?id=344456
_________________
OS: Gentoo KDE x86_64 (~amd64, 4.20.7-gentoo)
MB: MSI Z370-A PRO
CPU: Intel Core i7-8700K
GPU: NVIDIA GTX 1060 6GB & Intel UHD Graphics 630
SSD: Samsung 970 Pro 512GB
RAM: Crucial Ballistix 32GB DDR4-2400
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum