Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
usb mouse is not working although trackpad is.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
diablo465
Apprentice
Apprentice


Joined: 10 Sep 2013
Posts: 194

PostPosted: Sat Jun 27, 2015 1:24 pm    Post subject: usb mouse is not working although trackpad is. Reply with quote

my laptop is like this after i upgrade from gentoo 3.10.25.

Specifically the laptop can not recongnize anything associated with mouse (e.g., usb wired mouse, usb mouse receiver) for all kerners after 3.10.25. Interestingly, the trackpad inbuilt on the laptop is working perfectly, even before X boot.


here are the configurations of my laptop (after logitech mouse receiver installed) :
lsusb
Code:

ae429-3176 profile # lsusb
Bus 003 Device 002: ID 10f1:1a34 Importek
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 0bda:0138 Realtek Semiconductor Corp. RTS5138 Card Reader Controller
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


lsmod
Code:

 lsmod
Module                  Size  Used by
uvcvideo               71485  0
videobuf2_vmalloc       2736  1 uvcvideo
videobuf2_memops        1799  1 videobuf2_vmalloc
videobuf2_core         25786  1 uvcvideo
v4l2_common             3914  1 videobuf2_core
videodev              120979  3 uvcvideo,v4l2_common,videobuf2_core
media                  11273  2 uvcvideo,videodev
radeon               1317310  2
rtl8192ce              47660  0
rtl_pci                15483  1 rtl8192ce
rtlwifi                47583  2 rtl_pci,rtl8192ce
ttm                    60270  1 radeon
rtl8192c_common        36394  1 rtl8192ce
atl1c                  33834  0
vboxnetflt             15666  0
vboxnetadp             17766  0
vboxdrv              1809437  2 vboxnetadp,vboxnetflt
nfsv4                 362631  0
nfs                   161961  1 nfsv4
nfsd                  233641  0
auth_rpcgss            41823  1 nfsd
oid_registry            2211  1 auth_rpcgss
nfs_acl                 2527  1 nfsd
lockd                  60071  2 nfs,nfsd
sunrpc                189272  6 nfs,nfsd,auth_rpcgss,lockd,nfsv4,nfs_acl


please do not hesitate to ask me if any further information is required. Thanks
Back to top
View user's profile Send private message
mir3x
Guru
Guru


Joined: 02 Jun 2012
Posts: 427

PostPosted: Sat Jun 27, 2015 1:46 pm    Post subject: Reply with quote

I'm not fully understand that:
Quote:
here are the configurations of my laptop (after logitech mouse receiver installed) : lsusb


Did u cut something like that :Bus 004 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
before pasting ? Or what u mean that recevier is installed ? It seems he is not installed. I guess u mean u put him in usb port.

If not u have just to enable logitech in kernel:
Device drivers ->Hid support->special hid drivers -> logitech devices
and enable Logitech Unifying receivers full support (HID_LOGITECH_DJ)
_________________
Installation aborted to prevent system self-destruction
Back to top
View user's profile Send private message
diablo465
Apprentice
Apprentice


Joined: 10 Sep 2013
Posts: 194

PostPosted: Sat Jun 27, 2015 2:37 pm    Post subject: Reply with quote

thanks for the reply @mir3x.

in the first post I just paste the results of lsusb, lsmod with unifying receiver plugged in. Apparently they are not identified by the system.

I had a look on the kenrel configure and found HID_LOGITECH_DJ is enabled as inbuilding module. Still mouse is not working (mouse is tested on the another machine)

Interestingly, nothing is happening after running the following commands, and module can not be seen from the lsmod command result

Code:

ae429-3176 linux # modprobe -r hid_logitech_dj
modprobe: FATAL: Module hid_logitech_dj is builtin.
ae429-3176 linux # modprobe hid_logitech_dj
ae429-3176 linux # lsmod
Module                  Size  Used by
uvcvideo               71485  0
videobuf2_vmalloc       2736  1 uvcvideo
videobuf2_memops        1799  1 videobuf2_vmalloc
videobuf2_core         25786  1 uvcvideo
v4l2_common             3914  1 videobuf2_core
videodev              120979  3 uvcvideo,v4l2_common,videobuf2_core
media                  11273  2 uvcvideo,videodev
radeon               1317310  2
rtl8192ce              47660  0
rtl_pci                15483  1 rtl8192ce
rtlwifi                47583  2 rtl_pci,rtl8192ce
ttm                    60270  1 radeon
rtl8192c_common        36394  1 rtl8192ce
atl1c                  33834  0
vboxnetflt             15666  0
vboxnetadp             17766  0
vboxdrv              1809437  2 vboxnetadp,vboxnetflt
nfsv4                 362631  0
nfs                   161961  1 nfsv4
nfsd                  233641  0
auth_rpcgss            41823  1 nfsd
oid_registry            2211  1 auth_rpcgss
nfs_acl                 2527  1 nfsd
lockd                  60071  2 nfs,nfsd
sunrpc                189272  6 nfs,nfsd,auth_rpcgss,lockd,nfsv4,nfs_acl
Back to top
View user's profile Send private message
diablo465
Apprentice
Apprentice


Joined: 10 Sep 2013
Posts: 194

PostPosted: Sat Jun 27, 2015 2:48 pm    Post subject: Reply with quote

more updates:
I have updated the gentoo kernel into 4.0.5 and installed hid_logitech_dj as a modules, as shown below. Still the unifying receiver can not be found. ....

Code:

chenming@ae429-3176 ~ $ uname -a
Linux ae429-3176 4.0.5-gentoo #1 SMP Sun Jun 28 10:38:20 AEST 2015 x86_64 AMD E-450 APU with Radeon(tm) HD Graphics AuthenticAMD GNU/Linux
chenming@ae429-3176 ~ $ lsmod |grep hid_logitech_dj
hid_logitech_dj        10101  0
Back to top
View user's profile Send private message
mir3x
Guru
Guru


Joined: 02 Jun 2012
Posts: 427

PostPosted: Sat Jun 27, 2015 6:57 pm    Post subject: Reply with quote

I have something in dmesg:
logitech-djreceiver 0003:046D:C52B.0004: hiddev0,hidraw0: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:1a.1-1/input2

So it means that /dev/hiddev raw HID device support (USB_HIDDEV) should be in kernel also
and /dev/hidraw raw HID device support (HIDRAW), check for them ( and maybe also USB_UHCI_HCD, at least for my system )

Btw anything from usb port works ?
EDIT_X:
I checked mint where djreceiver is as module and its lsmod looks like:
hid_generic 12548 0
hid_logitech_dj 18581 0
usbhid 53014 0
hid 101512 4 hid_generic,usbhid,hid_logitech_dj

so maybe u lack some hid* ...
_________________
Installation aborted to prevent system self-destruction
Back to top
View user's profile Send private message
diablo465
Apprentice
Apprentice


Joined: 10 Sep 2013
Posts: 194

PostPosted: Sun Jun 28, 2015 11:53 pm    Post subject: Reply with quote

mir3x wrote:
I have something in dmesg:
logitech-djreceiver 0003:046D:C52B.0004: hiddev0,hidraw0: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:1a.1-1/input2

So it means that /dev/hiddev raw HID device support (USB_HIDDEV) should be in kernel also
and /dev/hidraw raw HID device support (HIDRAW), check for them ( and maybe also USB_UHCI_HCD, at least for my system )

Btw anything from usb port works ?
EDIT_X:
I checked mint where djreceiver is as module and its lsmod looks like:
hid_generic 12548 0
hid_logitech_dj 18581 0
usbhid 53014 0
hid 101512 4 hid_generic,usbhid,hid_logitech_dj

so maybe u lack some hid* ...


Thanks for the update. it is confirmed that usb storage is working for my laptop ATM. I then start looking for all the modules associated with hid, and build them as modules (previously they are all inbuilding kernels which I can not see the status by lsmod and cat /proc/modules)

now this is the updated situation:
Quote:

# modprobe usbhid
modprobe: ERROR: could not insert 'usbhid': Exec format error
# modprobe hid_generic
modprobe: ERROR: could not insert 'hid_generic': Device or resource busy
# modinfo hid
modinfo: ERROR: Module hid not found.
# lsmod |grep hid
hid_logitech_dj 10101 0
Back to top
View user's profile Send private message
mir3x
Guru
Guru


Joined: 02 Jun 2012
Posts: 427

PostPosted: Mon Jun 29, 2015 8:30 am    Post subject: Reply with quote

Can u check dmesg when hid_logitech_dj is loaded?
Maybe there is some error about pairing.
On https://wiki.gentoo.org/wiki/Evdev its written
that some mouses needs USB_EHCI_TT_NEWSCHED.
_________________
Installation aborted to prevent system self-destruction
Back to top
View user's profile Send private message
diablo465
Apprentice
Apprentice


Joined: 10 Sep 2013
Posts: 194

PostPosted: Mon Jun 29, 2015 12:59 pm    Post subject: Reply with quote

mir3x wrote:
Can u check dmesg when hid_logitech_dj is loaded?
Maybe there is some error about pairing.
On https://wiki.gentoo.org/wiki/Evdev its written
that some mouses needs USB_EHCI_TT_NEWSCHED.


here is the demsg for the kernel (3.10.25) that mouse is working
Code:

dmesg |grep Logitech
[    2.760539] usb 4-1: Manufacturer: Logitech
[    2.769325] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:12.0/usb4/4-1/4-1:1.0/input/input5
[    2.770902] hid-generic 0003:046D:C52F.0001: input,hidraw0: USB HID v1.11 Mouse [Logitech USB Receiver] on usb-0000:00:12.0-1/input0
[    2.779733] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:12.0/usb4/4-1/4-1:1.1/input/input6
[    2.783405] hid-generic 0003:046D:C52F.0002: input,hiddev0,hidraw1: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:12.0-1/input1
[    2.829659] input: PS/2 Logitech Wheel Mouse as /devices/platform/i8042/serio1/input/input7



and the following is the demsg from the kernel that mouse is not working.

Code:

ae429-0176 chenming # dmesg |grep Logitech
[    2.515042] input: PS/2 Logitech Wheel Mouse as /devices/platform/i8042/serio1/input/input6


I guess hid-generic is not loaded properly (3.17.5 and 4.0.5). but once I instert hid-generic, error comes:
Code:

ae429-0176 chenming # modprobe hid-generic
modprobe: ERROR: could not insert 'hid_generic': Device or resource busy

or equivalently
Code:

# insmod /lib/modules/4.0.5-gentoo/kernel/drivers/hid/hid-generic.ko
insmod: ERROR: could not insert module /lib/modules/4.0.5-gentoo/kernel/drivers/hid/hid-generic.ko: Device or resource busy
Back to top
View user's profile Send private message
Goingtobecrazy
n00b
n00b


Joined: 13 Feb 2015
Posts: 14

PostPosted: Thu Jul 16, 2015 7:45 pm    Post subject: Reply with quote

I have the exact same issue since like 7 months with my mouse.

dmesg when i connect it:
Code:

[20869.517729] usb 2-1.2: new full-speed USB device number 3 using ehci-pci
[20869.604799] usb 2-1.2: New USB device found, idVendor=1038, idProduct=1369
[20869.604810] usb 2-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[20869.604815] usb 2-1.2: Product: Sensei Raw Gaming Mouse
[20869.604820] usb 2-1.2: Manufacturer: SteelSeries
[20869.608359] hid-generic 0003:1038:1369.0003: hiddev0,hidraw2: USB HID v1.11 Device [SteelSeries Sensei Raw Gaming Mouse] on usb-0000:00:1d.0-1.2/input0
[20869.609244] input: SteelSeries Sensei Raw Gaming Mouse as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.1/0003:1038:1369.0004/input/input10
[20869.609382] hid-generic 0003:1038:1369.0004: input,hidraw3: USB HID v1.11 Mouse [SteelSeries Sensei Raw Gaming Mouse] on usb-0000:00:1d.0-1.2/input1
[20869.610235] input: SteelSeries Sensei Raw Gaming Mouse as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.2/0003:1038:1369.0005/input/input11
[20869.661025] hid-generic 0003:1038:1369.0005: input,hidraw4: USB HID v1.11 Keyboard [SteelSeries Sensei Raw Gaming Mouse] on usb-0000:00:1d.0-1.2/input2
[20869.662379] input: SteelSeries Sensei Raw Gaming Mouse as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.3/0003:1038:1369.0006/input/input12
[20869.712980] hid-generic 0003:1038:1369.0006: input,hidraw5: USB HID v1.11 Device [SteelSeries Sensei Raw Gaming Mouse] on usb-0000:00:1d.0-1.2/input3


What's really interesting here, it's that my button on the border of my mouse works, but not the other one.
It's like the button assigned to the synaptics trackpoint aren't reassign to the mouse, and add more button just work.
I have a thinkpad, with 2 different trackpoint (center of the computer, and bottom). On my first install of gentoo, only the first trackpoint was working. After add some config and 50-synaptics.conf, the second tracpoint work. But i just can't use my mouse. I don't know what i have to configure, or what a 50-usb-mouse.conf looks like...

The 50-synaptics.conf:
Code:
Section "InputClass"
    Identifier "touchpad catchall"
    Driver "synaptics"
    MatchIsTouchpad "on"
    MatchDevicePath "/dev/input/event*"
        Option "TapButton1" "1"
        Option "TapButton2" "2"
        Option "TapButton3" "3"
        Option "VertEdgeScroll" "on"
        Option "VertTwoFingerScroll" "on"
        Option "HorizEdgeScroll" "on"
        Option "HorizTwoFingerScroll" "on"
        Option "CircularScrolling" "on"
        Option "CircScrollTrigger" "2"
        Option "EmulateTwoFingerMinZ" "40"
        Option "EmulateTwoFingerMinW" "8"
        Option "CoastingSpeed" "0"
        Option "FingerLow" "35"
        Option "FingerHigh" "40"
EndSection
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum