Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Interfaces doesnot show up in Gentoo
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
manu_leo
Guru
Guru


Joined: 20 Jan 2014
Posts: 453
Location: India

PostPosted: Fri Jul 03, 2015 2:41 am    Post subject: [SOLVED] Interfaces doesnot show up in Gentoo Reply with quote

Hi Experts, Need you help.

I have recently installed gentoo on my server. I boot from the livecd, do the ip addressing on the physical interface, and rest of the configuration, then do a chroot, emerge gentoo-sources and other stuff. Till this point , if I do ifconfig -a, I see all the physical interfaces for the server including the 10G NIC. Now, once the installation is completed, I reboot my sever and boot it from the hdd. Now if I do ifconfig -a, I see just the lo interface and nothing else.

The NIC installed on my machine is
Quote:
Intel I350 Gigabit Network connection
, however I donot see this option in the kernel when I run make menuconfig. I also tried to manually load the drivers using
Quote:
modprobe igb
, but it says
Quote:
driver igb not found.


I am bit confused as to why I see all the interfaces when I boot from livecd and do a chroot and NOT when I boot the server from the hdd. Also need help in how to fix it.

Appreciate all your help in advance.


Last edited by manu_leo on Tue Jul 07, 2015 3:36 am; edited 1 time in total
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2613

PostPosted: Fri Jul 03, 2015 5:40 am    Post subject: Re: Interfaces doesnot show up in Gentoo Reply with quote

manu_leo wrote:
I am bit confused as to why I see all the interfaces when I boot from livecd and do a chroot and NOT when I boot the server from the hdd. Also need help in how to fix it.

You should have compiled the kernel with CONFIG_IGB.
When you are in make menuconfig, type / giving you the search command line. Then type config_igb$ and it will show you the location of that option.
After re-compiling the kernel, do not forget to grub2-mkconfig, and after reboot check with ifconfig -a.
Back to top
View user's profile Send private message
manu_leo
Guru
Guru


Joined: 20 Jan 2014
Posts: 453
Location: India

PostPosted: Tue Jul 07, 2015 3:35 am    Post subject: Reply with quote

Thank you very much. I was looking for I350 drivers in the kernel where as I should be looking for Intel(R) 82575/82576 PCI-Express. I compiled the correct ones in the kernel now, did a grub2-mkconfig, reboot and now I see all my interfaces.

Appreciate all your help and thank you very much once again.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum