Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
update world
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
yaxon
n00b
n00b


Joined: 14 Apr 2015
Posts: 4

PostPosted: Sun Jul 05, 2015 8:37 am    Post subject: update world Reply with quote

how to be ?!
Code:

# emerge -uND world

Local copy of remote index is up-to-date and will be used.

 * IMPORTANT: 24 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/icu:0

  (dev-libs/icu-55.1::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/icu:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtwebkit-4.8.6-r1::gentoo, ebuild scheduled for merge)
    >=dev-libs/icu-51.2-r1:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-libs/libxml2-2.9.2-r1::gentoo, ebuild scheduled for merge)
    >=dev-libs/icu-51.2-r1:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-libs/harfbuzz-0.9.38::gentoo, ebuild scheduled for merge)

  (dev-libs/icu-52.1::gentoo, installed) pulled in by
    dev-libs/icu:0/52= required by (media-libs/raptor-2.0.9::gentoo, installed)
    (and 1 more with the same problem)

  (dev-libs/icu-54.1-r1::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/icu:0/54a= required by (app-text/libmspub-0.1.2::gentoo, binary scheduled for merge)
    dev-libs/icu:0/54a= required by (media-libs/libcdr-0.1.1::gentoo, binary scheduled for merge)
    dev-libs/icu:0/54a= required by (media-libs/libvisio-0.1.1::gentoo, binary scheduled for merge)
    dev-libs/icu:0/54a= required by (app-text/libebook-0.1.2::gentoo, binary scheduled for merge)
    (and 4 more with the same problems)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


emerge: there are no ebuilds to satisfy "dev-lang/perl:0/5.18=[-build(-)]".
(dependency required by "dev-perl/JSON-2.590.0-r1" [installed])
(dependency required by "www-client/chromium-43.0.2357.65" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

is it really necessary to remove all that hinders renewal
Back to top
View user's profile Send private message
ShadowCat8
Apprentice
Apprentice


Joined: 07 Oct 2008
Posts: 161
Location: San Bernardino, CA, USA

PostPosted: Wed Jul 15, 2015 8:58 pm    Post subject: Reply with quote

Greetings,

To start with, I'm not sure why this thread is in "Unsupported Software", since dev-libs/icu is supported by and in Gentoo. But, that not withstanding...

I'm never sure about completely removing problematic packages for an upgrade (Ever had the experience of trying that with your active python? doh! :-p hehe), so that tends to be my last resort.

But this subslot business with icu certainly seems to be more trouble than it's worth from this end.

What started it for me:
Code:
tech8 ~ # emerge -pv @preserved-rebuild

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] sys-libs/ncurses-5.9-r3:5::gentoo  USE="cxx unicode -ada -debug -doc -gpm -minimal -profile -static-libs -tinfo -trace" ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] virtual/libintl-0-r1::gentoo  ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] app-arch/bzip2-1.0.6-r6::gentoo  USE="-static -static-libs" ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild     U  ] dev-libs/expat-2.1.0-r4::gentoo [2.1.0-r3::gentoo] USE="unicode -examples -static-libs" ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] media-libs/libpng-1.6.16:0/16::gentoo  USE="apng static-libs (-neon)" ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] dev-libs/gmp-5.1.3-r1::gentoo  USE="cxx -doc -pgo -static-libs" ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild     U  ] dev-util/pkgconfig-0.28-r2::gentoo [0.28-r1::gentoo] USE="-hardened -internal-glib" ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] virtual/pkgconfig-0-r1::gentoo  ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild     U  ] media-libs/freetype-2.5.5:2::gentoo [2.5.3-r1:2::gentoo] USE="X adobe-cff bzip2 png -auto-hinter -bindist -debug -doc -fontforge -harfbuzz -infinality -static-libs -utils" ABI_X86="32* (64) (-x32)" 1675 KiB
[ebuild     U  ] x11-proto/xproto-7.0.27::gentoo [7.0.25::gentoo] USE="-doc" ABI_X86="32* (64) (-x32)" 299 KiB
[ebuild   R    ] x11-proto/xextproto-7.3.0::gentoo  USE="-doc" ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild     U  ] media-libs/alsa-lib-1.0.29::gentoo [1.0.28::gentoo] USE="-alisp -debug -doc -python" ABI_X86="32* (64) (-x32)" PYTHON_TARGETS="python2_7" 885 KiB
[ebuild     U  ] x11-proto/inputproto-2.3.1::gentoo [2.3::gentoo] ABI_X86="32* (64) (-x32)" 192 KiB
[ebuild     U  ] dev-libs/icu-55.1:0/55::gentoo [53.1:0/53::gentoo] USE="-debug -doc -examples -static-libs" ABI_X86="32* (64) (-x32)" 25001 KiB
[ebuild   R    ] x11-proto/kbproto-1.0.6-r1::gentoo  ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] x11-proto/xf86vidmodeproto-2.3.1-r1::gentoo  ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] dev-libs/libpthread-stubs-0.3-r1::gentoo  USE="-static-libs" ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] x11-proto/renderproto-0.11.1-r1::gentoo  ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] x11-proto/xineramaproto-1.2.1-r1::gentoo  ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] x11-proto/xf86bigfontproto-1.2.0-r1::gentoo  ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] x11-proto/randrproto-1.4.0-r1::gentoo  ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild     U  ] dev-libs/nettle-2.7.1-r4:0/4::gentoo [2.7.1-r1:0/4::gentoo] USE="gmp -doc (-neon) -static-libs {-test}" ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] x11-proto/damageproto-1.2.1-r1::gentoo  ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] x11-proto/dri2proto-2.8-r1::gentoo  ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] x11-proto/dri3proto-1.0::gentoo  ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] x11-proto/presentproto-1.0::gentoo  ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] x11-proto/glproto-1.4.17::gentoo  ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] x11-proto/xf86driproto-2.1.1-r1::gentoo  ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild     U  ] sys-boot/grub-0.97-r14::gentoo [0.97-r12::gentoo] USE="ncurses -custom-cflags -netboot -static" 0 KiB
[ebuild   R    ] x11-libs/libXau-1.0.8::gentoo  USE="-static-libs" ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] x11-libs/libXdmcp-1.1.1-r1::gentoo  USE="-doc -static-libs" ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild     U  ] x11-libs/libxshmfence-1.2::gentoo [1.1::gentoo] USE="-static-libs" ABI_X86="32* (64) (-x32)" 261 KiB
[ebuild     U  ] x11-libs/libdrm-2.4.59::gentoo [2.4.58::gentoo] USE="-libkms -static-libs" ABI_X86="32* (64) (-x32)" VIDEO_CARDS="(-exynos) (-freedreno) -intel -nouveau (-omap) -radeon (-tegra) -vmware" 579 KiB
[ebuild   R    ] x11-proto/fixesproto-5.0-r1::gentoo  ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] media-sound/mpg123-1.18.1::gentoo  USE="alsa ipv6 (-altivec) (-coreaudio) -int-quality -jack -nas -oss -portaudio -pulseaudio -sdl" ABI_X86="32* (64) (-x32)" CPU_FLAGS_X86="sse (-3dnow) (-3dnowext) (-mmx)" 0 KiB
[ebuild   R    ] media-libs/fontconfig-2.11.1-r2:1.0::gentoo  USE="-doc -static-libs" ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] sys-devel/llvm-3.5.0:0/3.5::gentoo  USE="libffi ncurses static-analyzer xml -clang -debug -doc -gold -libedit -multitarget -ocaml -python {-test}" ABI_X86="32* (64) (-x32)" PYTHON_TARGETS="python2_7 (-pypy)" VIDEO_CARDS="-radeon" 0 KiB
[ebuild     U  ] dev-libs/libxml2-2.9.2-r1:2::gentoo [2.9.2:2::gentoo] USE="icu ipv6 python readline -debug -examples -lzma -static-libs {-test}" ABI_X86="32* (64) (-x32)" PYTHON_TARGETS="python2_7 python3_3 -python3_4" 0 KiB
[ebuild     U  ] x11-proto/xcb-proto-1.11::gentoo [1.10::gentoo] ABI_X86="32* (64) (-x32)" PYTHON_TARGETS="python2_7 python3_3 -python3_4% (-python2_6%) (-python3_2%)" 136 KiB
[ebuild   R    ] virtual/jpeg-62:62::gentoo  ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] sys-devel/gettext-0.19.3::gentoo  USE="acl cxx java ncurses nls openmp -cvs -doc -emacs -git -static-libs" ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] dev-libs/libgpg-error-1.13::gentoo  USE="nls -common-lisp -static-libs" ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild     U  ] sys-devel/gcc-4.7.4:4.7::gentoo [4.7.3-r1:4.7::gentoo] USE="cxx fortran gcj (multilib) nls nptl openmp (-altivec) (-awt) -debug% -doc (-fixed-point) -go (-hardened) (-libssp) -mudflap (-multislot) -nopie -nossp -objc -objc++ -objc-gc -regression-test -vanilla (-graphite%)" 81027 KiB
[ebuild   R    ] dev-libs/libgcrypt-1.5.4-r1:0/11::gentoo  USE="static-libs" ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild     U  ] dev-libs/libtasn1-4.5:0/6::gentoo [4.2:0/6::gentoo] USE="-doc -static-libs" ABI_X86="32* (64) (-x32)" 1807 KiB
[ebuild   R    ] dev-libs/libxslt-1.1.28-r4::gentoo  USE="crypt -debug -python -static-libs" ABI_X86="32* (64) (-x32)" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild     U  ] x11-libs/libxcb-1.11-r1:0/1.11::gentoo [1.10:0/0::gentoo] USE="-doc (-selinux) -static-libs {-test%} -xkb" ABI_X86="32* (64) (-x32)" 506 KiB
[ebuild   R    ] sys-fs/eudev-1.10-r2::gentoo  USE="gudev hwdb keymap kmod modutils openrc rule-generator -doc -introspection (-selinux) -static-libs {-test}" ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] x11-libs/libX11-1.6.2::gentoo  USE="ipv6 -doc -static-libs {-test}" ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] virtual/libudev-215-r1:0/1::gentoo  USE="-static-libs -systemd" ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild     U  ] x11-libs/libXext-1.3.3::gentoo [1.3.2::gentoo] USE="-doc -static-libs" ABI_X86="32* (64) (-x32)" 381 KiB
[ebuild     U  ] sys-apps/dbus-1.8.16::gentoo [1.8.10::gentoo] USE="X -debug -doc (-selinux) -static-libs -systemd {-test}" ABI_X86="32* (64) (-x32)" 1823 KiB
[ebuild   R    ] x11-libs/libXrender-0.9.8::gentoo  USE="-static-libs" ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] x11-libs/libXfixes-5.0.1::gentoo  USE="-static-libs" ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild     U  ] x11-libs/libXi-1.7.4::gentoo [1.7.2::gentoo] USE="-doc -static-libs" ABI_X86="32* (64) (-x32)" 448 KiB
[ebuild   R    ] x11-libs/libXrandr-1.4.2::gentoo  USE="-static-libs" ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] x11-libs/libXcursor-1.1.14::gentoo  USE="-static-libs" ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] x11-libs/libXinerama-1.1.3::gentoo  USE="-static-libs" ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild     U  ] x11-libs/libXxf86vm-1.1.4::gentoo [1.1.3::gentoo] USE="-static-libs" ABI_X86="32* (64) (-x32)" 289 KiB
[ebuild   R    ] x11-libs/libXdamage-1.1.4-r1::gentoo  USE="-static-libs" ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild     U  ] media-libs/mesa-10.3.7-r1::gentoo [10.2.8::gentoo] USE="classic dri3 egl gallium gbm llvm nptl udev -bindist -debug -gles1 -gles2 -opencl -openmax -openvg -osmesa -pax_kernel -pic (-selinux) -vdpau -wayland -xa -xvmc (-r600-llvm-compiler%)" ABI_X86="32* (64) (-x32)" VIDEO_CARDS="(-freedreno) -i915 -i965 -ilo -intel -nouveau -r100 -r200 -r300 -r600 -radeon -radeonsi -vmware" 7117 KiB
[ebuild   R    ] virtual/opengl-7.0-r1::gentoo  ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] media-libs/glu-9.0.0-r1::gentoo  USE="-static-libs" ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild   R    ] x11-drivers/nvidia-drivers-340.76::gentoo  USE="X acpi multilib tools -pax_kernel -uvm" 0 KiB
[ebuild   R    ] virtual/glu-9.0-r1::gentoo  ABI_X86="32* (64) (-x32)" 0 KiB
[ebuild     U  ] net-libs/gnutls-3.3.15::gentoo [3.3.10-r2::gentoo] USE="crywrap cxx nls openssl%* zlib -dane -doc -examples -guile -pkcs11 -static-libs {-test}" ABI_X86="32* (64) (-x32)" LINGUAS="-cs -de -en -fi -fr -it -ms -nl -pl -sv -uk -vi -zh_CN" 6139 KiB
[ebuild     U  ] net-print/cups-2.0.2-r1::gentoo [2.0.1-r1::gentoo] USE="X acl dbus java pam ssl threads -debug -kerberos -lprng-compat -python (-selinux) -static-libs -systemd -usb -xinetd -zeroconf" ABI_X86="32* (64) (-x32)" LINGUAS="ca%* cs%* de%* es fr%* it%* ja%* pt_BR%* ru%*" PYTHON_TARGETS="python2_7" 8562 KiB
[ebuild     U  ] net-print/cndrvcups-common-lb-2.90::gentoo [2.70-r2::gentoo] 88771 KiB
[ebuild   R    ] app-emulation/wine-1.6.2::gentoo  USE="X alsa cups fontconfig gecko jpeg mono mp3 ncurses nls opengl perl png prelink realtime run-exes samba ssl threads truetype udisks xinerama xml -capi -custom-cflags -dos -gphoto2 -gsm -gstreamer -lcms -ldap -odbc -openal -opencl -osmesa -oss -pulseaudio -scanner (-selinux) {-test} -v4l -xcomposite" ABI_X86="32 64 (-x32)" LINGUAS="-ar -bg -ca -cs -da -de -el -en -en_US -eo -es -fa -fi -fr -he -hi -hr -hu -it -ja -ko -lt -ml -nb_NO -nl -or -pa -pl -pt_BR -pt_PT -rm -ro -ru -sk -sl -sr_RS@cyrillic -sr_RS@latin -sv -te -th -tr -uk -wa -zh_CN -zh_TW" 0 KiB
[ebuild     U  ] net-print/cndrvcups-lb-2.90::gentoo [2.70-r2::gentoo] 0 KiB

Total: 70 packages (25 upgrades, 45 reinstalls), Size of downloads: 225892 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/icu:0

  (dev-libs/icu-55.1:0/55::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/icu-51.2-r1:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-libs/libxml2-2.9.2-r1:2/2::gentoo, ebuild scheduled for merge)


  (dev-libs/icu-53.1:0/53::gentoo, installed) pulled in by
    >=dev-libs/icu-3.8.1-r1:0/53= required by (net-libs/webkit-gtk-2.4.8-r200:2/2::gentoo, installed)
 
    (and 8 more with the same problem)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

tech8 ~ #


And, for those that are interested in what is apparently locked on icu-53.1 (i.e. "icu:0/53"):
Code:
tech8 ~ # equery depends dev-libs/icu:0/53
 * These packages depend on dev-libs/icu:
app-office/odeskteam-3.6.1 (dev-libs/icu)
app-text/libebook-0.1.1 (dev-libs/icu)
app-text/libmspub-0.1.1 (dev-libs/icu)
dev-db/sqlite-3.8.7.4 (dev-libs/icu:0[abi_x86_64(-)])
dev-libs/boost-1.55.0-r2 (icu ? >=dev-libs/icu-3.6[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
dev-libs/libxml2-2.9.2 (>=dev-libs/icu-51.2-r1:0[abi_x86_64(-)])
dev-qt/qtcore-4.8.5-r2 (icu ? >=dev-libs/icu-49)
dev-qt/qtwebkit-4.8.5 (icu ? dev-libs/icu)
media-libs/harfbuzz-0.9.35 (icu ? >=dev-libs/icu-51.2-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
media-libs/libcdr-0.1.0 (dev-libs/icu)
media-libs/libvisio-0.1.0 (dev-libs/icu)
media-libs/raptor-2.0.9 (unicode ? dev-libs/icu)
net-libs/webkit-gtk-2.4.4-r1 (>=dev-libs/icu-3.8.1-r1:0)
net-libs/webkit-gtk-2.4.8-r200 (>=dev-libs/icu-3.8.1-r1)
net-nds/openldap-2.4.38-r2 (icu ? dev-libs/icu)
www-client/chromium-40.0.2214.111 (dev-libs/icu:0)
tech8 ~ #


My "emerge --info":
Code:
tech8 ~ # emerge --info
Portage 2.2.18 (python 2.7.9-final-0, default/linux/amd64/13.0, gcc-4.8.4, glibc-2.19-r1, 3.10.25-gentoo-LinearVOS-ws-20140617-01 x86_64)
=================================================================
System uname: Linux-3.10.25-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q6700_@_2.66GHz-with-gentoo-2.2
KiB Mem:     8160604 total,   1059032 free
KiB Swap:    7653372 total,   7025416 free
Timestamp of repository gentoo: Fri, 19 Jun 2015 19:45:01 +0000
sh bash 4.2_p53
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.2_p53::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.20.1-r4::gentoo
dev-lang/python:          2.7.9-r1::gentoo, 3.2.5-r6::gentoo, 3.3.5-r1::gentoo, 3.4.1::gentoo
dev-util/cmake:           2.8.12.2-r1::gentoo
dev-util/pkgconfig:       0.28-r1::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.13.9::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.12.6::gentoo, 1.13.4::gentoo, 1.14.1::gentoo
sys-devel/binutils:       2.24-r3::gentoo
sys-devel/gcc:            4.5.4::gentoo, 4.6.3::gentoo, 4.7.3-r1::gentoo, 4.8.4::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.4::gentoo
sys-devel/make:           4.0-r1::gentoo
sys-kernel/linux-headers: 3.16::gentoo (virtual/os-headers)
sys-libs/glibc:           2.19-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.namerica.gentoo.org/gentoo-portage
    priority: -1000

x-portage
    location: /usr/local/portage
    masters: gentoo
    priority: 0

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ http://cudlug.ucdenver.edu/gentoo/ http://mirror.usu.edu/mirrors/gentoo/ http://gentoo.mirrors.easynews.com/linux/gentoo/ ftp://ftp.wallawalla.edu/pub/mirrors/ftp.gentoo.org "
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac aalib acl acpi alsa amd64 apache2 apm audiofile avi berkdb browserplugin bzip2 cairo cdda cddb cdr clamav cli consolekit cracklib crypt css cups curl cxx dbus divx4linux djvu dri dv dvd dvdr exif ffmpeg flac flash fontconfig fortran gdbm gif gimp glut gnutls gtk gtk2 gzip iconv icu imagemagick imlib ipv6 java jpeg jpeg2k junit lame lm_sensors matroska mime ming mmx mmxext mng modules mono mozcalendar mozilla mozsvg mozxmlterm mp3 mp4 mpeg mplayer multilib mysql mysqli ncurses nls nptl nsplugin ogg openexr opengl openmp pam pcre pdf png policykit qt quicktime raw readline samba sandbox sensord session smp sockets speex sse sse2 sse3 ssl svg tcpd theora tiff truetype udev udisks unicode usb vcd vorbis wmf x264 xinerama xml xpm xprint xscreensaver xv xvid zlib" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nvidia vesa vga" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

tech8 ~ #


So, at this point, I'm not sure what the resolution is... I have read the bug reports (e.g. https://bugs.gentoo.org/show_bug.cgi?id=455900 and https://bugs.gentoo.org/show_bug.cgi?id=461464 and https://bugs.gentoo.org/show_bug.cgi?id=478838 and https://bugs.gentoo.org/show_bug.cgi?id=460816 and, finally, https://bugs.gentoo.org/show_bug.cgi?id=250286) and, supposedly, we shouldn't be seeing this problem in the current portage.

Any suggestions?
_________________
________________________

"As far as the laws of mathematics refer to reality, they are not
certain, and as far as they are certain, they do not refer to reality."

-- Albert Einstein
Back to top
View user's profile Send private message
ShadowCat8
Apprentice
Apprentice


Joined: 07 Oct 2008
Posts: 161
Location: San Bernardino, CA, USA

PostPosted: Wed Jul 15, 2015 10:50 pm    Post subject: Reply with quote

And, for those that are curious, here is the output of *just* emerging icu:
Code:
tech8 ~ # emerge -pv dev-libs/icu

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-libs/icu-55.1:0/55::gentoo [53.1:0/53::gentoo] USE="-debug -doc -examples -static-libs" ABI_X86="32* (64) (-x32)" 25001 KiB

Total: 1 package (1 upgrade), Size of downloads: 25001 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/icu:0

  (dev-libs/icu-55.1:0/55::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/icu (Argument)

  (dev-libs/icu-53.1:0/53::gentoo, installed) pulled in by
    >=dev-libs/icu-51.2-r1:0/53=[abi_x86_64(-)] required by (dev-libs/libxml2-2.9.2:2/2::gentoo, installed)
                          ^^^^^^                                                                                                               
    (and 9 more with the same problem)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


tech8 ~ #

_________________
________________________

"As far as the laws of mathematics refer to reality, they are not
certain, and as far as they are certain, they do not refer to reality."

-- Albert Einstein
Back to top
View user's profile Send private message
ShadowCat8
Apprentice
Apprentice


Joined: 07 Oct 2008
Posts: 161
Location: San Bernardino, CA, USA

PostPosted: Wed Jul 15, 2015 11:21 pm    Post subject: Reply with quote

Well,

I ran a new emerge --sync and then a new emerge -pvuDN @world and it stopped complaining about icu.

@yaxon: Seems this is resolved for me. Are you still having issues?

Let us know.
_________________
________________________

"As far as the laws of mathematics refer to reality, they are not
certain, and as far as they are certain, they do not refer to reality."

-- Albert Einstein
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum