Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201507-07 ] LibVNCServer
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2189

PostPosted: Tue Jul 07, 2015 11:26 am    Post subject: [ GLSA 201507-07 ] LibVNCServer Reply with quote

Gentoo Linux Security Advisory

Title: LibVNCServer: Multiple vulnerabilities (GLSA 201507-07)
Severity: normal
Exploitable: remote
Date: July 07, 2015
Bug(s): #523590
ID: 201507-07

Synopsis

Multiple vulnerabilities have been found in LibVNCServer, the worst
of which could result in execution of arbitrary code or Denial of Service.


Background

LibVNCServer is a cross-platform C library that allows you to easily
implement VNC server functionality in your program.


Affected Packages

Package: net-libs/libvncserver
Vulnerable: < 0.9.10-r1
Unaffected: >= 0.9.10-r1
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in LibVNCServer. Please
review the CVE identifiers referenced below for details.


Impact

A remote attacker may be able to execute arbitrary code with the
privileges of the process or cause a Denial of Service condition.


Workaround

There is no known workaround at this time.

Resolution

All LibVNCServer users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-libs/libvncserver-0.9.10-r1"
   


References

CVE-2014-6051
CVE-2014-6052
CVE-2014-6053
CVE-2014-6054
CVE-2014-6055
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum