Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Unable to install under XenServer?
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43198
Location: 56N 3W

PostPosted: Mon Jul 13, 2015 9:30 am    Post subject: Reply with quote

The_Great_Sephiroth,

To use net.eth0 you also need net.ifnames=0 on your kernel line.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
The_Great_Sephiroth
Veteran
Veteran


Joined: 03 Oct 2014
Posts: 1364
Location: Fayetteville, NC, USA

PostPosted: Mon Jul 13, 2015 1:22 pm    Post subject: Reply with quote

Neddy, I have that on my kernel command line in /boot/grub/grub.cfg and still nothing. I need to be able to SEE the console to do anything. Using lspci and lsusb was of little help also.

Screenshot

I have drivers compiled into my kernel for those devices, but it isn't showing me the Xen Ethernet/network interface, yet it works on the live DVD. As far as frame buffer devices go, I have the Cirrus driver and Xen driver on and everything else off.
_________________
Ever picture systemd as what runs "The Borg"?
Back to top
View user's profile Send private message
The_Great_Sephiroth
Veteran
Veteran


Joined: 03 Oct 2014
Posts: 1364
Location: Fayetteville, NC, USA

PostPosted: Mon Jul 13, 2015 3:05 pm    Post subject: Reply with quote

Still stuck. I have blown a week just trying to get Gentoo to show me a tty in XenServer. At this point I am beginning to believe that Gentoo does something abnormal. I need an answer. Can Gentoo work inside XenServer or are they no longer compatible? I am pulling my hair out! We have no phones in the entire company because I cannot see a stupid console! I can make DOS work in XenServer, but not Gentoo?!
_________________
Ever picture systemd as what runs "The Borg"?
Back to top
View user's profile Send private message
The_Great_Sephiroth
Veteran
Veteran


Joined: 03 Oct 2014
Posts: 1364
Location: Fayetteville, NC, USA

PostPosted: Mon Jul 13, 2015 3:27 pm    Post subject: Reply with quote

I see a message "Console: switching to a colour frame buffer device 80x30" in my dmesg log. Shouldn't that be 80x25?
_________________
Ever picture systemd as what runs "The Borg"?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43198
Location: 56N 3W

PostPosted: Mon Jul 13, 2015 4:16 pm    Post subject: Reply with quote

Message
The_Great_Sephiroth,

That console message says its switching to a framebuffer console.
Its only fixed at 80x25 if you use the VGA console.

There is at least one dev uses Xen. Hes been working on Xen on ARM with some success.

Post your kernel .config and your bootloader config file.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
The_Great_Sephiroth
Veteran
Veteran


Joined: 03 Oct 2014
Posts: 1364
Location: Fayetteville, NC, USA

PostPosted: Tue Jul 14, 2015 1:43 pm    Post subject: Reply with quote

Sorry, I zeroed the virtual disk and installed Debian 7.8 for now. Our company was without phones for a full day and I did not have time to play for a week figuring things out. I will be revisiting Gentoo under Xen AFTER I am sure our phones are working correctly. I can then start a discussion on the matter. This is nothing personal, we just need our business to function. Oh, and I chose Debian 7.8 to avoid systemd.
_________________
Ever picture systemd as what runs "The Borg"?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum