Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Someone got a working ebuild for Atom?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
avx
Advocate
Advocate


Joined: 21 Jun 2004
Posts: 2152

PostPosted: Tue Jul 07, 2015 9:02 pm    Post subject: Someone got a working ebuild for Atom? Reply with quote

I wanted to give Atom a spin to see what all the fuzz & hype is about, but so far I only found ebuilds in the aegypius overlay and they fail to build(already tried downgrading nodejs to stable as that could be a problem listed in one of the issues filed).

Trying to build manually according to this page works, however I'd prefer an ebuild of course, which currently fails on dep atom-shell with
Code:
> node-gyp rebuild

make: Entering directory '/var/tmp/portage/dev-util/atom-shell-9999/work/atom-shell-9999/node_modules/runas/build'
  CXX(target) Release/obj.target/runas/src/main.o
/var/tmp/portage/dev-util/atom-shell-9999/work/atom-shell-9999/vendor/llvm-build/Release+Asserts/bin/clang++: error while loading shared libraries: libtinfo.so.5: cannot open shared object file: No such file or directory
runas.target.mk:88: recipe for target 'Release/obj.target/runas/src/main.o' failed
make: *** [Release/obj.target/runas/src/main.o] Error 127
make: Leaving directory '/var/tmp/portage/dev-util/atom-shell-9999/work/atom-shell-9999/node_modules/runas/build'
gyp ERR! build error
gyp ERR! stack Error: `make` failed with exit code: 2
gyp ERR! stack     at ChildProcess.onExit (/usr/lib64/node_modules/npm/node_modules/node-gyp/lib/build.js:269:23)
gyp ERR! stack     at ChildProcess.emit (events.js:110:17)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (child_process.js:1074:12)
gyp ERR! System Linux 4.1.1-gentoo-r1
gyp ERR! command "node" "/usr/lib64/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /var/tmp/portage/dev-util/atom-shell-9999/work/atom-shell-9999/node_modules/runas
gyp ERR! node -v v0.12.6
gyp ERR! node-gyp -v v2.0.1
gyp ERR! not ok
npm ERR! Linux 4.1.1-gentoo-r1
npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install"
npm ERR! node v0.12.6
npm ERR! npm  v2.11.2
npm ERR! code ELIFECYCLE

npm ERR! runas@2.0.0 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the runas@2.0.0 install script 'node-gyp rebuild'.
npm ERR! This is most likely a problem with the runas package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-gyp rebuild
npm ERR! You can get their info via:
npm ERR!     npm owner ls runas
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!     /var/tmp/portage/dev-util/atom-shell-9999/work/atom-shell-9999/npm-debug.log

Traceback (most recent call last):
  File "./script/bootstrap.py", line 189, in <module>
    sys.exit(main())
  File "./script/bootstrap.py", line 41, in main
[/mnt/old/avx/downloads/p2p/usenet/atom][hikaru]                                                                                                                                                                               [22:57]B
  File "./script/bootstrap.py", line 127, in update_node_modules
    execute_stdout(args, env)
  File "/var/tmp/portage/dev-util/atom-shell-9999/work/atom-shell-9999/script/lib/util.py", line 178, in execute_stdout
    execute(argv, env)
  File "/var/tmp/portage/dev-util/atom-shell-9999/work/atom-shell-9999/script/lib/util.py", line 166, in execute
    raise e
subprocess.CalledProcessError: Command '['npm', 'install']' returned non-zero exit status 1
 * ERROR: dev-util/atom-shell-9999::aegypius failed (prepare phase):
 *   bootstrap failed
 *
 * Call stack:
 *     ebuild.sh, line  93:  Called src_prepare
 *   environment, line 3685:  Called die
 * The specific snippet of code:
 *       ./script/bootstrap.py || die "bootstrap failed";
 *
 * If you need support, post the output of `emerge --info '=dev-util/atom-shell-9999::aegypius'`,
 * the complete build log and the output of `emerge -pqv '=dev-util/atom-shell-9999::aegypius'`.
 * The complete build log is located at '/var/tmp/portage/dev-util/atom-shell-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-util/atom-shell-9999/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-util/atom-shell-9999/work/atom-shell-9999'
 * S: '/var/tmp/portage/dev-util/atom-shell-9999/work/atom-shell-9999'

>>> Failed to emerge dev-util/atom-shell-9999

 * Messages for package dev-util/atom-shell-9999:

 * ERROR: dev-util/atom-shell-9999::aegypius failed (prepare phase):
 *   bootstrap failed
 *
 * Call stack:
 *     ebuild.sh, line  93:  Called src_prepare
 *   environment, line 3685:  Called die
 * The specific snippet of code:
 *       ./script/bootstrap.py || die "bootstrap failed";
 *
 * If you need support, post the output of `emerge --info '=dev-util/atom-shell-9999::aegypius'`,
 * the complete build log and the output of `emerge -pqv '=dev-util/atom-shell-9999::aegypius'`.
 * The complete build log is located at '/var/tmp/portage/dev-util/atom-shell-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-util/atom-shell-9999/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-util/atom-shell-9999/work/atom-shell-9999'
 * S: '/var/tmp/portage/dev-util/atom-shell-9999/work/atom-shell-9999'


Anyone got a working ebuild?
_________________
++++++++++[>+++++++>++++++++++>+++>+<<<<-]>++.>+.+++++++..+++.>++.<<+++++++++++++++.>.+++.------.--------.>+.>.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2657

PostPosted: Wed Jul 08, 2015 5:43 am    Post subject: Re: Someone got a working ebuild for Atom? Reply with quote

avx wrote:
I wanted to give Atom a spin to see what all the fuzz & hype is about, but so far I only found ebuilds in the aegypius overlay and they fail to build(already tried downgrading nodejs to stable as that could be a problem listed in one of the issues filed).

[...]

Anyone got a working ebuild?
Could you use one from http://gpo.zugaina.org/app-editors/atom?
Back to top
View user's profile Send private message
avx
Advocate
Advocate


Joined: 21 Jun 2004
Posts: 2152

PostPosted: Wed Jul 08, 2015 10:19 am    Post subject: Reply with quote

Thanks, will check them out. So far I tried emc overlay, same error as above. Edit, the one from jorgicio overlay works.
_________________
++++++++++[>+++++++>++++++++++>+++>+<<<<-]>++.>+.+++++++..+++.>++.<<+++++++++++++++.>.+++.------.--------.>+.>.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum