Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201507-09 ] PyPAM
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2226

PostPosted: Thu Jul 09, 2015 7:26 pm    Post subject: [ GLSA 201507-09 ] PyPAM Reply with quote

Gentoo Linux Security Advisory

Title: PyPAM: Arbitrary code execution (GLSA 201507-09)
Severity: normal
Exploitable: remote
Date: July 09, 2015
Bug(s): #407603
ID: 201507-09

Synopsis

A double free vulnerability in PyPAM could result in execution of
arbitrary code or Denial of Service.


Background

PyPAM is a PAM binding for Python.

Affected Packages

Package: dev-python/pypam
Vulnerable: < 0.5.0-r3
Unaffected: >= 0.5.0-r3
Architectures: All supported architectures


Description

PyPAM does not handle passwords correctly if there is NULL byte in the
string.


Impact

A remote attacker could possibly execute arbitrary code or cause a
Denial of Service condition.


Workaround

There is no known workaround at this time.

Resolution

All PyPAM users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-python/pypam-0.5.0-r3"
   


References

CVE-2012-1502
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum