Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sshguard fails to start
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
deltamalloc
Apprentice
Apprentice


Joined: 18 Jan 2013
Posts: 279

PostPosted: Sat Jul 11, 2015 6:08 pm    Post subject: sshguard fails to start Reply with quote

On a new Gentoo system, stable, I cannot get sshguard to start up.

I've followed the simple steps outlined at: https://wiki.gentoo.org/wiki/Sshguard

I've done:

Code:

emerge --ask app-admin/sshguard
emerge --ask net-firewall/iptables
iptables -N sshguard
iptables -A INPUT -j sshguard


My /etc/conf.d/sshguard.conf:

Code:

PARDONTIME="3600" # Blocks last at least 1 hour (3600 seconds)
WATCHTIME="360"   # Track IP addresses for 5 minutes (360 seconds)
THRESHOLD="10"    # How many problematic attempts trigger a block
 
LOGFILES="-l /var/log/messages"                      # Watch this file...
LOGFILES="${LOGFILES} -l /var/log/auth.log"          # And this one
 
SSHGUARD_OPTS="-p ${PARDONTIME} -s ${WATCHTIME} -a ${THRESHOLD} ${LOGFILES}"


This happens when I attempt to start sshguard:

Code:

# rc-service sshguard start
 * Starting sshguard ...
 * start-stop-daemon: caught an interrupt
 * start-stop-daemon: /usr/sbin/sshguard died                                                                                              [ !! ]
 * ERROR: sshguard failed to start


When I start sshguard manually:

Code:

# sshguard
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         
sshguard   all  --  anywhere             anywhere           

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination         

Chain sshguard (1 references)
target     prot opt source               destination         
^Csh: /sbin/ip6tables: No such file or directory


Note that I terminated sshguard with CTRL+C, it does not terminate by itself.

Version:

Code:

# sshguard -v
sshguard 1.5.
# iptables -v
iptables v1.4.21: no command specified


I don't have IPv6 support, I don't use it. I have -ipv6 as a global USE flag. I'm assuming it is not related to the issue with OpenRC not being able to start the program.
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Sun Jul 12, 2015 8:58 am    Post subject: Reply with quote

well

sh: /sbin/ip6tables: No such file or directory


worth a try to enabling ipv6 and test it out than. that thing clearly states that it can not find that file
Back to top
View user's profile Send private message
deltamalloc
Apprentice
Apprentice


Joined: 18 Jan 2013
Posts: 279

PostPosted: Sun Jul 12, 2015 7:09 pm    Post subject: Reply with quote

tw04l124 wrote:
well

sh: /sbin/ip6tables: No such file or directory


worth a try to enabling ipv6 and test it out than. that thing clearly states that it can not find that file


It does not terminate, I terminate it manually with CTRL+C, the missing ip6tables binary doesn't prevent it from running.

Why would I enable ipv6 when I don't use ipv6? I agree it might just work, however, in that case I should file a bug report for this issue? Why should it not work without ipv6?
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Mon Jul 13, 2015 10:54 am    Post subject: Reply with quote

just a guess and personal opinion.

those issues i had with ebuilds or binaries / software which did not run because the required stuff was not found sometimes get fixed when i provided the "kernel settings / module" or the feature.

i would not be surprised that any newer software will be / was build with ipv6 in mind and was not tested with ipv4 or wont wortk with ipv4 only..

Feel free to submit a bug report but my bugs are still open for a long time for various ebuilds.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum