Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Trying to emerge banshee causes a lot of blocking packages
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
leonchik1976
Apprentice
Apprentice


Joined: 24 Jan 2010
Posts: 176

PostPosted: Mon Aug 24, 2015 3:35 am    Post subject: Trying to emerge banshee causes a lot of blocking packages Reply with quote

# emerge banshee -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] media-libs/libsoundtouch-1.9.0::gentoo USE="openmp -static-libs" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse" 166 KiB
[ebuild UD ] dev-lang/mono-3.12.1::gentoo [4.0.3.20::gentoo] USE="nls -debug% (-doc) -minimal -pax_kernel -xen" 71,766 KiB
[ebuild NS ] sys-devel/automake-1.10.3-r1:1.10::gentoo [1.11.6-r1:1.11::gentoo, 1.13.4:1.13::gentoo, 1.14.1:1.14::gentoo, 1.15:1.15::gentoo] 936 KiB
[ebuild N ] dev-dotnet/dbus-sharp-0.7.0-r1::gentoo 125 KiB
[ebuild N ] dev-dotnet/google-gdata-sharp-1.4.0.2-r2::gentoo 2,042 KiB
[ebuild N ] dev-dotnet/taglib-sharp-2.1.0.0::gentoo 503 KiB
[ebuild N ] dev-dotnet/gtk-sharp-gapi-2.12.10:2::gentoo USE="-debug" 1,601 KiB
[ebuild N ] dev-dotnet/glib-sharp-2.12.10:2::gentoo USE="-debug" 0 KiB
[ebuild N ] dev-dotnet/dbus-sharp-glib-0.5.0::gentoo 94 KiB
[ebuild N ] media-plugins/gst-plugins-soundtouch-0.10.23-r1:0.10::gentoo ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild N ] dev-dotnet/pango-sharp-2.12.10:2::gentoo USE="-debug" 0 KiB
[ebuild N ] dev-dotnet/gio-sharp-0.3::gentoo 88 KiB
[ebuild N ] dev-dotnet/atk-sharp-2.12.10:2::gentoo USE="-debug" 0 KiB
[ebuild N ] dev-dotnet/gkeyfile-sharp-0.1::gentoo 20 KiB
[ebuild N ] dev-dotnet/mono-addins-1.0-r1::gentoo USE="gtk" 537 KiB
[ebuild N ] dev-dotnet/art-sharp-2.24.2:2::gentoo USE="-debug" 412 KiB
[ebuild N ] dev-dotnet/gdk-sharp-2.12.10:2::gentoo USE="-debug" 0 KiB
[ebuild NS ] media-libs/musicbrainz-3.0.3:3::gentoo [5.0.1:5::gentoo] USE="{-test}" 104 KiB
[ebuild N ] dev-dotnet/gtk-sharp-beans-2.14.0::gentoo 21 KiB
[ebuild UD ] dev-dotnet/gtk-sharp-2.12.10:2::gentoo [2.12.21:2::gentoo] USE="-debug" 0 KiB
[ebuild N ] dev-dotnet/gudev-sharp-0.1::gentoo 101 KiB
[ebuild N ] dev-dotnet/glade-sharp-2.12.10:2::gentoo USE="-debug" 0 KiB
[ebuild N ] dev-dotnet/notify-sharp-0.4.0_pre20090305::gentoo USE="-doc" 78 KiB
[ebuild NS ] net-libs/webkit-gtk-2.4.9-r200:2::gentoo [2.4.9:3/25::gentoo, 2.8.5:4/37::gentoo] USE="X egl geoloc gstreamer introspection jit libsecret opengl spell webgl (-aqua) -coverage -debug -gles2 {-test}" 0 KiB
[ebuild N ] dev-dotnet/gnome-sharp-2.24.2-r1:2::gentoo USE="-debug" 0 KiB
[ebuild N ] dev-dotnet/gconf-sharp-2.24.2:2::gentoo USE="-debug" 0 KiB
[ebuild N ] media-sound/banshee-2.6.2::gentoo USE="aac bpm cdda encode ipod udev web youtube -daap -doc -karma -mtp {-test}" 3,294 KiB
[blocks B ] dev-dotnet/gtk-sharp-gapi ("dev-dotnet/gtk-sharp-gapi" is blocking dev-dotnet/gtk-sharp-2.12.21)
[blocks B ] dev-dotnet/pango-sharp ("dev-dotnet/pango-sharp" is blocking dev-dotnet/gtk-sharp-2.12.21)
[blocks B ] dev-dotnet/gdk-sharp ("dev-dotnet/gdk-sharp" is blocking dev-dotnet/gtk-sharp-2.12.21)
[blocks B ] dev-dotnet/gconf-sharp ("dev-dotnet/gconf-sharp" is blocking dev-dotnet/gnome-sharp-2.24.2-r1)
[blocks B ] dev-dotnet/art-sharp ("dev-dotnet/art-sharp" is blocking dev-dotnet/gnome-sharp-2.24.2-r1)
[blocks B ] dev-dotnet/atk-sharp ("dev-dotnet/atk-sharp" is blocking dev-dotnet/gtk-sharp-2.12.21)
[blocks B ] dev-dotnet/glade-sharp ("dev-dotnet/glade-sharp" is blocking dev-dotnet/gtk-sharp-2.12.21)
[blocks B ] dev-dotnet/glib-sharp ("dev-dotnet/glib-sharp" is blocking dev-dotnet/gtk-sharp-2.12.21)

Total: 27 packages (2 downgrades, 22 new, 3 in new slots), Size of downloads: 81,878 KiB
Conflict: 8 blocks (8 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-dotnet/gtk-sharp:2

(dev-dotnet/gtk-sharp-2.12.21:2/2::gentoo, installed) pulled in by
>=dev-dotnet/gtk-sharp-2.12.21:2 required by (dev-dotnet/gnome-sharp-2.24.2-r1:2/2::gentoo, ebuild scheduled for merge)
^^ ^^^^^^^^^
(and 1 more with the same problem)

(dev-dotnet/gtk-sharp-2.12.10:2/2::gentoo, ebuild scheduled for merge) pulled in by
~dev-dotnet/gtk-sharp-2.12.10 required by (dev-dotnet/glade-sharp-2.12.10:2/2::gentoo, ebuild scheduled for merge)
^ ^^^^^^^


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(dev-dotnet/pango-sharp-2.12.10:2/2::gentoo, ebuild scheduled for merge) pulled in by
~dev-dotnet/pango-sharp-2.12.10 required by (dev-dotnet/gtk-sharp-2.12.10:2/2::gentoo, ebuild scheduled for merge)
~dev-dotnet/pango-sharp-2.12.10 required by (dev-dotnet/glade-sharp-2.12.10:2/2::gentoo, ebuild scheduled for merge)
~dev-dotnet/pango-sharp-2.12.10 required by (dev-dotnet/gdk-sharp-2.12.10:2/2::gentoo, ebuild scheduled for merge)

(dev-dotnet/gconf-sharp-2.24.2:2/2::gentoo, ebuild scheduled for merge) pulled in by
>=dev-dotnet/gconf-sharp-2.24.0:2 required by (media-sound/banshee-2.6.2:0/0::gentoo, ebuild scheduled for merge)

(dev-dotnet/gdk-sharp-2.12.10:2/2::gentoo, ebuild scheduled for merge) pulled in by
~dev-dotnet/gdk-sharp-2.12.10 required by (dev-dotnet/gtk-sharp-2.12.10:2/2::gentoo, ebuild scheduled for merge)
~dev-dotnet/gdk-sharp-2.12.10 required by (dev-dotnet/glade-sharp-2.12.10:2/2::gentoo, ebuild scheduled for merge)

(dev-dotnet/glib-sharp-2.12.10:2/2::gentoo, ebuild scheduled for merge) pulled in by
>=dev-dotnet/glib-sharp-2.12.9 required by (dev-dotnet/gkeyfile-sharp-0.1:0/0::gentoo, ebuild scheduled for merge)
>=dev-dotnet/glib-sharp-2.12 required by (dev-dotnet/gio-sharp-0.3:0/0::gentoo, ebuild scheduled for merge)
~dev-dotnet/glib-sharp-2.12.10 required by (dev-dotnet/gtk-sharp-2.12.10:2/2::gentoo, ebuild scheduled for merge)
>=dev-dotnet/glib-sharp-2.12 required by (dev-dotnet/gtk-sharp-beans-2.14.0:0/0::gentoo, ebuild scheduled for merge)
~dev-dotnet/glib-sharp-2.12.10 required by (dev-dotnet/glade-sharp-2.12.10:2/2::gentoo, ebuild scheduled for merge)
~dev-dotnet/glib-sharp-2.12.10 required by (dev-dotnet/atk-sharp-2.12.10:2/2::gentoo, ebuild scheduled for merge)
~dev-dotnet/glib-sharp-2.12.10 required by (dev-dotnet/pango-sharp-2.12.10:2/2::gentoo, ebuild scheduled for merge)
~dev-dotnet/glib-sharp-2.12.10 required by (dev-dotnet/gdk-sharp-2.12.10:2/2::gentoo, ebuild scheduled for merge)

(dev-dotnet/atk-sharp-2.12.10:2/2::gentoo, ebuild scheduled for merge) pulled in by
~dev-dotnet/atk-sharp-2.12.10 required by (dev-dotnet/glade-sharp-2.12.10:2/2::gentoo, ebuild scheduled for merge)
~dev-dotnet/atk-sharp-2.12.10 required by (dev-dotnet/gtk-sharp-2.12.10:2/2::gentoo, ebuild scheduled for merge)

(dev-dotnet/gtk-sharp-gapi-2.12.10:2/2::gentoo, ebuild scheduled for merge) pulled in by
>=dev-dotnet/gtk-sharp-gapi-2.12 required by (dev-dotnet/gio-sharp-0.3:0/0::gentoo, ebuild scheduled for merge)
>=dev-dotnet/gtk-sharp-gapi-1.9 required by (dev-dotnet/gudev-sharp-0.1:0/0::gentoo, ebuild scheduled for merge)
>=dev-dotnet/gtk-sharp-gapi-1.9 required by (dev-dotnet/gkeyfile-sharp-0.1:0/0::gentoo, ebuild scheduled for merge)
~dev-dotnet/gtk-sharp-gapi-2.12.10 required by (dev-dotnet/glade-sharp-2.12.10:2/2::gentoo, ebuild scheduled for merge)
~dev-dotnet/gtk-sharp-gapi-2.12.10 required by (dev-dotnet/gtk-sharp-2.12.10:2/2::gentoo, ebuild scheduled for merge)
>=dev-dotnet/gtk-sharp-gapi-2.12 required by (dev-dotnet/gtk-sharp-beans-2.14.0:0/0::gentoo, ebuild scheduled for merge)
~dev-dotnet/gtk-sharp-gapi-2.12.10 required by (dev-dotnet/atk-sharp-2.12.10:2/2::gentoo, ebuild scheduled for merge)
~dev-dotnet/gtk-sharp-gapi-2.12.10 required by (dev-dotnet/pango-sharp-2.12.10:2/2::gentoo, ebuild scheduled for merge)
~dev-dotnet/gtk-sharp-gapi-2.12.10 required by (dev-dotnet/gdk-sharp-2.12.10:2/2::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum