Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cannot configure timezone or locale (uclibc tarball)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
thurnax
Tux's lil' helper
Tux's lil' helper


Joined: 17 Apr 2014
Posts: 90

PostPosted: Sat Jul 25, 2015 11:07 pm    Post subject: Cannot configure timezone or locale (uclibc tarball) Reply with quote

When following the installation handbook, there is a section covering the configuration of timezones and locale. The problem however is that there are no files for timezone found, i.e. the path '/usr/share/zoneinfo' is non-existent.

Also, when trying to issue

Code:
emerge --config sys-libs/timezone-data


it merely returns

Code:
Package not found.


and I'm unable to issue the 'locale-gen' command. I read on a very old thread that different installation instructions follow for uclibc based stage3 non-hardened/vanilla tarballs. I'm unable to find any installation instructions. But I don't understand this, at one stage or another the unicode locales and timezones must be set. Does anyone know how to proceed with this?


Last edited by thurnax on Thu Jul 30, 2015 10:13 pm; edited 1 time in total
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7561
Location: Goose Creek SC

PostPosted: Sun Jul 26, 2015 3:54 am    Post subject: Reply with quote

probably not actually in the chroot when running those commands
_________________
Defund the FCC.
Back to top
View user's profile Send private message
thurnax
Tux's lil' helper
Tux's lil' helper


Joined: 17 Apr 2014
Posts: 90

PostPosted: Sun Jul 26, 2015 10:27 am    Post subject: Reply with quote

No, I have chrooted alright. I think I found the problem; uclibc doesn't support locale the same way the other tarballs do. The Debian scripts 'locale-gen' etc don't exist in the tarball. There is a thread that discusses this in slightly more detail:

https://forums.gentoo.org/viewtopic-p-7555090.html

I don't really understand how to proceed here or how the guy solved the issue with the 'sys-libs/timezone-data' package by emerging it 'manually'. The uclibc specific handbook that is mentioned in that thread cannot be found.

But, it doesn't seem that I really need to use uclibc. Uclibc is apparently a lightweight environment for embedded systems. I mistakenly chose uclibc as I wanted to switch from a no-multilib to a multilib environment. When I went through the download page of Gentoo I went straight to the 'advanced' alternatives. When choosing between no-multilib and multilib, the uclibc sounded appealing as it has 'lib' in it. It didn't appear to me that the very first alternatives on the top of the page was what I was looking for.

I have now chosen the standard environment with multilib support, and things seem to work fine so far, I'm doing a world update so within a day or so I will get to find out how well that went...

Edit: That went well, so I'm satisfied with my situation here. However, it should be noted that this topic is still unresolved although I no longer have any interest in the resolution of it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum