Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Dantrell's GNOME Without Systemd Project (Part 1)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 12, 13, 14 ... 27, 28, 29  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
mingdao
n00b
n00b


Joined: 19 Sep 2011
Posts: 10
Location: Alabama, USA

PostPosted: Mon Sep 04, 2017 1:04 am    Post subject: depclean wants to take out Reply with quote

After getting gnome-3.24 emerged, I synced and updated with:
Code:
eix-sync && emerge -aDNtuv @world && dispatch-conf && emerge -a --depclean

However, depclean wants to remove 166 files:
Code:
mingdao@workstation ~ $ cat depclean-madness
>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.
 * After world updates, it is important to remove obsolete packages with
 * emerge --depclean. Refer to `man emerge` for more information.

 * Always study the list of packages to be cleaned for any obvious
 * mistakes. Packages that are part of the world set will always
 * be kept.  They can be manually added to this set with
 * `emerge --noreplace <atom>`.  Packages that are listed in
 * package.provided (see portage(5)) will be removed by
 * depclean, even if they are part of the world set.
 *
 * As a safety measure, depclean will not remove any packages
 * unless *all* required dependencies have been resolved.  As a
 * consequence of this, it often becomes necessary to run
 * `emerge --update --newuse --deep @world` prior to depclean.

Calculating dependencies... done!
>>> Calculating removal order...

>>> These are the packages that would be unmerged:

 x11-proto/glproto
    selected: 1.4.17-r1
   protected: none
     omitted: none

 x11-libs/libcryptui
    selected: 3.12.2
   protected: none
     omitted: none

 dev-libs/check
    selected: 0.10.0-r1
   protected: none
     omitted: none

 virtual/libusb
    selected: 0-r2
   protected: none
     omitted: 1-r2

 dev-util/gperf
    selected: 3.0.4
   protected: none
     omitted: none

 x11-proto/trapproto
    selected: 3.4.3
   protected: none
     omitted: none

 app-text/enchant
    selected: 1.6.0
   protected: none
     omitted: none

 sys-devel/automake
    selected: 1.11.6-r1
   protected: none
     omitted: none

 x11-misc/icon-naming-utils
    selected: 0.8.90-r1
   protected: none
     omitted: none

 app-text/po4a
    selected: 0.47-r1
   protected: none
     omitted: none

 dev-scheme/guile
    selected: 2.0.14-r1
   protected: none
     omitted: none

 app-arch/zip
    selected: 3.0-r3
   protected: none
     omitted: none

 x11-proto/dri2proto
    selected: 2.8-r1
   protected: none
     omitted: none

 dev-libs/cyrus-sasl
    selected: 2.1.26-r9
   protected: none
     omitted: none

 dev-python/docutils
    selected: 0.12
   protected: none
     omitted: none

 dev-util/gtk-doc
    selected: 1.25-r1
   protected: none
     omitted: none

 app-doc/xmltoman
    selected: 0.4
   protected: none
     omitted: none

 gnome-base/gnome-common
    selected: 3.18.0
   protected: none
     omitted: none

 dev-util/cppunit
    selected: 1.13.2-r2
   protected: none
     omitted: none

 sys-devel/clang-runtime
    selected: 3.9.1
   protected: none
     omitted: none

 media-libs/libsdl2
    selected: 2.0.4
   protected: none
     omitted: none

 sys-apps/lsb-release
    selected: 1.4
   protected: none
     omitted: none

 x11-proto/scrnsaverproto
    selected: 1.2.2-r1
   protected: none
     omitted: none

 x11-proto/xcmiscproto
    selected: 1.2.2
   protected: none
     omitted: none

 sys-auth/consolekit
    selected: 1.1.2
   protected: none
     omitted: none


!!! 'app-editors/nano' (virtual/editor) is part of your system profile.
!!! Unmerging it may be damaging to your system.


 app-editors/nano
    selected: 2.7.5
   protected: none
     omitted: none

 dev-lang/vala
    selected: 0.26.2
   protected: none
     omitted: 0.36.4

 media-fonts/liberation-fonts
    selected: 2.00.1-r1
   protected: none
     omitted: none

 x11-proto/xf86driproto
    selected: 2.1.1-r1
   protected: none
     omitted: none

 sys-libs/gpm
    selected: 1.20.7-r2
   protected: none
     omitted: none

 gnome-extra/polkit-gnome
    selected: 0.105-r1
   protected: none
     omitted: none

 x11-proto/xf86rushproto
    selected: 1.1.2-r1
   protected: none
     omitted: none

 x11-wm/twm
    selected: 1.0.9
   protected: none
     omitted: none

 x11-proto/dri3proto
    selected: 1.0
   protected: none
     omitted: none

 x11-terms/xterm
    selected: 327
   protected: none
     omitted: none

 app-text/xmlto
    selected: 0.0.26-r1
   protected: none
     omitted: none

 app-text/gnome-doc-utils
    selected: 0.20.10-r1
   protected: none
     omitted: none

 x11-apps/bdftopcf
    selected: 1.0.5
   protected: none
     omitted: none

 sys-apps/paxctl
    selected: 0.9
   protected: none
     omitted: none

 dev-python/m2crypto
    selected: 0.24.0
   protected: none
     omitted: none

 mail-filter/bogofilter
    selected: 1.2.4-r1
   protected: none
     omitted: none

 sys-devel/autoconf
    selected: 2.13
   protected: none
     omitted: none

 x11-apps/xsm
    selected: 1.0.3
   protected: none
     omitted: none

 x11-proto/presentproto
    selected: 1.1
   protected: none
     omitted: none

 app-text/docbook-sgml-utils
    selected: 0.6.14-r1
   protected: none
     omitted: none

 app-i18n/unicode-emoji
    selected: 5.0
   protected: none
     omitted: none

 media-libs/glew
    selected: 1.13.0
   protected: none
     omitted: none

 media-libs/xvid
    selected: 1.3.3
   protected: none
     omitted: none

 media-sound/lame
    selected: 3.99.5-r1
   protected: none
     omitted: none

 app-i18n/unicode-cldr
    selected: 31.0.1
   protected: none
     omitted: none

 media-libs/x264
    selected: 0.0.20160712
   protected: none
     omitted: none

 app-text/mupdf
    selected: 1.11-r1
   protected: none
     omitted: none

 x11-apps/xclock
    selected: 1.0.7
   protected: none
     omitted: none

 x11-proto/bigreqsproto
    selected: 1.1.2
   protected: none
     omitted: none

 dev-lang/nasm
    selected: 2.12.01
   protected: none
     omitted: none

 app-text/rarian
    selected: 0.8.1-r3
   protected: none
     omitted: none

 gnome-base/libgnome-keyring
    selected: 3.12.0-r1
   protected: none
     omitted: none

 dev-libs/libusb-compat
    selected: 0.1.5-r2
   protected: none
     omitted: none

 app-arch/pax
    selected: 3.4.12.16
   protected: none
     omitted: none

 sys-libs/libomp
    selected: 3.9.1
   protected: none
     omitted: none

 dev-perl/XML-Simple
    selected: 2.220.0
   protected: none
     omitted: none

 dev-perl/TermReadKey
    selected: 2.330.0
   protected: none
     omitted: none

 dev-perl/Text-WrapI18N
    selected: 0.60.0-r1
   protected: none
     omitted: none

 dev-perl/Module-Build
    selected: 0.421.600
   protected: none
     omitted: none

 net-mail/mailbase
    selected: 1.1
   protected: none
     omitted: none

 dev-python/pygments
    selected: 2.1.1
   protected: none
     omitted: none

 app-text/yelp-tools
    selected: 3.18.0
   protected: none
     omitted: none

 sys-devel/autoconf-archive
    selected: 2016.03.20-r1
   protected: none
     omitted: none

 app-text/docbook-sgml-dtd
    selected: 3.1-r3
   protected: none
     omitted: none

 x11-libs/libXfont
    selected: 1.5.2
   protected: none
     omitted: none

 sci-libs/gsl
    selected: 1.16
   protected: none
     omitted: none

 app-text/docbook-xml-simple-dtd
    selected: 1.0-r1
   protected: none
     omitted: none

 media-libs/glfw
    selected: 3.2.1
   protected: none
     omitted: none

 app-text/docbook-sgml-dtd
    selected: 4.1-r3
   protected: none
     omitted: none

 app-text/docbook-sgml-dtd
    selected: 4.0-r3
   protected: none
     omitted: none

 sys-libs/libutempter
    selected: 1.1.6-r2
   protected: none
     omitted: none

 app-text/docbook-xml-simple-dtd
    selected: 4.1.2.4-r2
   protected: none
     omitted: none

 sys-devel/binutils
    selected: 2.28-r2
   protected: none
     omitted: 2.28.1

 dev-lang/swig
    selected: 3.0.12
   protected: none
     omitted: none

 app-text/docbook-xml-dtd
    selected: 4.5-r1
   protected: none
     omitted: none

 app-text/docbook-sgml-dtd
    selected: 3.0-r3
   protected: none
     omitted: none

 virtual/w3m
    selected: 0
   protected: none
     omitted: none

 dev-perl/SGMLSpm
    selected: 1.03-r7
   protected: none
     omitted: none

 app-text/openjade
    selected: 1.3.2-r7
   protected: none
     omitted: none

 app-text/docbook-xml-dtd
    selected: 4.1.2-r6
   protected: none
     omitted: none

 app-text/docbook-xml-dtd
    selected: 4.2-r2
   protected: none
     omitted: none

 dev-lang/yasm
    selected: 1.3.0
   protected: none
     omitted: none

 app-text/docbook-xml-dtd
    selected: 4.3-r1
   protected: none
     omitted: none

 app-text/docbook-dsssl-stylesheets
    selected: 1.79
   protected: none
     omitted: none

 app-text/docbook-xml-dtd
    selected: 4.4-r2
   protected: none
     omitted: none

 sys-apps/texinfo
    selected: 6.3
   protected: none
     omitted: none

 dev-perl/libintl-perl
    selected: 1.240.0-r2
   protected: none
     omitted: none

 dev-util/ninja
    selected: 1.7.2
   protected: none
     omitted: none

 dev-perl/XML-SAX-Expat
    selected: 0.510.0
   protected: none
     omitted: none

 app-arch/rpm2targz
    selected: 9.0.0.5g
   protected: none
     omitted: none

 virtual/perl-Getopt-Long
    selected: 2.480.0-r1
   protected: none
     omitted: none

 www-client/w3m
    selected: 0.5.3-r9
   protected: none
     omitted: none

 virtual/perl-Perl-OSType
    selected: 1.9.0-r1
   protected: none
     omitted: none

 dev-libs/tinyxml
    selected: 2.6.2-r2
   protected: none
     omitted: none

 app-eselect/eselect-cblas
    selected: 0.1
   protected: none
     omitted: none

 virtual/perl-Text-ParseWords
    selected: 3.300.0-r3
   protected: none
     omitted: none

 virtual/perl-CPAN-Meta
    selected: 2.150.5-r1
   protected: none
     omitted: none

 dev-perl/Text-CharWidth
    selected: 0.40.0-r1
   protected: none
     omitted: none

 dev-perl/Unicode-EastAsianWidth
    selected: 1.330.0-r1
   protected: none
     omitted: none

 virtual/perl-ExtUtils-Manifest
    selected: 1.700.0-r4
   protected: none
     omitted: none

 virtual/perl-ExtUtils-Install
    selected: 2.40.0-r3
   protected: none
     omitted: none

 virtual/perl-version
    selected: 0.991.600-r1
   protected: none
     omitted: none

 dev-util/itstool
    selected: 2.0.2
   protected: none
     omitted: none

 virtual/perl-Module-Metadata
    selected: 1.0.31-r1
   protected: none
     omitted: none

 virtual/perl-ExtUtils-ParseXS
    selected: 3.310.0-r1
   protected: none
     omitted: none

 virtual/perl-ExtUtils-CBuilder
    selected: 0.280.225-r2
   protected: none
     omitted: none

 dev-perl/Text-Unidecode
    selected: 1.270.0
   protected: none
     omitted: none

 app-text/opensp
    selected: 1.5.2-r3
   protected: none
     omitted: none

 dev-util/cmake
    selected: 3.7.2
   protected: none
     omitted: none

 virtual/awk
    selected: 1
   protected: none
     omitted: none

 dev-util/gtk-doc-am
    selected: 1.25-r1
   protected: none
     omitted: none

 virtual/yacc
    selected: 0
   protected: none
     omitted: none

 dev-util/intltool
    selected: 0.51.0-r1
   protected: none
     omitted: none

 app-text/docbook-xsl-stylesheets
    selected: 1.79.1-r1
   protected: none
     omitted: none

 app-text/sgml-common
    selected: 0.6.3-r5
   protected: none
     omitted: none

 app-arch/unzip
    selected: 6.0_p20
   protected: none
     omitted: none

 dev-util/re2c
    selected: 0.16
   protected: none
     omitted: none

 app-arch/cpio
    selected: 2.12-r1
   protected: none
     omitted: none

 virtual/perl-JSON-PP
    selected: 2.273.0.100_rc-r3
   protected: none
     omitted: none

 dev-libs/libuv
    selected: 1.10.2
   protected: none
     omitted: none

 dev-perl/XML-SAX
    selected: 0.990.0-r1
   protected: none
     omitted: none

 dev-libs/boehm-gc
    selected: 7.4.2
   protected: none
     omitted: none

 sys-devel/bison
    selected: 3.0.4-r1
   protected: none
     omitted: none

 virtual/perl-Parse-CPAN-Meta
    selected: 1.441.700.100_rc-r1
   protected: none
     omitted: none

 virtual/perl-CPAN-Meta-YAML
    selected: 0.18.0-r2
   protected: none
     omitted: none

 dev-perl/XML-Parser
    selected: 2.440.0
   protected: none
     omitted: none

 app-text/build-docbook-catalog
    selected: 1.19.1
   protected: none
     omitted: none

 dev-perl/XML-SAX-Base
    selected: 1.90.0
   protected: none
     omitted: none

 dev-libs/libatomic_ops
    selected: 7.4.2
   protected: none
     omitted: none

 dev-perl/XML-NamespaceSupport
    selected: 1.120.0
   protected: none
     omitted: none

 sys-devel/flex
    selected: 2.6.1
   protected: none
     omitted: none

 virtual/perl-ExtUtils-MakeMaker
    selected: 7.100.200_rc-r1
   protected: none
     omitted: none

 dev-util/ragel
    selected: 6.7-r1
   protected: none
     omitted: none

 dev-ruby/racc
    selected: 1.4.11
   protected: none
     omitted: none

 sys-apps/help2man
    selected: 1.46.6
   protected: none
     omitted: none

 dev-perl/Locale-gettext
    selected: 1.50.0-r1
   protected: none
     omitted: none

 sys-devel/libtool
    selected: 2.4.6-r3
   protected: none
     omitted: none

 sys-devel/automake
    selected: 1.15-r2
   protected: none
     omitted: none

 sys-devel/automake-wrapper
    selected: 10
   protected: none
     omitted: none

 sys-devel/autoconf
    selected: 2.69
   protected: none
     omitted: none

 sys-devel/autoconf-wrapper
    selected: 13
   protected: none
     omitted: none

 sys-devel/m4
    selected: 1.4.17
   protected: none
     omitted: none

 app-portage/elt-patches
    selected: 20170422
   protected: none
     omitted: none

 dev-ruby/minitest
    selected: 5.8.4
   protected: none
     omitted: none

 dev-qt/qttranslations
    selected: 4.8.7
   protected: none
     omitted: none

 dev-ruby/rdoc
    selected: 4.2.0
   protected: none
     omitted: none

 dev-ruby/test-unit
    selected: 3.1.9
   protected: none
     omitted: none

 dev-qt/qt3support
    selected: 4.8.7
   protected: none
     omitted: none

 dev-qt/qtsql
    selected: 4.8.7-r1
   protected: none
     omitted: none

 dev-ruby/json
    selected: 1.8.3
   protected: none
     omitted: none

 dev-qt/qtgui
    selected: 4.8.7
   protected: none
     omitted: none

 dev-qt/qtscript
    selected: 4.8.7
   protected: none
     omitted: none

 app-eselect/eselect-qtgraphicssystem
    selected: 1.1.1
   protected: none
     omitted: none

 media-libs/libmng
    selected: 2.0.2-r1
   protected: none
     omitted: none

 dev-qt/qtcore
    selected: 4.8.7-r2
   protected: none
     omitted: none

 dev-qt/qtchooser
    selected: 0_p20151008
   protected: none
     omitted: none

 dev-ruby/power_assert
    selected: 0.3.1
   protected: none
     omitted: none

 dev-ruby/rake
    selected: 10.5.0
   protected: none
     omitted: none

 virtual/rubygems
    selected: 11
   protected: none
     omitted: none

 dev-ruby/rubygems
    selected: 2.5.2
   protected: none
     omitted: none

 dev-lang/ruby
    selected: 2.2.6
   protected: none
     omitted: none

 app-eselect/eselect-ruby
    selected: 20161226
   protected: none
     omitted: none

All selected packages: =app-text/xmlto-0.0.26-r1 =app-text/gnome-doc-utils-0.20.10-r1 =app-text/docbook-xml-simple-dtd-4.1.2.4-r2 =dev-lang/ruby-2.2.6 =app-portage/elt-patches-20170422 =net-mail/mailbase-1.1 =app-text/opensp-1.5.2-r3 =dev-ruby/test-unit-3.1.9 =dev-ruby/rake-10.5.0 =dev-ruby/rdoc-4.2.0 =sys-devel/automake-wrapper-10 =sci-libs/gsl-1.16 =sys-auth/consolekit-1.1.2 =dev-util/cmake-3.7.2 =sys-devel/m4-1.4.17 =app-text/sgml-common-0.6.3-r5 =virtual/perl-CPAN-Meta-YAML-0.18.0-r2 =app-arch/pax-3.4.12.16 =x11-proto/dri3proto-1.0 =x11-terms/xterm-327 =app-text/docbook-sgml-dtd-4.0-r3 =dev-util/re2c-0.16 =x11-proto/xf86driproto-2.1.1-r1 =app-text/docbook-dsssl-stylesheets-1.79 =sys-devel/autoconf-2.69 =x11-proto/glproto-1.4.17-r1 =x11-proto/dri2proto-2.8-r1 =virtual/perl-CPAN-Meta-2.150.5-r1 =dev-ruby/racc-1.4.11 =dev-perl/libintl-perl-1.240.0-r2 =sys-devel/bison-3.0.4-r1 =dev-python/m2crypto-0.24.0 =app-text/enchant-1.6.0 =dev-util/cppunit-1.13.2-r2 =app-text/docbook-xml-dtd-4.5-r1 =virtual/libusb-0-r2 =app-text/openjade-1.3.2-r7 =app-text/docbook-sgml-utils-0.6.14-r1 =dev-qt/qtcore-4.8.7-r2 =dev-libs/tinyxml-2.6.2-r2 =virtual/awk-1 =x11-proto/scrnsaverproto-1.2.2-r1 =x11-proto/xcmiscproto-1.2.2 =media-sound/lame-3.99.5-r1 =gnome-base/libgnome-keyring-3.12.0-r1 =app-arch/unzip-6.0_p20 =virtual/perl-Perl-OSType-1.9.0-r1 =dev-perl/XML-SAX-Expat-0.510.0 =virtual/perl-ExtUtils-CBuilder-0.280.225-r2 =dev-ruby/rubygems-2.5.2 =mail-filter/bogofilter-1.2.4-r1 =sys-apps/help2man-1.46.6 =app-text/docbook-xsl-stylesheets-1.79.1-r1 =sys-apps/texinfo-6.3 =dev-perl/TermReadKey-2.330.0 =sys-devel/autoconf-wrapper-13 =app-eselect/eselect-qtgraphicssystem-1.1.1 =dev-perl/Text-WrapI18N-0.60.0-r1 =media-libs/glfw-3.2.1 =dev-perl/Text-Unidecode-1.270.0 =dev-qt/qttranslations-4.8.7 =dev-lang/yasm-1.3.0 =sys-devel/binutils-2.28-r2 =sys-devel/automake-1.11.6-r1 =dev-qt/qt3support-4.8.7 =x11-misc/icon-naming-utils-0.8.90-r1 =sys-devel/clang-runtime-3.9.1 =dev-util/ninja-1.7.2 =sys-devel/libtool-2.4.6-r3 =app-text/mupdf-1.11-r1 =x11-apps/xclock-1.0.7 =x11-apps/xsm-1.0.3 =dev-libs/boehm-gc-7.4.2 =x11-apps/bdftopcf-1.0.5 =sys-libs/libutempter-1.1.6-r2 =app-i18n/unicode-cldr-31.0.1 =app-text/po4a-0.47-r1 =app-eselect/eselect-cblas-0.1 =dev-ruby/json-1.8.3 =app-text/rarian-0.8.1-r3 =dev-libs/libatomic_ops-7.4.2 =x11-proto/xf86rushproto-1.1.2-r1 =dev-util/gtk-doc-am-1.25-r1 =dev-perl/XML-NamespaceSupport-1.120.0 =virtual/w3m-0 =dev-perl/SGMLSpm-1.03-r7 =virtual/perl-Getopt-Long-2.480.0-r1 =x11-proto/bigreqsproto-1.1.2 =dev-util/ragel-6.7-r1 =dev-lang/vala-0.26.2 =dev-lang/nasm-2.12.01 =dev-python/pygments-2.1.1 =app-text/docbook-xml-simple-dtd-1.0-r1 =app-text/build-docbook-catalog-1.19.1 =media-libs/x264-0.0.20160712 =app-text/docbook-xml-dtd-4.1.2-r6 =dev-util/gperf-3.0.4 =dev-util/intltool-0.51.0-r1 =dev-libs/check-0.10.0-r1 =media-libs/libmng-2.0.2-r1 =sys-apps/paxctl-0.9 =dev-libs/libusb-compat-0.1.5-r2 =app-text/docbook-xml-dtd-4.4-r2 =dev-qt/qtsql-4.8.7-r1 =virtual/perl-version-0.991.600-r1 =virtual/yacc-0 =app-arch/cpio-2.12-r1 =app-text/yelp-tools-3.18.0 =app-text/docbook-sgml-dtd-4.1-r3 =virtual/perl-Parse-CPAN-Meta-1.441.700.100_rc-r1 =gnome-extra/polkit-gnome-0.105-r1 =app-eselect/eselect-ruby-20161226 =app-text/docbook-sgml-dtd-3.1-r3 =dev-ruby/minitest-5.8.4 =virtual/perl-ExtUtils-MakeMaker-7.100.200_rc-r1 =app-text/docbook-xml-dtd-4.2-r2 =app-editors/nano-2.7.5 =dev-python/docutils-0.12 =app-doc/xmltoman-0.4 =media-libs/libsdl2-2.0.4 =virtual/perl-Text-ParseWords-3.300.0-r3 =dev-scheme/guile-2.0.14-r1 =app-text/docbook-sgml-dtd-3.0-r3 =dev-ruby/power_assert-0.3.1 =virtual/perl-Module-Metadata-1.0.31-r1 =media-libs/glew-1.13.0 =x11-wm/twm-1.0.9 =dev-perl/XML-SAX-0.990.0-r1 =dev-perl/XML-Simple-2.220.0 =virtual/rubygems-11 =dev-qt/qtgui-4.8.7 =virtual/perl-ExtUtils-Install-2.40.0-r3 =app-arch/rpm2targz-9.0.0.5g =media-fonts/liberation-fonts-2.00.1-r1 =virtual/perl-ExtUtils-ParseXS-3.310.0-r1 =dev-util/gtk-doc-1.25-r1 =dev-qt/qtscript-4.8.7 =dev-qt/qtchooser-0_p20151008 =app-arch/zip-3.0-r3 =sys-apps/lsb-release-1.4 =dev-perl/Unicode-EastAsianWidth-1.330.0-r1 =virtual/perl-ExtUtils-Manifest-1.700.0-r4 =x11-libs/libXfont-1.5.2 =x11-libs/libcryptui-3.12.2 =dev-util/itstool-2.0.2 =dev-lang/swig-3.0.12 =dev-perl/XML-SAX-Base-1.90.0 =dev-perl/Locale-gettext-1.50.0-r1 =sys-devel/autoconf-archive-2016.03.20-r1 =dev-libs/cyrus-sasl-2.1.26-r9 =sys-devel/automake-1.15-r2 =dev-libs/libuv-1.10.2 =app-i18n/unicode-emoji-5.0 =dev-perl/XML-Parser-2.440.0 =media-libs/xvid-1.3.3 =x11-proto/trapproto-3.4.3 =sys-libs/libomp-3.9.1 =www-client/w3m-0.5.3-r9 =sys-libs/gpm-1.20.7-r2 =virtual/perl-JSON-PP-2.273.0.100_rc-r3 =x11-proto/presentproto-1.1 =dev-perl/Module-Build-0.421.600 =gnome-base/gnome-common-3.18.0 =dev-perl/Text-CharWidth-0.40.0-r1 =sys-devel/autoconf-2.13 =app-text/docbook-xml-dtd-4.3-r1 =sys-devel/flex-2.6.1

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

Would you like to unmerge these packages? [Yes/No]

Quitting.

Packages installed:   1003
Packages in world:    42
Packages in system:   44
Required packages:    837
Number to remove:     166
workstation ~ #

Here's my world file:
Code:

app-admin/logrotate
app-admin/sudo
app-admin/syslog-ng
app-admin/tenshi
app-misc/screen
app-misc/tmux
app-portage/eix
app-portage/elogv
app-portage/genlop
app-portage/gentoolkit
app-portage/layman
app-portage/pfl
app-text/wgetpaste
dev-vcs/git
gnome-base/gnome
media-fonts/noto
net-analyzer/nmap
net-analyzer/tcpdump
media-libs/mesa
net-ftp/lftp
net-irc/irssi
net-libs/nodejs
net-misc/dhcpcd
net-misc/ntp
sys-apps/ethtool
sys-apps/mlocate
sys-apps/pciutils
sys-boot/boot-update::funtoo2gentoo
sys-boot/grub
sys-devel/bc
sys-fs/mdadm
sys-fs/ntfs3g
sys-fs/xfsprogs
sys-kernel/linux-firmware
sys-libs/ncurses
sys-process/cronie
www-client/firefox
www-client/pybugz
x11-apps/xdm
x11-base/xorg-x11
x11-terms/rxvt-unicode
x11-wm/fluxbox

I have essentially the same world on my laptop freshly installed, and it doesn't want to remove these files.
_________________
Are the things you're living for worth Christ dying for?
~ Leonard Ravenhill
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 580
Location: Earth

PostPosted: Mon Sep 04, 2017 5:37 am    Post subject: Re: depclean wants to take out Reply with quote

mingdao wrote:
However, depclean wants to remove 166 files [...]

I haven't made any kind of change that would result in this outcome.

I checked Gentoo to be sure (and Funtoo as well for good measure) and everything is clear.

Make sure that /etc/portage and /var/lib/portage are sane (and if this is a Funtoo install make sure that you are following their current portage tree).
_________________
Dantrell B.
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 448
Location: Brazil

PostPosted: Wed Sep 06, 2017 3:52 am    Post subject: Reply with quote

Got this today:

Code:
The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by sys-libs/libblockdev-2.12::gentoo[crypt]
# required by sys-fs/udisks-2.7.2::dantrell-gnome
# required by gnome-base/gvfs-1.32.1::dantrell-gnome-3-24[udisks]
# required by app-text/evince-3.24.1::dantrell-gnome-3-24
# required by gnome-extra/sushi-3.24.0::dantrell-gnome-3-24
# required by gnome-base/nautilus-3.24.2.1::dantrell-gnome-3-24[previewer]
# required by app-arch/file-roller-3.24.1::dantrell-gnome-3-24[nautilus]
# required by @gnome
# required by @selected
# required by @world (argument)
=dev-libs/volume_key-0.3.9 ~amd64
# required by sys-libs/libblockdev-2.12::gentoo
# required by sys-fs/udisks-2.7.2::dantrell-gnome
# required by gnome-base/gvfs-1.32.1::dantrell-gnome-3-24[udisks]
# required by app-text/evince-3.24.1::dantrell-gnome-3-24
# required by gnome-extra/sushi-3.24.0::dantrell-gnome-3-24
# required by gnome-base/nautilus-3.24.2.1::dantrell-gnome-3-24[previewer]
# required by app-arch/file-roller-3.24.1::dantrell-gnome-3-24[nautilus]
# required by @gnome
# required by @selected
# required by @world (argument)
=dev-libs/libbytesize-0.11 ~amd64
# required by sys-fs/udisks-2.7.2::dantrell-gnome
# required by gnome-base/gvfs-1.32.1::dantrell-gnome-3-24[udisks]
# required by app-text/evince-3.24.1::dantrell-gnome-3-24
# required by gnome-extra/sushi-3.24.0::dantrell-gnome-3-24
# required by gnome-base/nautilus-3.24.2.1::dantrell-gnome-3-24[previewer]
# required by app-arch/file-roller-3.24.1::dantrell-gnome-3-24[nautilus]
# required by @gnome
# required by @selected
# required by @world (argument)
=sys-libs/libblockdev-2.12 ~amd64


Should this be on the profile unmask or am I using something unstable even for the overlay? Also had libusb for cups earlier, but didn't mention it here.
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 580
Location: Earth

PostPosted: Thu Sep 07, 2017 4:05 am    Post subject: Reply with quote

saboya wrote:
Should this be on the profile unmask or am I using something unstable even for the overlay?

Generally, I ensure clean emerge output for users who follow the project documentation alongside (or immediately after) the Gentoo Handbook. I check this about once a month or so but maybe I should automate the process.

Anyway, all the keyword changes you mentioned have been accounted for.

saboya wrote:
Also had libusb for cups earlier, but didn't mention it here.

Except this one which I wasn't able to reproduce.

If it's still valid, this it's probably just a normal keyword change you need to account for on your end.
_________________
Dantrell B.
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 448
Location: Brazil

PostPosted: Thu Sep 07, 2017 4:42 am    Post subject: Reply with quote

dantrell wrote:
If it's still valid, this it's probably just a normal keyword change you need to account for on your end.


I always do :) Here's what I have on my accepted keywords for this instance:

Quote:
# required by virtual/libusb-1-r2::gentoo
# required by net-print/cups-2.1.4::gentoo[usb]
# required by net-print/cups-filters-1.16.1::dantrell-gnome
=dev-libs/libusb-1.0.21 ~amd64


Maybe it's already fixed, because it was a while ago.

Anyway, after the udisks unmasks, Gnome is showing every possible mount point listed in my fstab, even the unpriviledged ones. Is this configurable somewhere?
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 580
Location: Earth

PostPosted: Thu Sep 07, 2017 8:19 am    Post subject: Reply with quote

saboya wrote:
Maybe it's already fixed, because it was a while ago.

I'm going to say yes because these are the relevant packages I get on stable:
Code:
dev-libs/libusb-1.0.19-r1:1::gentoo
dev-libs/libusb-compat-0.1.5-r2::gentoo
net-print/cups-2.1.4::gentoo
net-print/cups-filters-1.16.4::dantrell-gnome
net-print/cups-pk-helper-0.2.6::gentoo
virtual/libusb-0-r2::gentoo
virtual/libusb-1-r2:1::gentoo

Maybe look into what pulled dev-libs/libusb-1.0.21?

saboya wrote:
Anyway, after the udisks unmasks, Gnome is showing every possible mount point listed in my fstab, even the unpriviledged ones. Is this configurable somewhere?

As for this... if it's not intentional, I have no clue. Sure sounds familiar though. :o
_________________
Dantrell B.
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 448
Location: Brazil

PostPosted: Thu Sep 07, 2017 2:18 pm    Post subject: Reply with quote

dantrell wrote:
Maybe look into what pulled dev-libs/libusb-1.0.21?


Found it:
Code:
equery depends libusb
 * These packages depend on libusb:
(...)
gnome-base/gvfs-1.32.1 (mtp ? >=dev-libs/libusb-1.0.21)
(...)


dantrell wrote:
As for this... if it's not intentional, I have no clue. Sure sounds familiar though. :o

After your fix to the packages I sync'd and sys-fs/udisks downgraded to 2.6.5 (from 2.7.2), which seemed to fix the issue (mount points are now the same as before in nautilus). All good now.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 631

PostPosted: Mon Sep 11, 2017 12:09 pm    Post subject: Problem starting gnome shell Reply with quote

Hi guys !
Here my strange problem! I've just moved from KDE to gnome without systemd (dantrell repos 3.24) .. i use lightdm as display manager, when I try to log into gnome DE the screen become black for 1 second and after that I fell back on login screen again ..
this happens 8 time of 10 ... if i continue trying login some times I log into normally gnome shell ! and I can work quietly

could some one help me about ?? is very boring try every time repeating the logging to log in
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 631

PostPosted: Fri Sep 15, 2017 9:04 am    Post subject: Reply with quote

little up .. ! :oops:
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 580
Location: Earth

PostPosted: Fri Sep 15, 2017 9:03 pm    Post subject: Reply with quote

drudox wrote:
little up .. ! :oops:

Please excuse the late reply, I was on the road.

drudox wrote:
Hi guys !
Here my strange problem! I've just moved from KDE to gnome without systemd (dantrell repos 3.24) .. i use lightdm as display manager, when I try to log into gnome DE the screen become black for 1 second and after that I fell back on login screen again ..
this happens 8 time of 10 ... if i continue trying login some times I log into normally gnome shell ! and I can work quietly

could some one help me about ?? is very boring try every time repeating the logging to log in

LightDM isn't really something I provide support for but I'll make some time and at least check to see if it works.
_________________
Dantrell B.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 631

PostPosted: Sat Sep 16, 2017 5:42 pm    Post subject: Reply with quote

In particular if i put a background (inside lightdm-gtk-greeter.conf) gnome doesn't login ... I saw, using gnome shell during this days, that few times it crashed during the session and then I cannot relogin .. also if i try 20 times ..
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 580
Location: Earth

PostPosted: Sat Sep 23, 2017 11:14 pm    Post subject: Reply with quote

drudox wrote:
In particular if i put a background (inside lightdm-gtk-greeter.conf) gnome doesn't login ... I saw, using gnome shell during this days, that few times it crashed during the session and then I cannot relogin .. also if i try 20 times ..

I finally made time to test this and from what I saw, with the out-of-the-box settings, LightDM works like a charm.

If the configuration change you mentioned is causing problems then maybe this issue should be reported to LightDM upstream?
_________________
Dantrell B.
Back to top
View user's profile Send private message
mingdao
n00b
n00b


Joined: 19 Sep 2011
Posts: 10
Location: Alabama, USA

PostPosted: Thu Sep 28, 2017 11:48 pm    Post subject: Re: depclean wants to take out Reply with quote

dantrell wrote:
mingdao wrote:
However, depclean wants to remove 166 files [...]

I haven't made any kind of change that would result in this outcome.

I checked Gentoo to be sure (and Funtoo as well for good measure) and everything is clear.

Make sure that /etc/portage and /var/lib/portage are sane (and if this is a Funtoo install make sure that you are following their current portage tree).

No worries; I'm finished with Funtoo and Gentoo. The maintenance is way too high; primarily because the quality of the devs/maintainers has gone so far down.

No longer will I hack and work on my computer to get/keep it working; I've used Fedora since Saturday, 10+ hours a day, and been able to just use my computer
for work, rather than constantly working on it. From downloaded the ISO, to writing it to USB, to installing Fedora encrypted took ~30 minutes.

C'ya
_________________
Are the things you're living for worth Christ dying for?
~ Leonard Ravenhill
Back to top
View user's profile Send private message
vitosans
n00b
n00b


Joined: 29 Sep 2017
Posts: 1
Location: Orange * County

PostPosted: Fri Sep 29, 2017 11:43 pm    Post subject: Reply with quote

Been away from Gentoo for about 8 years now, decided I needed more control again over my linux experience so I came back. I don't want systemd so I naturally came to this project ;)

I installed a fresh system and then applied this overlay got everything compiled just fine ( except evolution, I am getting access violation but that can wait ), except I can't get gnome to start - GDM starts just fine but when I login with GDM set for debugging I see:

Code:
 
Sep 28 13:08:23 vito-gen2 gdm-x-session: could not fetch environment: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.systemd1 was not provided by any .service files


all of the errors I see are around dbus and not being able to connect to dbus. The message above stood out as it mentions systemd if I disable xdm and elogin I try from console with startx I get the following:

Code:


gnome-session-binary[5998]: WARNING: Failed to connect to systemd: Error calling StartServiceByName for org.freedesktop.login1: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 1
gnome-session-binary[5998]: GLib-GObject-WARNING: invalid (NULL) pointer instance
gnome-session-binary[5998]: GLib-GObject-CRITICAL: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed
gnome-session-binary[5998]: GLib-GIO-CRITICAL: g_dbus_proxy_call_sync_internal: assertion 'G_IS_DBUS_PROXY (proxy)' failed
gnome-session-binary[5998]: WARNING: Could not get session id for session. Check that logind is properly installed and pam_systemd is getting used at login.
** Message: couldn't access control socket: /run/user/1000/keyring/control: No such file or directory
** Message: couldn't access control socket: /run/user/1000/keyring/control: No such file or directory
** Message: couldn't access control socket: /run/user/1000/keyring/control: No such file or directory
SSH_AUTH_SOCK=/run/user/1000/keyring/ssh
SSH_AUTH_SOCK=/run/user/1000/keyring/ssh
SSH_AUTH_SOCK=/run/user/1000/keyring/ssh
Gjs-Message: JS WARNING: [resource:///org/gnome/shell/ui/main.js 317]: reference to undefined property global.stage
Gjs-Message: JS WARNING: [resource:///org/gnome/shell/ui/layout.js 217]: reference to undefined property global.window_group

(gnome-shell:6052): Gjs-WARNING **: JS ERROR: Gio.DBusError: Error calling StartServiceByName for org.freedesktop.login1: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 1



Every now and then it will start, but gnome is not happy - gnome-terminal will not launch unless I launch a xterm and run dbus-launch gnome-terminal and its the same for allot of other applications which could actually be a hint to what the problem is..

Like I said in the beginning I have been away from the community for ages so not sure what information to post to help get my problem understood.

Here is my emerge --info output:

Code:


emerge --info

Portage 2.3.8 (python 3.4.5-final-0, !../../var/lib/layman/dantrell-gnome/profiles/default/amd64/3.24/extended, gcc-5.4.0, glibc-2.23-r4, 4.12.12-gentoo x86_64)
=================================================================
System uname: Linux-4.12.12-gentoo-x86_64-Intel-R-_Xeon-R-_CPU_E5620_@_2.40GHz-with-gentoo-2.3
KiB Mem:     8142032 total,   5500692 free
KiB Swap:     975868 total,    975868 free
Timestamp of repository gentoo: Wed, 27 Sep 2017 20:00:01 +0000
Head commit of repository gentoo: 44d8e66a31224b92acb92e1bcdfbf290752a4132
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.28.1 p1.0) 2.28.1
ccache version 3.2.4 [disabled]
app-shells/bash:          4.3_p48-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.1-r2::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/ccache:          3.2.4::gentoo
dev-util/cmake:           3.7.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.28::gentoo
sys-apps/sandbox:         2.10-r3::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.28.1::gentoo
sys-devel/gcc:            5.4.0-r3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r4::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

raiagent
    location: /var/lib/layman/raiagent
    masters: gentoo
    priority: 50

dantrell-gnome-3-24
    location: /var/lib/layman/dantrell-gnome-3-24
    masters: gentoo
    priority: 100

dantrell-gnome
    location: /var/lib/layman/dantrell-gnome
    masters: gentoo
    priority: 150

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://xxxxxxxxxxxxxx/gentoo"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli colord consolekit cracklib crypt cryptsetup cxx dbus dri dts dvd dvdr eds elogind encode evo exif fam flac foomaticdb fortran gdbm gif git glamor gnome gnome-keyring gnome-online-accounts gpm gtk gtk3 gtkstyle iconv introspection ipv6 java jpeg lcms ldap libnotify libsecret mad mng modules mp3 mp4 mpeg multilib nautilus ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pulseaudio readline sdl seccomp session spell ssl startup-notification svg tcpd threads tiff tracker truetype udev udisks unicode upower usb vorbis x264 xattr xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ens1371" CPU_FLAGS_X86="mmx sse sse2" ELIBC="glibc" INPUT_DEVICES="keyboard mouse vmmouse evdev" KERNEL="linux" L10N="en en-US" LINGUAS="en" PHP_TARGETS="php5-6" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby22" USERLAND="GNU" VIDEO_CARDS="vmware fbdev vesa nv vga"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



contents of xinitrc

Code:

export XDG_MENU_PREFIX=gnome-
exec gnome-session


contents of /etc/conf.d/xdm

Code:

CHECKVT=7
DISPLAYMANAGER="gdm"




Thanks for your efforts glad someone is keeping things going without systemd.

Cheers,
Back to top
View user's profile Send private message
shevy
n00b
n00b


Joined: 28 Aug 2017
Posts: 9

PostPosted: Mon Oct 02, 2017 3:35 am    Post subject: Reply with quote

Quote:
Thanks for your efforts glad someone is keeping things going without systemd.


Agreed. It's a general service done by the Gentoo hackers there, including maintaining
eudev.

Quote:
Been away from Gentoo for about 8 years now, decided I needed more control again over my linux
experience so I came back. I don't want systemd so I naturally came to this project ;)


While there are some systemd-free distributions, the numbers are quite ... low compared to
the general systemd-BORG-snake eating away at things. What actually surprised me more
was that you CAN run gnome without systemd - I thought that at that time, Red Hat would
have completely cut off access. But perhaps the BSDs kept Gnome semi-free - until they
also get a systemd variant. Can't have that kind of fun only with Linux now, can it ... :)
Back to top
View user's profile Send private message
simonvanderveldt
Tux's lil' helper
Tux's lil' helper


Joined: 26 Jan 2016
Posts: 105

PostPosted: Mon Oct 02, 2017 9:55 pm    Post subject: Reply with quote

Any idea what could be causing this?

Emerging media-gfx/simple-scan-3.20.0::dantrell-gnome-3-20 with USE -colord (-packagekit) results in the following:
Code:
simple-scan.vala:17.5-28.6: warning: the modifier `static' is not applicable to constants
ui.vala:456.42-456.45: error: Argument 1: Cannot pass value to reference or output parameter
                    device_model.remove (iter);
                                         ^^^^
ui.vala:469.34-469.37: error: Argument 1: Cannot pass value to reference or output parameter
            device_model.remove (iter);
                                 ^^^^
Compilation failed: 2 error(s), 1 warning(s)
make[1]: *** [Makefile:637: simple_scan_vala.stamp] Error 1
make[1]: Leaving directory '/var/tmp/portage/media-gfx/simple-scan-3.20.0/work/simple-scan-3.20.0/src'
make: *** [Makefile:380: all-recursive] Error 1
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22201
Location: here

PostPosted: Tue Oct 03, 2017 5:59 am    Post subject: Reply with quote

It seems a simple scan bug
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 580
Location: Earth

PostPosted: Tue Oct 03, 2017 7:18 am    Post subject: Reply with quote

mingdao wrote:
No worries; I'm finished with Funtoo and Gentoo.

Completely understandable.

Fair winds.

vitosans wrote:
I installed a fresh system and then applied this overlay got everything compiled just fine ( except evolution, I am getting access violation but that can wait ), except I can't get gnome to start [...]

Unfortunately, this is another issue I can't reproduce and it's actually pretty hard to diagnose remotely (exception for evolution, the access violation should now be resolved).

In general, if GNOME doesn't start, you probably missed something so my suggestion would be to review the major sections of the Gentoo Handbook and the GNOME Without Systemd project documentation to see if something stands out.

vitosans wrote:
Every now and then it will start, but gnome is not happy - gnome-terminal will not launch unless I launch a xterm and run dbus-launch gnome-terminal and its the same for allot of other applications which could actually be a hint to what the problem is..

The latter issue here sounds similar to a locale problem I heard about previously but I don't have the link handy.

shevy wrote:
Agreed. It's a general service done by the Gentoo hackers there, including maintaining
eudev.

Don't forget elogind.

At one point I thought I'd have to tackle it myself but then Sven saved me from that nightmare. :wink:

simonvanderveldt wrote:
Any idea what could be causing this?

fedeliallalinea wrote:
It seems a simple scan bug

Yep, Vala shenanigans. Turns out 3 provided versions were affected.

Sync up and you should be good to go.
_________________
Dantrell B.
Back to top
View user's profile Send private message
simonvanderveldt
Tux's lil' helper
Tux's lil' helper


Joined: 26 Jan 2016
Posts: 105

PostPosted: Wed Oct 04, 2017 6:24 pm    Post subject: Reply with quote

dantrell wrote:
simonvanderveldt wrote:
Any idea what could be causing this?

fedeliallalinea wrote:
It seems a simple scan bug

Yep, Vala shenanigans. Turns out 3 provided versions were affected.

Sync up and you should be good to go.

Just emerged simple-scan without issues, thanks for the quick fix!
Back to top
View user's profile Send private message
At4ri
n00b
n00b


Joined: 11 Mar 2016
Posts: 52

PostPosted: Sun Oct 08, 2017 5:47 pm    Post subject: Reply with quote

# layman --add dantrell-gnome-3-24

* Adding overlay...
* Exception: Overlay "dantrell-gnome-3-24" does not exist.

* CLI: Errors occurred processing action add
* Exception: Overlay "dantrell-gnome-3-24" does not exist.
_________________
Grupo telegram gentoo y otras hierbas
https://telegram.me/joinchat/C3V8xD5C1VzvaYH4CJULyw

OS: Gentoo ~amd64 & windows 10
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22201
Location: here

PostPosted: Sun Oct 08, 2017 5:51 pm    Post subject: Reply with quote

You followed instructions?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
At4ri
n00b
n00b


Joined: 11 Mar 2016
Posts: 52

PostPosted: Sun Oct 08, 2017 6:54 pm    Post subject: Reply with quote

fedeliallalinea wrote:
You followed instructions?



It's strange because I had no problems with version 3.22
_________________
Grupo telegram gentoo y otras hierbas
https://telegram.me/joinchat/C3V8xD5C1VzvaYH4CJULyw

OS: Gentoo ~amd64 & windows 10
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22201
Location: here

PostPosted: Sun Oct 08, 2017 7:12 pm    Post subject: Reply with quote

At4ri wrote:
It's strange because I had no problems with version 3.22

Try to add --debug-level=4 to layman
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
At4ri
n00b
n00b


Joined: 11 Mar 2016
Posts: 52

PostPosted: Sun Oct 08, 2017 8:30 pm    Post subject: Reply with quote

fedeliallalinea wrote:
At4ri wrote:
It's strange because I had no problems with version 3.22

Try to add --debug-level=4 to layman



I was already playing with the configuration file of layman and I saw that it is going like this
https://raw.githubusercontent.com/dantrell/gentoo-overlay-dantrell-gnome/master/repositories.xm

I lacked

8O 8O 8O 8O 8O :D :mrgreen:
_________________
Grupo telegram gentoo y otras hierbas
https://telegram.me/joinchat/C3V8xD5C1VzvaYH4CJULyw

OS: Gentoo ~amd64 & windows 10
Back to top
View user's profile Send private message
tallefjant
n00b
n00b


Joined: 09 Oct 2017
Posts: 2

PostPosted: Mon Oct 09, 2017 2:29 pm    Post subject: Reply with quote

Currently experimenting with Gnome 3.20 without systemd. During installation I encountered a problem:

/usr/local/portage/dantrell-gnome/sys-libs/libosinfo/libosinfo-0.3.1.ebuild should be updated with a new SRC_URI since http://fedorahosted.org/releases/ leads to https://fedoraproject.org/wiki/Infrastructure/Fedorahosted-retirement.

I downloaded the source package from another server, but I do not remember where from.
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 12, 13, 14 ... 27, 28, 29  Next
Page 13 of 29

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum