Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Dantrell's GNOME Without Systemd Project (Part 1)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 19, 20, 21 ... 27, 28, 29  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 561
Location: Earth

PostPosted: Tue Dec 26, 2017 10:25 am    Post subject: Reply with quote

Elleni wrote:
Great :D

I just confirmed that GCC 6 is build passing (as I was overdue for a rebuild anyway).

The new profiles can now go live whenever I get around to them. :wink:

dantrell wrote:
I reviewed the GNOME 3.20 packages again and I'm not finding anything. The last test I did shows everything is working.

Still nothing on this front though. :(
_________________
Dantrell B.
Back to top
View user's profile Send private message
simonvanderveldt
Tux's lil' helper
Tux's lil' helper


Joined: 26 Jan 2016
Posts: 103

PostPosted: Tue Dec 26, 2017 8:07 pm    Post subject: Reply with quote

dantrell wrote:
simonvanderveldt wrote:
I can emerge 0.34.11 from either gentoo or from your overlay to give it a try.

Please try the most recent version (which is slotted in ~) from the project overlays.

It will emerge with USE="-vanilla-shutdown" which changes the shutdown process.

Unfortunately no difference with openrc 0.34.11 from your overlay :(

It seems to be purely Gnome related, because it already starts going wrong with the power off modal, which shows up slower/later than before. Also just noticed when I've clicked on poweroff on the poweroff modal I'm thrown back to the desktop and it takes +-30s before the actual shutdown happens. When I then click on the icons in the top bar and click on shutdown again Gnome immediately starts the shutdown sequence :?
This has on impact on the non-working shutdown process after xdm has been closed though.

The error messages I got seem to be pretty much the same as were fixed before. Any idea how it can be that I'm still seeing them?
From the last shutdown
Code:
Dec 26 01:32:07 [gnome-session-binary] GLib-GObject-CRITICAL: g_object_unref: assertion 'G_IS_OBJECT (obj
ect)' failed_
                - Last output repeated 3 times -
Dec 26 01:32:09 [gnome-session-binary] WARNING: Client '/org/gnome/SessionManager/Client7' failed to repl
y before timeout_
Dec 26 01:32:09 [kernel] usb 2-1.6.1.1: reset high-speed USB device number 13 using ehci-pci
Dec 26 01:32:11 [gnome-session-binary] GLib-GObject-CRITICAL: g_object_unref: assertion 'G_IS_OBJECT (obj
ect)' failed_
                - Last output repeated 3 times -
Dec 26 01:32:41 [kernel] usb 2-1.6.1.1: reset high-speed USB device number 13 using ehci-pci
                - Last output repeated twice -
Dec 26 01:33:41 [shutdown] shutting down for system halt
Dec 26 01:33:45 [init] Switching to runlevel: 0
Dec 26 01:33:46 [gnome-session-binary] WARNING: Lost name on bus: org.gnome.SessionManager_
Dec 26 01:33:46 [kernel] traps: gdm[4889] general protection ip:7fa3a1a3688b sp:7ffe16c15fb0 error:0
Dec 26 01:33:46 [kernel]  in libgobject-2.0.so.0.4800.2[7fa3a1a02000+52000]
Dec 26 01:33:46 [gnome-session-binary] WARNING: Could not connect to ConsoleKit: Unable to find session f
or cookie_


Btw. I like the new suggested profile names! Also nicer that they are part of the actual gnome version overlay and not of the common one.
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 561
Location: Earth

PostPosted: Tue Dec 26, 2017 9:16 pm    Post subject: Reply with quote

simonvanderveldt wrote:
It seems to be purely Gnome related, because it already starts going wrong with the power off modal, which shows up slower/later than before.

Technically, you could just switch to elogind:

Code:
USE="-ck elogind" emerge --ask --update --deep --changed-use --with-bdeps=y @world

It'll probably work but it won't answer what went wrong here.

The consolekit service is running right?
_________________
Dantrell B.
Back to top
View user's profile Send private message
Elleni
l33t
l33t


Joined: 23 May 2006
Posts: 844

PostPosted: Tue Dec 26, 2017 9:26 pm    Post subject: Reply with quote

Dantrell, as I update to 17 plasma profile, I temporary uninstall gnome without systemd, to wait the new combined profile and re-install it then. So I removed your profiles and overlays, did an emerge -C gnome followed by depclean. My question is, is there a way to see, if there are still any dantrell-gnome related packages installed ? I am asking, as I had found out, that other packages from tree that rely on gnome packages had installed dependent gnome packages from dantrell gnome overlay. Ex. gvfs.
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 561
Location: Earth

PostPosted: Wed Dec 27, 2017 7:49 am    Post subject: Reply with quote

Elleni wrote:
My question is, is there a way to see, if there are still any dantrell-gnome related packages installed ?

Probably with:

Code:
emerge --emptytree --pretend --verbose @world | grep dantrell

The only thing I can think of is that you did not delete the overlays (or otherwise deference them) as simply switching profiles is not enough.

If you did then the above check should show the stragglers. Simply rebuild them manually (just remember to use --oneshot).
_________________
Dantrell B.
Back to top
View user's profile Send private message
Elleni
l33t
l33t


Joined: 23 May 2006
Posts: 844

PostPosted: Wed Dec 27, 2017 5:24 pm    Post subject: Reply with quote

Hi Dantrell,

perfect. That emerge did not give out any package, so I guess there is no cruft left, and I am looking forward to do the new install once you are ready to provide the combined profile. In the meantime I want to thank you again for your efforts and very great support. :D
Back to top
View user's profile Send private message
Marlo
Veteran
Veteran


Joined: 26 Jul 2003
Posts: 1413

PostPosted: Wed Dec 27, 2017 6:35 pm    Post subject: Reply with quote

Emoticons in 3.26?

Hello,
I'm looking for this menu https://help.gnome.org/misc/release-notes/3.26/
(scroll down) titled "Smileys & People".

Installed are =x11-libs/cairo-1.15.8 and media-fonts/symbola
Do I have to set a special USE flag or install an application?

Thanks for any advice
Ma

EDIT
It is installed: [ebuild R ] gnome-extra/gnome-characters-3.26.2::dantrell-gnome-3-26 USE="{-test}" 0 KiB
_________________
Thank you for your attention, interest and support.
------------------------------------------------------------------
http://radio.garden/


Last edited by Marlo on Wed Dec 27, 2017 7:48 pm; edited 1 time in total
Back to top
View user's profile Send private message
Marlo
Veteran
Veteran


Joined: 26 Jul 2003
Posts: 1413

PostPosted: Wed Dec 27, 2017 6:42 pm    Post subject: Reply with quote

polari-3.26.2 does not start

Code:
@tux ~ $ polari
(org.gnome.Polari:4733): GLib-GIO-ERROR **: Settings schema 'org.gnome.Polari' is not installed


How could I solve the problem.
x11 and Gnome have already been compiled again.


many thanks
Ma
_________________
Thank you for your attention, interest and support.
------------------------------------------------------------------
http://radio.garden/
Back to top
View user's profile Send private message
Marlo
Veteran
Veteran


Joined: 26 Jul 2003
Posts: 1413

PostPosted: Wed Dec 27, 2017 7:01 pm    Post subject: Reply with quote

Evolution 3.26.3

Is there any way that evolution regularly checks the mailboxes for incoming mail without being started? The check button in the account settings with the settings for retrieving the e-mail I have seen. But that only seems to work when evolution is started.

Thanks in advance for any hint

Ma

EDIT:
Just for good order, I know this page: https://help.gnome.org/users/evolution/stable/mail-send-and-receive-automatically.html.en
_________________
Thank you for your attention, interest and support.
------------------------------------------------------------------
http://radio.garden/
Back to top
View user's profile Send private message
Marlo
Veteran
Veteran


Joined: 26 Jul 2003
Posts: 1413

PostPosted: Wed Dec 27, 2017 9:57 pm    Post subject: Reply with quote

gnome-packagekit-3.26.0

Code:

# eix --installed-with-use packagekit
No hit


Do I need these programs in gentoo for Gnome 3.26?
Code:

gnome-extra/gnome-packagekit-3.26.0::dantrell-gnome-3-26
app-admin/packagekit-base-1.1.7:0/18::dantrell-gnome



Thank you for a quick note.
Ma
_________________
Thank you for your attention, interest and support.
------------------------------------------------------------------
http://radio.garden/
Back to top
View user's profile Send private message
simonvanderveldt
Tux's lil' helper
Tux's lil' helper


Joined: 26 Jan 2016
Posts: 103

PostPosted: Wed Dec 27, 2017 10:28 pm    Post subject: Reply with quote

dantrell wrote:
The consolekit service is running right?


Yeah, it is.

Did notice a couple of these in my logs
Code:
Dec 27 13:23:10 [dbus] [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.19" (uid=108 pid=5940 comm="/usr/bin/gnome-shell ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.0" (uid=0 pid=4138 comm="/usr/sbin/console-kit-daemon ")
Dec 27 13:23:10 [polkitd] Registered Authentication Agent for unix-session:/org/freedesktop/ConsoleKit/Session1 (system bus name :1.19 [/usr/bin/gnome-shell], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
Dec 27 13:23:10 [dbus] [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.19" (uid=108 pid=5940 comm="/usr/bin/gnome-shell ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.0" (uid=0 pid=4138 comm="/usr/sbin/console-kit-daemon ")
Dec 27 13:25:03 [dbus] [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.19" (uid=108 pid=5940 comm="/usr/bin/gnome-shell ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.0" (uid=0 pid=4138 comm="/usr/sbin/console-kit-daemon ")
Dec 27 13:25:04 [polkitd] Unregistered Authentication Agent for unix-session:/org/freedesktop/ConsoleKit/Session1 (system bus name :1.19, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (disconnected from bus)
Dec 27 13:25:09 [dbus] [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.39" (uid=1000 pid=8644 comm="/usr/bin/gnome-shell ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.0" (uid=0 pid=4138 comm="/usr/sbin/console-kit-daemon ")
Dec 27 13:25:09 [polkitd] Registered Authentication Agent for unix-session:/org/freedesktop/ConsoleKit/Session2 (system bus name :1.39 [/usr/bin/gnome-shell], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
Dec 27 13:25:10 [dbus] [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.39" (uid=1000 pid=8644 comm="/usr/bin/gnome-shell ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.0" (uid=0 pid=4138 comm="/usr/sbin/console-kit-daemon ")
Dec 27 13:25:10 [dbus] [system] Rejected send message, 2 matched rules; type="method_call", sender=":1.39" (uid=1000 pid=8644 comm="/usr/bin/gnome-shell ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.0" (uid=0 pid=4138 comm="/usr/sbin/console-kit-daemon ")


dantrell wrote:
simonvanderveldt wrote:
It seems to be purely Gnome related, because it already starts going wrong with the power off modal, which shows up slower/later than before.

Technically, you could just switch to elogind:

Code:
USE="-ck elogind" emerge --ask --update --deep --changed-use --with-bdeps=y @world

It'll probably work but it won't answer what went wrong here.


OK, I'll give that a try.
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 561
Location: Earth

PostPosted: Thu Dec 28, 2017 1:22 am    Post subject: Reply with quote

Marlo wrote:
Emoticons in 3.26?

You want >=x11-libs/cairo-1.15.8 and USE="fonts" gnome-base/gnome-extra-apps for color emojis in GNOME.

For special cases (e.g. Firefox) there is a detailed answer here (although, you should probably read it anyway for non-special cases).

Marlo wrote:
polari-3.26.2 does not start

Sync up and you should be good to go.

Marlo wrote:
EIs there any way that evolution regularly checks the mailboxes for incoming mail without being started? The check button in the account settings with the settings for retrieving the e-mail I have seen. But that only seems to work when evolution is started.

I'm only aware of mail-client/mail-notification but it's quite old and I'm not sure how it well it functions these days.

Marlo wrote:
Do I need these programs in gentoo for Gnome 3.26?
Code:

gnome-extra/gnome-packagekit-3.26.0::dantrell-gnome-3-26
app-admin/packagekit-base-1.1.7:0/18::dantrell-gnome

You only need them if you know why you need them (e.g. you want to experiment with PackageKit).

Nothing should pull them in by default.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Marlo
Veteran
Veteran


Joined: 26 Jul 2003
Posts: 1413

PostPosted: Thu Dec 28, 2017 10:43 am    Post subject: Reply with quote

dantrell wrote:


Marlo wrote:
polari-3.26.2 does not start

Sync up and you should be good to go.

Sync done and polari starts.


dantrell wrote:
Marlo wrote:
EIs there any way that evolution regularly checks the mailboxes for incoming mail without being started? The check button in the account settings with the settings for retrieving the e-mail I have seen. But that only seems to work when evolution is started.

I'm only aware of mail-client/mail-notification but it's quite old and I'm not sure how it well it functions these days.

Mail-notification comes with many dependencies. I give up first.


dantrell wrote:

Marlo wrote:
Do I need these programs in gentoo for Gnome 3.26?
Code:

gnome-extra/gnome-packagekit-3.26.0::dantrell-gnome-3-26
app-admin/packagekit-base-1.1.7:0/18::dantrell-gnome

You only need them if you know why you need them (e.g. you want to experiment with PackageKit).
Nothing should pull them in by default.

Deleted


Thank you very much dantrell for these clarifications.
Ma
_________________
Thank you for your attention, interest and support.
------------------------------------------------------------------
http://radio.garden/
Back to top
View user's profile Send private message
Marlo
Veteran
Veteran


Joined: 26 Jul 2003
Posts: 1413

PostPosted: Thu Dec 28, 2017 11:18 am    Post subject: Reply with quote

Emoticons in 3.26

dantrell wrote:
Marlo wrote:
Emoticons in 3.26?

You want >=x11-libs/cairo-1.15.8 and USE="fonts" gnome-base/gnome-extra-apps for color emojis in GNOME.

For special cases (e.g. Firefox) there is a detailed answer here (although, you should probably read it anyway for non-special cases).


Even after installing "x11-libs/cairo-1.15.8 and USE ="fonts" gnome-base/gnome-extra-apps"" emojis remained in the system and in Chromium and Firefox black/white. Only in google-chrome were all the emoijs in color.
I installed https://github.com/DeeDeeG/noto-color-emoji-font#install-on-linux and it stayed black and white.

Only after adding this /etc/fonts/local.conf from https://forums.gentoo.org/viewtopic-p-8139926.html#8139926 it became colored.

Anyway, most emojis were colorful. The exception are the faces. In gnome-characters, polari, firefox and Cromium (only) the faces are black and white (Google Chrome works all in color).

I checked Suse Tumbleweed. There is only the /etc/fonts/fonts.conf - as well as in gentoo. I do not know how Suse did that.

Is that important? I do not think so. But interesting. I do not understand anything, really nothing about fonts. So I'm waiting for anyone to write a good wiki for emoijs in gentoo.

Many thanks for your help
Ma

I found this old post on "Getting Beautiful Fonts in Gentoo Linux" again. This old howto was a real help back then.
_________________
Thank you for your attention, interest and support.
------------------------------------------------------------------
http://radio.garden/
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 561
Location: Earth

PostPosted: Thu Dec 28, 2017 10:37 pm    Post subject: Reply with quote

Marlo wrote:
Even after installing "x11-libs/cairo-1.15.8 and USE ="fonts" gnome-base/gnome-extra-apps"" emojis remained in the system and in Chromium and Firefox black/white. Only in google-chrome were all the emoijs in color.

This is the expected resulted. Installing those two only enable color emojis in applications provided by GNOME (assuming all other factors are met). Chromium and Firefox are not provided by GNOME.

Marlo wrote:
Only after adding this /etc/fonts/local.conf from https://forums.gentoo.org/viewtopic-p-8139926.html#8139926 it became colored.

That was what you needed to do. As there is no "one size fits all" when it comes to fontconfig, you have to write one that works for you when it comes to color emojis. You can force Firefox and Chromium based browsers to use specific settings (that's the only way I found to get them to work). Others like Polari, GNOME Terminal and text editors I haven't experimented with yet.

Marlo wrote:
Is that important? I do not think so.

Gentoo manages its fonts through fontconfig so changing that file is pointless as it will be overwritten when fontconfig is updated.

Marlo wrote:
I found this old post on "Getting Beautiful Fonts in Gentoo Linux" again. This old howto was a real help back then.

I remember post. Same techniques still apply. It just doesn't account for color emojis.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Shibotto
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2015
Posts: 109
Location: Italy

PostPosted: Thu Dec 28, 2017 11:29 pm    Post subject: Reply with quote

Marlo wrote:
Only after adding this /etc/fonts/local.conf from https://forums.gentoo.org/viewtopic-p-8139926.html#8139926 it became colored.

I did something a bit different, by stealing /etc/fonts/conf.avail/66-noto-color-emoji.conf from Arch and of course activating it using eselect or linking.

This is the result (I also grabbed a newer version of Noto while I was at it) and I'm pretty amazed it works in GTK+2 apps as well! :D
Back to top
View user's profile Send private message
Marlo
Veteran
Veteran


Joined: 26 Jul 2003
Posts: 1413

PostPosted: Fri Dec 29, 2017 1:53 am    Post subject: Reply with quote

Shibotto wrote:

I did something a bit different, by stealing /etc/fonts/conf.avail/66-noto-color-emoji.conf from Arch and of course activating it using eselect or linking.

This is the result (I also grabbed a newer version of Noto while I was at it) and I'm pretty amazed it works in GTK+2 apps as well! :D



Thank you very much Shibotto,

that seems to me a real gentoo way. And with the best results.
I estimate 98% of the emijos are now in color. This page is now displayed equally well by all browsers. Chromium, Google Chrome and Firefox.

The 2% in black and white could belong to the "New Emojis". Click the link above and scroll down to "New Emojis". If so then the 2% would not be a mistake but a good feature.

In the sense that dantrell wrote above to fontconfig. With "eselect fontconfig" and the config from the Archlinux this solution seems to me to be good enough for an ebuild. Maybe then these fonts can also be installed system-wide. Unfortunately I can not write ebuilds.

Thanks dantrell and also to the Dev's from Arch!

  Shibotto, could you please post the link to the newer versions of Noto?

Many Thanks
Ma
_________________
Thank you for your attention, interest and support.
------------------------------------------------------------------
http://radio.garden/
Back to top
View user's profile Send private message
Marlo
Veteran
Veteran


Joined: 26 Jul 2003
Posts: 1413

PostPosted: Fri Dec 29, 2017 7:46 pm    Post subject: Reply with quote

Emoticons in 3.26

I start again from scratch installing emojis. So I have removed everything that has to do with it.
As a result, I have to correct myself and can now say what has led to the best result on my PC.
Important: there are different emojis. I write only about nougat.

0. emaint sync -a && emerge -NDuva world

1. Set USE = "fonts" globally and also install gnome-base/gnome-extra-apps with the USE flag "fonts".
As a dependency, media-fonts/noto from Goggle is also installed. This seems to be absolutely necessary for emojis.

2. Install media-fonts/ttf-bitstream-vera

3. install >=x11-libs/cairo-1.15.8

4. Look here for the latest version of noto-color-emoji-font
https://github.com/DeeDeeG/noto-color-emoji-font/releases
(currently 1.2)

5. Then look here: https://github.com/DeeDeeG/noto-color-emoji-font#install-on-linux

Code:

# 1. Download the latest version as a user
wget https://github.com/DeeDeeG/noto-color-emoji-font/releases/download/v1.2-nougat/NotoColorEmoji-SVGinOT-Linux-1.2.tar.gz

# 2. Uncompress the file
tar zxf NotoColorEmoji-SVGinOT-Linux-1.2.tar.gz

# 3. Run the installer
cd NotoColorEmoji-SVGinOT-Linux-1.2

./install.sh


6. Adding this /etc/fonts/local.conf from https://forums.gentoo.org/viewtopic-p-8139926.html#8139926

7. Adding this /etc/fonts/conf.avail/66-noto-color-emoji.conf from Arch
https://git.archlinux.org/svntogit/packages.git/tree/trunk/66-noto-color-emoji.conf?h=packages/noto-fonts-emoji

enable 66-noto-color-emoji.conf with eselect fontconfig

8. Reboot

9. Go to this website http://getemoji.com/ and try firefox, chromium etc and see what happens.
All emojis should be colored except for "New Emojis"

10. Open a terminal and type as a user: gnome-characters

Ma
_________________
Thank you for your attention, interest and support.
------------------------------------------------------------------
http://radio.garden/
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 561
Location: Earth

PostPosted: Sat Dec 30, 2017 12:46 am    Post subject: Reply with quote

Just a few clarifications:

Marlo wrote:
1. Set USE = "fonts" globally and also install gnome-base/gnome-extra-apps with the USE flag "fonts".
As a dependency, media-fonts/noto from Goggle is also installed. This seems to be absolutely necessary for emojis.

USE="fonts" is already the default for gnome-base/gnome-extra-apps. It doesn't need to be set globally.

And, yes, it is a must. For details, see GNOME bug #762890.

Marlo wrote:
2. Install media-fonts/ttf-bitstream-vera

This shouldn't be needed.

Marlo wrote:
3. install >=x11-libs/cairo-1.15.8

Only to enable color emojis in cairo-dependent applications (provided by GNOME) which use that functionality.

Marlo wrote:

4. Look here for the latest version of noto-color-emoji-font
https://github.com/DeeDeeG/noto-color-emoji-font/releases
(currently 1.2)

5. Then look here: https://github.com/DeeDeeG/noto-color-emoji-font#install-on-linux

Code:

# 1. Download the latest version as a user
wget https://github.com/DeeDeeG/noto-color-emoji-font/releases/download/v1.2-nougat/NotoColorEmoji-SVGinOT-Linux-1.2.tar.gz

# 2. Uncompress the file
tar zxf NotoColorEmoji-SVGinOT-Linux-1.2.tar.gz

# 3. Run the installer
cd NotoColorEmoji-SVGinOT-Linux-1.2

./install.sh


6. Adding this /etc/fonts/local.conf from https://forums.gentoo.org/viewtopic-p-8139926.html#8139926

This is optional for color emojis in Firefox as you can use EmojiOne Mozilla instead.

Marlo wrote:
7. Adding this /etc/fonts/conf.avail/66-noto-color-emoji.conf from Arch
https://git.archlinux.org/svntogit/packages.git/tree/trunk/66-noto-color-emoji.conf?h=packages/noto-fonts-emoji

enable 66-noto-color-emoji.conf with eselect fontconfig

A working fontconfig file for Noto is key.

Marlo wrote:
8. Reboot

You only need to restart the application utilizing the font.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Shibotto
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2015
Posts: 109
Location: Italy

PostPosted: Tue Jan 02, 2018 9:25 am    Post subject: Reply with quote

Marlo wrote:
  Shibotto, could you please post the link to the newer versions of Noto?


I'm using this https://github.com/googlei18n/noto-emoji/blob/master/fonts/NotoColorEmoji.ttf (too lazy to build it myself...)
Back to top
View user's profile Send private message
Shibotto
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2015
Posts: 109
Location: Italy

PostPosted: Wed Jan 03, 2018 4:11 pm    Post subject: Reply with quote

A small update, I just noticed: dev-db/sqlite-3.20.1-r1 was unmasked on 2017-12-14 (ISO 8601 for the win!) and our app-misc/tracker needs to be rebuilt against it, otherwise every search exits with
Code:
no such tokenizer: TrackerTokenizer

Vanilla Gentoo unmasked it alongside app-misc/tracker-1.12.3, so it's only us.
Back to top
View user's profile Send private message
Marlo
Veteran
Veteran


Joined: 26 Jul 2003
Posts: 1413

PostPosted: Wed Jan 03, 2018 8:55 pm    Post subject: Reply with quote

Shibotto wrote:

I'm using this https://github.com/googlei18n/noto-emoji/blob/master/fonts/NotoColorEmoji.ttf (too lazy to build it myself...)


Thanks, Shibotto, that's now clear.

By the way, Google Drive connected to ~ home is also solved.

Ma
_________________
Thank you for your attention, interest and support.
------------------------------------------------------------------
http://radio.garden/
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 561
Location: Earth

PostPosted: Thu Jan 04, 2018 8:59 am    Post subject: Reply with quote

dantrell wrote:
The new profiles can now go live whenever I get around to them. :wink:

I got around to them:

Code:
  [51]  dantrell-gnome:default/linux/amd64/13.0/desktop/gnome+plasma
  [52]  dantrell-gnome:default/linux/amd64/17.0/desktop/gnome+plasma
  [53]  dantrell-gnome-3-14:default/linux/amd64/13.0/desktop/gnome/3.14
  [54]  dantrell-gnome-3-14:default/linux/amd64/13.0/desktop/gnome/3.14/extended
  [55]  dantrell-gnome-3-14:default/linux/amd64/17.0/desktop/gnome/3.14
  [56]  dantrell-gnome-3-14:default/linux/amd64/17.0/desktop/gnome/3.14/extended
  [57]  dantrell-gnome-3-16:default/linux/amd64/13.0/desktop/gnome/3.16
  [58]  dantrell-gnome-3-16:default/linux/amd64/13.0/desktop/gnome/3.16/extended
  [59]  dantrell-gnome-3-16:default/linux/amd64/17.0/desktop/gnome/3.16
  [60]  dantrell-gnome-3-16:default/linux/amd64/17.0/desktop/gnome/3.16/extended
  [61]  dantrell-gnome-3-18:default/linux/amd64/13.0/desktop/gnome/3.18
  [62]  dantrell-gnome-3-18:default/linux/amd64/13.0/desktop/gnome/3.18/extended
  [63]  dantrell-gnome-3-18:default/linux/amd64/17.0/desktop/gnome/3.18
  [64]  dantrell-gnome-3-18:default/linux/amd64/17.0/desktop/gnome/3.18/extended
  [65]  dantrell-gnome-3-20:default/linux/amd64/13.0/desktop/gnome/3.20
  [66]  dantrell-gnome-3-20:default/linux/amd64/13.0/desktop/gnome/3.20/extended
  [67]  dantrell-gnome-3-20:default/linux/amd64/17.0/desktop/gnome/3.20
  [68]  dantrell-gnome-3-20:default/linux/amd64/17.0/desktop/gnome/3.20/extended
  [69]  dantrell-gnome-3-22:default/linux/amd64/13.0/desktop/gnome/3.22
  [70]  dantrell-gnome-3-22:default/linux/amd64/13.0/desktop/gnome/3.22/extended
  [71]  dantrell-gnome-3-22:default/linux/amd64/17.0/desktop/gnome/3.22
  [72]  dantrell-gnome-3-22:default/linux/amd64/17.0/desktop/gnome/3.22/extended
  [73]  dantrell-gnome-3-24:default/linux/amd64/13.0/desktop/gnome/3.24
  [74]  dantrell-gnome-3-24:default/linux/amd64/13.0/desktop/gnome/3.24/extended
  [75]  dantrell-gnome-3-24:default/linux/amd64/17.0/desktop/gnome/3.24
  [76]  dantrell-gnome-3-24:default/linux/amd64/17.0/desktop/gnome/3.24/extended
  [77]  dantrell-gnome-3-26:default/linux/amd64/13.0/desktop/gnome/3.26
  [78]  dantrell-gnome-3-26:default/linux/amd64/13.0/desktop/gnome/3.26/extended
  [79]  dantrell-gnome-3-26:default/linux/amd64/17.0/desktop/gnome/3.26
  [80]  dantrell-gnome-3-26:default/linux/amd64/17.0/desktop/gnome/3.26/extended

You'll notice that the old profiles are no longer listed. This is correct, however, they are still around so anyone who hasn't switched to the new profiles yet will experience no change (the same holds true if they switch to the new 13.0 profiles).

There's also the even less unofficially supported GNOME+Plasma profiles. I will only test these to make sure they get clean emerge output. The rest, I leave an exercise to the user. :twisted:

If you switch to a 17.0 profile, remember to follow the relevant news item.

Shibotto wrote:
A small update, I just noticed: dev-db/sqlite-3.20.1-r1 was unmasked on 2017-12-14 (ISO 8601 for the win!) and our app-misc/tracker needs to be rebuilt against it, otherwise every search exits with
Code:
no such tokenizer: TrackerTokenizer

Vanilla Gentoo unmasked it alongside app-misc/tracker-1.12.3, so it's only us.

I'm going to investigate this a bit as app-misc/tracker should be auto rebuilt based on dev-db/sqlite slot/subslot changes and bumping tracker on every sqlite update isn't the way to go.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Marlo
Veteran
Veteran


Joined: 26 Jul 2003
Posts: 1413

PostPosted: Fri Jan 05, 2018 1:21 pm    Post subject: Reply with quote

dantrell wrote:

I got around to them:

Code:

    ...
    ...
   [80]  dantrell-gnome-3-26:default/linux/amd64/17.0/desktop/gnome/3.26/extended



Thanks dantrell,

finished, without mistakes.
only virtualbox-modules had to install with a new kernel ther was compiled in the new pie environment.

Ma
_________________
Thank you for your attention, interest and support.
------------------------------------------------------------------
http://radio.garden/
Back to top
View user's profile Send private message
Elleni
l33t
l33t


Joined: 23 May 2006
Posts: 844

PostPosted: Sun Jan 07, 2018 1:59 pm    Post subject: Reply with quote

Thank you dantrell, after having switched back to pure plasma profile and successfully re-emerged all to be on 17.0 profile, I witched to your new gnome+plasma 17.0 profile.

Code:
eselect profile list
Available profile symlink targets:

  (...)

  [51]  dantrell-gnome:default/linux/amd64/13.0/desktop/gnome+plasma
  [52]  dantrell-gnome:default/linux/amd64/17.0/desktop/gnome+plasma *
  [53]  dantrell-gnome-3-26:default/linux/amd64/13.0/desktop/gnome/3.26
  [54]  dantrell-gnome-3-26:default/linux/amd64/13.0/desktop/gnome/3.26/extended
  [55]  dantrell-gnome-3-26:default/linux/amd64/17.0/desktop/gnome/3.26
  [56]  dantrell-gnome-3-26:default/linux/amd64/17.0/desktop/gnome/3.26/extended
  [57]  test:default/amd64/fusion/gnome+plasma


According to your wki I did an emerge world -uDNav. Compile of gnome-color-manager fails:

https://paste.pound-python.org/show/lyGaX03BTRESfDSytdNc/
https://paste.pound-python.org/show/easN2CIHLi3vqB0HSC2H/
https://paste.pound-python.org/show/Rc0Iq90McCdaQhUVTqUv/
https://paste.pound-python.org/show/PssVr53RR6KbhIbtEM5Y/

emerge --ask --verbose --keep-going gnome-base/gnome fails at gnome-power-manager

https://paste.pound-python.org/show/udmkBvAVonqhU29cBagT/
https://paste.pound-python.org/show/zQUz8hCXtAYl3Bmj93r5/
https://paste.pound-python.org/show/Y6ZrgpfO2hlsmvrmx01G/
https://paste.pound-python.org/show/ax8awJhahzr35QQDde4t/

What did I do wrongly and how to proceed ? :o
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 19, 20, 21 ... 27, 28, 29  Next
Page 20 of 29

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum