Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Dantrell's GNOME Without Systemd Project (Part 1)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 25, 26, 27, 28, 29  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 561
Location: Earth

PostPosted: Fri Apr 27, 2018 2:42 am    Post subject: Reply with quote

saboya wrote:
Are you on a multilib profile?

Nope.

saboya wrote:
I just noticed I got this permanent warning, no matter what I do

Maybe try this change (locally as it's not live):

Code:
diff '--exclude=.git' -urN a/at-spi2-core-2.28.0-r1.ebuild b/at-spi2-core-2.28.0-r1.ebuild
--- a/at-spi2-core-2.28.0-r1.ebuild   2018-04-25 21:24:49.412372000 -0400
+++ b/at-spi2-core-2.28.0-r1.ebuild   2018-04-26 22:40:29.532464464 -0400
@@ -56,8 +56,13 @@
    fi
 }
 
-multilib_src_compile() { meson_src_compile; }
-multilib_src_install() { meson_src_install; }
+multilib_src_compile() {
+   eninja
+}
+
+multilib_src_install() {
+   DESTDIR="${D}" eninja install
+}
 
 # weird hacks (needs for multilib support)
 pkg_postinst() {

_________________
Dantrell B.
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 441
Location: Brazil

PostPosted: Fri Apr 27, 2018 2:45 am    Post subject: Reply with quote

Got an error compiling totem as well:

Code:
FAILED: src/plugins/rotation/rotation@sha/totem-rotation-plugin.c src/plugins/rotation/rotation.h src/plugins/rotation/rotation.vapi
/usr/bin/valac-0.40 -C --pkg clutter-gtk-1.0 --pkg cogl-pango-1.0 --pkg libpeas-1.0 --pkg gtk+-3.0 --color=always --directory src/plugins/rotation/rotation@sha --basedir ../totem-3.26.0/src/plugins/rotation --library rotation --header src/plugins/rotation/rotation.h --vapi ../rotation.vapi --girdir=/var/tmp/portage/media-video/totem-3.26.0/work/totem-3.26.0-build/src --pkg=Totem-1.0 ../totem-3.26.0/src/plugins/rotation/bacon-video.vapi ../totem-3.26.0/src/plugins/rotation/totem-rotation-plugin.vala
error: Package `Totem-1.0' not found in specified Vala API directories or GObject-Introspection GIR directories
Compilation failed: 1 error(s), 0 warning(s)
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 441
Location: Brazil

PostPosted: Fri Apr 27, 2018 2:48 am    Post subject: Reply with quote

at-spi-core patch got me this error:

Code:
strip: x86_64-pc-linux-gnu-strip --strip-unneeded -R .comment -R .GCC.command.line -R .note.gnu.gold-version
   usr/libexec/at-spi-bus-launcher
   usr/lib64/libatspi.so.0.0.1
   usr/libexec/at-spi2-registryd
ecompressdir: bzip2 -9 /usr/share/doc

>>> Installing (1 of 1) app-accessibility/at-spi2-core-2.28.0-r1::dantrell-gnome-3-28
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/portage/dbapi/_MergeProcess.py", line 235, in _spawn
    prev_mtimes=self.prev_mtimes, counter=counter)
  File "/usr/lib64/python2.7/site-packages/portage/dbapi/vartree.py", line 1704, in wrapper
    return f(self, *args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/portage/dbapi/vartree.py", line 5150, in merge
    counter=counter)
  File "/usr/lib64/python2.7/site-packages/portage/dbapi/vartree.py", line 4391, in treewalk
    preserve_paths=preserve_paths)
  File "/usr/lib64/python2.7/site-packages/portage/dbapi/vartree.py", line 1704, in wrapper
    return f(self, *args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/portage/dbapi/vartree.py", line 2127, in unmerge
    preserve_paths=preserve_paths)
  File "/usr/lib64/python2.7/site-packages/portage/dbapi/vartree.py", line 1966, in _prune_plib_registry
    unmerge_no_replacement)
  File "/usr/lib64/python2.7/site-packages/portage/dbapi/vartree.py", line 3297, in _find_unused_preserved_libs
    for c in self.vartree.dbapi._linkmap.findConsumers(f):
  File "/usr/lib64/python2.7/site-packages/portage/util/_dyn_libs/LinkageMapELF.py", line 798, in findConsumers
    raise KeyError("%s (%s) not in object list" % (obj_key, obj))
KeyError: u'<portage.util._dyn_libs.LinkageMapELF._ObjectKey object at 0x7f09c3b80c58> (/usr/lib32/libatspi.so.0.0.1) not in object list'

>>> Failed to install app-accessibility/at-spi2-core-2.28.0-r1, Log file:
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 441
Location: Brazil

PostPosted: Fri Apr 27, 2018 2:53 am    Post subject: Reply with quote

Totem issue has to do with meson parallel builds, probably have to compile totem with -j1:

https://lists.nongnu.org/archive/html/bug-guix/2017-10/msg00138.html

https://debbugs.gnu.org/cgi/bugreport.cgi?bug=28813

https://github.com/mesonbuild/meson/issues/1923

https://bugzilla.gnome.org/show_bug.cgi?id=786248

*edit* - Confirming, -j1 does work.
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 441
Location: Brazil

PostPosted: Fri Apr 27, 2018 3:09 am    Post subject: Reply with quote

Good news, it works!

Have no idea why, just unmerged all my gnome-related stuff, gtk+, etc, and it's all good now.

Btw, might be good to set a <nautiulus-3.28 dep on gnome-tweak-tool, and a warning on nautilus telling people to switch to gnome-tweaks.
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 561
Location: Earth

PostPosted: Fri Apr 27, 2018 3:10 am    Post subject: Reply with quote

saboya wrote:
at-spi-core patch got me this error

Hmm, could it require Python 3?

saboya wrote:
Confirming, -j1 does work.

I actually recall this one.

I thought I did something about it at the time. Guess not. :o

saboya wrote:
Good news, it works!

So happy it wasn't me. :lol:
_________________
Dantrell B.
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 441
Location: Brazil

PostPosted: Fri Apr 27, 2018 3:15 am    Post subject: Reply with quote

dantrell wrote:

Hmm, could it require Python 3?


No dice after eselecting python3:

Code:
>>> Safely unmerging already-installed instance...
Traceback (most recent call last):
  File "/usr/lib64/python3.5/site-packages/portage/dbapi/_MergeProcess.py", line 235, in _spawn
    prev_mtimes=self.prev_mtimes, counter=counter)
  File "/usr/lib64/python3.5/site-packages/portage/dbapi/vartree.py", line 1704, in wrapper
    return f(self, *args, **kwargs)
  File "/usr/lib64/python3.5/site-packages/portage/dbapi/vartree.py", line 5150, in merge
    counter=counter)
  File "/usr/lib64/python3.5/site-packages/portage/dbapi/vartree.py", line 4391, in treewalk
    preserve_paths=preserve_paths)
  File "/usr/lib64/python3.5/site-packages/portage/dbapi/vartree.py", line 1704, in wrapper
    return f(self, *args, **kwargs)
  File "/usr/lib64/python3.5/site-packages/portage/dbapi/vartree.py", line 2127, in unmerge
    preserve_paths=preserve_paths)
  File "/usr/lib64/python3.5/site-packages/portage/dbapi/vartree.py", line 1966, in _prune_plib_registry
    unmerge_no_replacement)
  File "/usr/lib64/python3.5/site-packages/portage/dbapi/vartree.py", line 3297, in _find_unused_preserved_libs
    for c in self.vartree.dbapi._linkmap.findConsumers(f):
  File "/usr/lib64/python3.5/site-packages/portage/util/_dyn_libs/LinkageMapELF.py", line 798, in findConsumers
    raise KeyError("%s (%s) not in object list" % (obj_key, obj))
KeyError: '<portage.util._dyn_libs.LinkageMapELF.LinkageMapELF._ObjectKey object at 0x7fbf86f42df8> (/usr/lib32/libatspi.so.0.0.1) not in object list'


dantrell wrote:

So happy it wasn't me. :lol:


Yeah :) Sorry for wasting your time, at least I picked a few bugs.
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 441
Location: Brazil

PostPosted: Fri Apr 27, 2018 4:10 am    Post subject: Reply with quote

One more thing

After masking xpyb, Gentoo team just moved x11-proto/xcb-proto to x11-base/xcb-proto. I guess this means you either have to update xpub dependencies or move to a new pycairo version afterall. Can't depclean now because portage can't find x11-proto/xcb-proto:

Code:
Calculating dependencies... done!
 * Dependencies could not be completely resolved due to
 * the following required packages not being installed:
 *
 *   >=x11-proto/xcb-proto-1.7.1[python_targets_python2_7(-),-python_single_target_python2_7(-)] pulled in by:
 *     x11-libs/xpyb-1.3.1-r4
 *
 * Have you forgotten to do a complete update prior to depclean? The
 * most comprehensive command for this purpose is as follows:
 *
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 561
Location: Earth

PostPosted: Fri Apr 27, 2018 9:58 am    Post subject: Reply with quote

saboya wrote:
Totem issue has to do with meson parallel builds, probably have to compile totem with -j1

I disabled parallel builds for Totem but I'll be looking to improve this workaround.

saboya wrote:
Btw, might be good to set a <nautiulus-3.28 dep on gnome-tweak-tool, and a warning on nautilus telling people to switch to gnome-tweaks.

As long as gnome-extra/gnome-tweak-tool isn't in your world file you will be transitioned to gnome-extra/gnome-tweaks correctly.

If it is in your world file things get a bit bumpy. I'm going to think on this one for a bit.

saboya wrote:
No dice after eselecting python3

I think I got it this time. Change is live too so sync up and you should be good to go.

saboya wrote:
[...] at least I picked a few bugs.

That you did.

Thanks for volunteering. :twisted:

saboya wrote:
After masking xpyb, Gentoo team just moved x11-proto/xcb-proto to x11-base/xcb-proto.

This should be accounted for.
_________________
Dantrell B.
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 441
Location: Brazil

PostPosted: Fri Apr 27, 2018 10:17 am    Post subject: Reply with quote

saboya wrote:
Another thing to report: I'm always getting a dialog to unlock my keyring when I open the first app that accesses it. For some reason it isn't getting unlocked when session is created. Any ideas on this one?


Ok, just got this one.

Apparently pam.d was starting gnome_keyring.so multiple times for some reason. I don't know if I put it there or what, but I don't remember that. On /etc/pam.d/login-session, removing this line made it work:

Code:
session         optional        pam_gnome_keyring.so auto_start


Because the same line exists at /etc/pam.d/gdm-password
Back to top
View user's profile Send private message
Juippisi
Guru
Guru


Joined: 30 Sep 2005
Posts: 336
Location: /home

PostPosted: Fri Apr 27, 2018 6:28 pm    Post subject: Reply with quote

Oh well, didnt have motivation or time really to try and fix 3.26. I updated straight to 3.28 :P

Im sorry I dont have 100 % exact logs since I kinda "hurried" the update, but gnome-desktop required newer gsettings-desktop-schemas than what was specified in the ebuild. I think it needed 3.28 version and I had 3.24 installed (guess it tried to update gnome-desktop before gsettings-desktop-schemas).

Then, gnome-shell required ibus even though I had the USE flag disabled. Not sure if this is meson-related, but it continued when I manually emerged ibus before gnome-shell. Then there was something weird with evolution-data-server... It complained that I didnt have webkit libraries installed (and I dont, but why would evolution-data-server need it?) and it suggested that I add -DENABLE_OAUTH2=OFF to cmakeargs. I manually added this line to the evolution-data-server-3.28.1.ebuild and emerging works. Fully emerged gnome-light-3.28 after these.

Sorry I dont have time to format my message or dig deeper into the problems, but once again, wanted to get the info out here ASAP.
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 441
Location: Brazil

PostPosted: Fri Apr 27, 2018 7:03 pm    Post subject: Reply with quote

I didn't even know it was possible to have Gnome3 installed without webkit-gtk.
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 561
Location: Earth

PostPosted: Sat Apr 28, 2018 4:38 am    Post subject: Reply with quote

saboya wrote:
Because the same line exists at /etc/pam.d/gdm-password

GDM does its thing correctly with /etc/pam.d/gdm-password. So your problem is almost definitely /etc/pam.d/login-session because I don't have that file.

Check with equery belongs?

Juippisi wrote:
Oh well, didnt have motivation or time really to try and fix 3.26. I updated straight to 3.28 :P

Completely understandable. :P

Juippisi wrote:
Im sorry I dont have 100 % exact logs since I kinda "hurried" the update, but gnome-desktop required newer gsettings-desktop-schemas than what was specified in the ebuild. I think it needed 3.28 version and I had 3.24 installed (guess it tried to update gnome-desktop before gsettings-desktop-schemas).

Done.

Juippisi wrote:
Then, gnome-shell required ibus even though I had the USE flag disabled. Not sure if this is meson-related, but it continued when I manually emerged ibus before gnome-shell.

Done.

Juippisi wrote:
Then there was something weird with evolution-data-server... It complained that I didnt have webkit libraries installed (and I dont, but why would evolution-data-server need it?) and it suggested that I add -DENABLE_OAUTH2=OFF to cmakeargs. I manually added this line to the evolution-data-server-3.28.1.ebuild and emerging works. Fully emerged gnome-light-3.28 after these.

And done (WebKitGTK+ is still optional).

Juippisi wrote:
Sorry I dont have time to format my message or dig deeper into the problems, but once again, wanted to get the info out here ASAP.

No problem. Thanks for the feedback.

Now calling for the third volunteer. :twisted:

saboya wrote:
I didn't even know it was possible to have Gnome3 installed without webkit-gtk.

In hindsight, it's very doable with gnome-base/gnome-light as long as you are willing to drop (or switch out) some packages and/or functionality.

Maybe even a little package.provided for good measure.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Juippisi
Guru
Guru


Joined: 30 Sep 2005
Posts: 336
Location: /home

PostPosted: Sat Apr 28, 2018 5:00 am    Post subject: Reply with quote

saboya wrote:
I didn't even know it was possible to have Gnome3 installed without webkit-gtk.


It was actually very easy in the end to get rid of it. There was only few packages that straight up depended on it with a 'webkit' USE flag, then few packages that depended on other packages with certain USE flag enabled (for example nautilus[previewer] depended on zenity[webkit] etc).

So far Im really happy with 3.28. Thumbnails work in Nautilus, my extensions work, CSD with Firefox works... huge thanks dantrell, your work is truly appreciated :)

Ill keep updating and report any oddities I might find.
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 441
Location: Brazil

PostPosted: Sat Apr 28, 2018 3:28 pm    Post subject: Reply with quote

dantrell wrote:

GDM does its thing correctly with /etc/pam.d/gdm-password. So your problem is almost definitely /etc/pam.d/login-session because I don't have that file.

Check with equery belongs?


Code:
$ equery belongs /etc/pam.d/system-login
 * Searching for /etc/pam.d/system-login ...
sys-auth/pambase-20150213-r1 (/etc/pam.d/system-login)


And then:

Code:
# emerge -1av pambase

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] sys-auth/pambase-20150213-r1::dantrell-gnome  USE="cracklib elogind gnome-keyring nullok sha512 -ck (-consolekit) -debug -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc -securetty (-selinux) (-systemd)" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB

Would you like to merge these packages? [Yes/No]
Back to top
View user's profile Send private message
Marlo
Veteran
Veteran


Joined: 26 Jul 2003
Posts: 1413

PostPosted: Sat Apr 28, 2018 3:33 pm    Post subject: Reply with quote

Dantrell-gnome-3-26/extended is installed


Is it possible to scale 150% in GNOME 3.26?

The background of the question is. I have a monitor on a workstation with a resolution of 3840x2160. In the normal scaling of 100% Gnome has "disappeared".
The panel and the icons are really, very small. A scaling of 200% is unfortunately too big.

Ideal would be a scaling of 150%. Is this possible and if so, how?

Thanks for any hint!
Ma
_________________
Thank you for your attention, interest and support.
------------------------------------------------------------------
http://radio.garden/
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 561
Location: Earth

PostPosted: Sat Apr 28, 2018 10:08 pm    Post subject: Reply with quote

saboya wrote:
And then

You said the file was /etc/pam.d/login-session though?

P.S. Off topic, but I ran into this performance related merge request for Mutter. Will probably back port it (provided previews look fine without mipmapping).

Marlo wrote:
Ideal would be a scaling of 150%. Is this possible and if so, how?

Use gsettings (or dconf-editor) to enable experimental fractional scaling for Mutter then restart GNOME Shell:

Code:
gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']"

It's experimental because it's blurry without Wayland (and even with Wayland for non-GNOME applications).
_________________
Dantrell B.
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 441
Location: Brazil

PostPosted: Sun Apr 29, 2018 2:20 am    Post subject: Reply with quote

dantrell wrote:
You said the file was /etc/pam.d/login-session though?

Apparently I did, I don't know why. I can confirm I meant /etc/pam.d/system-login, since I can find the line that I commented out in the file.

Nice find with the patch!
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 441
Location: Brazil

PostPosted: Sun Apr 29, 2018 8:31 am    Post subject: Reply with quote

Just figured out the bizarre issue I had with gdm / gnome-shell with grey screens. Turns out having

Code:
export CLUTTER_VBLANK=none


I'm my /etc/environment causes this. The weird thing is, this was already set when I was using 3.26 and I had no issues whatsoever. I commented it out, along with some others, to see if they had any effect but I totally forgot about it. I turned it on now, and there it was, my good friend grey screen.
Back to top
View user's profile Send private message
simonvanderveldt
Tux's lil' helper
Tux's lil' helper


Joined: 26 Jan 2016
Posts: 103

PostPosted: Sun Apr 29, 2018 8:43 am    Post subject: Reply with quote

Having a small issue with compilation for net-libs/webkit-gtk-2.20.1 failing with the following error

Code:

/var/tmp/portage/net-libs/webkit-gtk-2.20.1/work/webkitgtk-2.20.1/Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamerBase.cpp:187:36: error: 'TextureMapperPlatformLayerBuffer' has not been declared


There are other errors btw, this is just the first one. A (very long) complete log can be found here https://bpaste.net/show/0a9432a50d2b
I'm using GCC 7.3.0 btw, not sure if that's relevant or not.

Reading the messages above it sounds like it would be possible to get rid of webkit-gtk, that would be great! This is the current list of packages I have installed that depend on webkit-gtk
Code:

gnome-extra/evolution-data-server-3.26.6 (google ? >=net-libs/webkit-gtk-2.11.91:4)
gnome-extra/sushi-3.24.0 (net-libs/webkit-gtk:4[introspection])
gnome-extra/zenity-3.24.0 (webkit ? >=net-libs/webkit-gtk-2.8.1:4)
net-libs/gnome-online-accounts-3.26.2 (>=net-libs/webkit-gtk-2.7.2:4)
net-libs/libproxy-0.4.13-r2 (webkit ? net-libs/webkit-gtk:4)


I don't think it would be possible to get rid of it, since gnome-online-accounts depends on it and I need that to get my calendar integration going. I expect webkit-gtk is used for the pop-up window you get when logging into an online service. Or is there a way around this?
Back to top
View user's profile Send private message
Marlo
Veteran
Veteran


Joined: 26 Jul 2003
Posts: 1413

PostPosted: Sun Apr 29, 2018 12:20 pm    Post subject: Reply with quote

dantrell wrote:

Marlo wrote:
Ideal would be a scaling of 150%. Is this possible and if so, how?

Use gsettings (or dconf-editor) to enable experimental fractional scaling for Mutter then restart GNOME Shell:

Code:
gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']"

It's experimental because it's blurry without Wayland (and even with Wayland for non-GNOME applications).


Thanks for the hint dantrell,

Unfortunately I can not use wayland at the moment. Under wayland, the mouse does not work properly.
The keyboard works but the mouse does not give any clicks. Neither right nor left. The mouse wheel does not work either.
I can move the curser and so the upper left corner moves. But nothing else.

I have set these programs to ~ amd64. But it did not help.
Code:

tux ~ # emerge -1 llvm clang x11-libs/libdrm  media-libs/mesa x11-apps/mesa-progs x11-base/xorg-server x11-base/xorg-drivers $(qlist -IC x11-drivers/) wayland -av

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ~] x11-libs/libdrm-2.4.91::gentoo  USE="libkms -valgrind" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="amdgpu radeon (-exynos) (-freedreno) -intel -nouveau (-omap) (-tegra) (-vc4) (-vivante) -vmware" 0 KiB

[ebuild   R   ~] dev-libs/wayland-1.14.0::gentoo  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB

[ebuild   R   ~] sys-devel/llvm-6.0.0-r1:6::gentoo  USE="libffi ncurses xml -debug -doc -gold -libedit {-test} -xar" ABI_X86="(64) -32 (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -Lanai -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore" 0 KiB

[ebuild   R   ~] sys-devel/clang-6.0.0-r1:6::gentoo  USE="static-analyzer xml -debug -default-compiler-rt -default-libcxx -doc {-test} (-z3)" ABI_X86="(64) -32 (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -Lanai -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore" PYTHON_TARGETS="python2_7" 0 KiB

[ebuild   R   ~] media-libs/mesa-18.0.1::gentoo  USE="classic dri3 egl gallium gbm gles1 gles2 llvm nptl opencl openmax vaapi vdpau vulkan wayland xa xvmc -bindist -d3d9 -debug -osmesa -pax_kernel -pic (-selinux) -unwind -valgrind" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="radeonsi (-freedreno) -i915 -i965 (-imx) -intel -nouveau -r100 -r200 -r300 -r600 -radeon (-vc4) -virgl (-vivante) -vmware" 0 KiB

[ebuild   R    ] x11-apps/mesa-progs-8.3.0::gentoo  USE="egl gles2" 0 KiB

[ebuild   R    ] x11-base/xorg-server-1.19.5-r1:0/1.19.5::gentoo  USE="glamor ipv6 kdrive suid udev wayland xorg xvfb -debug -dmx -doc -libressl -minimal (-selinux) -static-libs (-systemd) -tslib -unwind -xcsecurity -xephyr -xnest" 0 KiB

[ebuild   R   ~] x11-drivers/xf86-input-libinput-0.27.1::gentoo  0 KiB

[ebuild   R   ~] x11-drivers/xf86-video-amdgpu-18.0.1::gentoo  0 KiB

[ebuild   R   ~] x11-drivers/xf86-video-ati-18.0.1::gentoo  USE="glamor udev" 0 KiB

[ebuild   R    ] x11-base/xorg-drivers-1.19::gentoo  INPUT_DEVICES="libinput -elographics -evdev -joystick -keyboard -mouse -synaptics -tslib -vmmouse -void -wacom" VIDEO_CARDS="amdgpu radeonsi -ast -dummy -fbdev (-freedreno) (-geode) -glint -i915 -i965 -intel -mga (-newport) -nouveau -nv -nvidia (-omap) -qxl -r128 -radeon -siliconmotion (-tdfx) (-tegra) (-vc4) -vesa -via -virtualbox -vmware (-voodoo)" 0 KiB

Total: 11 packages (11 reinstalls), Size of downloads: 0 KiB

Would you like to merge these packages? [Yes/No]



Do you have an idea where I made a mistake?

Thank you
Ma
_________________
Thank you for your attention, interest and support.
------------------------------------------------------------------
http://radio.garden/
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 561
Location: Earth

PostPosted: Mon Apr 30, 2018 3:51 am    Post subject: Reply with quote

saboya wrote:
Apparently I did, I don't know why. I can confirm I meant /etc/pam.d/system-login, since I can find the line that I commented out in the file.

Thanks for the clarification.

I'll see if I can reproduce this issue.

simonvanderveldt wrote:
Having a small issue with compilation for net-libs/webkit-gtk-2.20.1 failing with the following error

simonvanderveldt wrote:
I'm using GCC 7.3.0 btw, not sure if that's relevant or not.

I suspected GCC 7.3.0 but my build against it was successful.

My next suspect is somewhere between WebKitGTK+ and GStreamer since that's where the errors seem to originate.

P.S. I actually recall this issue but apparently it fell through the cracks.

simonvanderveldt wrote:
Reading the messages above it sounds like it would be possible to get rid of webkit-gtk, that would be great! This is the current list of packages I have installed that depend on webkit-gtk

simonvanderveldt wrote:
I don't think it would be possible to get rid of it, since gnome-online-accounts depends on it and I need that to get my calendar integration going. I expect webkit-gtk is used for the pop-up window you get when logging into an online service. Or is there a way around this?

You can get rid of it if you drop gnome-extra/sushi and net-libs/gnome-online-accounts.

Since you need the latter, you are probably out of luck (for the record, I checked the code for GNOME Online Accounts to see if WebKitGTK+ could be made optional but it looked pretty important).

Marlo wrote:
Do you have an idea where I made a mistake?

This sounds like a GNOME+Wayland issue. I'm seeing a lot of reports like this one and apparently the workaround is to not use Wayland. :o
_________________
Dantrell B.
Back to top
View user's profile Send private message
simonvanderveldt
Tux's lil' helper
Tux's lil' helper


Joined: 26 Jan 2016
Posts: 103

PostPosted: Tue May 01, 2018 11:21 am    Post subject: Reply with quote

dantrell wrote:
simonvanderveldt wrote:
Having a small issue with compilation for net-libs/webkit-gtk-2.20.1 failing with the following error

simonvanderveldt wrote:
I'm using GCC 7.3.0 btw, not sure if that's relevant or not.

I suspected GCC 7.3.0 but my build against it was successful.

My next suspect is somewhere between WebKitGTK+ and GStreamer since that's where the errors seem to originate.

P.S. I actually recall this issue but apparently it fell through the cracks.

I just re-emerged net-libs/webkit-gtk-2.18.6 and that worked fine. Could still be a gcc 7 issue, but seems somewhat unlikely a newer version would have issues with gcc 7 I guess?


dantrell wrote:

simonvanderveldt wrote:
Reading the messages above it sounds like it would be possible to get rid of webkit-gtk, that would be great! This is the current list of packages I have installed that depend on webkit-gtk

simonvanderveldt wrote:
I don't think it would be possible to get rid of it, since gnome-online-accounts depends on it and I need that to get my calendar integration going. I expect webkit-gtk is used for the pop-up window you get when logging into an online service. Or is there a way around this?

You can get rid of it if you drop gnome-extra/sushi and net-libs/gnome-online-accounts.

Since you need the latter, you are probably out of luck (for the record, I checked the code for GNOME Online Accounts to see if WebKitGTK+ could be made optional but it looked pretty important).

Thanks for checking! Pity, it's an annoying package that takes way too long to emerge for something I don't directly need :(
Back to top
View user's profile Send private message
Elleni
l33t
l33t


Joined: 23 May 2006
Posts: 844

PostPosted: Tue May 01, 2018 8:58 pm    Post subject: Reply with quote

With combined gnome+plasma profile, I had to modify
Code:
/var/lib/layman/dantrell-gnome/profiles/default/linux/amd64/17.0/desktop/gnome+plasma/parent
and change 3.26 to 3.28 in order to be able to update to newest version. After that it worked like a charme :)
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 561
Location: Earth

PostPosted: Tue May 01, 2018 9:56 pm    Post subject: Reply with quote

simonvanderveldt wrote:
I just re-emerged net-libs/webkit-gtk-2.18.6 and that worked fine. Could still be a gcc 7 issue, but seems somewhat unlikely a newer version would have issues with gcc 7 I guess

It built for me with GCC 7 so I do think it's unlikely. I suppose you could try building with GCC 6 to double check.

Just be careful about using WebKitGTK+ 2.18.6 with applications that actively interact with web content due to all the recent security vulnerabilities.

Elleni wrote:
With combined gnome+plasma profile, I had to modify
Code:
/var/lib/layman/dantrell-gnome/profiles/default/linux/amd64/17.0/desktop/gnome+plasma/parent
and change 3.26 to 3.28 in order to be able to update to newest version. After that it worked like a charme :)

Nice. Although, I think you missed this from the last page:

dantrell wrote:
Elleni wrote:
Just want to report, that everything compiled fine with new plasma+gnome profile.

Since you were the reason GNOME+Plasma profiles were added, just let me know when you want the profiles to be switched from GNOME 3.26 to GNOME 3.28.

That is, after someone other than me confirms that it builds. :twisted:

I guess I can go ahead and switch it though? :wink:
_________________
Dantrell B.
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 25, 26, 27, 28, 29  Next
Page 26 of 29

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum