Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
wifi random disconnection problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
xcraft
n00b
n00b


Joined: 03 Jul 2006
Posts: 2

PostPosted: Fri Jul 17, 2015 6:28 pm    Post subject: wifi random disconnection problem Reply with quote

I have an old HP HDX Premium Series laptop with touch sensitive buttons on the top of the keyboard for sound adjustment and also a touchkey for turning on-off wifi. I set these keys on my .xbindkeys config file but i didn't need to define the wifi toggle key since it was working when i installed the system.

My problem is that my wifi turns on and off from time to time. Regarding dmesg output is as follows.

Code:

[ 6541.594254] iwlwifi 0000:02:00.0: RF_KILL bit toggled to disable radio.
[ 6541.594925] iwlwifi 0000:02:00.0: Not sending command - RF KILL
[ 6541.594951] iwlwifi 0000:02:00.0: Not sending command - RF KILL
[ 6541.594991] iwlwifi 0000:02:00.0: Not sending command - RF KILL
[ 6541.594998] iwlwifi 0000:02:00.0: Not sending command - RF KILL
[ 6541.595027] iwlwifi 0000:02:00.0: Not sending command - RF KILL
[ 6541.595035] iwlwifi 0000:02:00.0: Not sending command - RF KILL
[ 6541.595043] iwlwifi 0000:02:00.0: Not sending command - RF KILL
[ 6541.595054] iwlwifi 0000:02:00.0: Not sending command - RF KILL
[ 6541.595158] iwlwifi 0000:02:00.0: Not sending command - RF KILL
[ 6541.595204] iwlwifi 0000:02:00.0: Not sending command - RF KILL
[ 6549.681153] iwlwifi 0000:02:00.0: RF_KILL bit toggled to enable radio.
[ 6566.024398] iwlwifi 0000:02:00.0: RF_KILL bit toggled to disable radio.
[ 6566.024909] iwlwifi 0000:02:00.0: Not sending command - RF KILL
[ 6566.024931] iwlwifi 0000:02:00.0: Not sending command - RF KILL
[ 6566.024998] iwlwifi 0000:02:00.0: Not sending command - RF KILL
[ 6566.025025] iwlwifi 0000:02:00.0: Not sending command - RF KILL
[ 6566.025470] iwlwifi 0000:02:00.0: Not sending command - RF KILL
[ 6566.025479] iwlwifi 0000:02:00.0: Not sending command - RF KILL
[ 6566.025487] iwlwifi 0000:02:00.0: Not sending command - RF KILL
[ 6566.025500] iwlwifi 0000:02:00.0: Not sending command - RF KILL
[ 6566.026833] iwlwifi 0000:02:00.0: Not sending command - RF KILL
[ 6566.026931] iwlwifi 0000:02:00.0: Not sending command - RF KILL
[ 6578.893717] iwlwifi 0000:02:00.0: RF_KILL bit toggled to enable radio.


output of rfkill list all is when wifi is working:
Code:

0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no


when it disconnects, although i don't press the wifi toggle hardware key, Hard blocked changes to Yes. Also i see a lot of keycode errors in the dmesg.

Code:

[ 6299.655102] atkbd serio0: Use 'setkeycodes e03e <keycode>' to make it known.
[ 6299.708768] atkbd serio0: Unknown key pressed (translated set 2, code 0xbf on isa0060/serio0).
[ 6299.708772] atkbd serio0: Use 'setkeycodes e03f <keycode>' to make it known.
[ 6299.714846] atkbd serio0: Unknown key released (translated set 2, code 0xbf on isa0060/serio0).
[ 6299.714855] atkbd serio0: Use 'setkeycodes e03f <keycode>' to make it known.


Any suggestion how to solve my problem?
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Sat Jul 18, 2015 6:57 am    Post subject: Reply with quote

Quote:
[ 6549.681153] iwlwifi 0000:02:00.0: RF_KILL bit toggled to enable radio.
[ 6566.024398] iwlwifi 0000:02:00.0: RF_KILL bit toggled to disable radio.



AFAIK rf_kill, comparing to my hardware, is the kill switch for the wifi and bluetooth (wireless devices board).

Check the wiring of the wifi rf_kill switch, thats a hardware switch, teh wifi boards, screws, cables.
if you have a broken cable, you hardly will be able to check that out easily, as the connectors or the small wires in teh cable could have already a loose connection.

When I turn off the kill switch wifi and bluetooth is instantly disabled until I enable it again with that rf_kill switch.

i think this is more a hardware issue but i may be wrong. did you booted up a livecd and checked if it happens there?

check teh wiring of your keyboard, if thats a ribbon cable you need to take it out and put it in, careful they need to be handled special. some notebook manufactuerers provide service / repair manuals.

Quote:
[ 6299.655102] atkbd serio0: Use 'setkeycodes e03e <keycode>' to make it known.
[ 6299.708768] atkbd serio0: Unknown key pressed (translated set 2, code 0xbf on isa0060/serio0).
[ 6299.708772] atkbd serio0: Use 'setkeycodes e03f <keycode>' to make it known.
[ 6299.714846] atkbd serio0: Unknown key released (translated set 2, code 0xbf on isa0060/serio0).
[ 6299.714855] atkbd serio0: Use 'setkeycodes e03f <keycode>' to make it known.


looks like two different keys are pressed and they seems to be on the isa bus, maybe these events suggest that the rf kill button was pressed and not recognized .. as i do not have the schematics / software of your motherboard i can only guess. it also looks that they are on the isa bus.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum