Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Timezone change during install results clock skew
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
zhak
n00b
n00b


Joined: 04 May 2015
Posts: 21

PostPosted: Tue Jul 21, 2015 8:51 pm    Post subject: [solved] Timezone change during install results clock skew Reply with quote

Hi guys,

I'm installing Gentoo on a VMWare VM following the Gentoo Handbook.
VM clock is syncronized with the host, so in /etc/conf.d/hwclock I set:
Code:
clock="local"
clock_systohc="NO"

Section which describes Timezone configuration says I need to do
Code:
emerge --config sys-libs/timezone-data

The problem is that after this command is executed, local time is automatically changed to +couple of hours (adjusted according to timezone), which later results clock skew.

How to set timezone correctly, so that local time is not adjusted, but remains the same. Only timezone changes

Thanks in advance!


Last edited by zhak on Fri Jul 24, 2015 9:42 am; edited 1 time in total
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 433
Location: Australia

PostPosted: Wed Jul 22, 2015 1:29 am    Post subject: Reply with quote

If the host is serving UTC then your "local" setting will result in this behaviour, with the skew=<your UTC offset>

edit /etc/conf.d/hwclock again and change to
Code:

clock="UTC"
# clock_systohc="NO"


and see if that helps.
Back to top
View user's profile Send private message
zhak
n00b
n00b


Joined: 04 May 2015
Posts: 21

PostPosted: Thu Jul 23, 2015 4:08 pm    Post subject: Reply with quote

Thanks for advice, but it didn't work. However, I solved the problem by executing

Code:
emerge --config sys-libs/timezone-data
hwclock --localtime -s


sequence.
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 433
Location: Australia

PostPosted: Thu Jul 23, 2015 11:33 pm    Post subject: Reply with quote

glad you got it fixed, that's the main thing.

Could you edit your subject if this is [solved] so others can reference your solution.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum