Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kde-overlay
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
davidm
Guru
Guru


Joined: 26 Apr 2009
Posts: 557
Location: US

PostPosted: Sun Jul 26, 2015 4:01 am    Post subject: kde-overlay Reply with quote

So I decided to try the kde-overlay again and am running plasma and kf5 live packages to get osme bug fixes dealing with session management. All went well there. But upon trying to install the kde-apps 15.08.49.9999 beta packages I ran across this:

Code:

emerge -uavDN --backtrack=100 @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] net-libs/http-parser-2.5.0:0/2.5.0::gentoo  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ] dev-libs/libgit2-0.23.0:0/23::gentoo  USE="threads -examples -gssapi -ssh {-test} -trace" 3,628 KiB
[ebuild  NS   *] kde-apps/libkomparediff2-15.08.49.9999:5::kde [4.14.3:4/4.14::gentoo] USE="-debug {-test}" 0 KiB
[uninstall     ] kde-apps/libkomparediff2-4.14.3:4/4.14::gentoo  USE="(-aqua) -debug {-test}"
[blocks b      ] kde-apps/libkomparediff2:4 ("kde-apps/libkomparediff2:4" is blocking kde-apps/libkomparediff2-15.08.49.9999)
[ebuild  NS   *] kde-apps/libkonq-5.9999:5::kde [4.14.3:4/4.14::gentoo] USE="-debug -doc {-test}" 0 KiB
[ebuild  N    *] kde-apps/baloo-widgets-9999:5::kde  USE="-debug" 0 KiB
[ebuild  NS   *] kde-apps/kcalc-15.08.49.9999:5::kde [4.14.3:4/4.14::gentoo] USE="handbook -debug" 0 KiB
[uninstall     ] kde-apps/kcalc-4.14.3:4/4.14::gentoo  USE="handbook (-aqua) -debug"
[blocks b      ] kde-apps/kcalc:4 ("kde-apps/kcalc:4" is blocking kde-apps/kcalc-15.08.49.9999)
[ebuild  NS   *] kde-apps/ark-15.08.49.9999:5::kde [4.14.3-r1:4/4.14::gentoo] USE="handbook -debug -dolphin {-test}" 0 KiB
[uninstall     ] kde-apps/ark-4.14.3-r1:4/4.14::gentoo  USE="archive bzip2 handbook (-aqua) -debug -lzma"
[blocks b      ] kde-apps/ark:4 ("kde-apps/ark:4" is blocking kde-apps/ark-15.08.49.9999)
[ebuild  NS   *] kde-apps/konsole-15.08.49.9999:5::kde [4.14.3:4/4.14::gentoo] USE="X handbook -debug {-test}" 0 KiB
[uninstall     ] kde-apps/konsole-4.14.3:4/4.14::gentoo  USE="handbook (-aqua) -debug {-test}"
[blocks b      ] kde-apps/konsole:4 ("kde-apps/konsole:4" is blocking kde-apps/konsole-15.08.49.9999)
[ebuild  NS   *] kde-apps/dolphin-15.08.49.9999:5::kde [4.14.3:4/4.14::gentoo] USE="handbook semantic-desktop -debug {-test} (-thumbnail)" 0 KiB
[uninstall     ] kde-apps/dolphin-4.14.3:4/4.14::gentoo  USE="handbook semantic-desktop thumbnail (-aqua) -debug"
[blocks b      ] kde-apps/dolphin:4 ("kde-apps/dolphin:4" is blocking kde-apps/dolphin-15.08.49.9999)
[ebuild  NS   *] kde-apps/kmix-15.08.49.9999:5::kde [4.14.3-r1:4/4.14::gentoo] USE="alsa pulseaudio -canberra -debug" 0 KiB
[uninstall     ] kde-apps/kmix-4.14.3-r1:4/4.14::gentoo  USE="alsa handbook pulseaudio (-aqua) -canberra -debug"
[blocks b      ] kde-apps/kmix:4 ("kde-apps/kmix:4" is blocking kde-apps/kmix-15.08.49.9999)
[ebuild  NS   *] kde-apps/print-manager-15.08.49.9999:5::kde [4.14.3:4/4.14::gentoo] USE="gtk -debug" 0 KiB
[uninstall     ] kde-apps/print-manager-4.14.3:4/4.14::gentoo  USE="gtk (-aqua) -debug"
[blocks b      ] kde-apps/print-manager:4 ("kde-apps/print-manager:4" is blocking kde-apps/print-manager-15.08.49.9999)
[ebuild  NS   *] kde-apps/kompare-15.08.49.9999:5::kde [4.14.3:4/4.14::gentoo] USE="handbook -debug" 0 KiB
[uninstall     ] kde-apps/kompare-4.14.3:4/4.14::gentoo  USE="handbook (-aqua) -debug"
[blocks b      ] kde-apps/kompare:4 ("kde-apps/kompare:4" is blocking kde-apps/kompare-15.08.49.9999)
[ebuild  NS   *] kde-apps/dolphin-plugins-15.08.49.9999:5::kde [4.14.3:4/4.14::gentoo] USE="-bazaar -debug -dropbox -git -subversion" 0 KiB
[uninstall     ] kde-apps/dolphin-plugins-4.14.3:4/4.14::gentoo  USE="(-aqua) -bazaar -debug -git -mercurial -subversion"
[blocks b      ] kde-apps/dolphin-plugins:4 ("kde-apps/dolphin-plugins:4" is blocking kde-apps/dolphin-plugins-15.08.49.9999)
[ebuild  NS   *] kde-apps/kate-15.08.49.9999:5::kde [4.14.3:4/4.14::gentoo] USE="addons handbook -debug {-test}" 0 KiB
[uninstall     ] kde-apps/kate-4.14.3:4/4.14::gentoo  USE="handbook (-aqua) -debug -python" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_4 -python3_3"
[blocks b      ] kde-apps/kate:4 ("kde-apps/kate:4" is blocking kde-apps/kate-15.08.49.9999)
[ebuild  NS   *] kde-apps/gwenview-15.08.49.9999:5::kde [4.14.3:4/4.14::gentoo] USE="X handbook semantic-desktop -debug (-kipi) (-raw) {-test}" 0 KiB
[uninstall     ] kde-apps/gwenview-4.14.3:4/4.14::gentoo  USE="handbook kipi semantic-desktop (-aqua) -debug"
[blocks b      ] kde-apps/gwenview:4 ("kde-apps/gwenview:4" is blocking kde-apps/gwenview-15.08.49.9999)
[ebuild  NS   *] kde-apps/kwrite-15.08.49.9999:5::kde [4.14.3:4/4.14::gentoo] USE="-debug" 0 KiB
[uninstall     ] kde-apps/kwrite-4.14.3:4/4.14::gentoo  USE="handbook (-aqua) -debug"
[blocks b      ] kde-apps/kwrite:4 ("kde-apps/kwrite:4" is blocking kde-apps/kwrite-15.08.49.9999)
[ebuild     U *] kde-apps/kfmclient-15.08.49.9999:4/15.08::kde [4.14.3:4/4.14::gentoo] USE="(-aqua) -debug" 0 KiB
[ebuild     U *] kde-apps/knotify-15.08.49.9999:4/15.08::kde [4.14.3:4/4.14::gentoo] USE="(-aqua) -debug" 0 KiB
[ebuild     U *] kde-apps/libkonq-15.08.49.9999:4/15.08::kde [4.14.3:4/4.14::gentoo] USE="(-aqua) -debug {-test}" 0 KiB
[ebuild     U *] kde-apps/kwalletd-15.08.49.9999:4/15.08::kde [4.14.3-r2:4/4.14::gentoo] USE="(-aqua) -debug -gpg" 0 KiB
[ebuild  NS   *] kde-apps/oxygen-icons-15.08.49.9999:5::kde [4.14.3:4/4.14::gentoo] USE="-debug -sources" 0 KiB
[uninstall     ] kde-apps/oxygen-icons-4.14.3:4/4.14::gentoo  USE="(-aqua) -sources"
[blocks b      ] kde-apps/oxygen-icons:4 ("kde-apps/oxygen-icons:4" is blocking kde-apps/oxygen-icons-15.08.49.9999)
[ebuild     U *] kde-apps/libkexiv2-15.08.49.9999:4/15.08::kde [4.14.3:4/4.14::gentoo] USE="xmp (-aqua) -debug" 0 KiB
[ebuild     U *] kde-apps/keditbookmarks-15.08.49.9999:4/15.08::kde [4.14.3:4/4.14::gentoo] USE="(-aqua) -debug {-test}" 0 KiB
[ebuild     U *] kde-apps/kfind-15.08.49.9999:4/15.08::kde [4.14.3:4/4.14::gentoo] USE="handbook (-aqua) -debug" 0 KiB
[ebuild     U *] kde-apps/kurifilter-plugins-15.08.49.9999:4/15.08::kde [4.14.3:4/4.14::gentoo] USE="(-aqua) -debug" 0 KiB
[ebuild     U *] kde-apps/svgpart-15.08.49.9999:4/15.08::kde [4.14.3:4/4.14::gentoo] USE="(-aqua) -debug" 0 KiB
[ebuild     U *] kde-apps/plasma-apps-15.08.49.9999:4/15.08::kde [4.14.3:4/4.14::gentoo] USE="(-aqua) -debug" 0 KiB
[ebuild     U *] kde-apps/kdesu-15.08.49.9999:4/15.08::kde [4.14.3:4/4.14::gentoo] USE="(-aqua) -debug -handbook" 0 KiB
[ebuild     U *] kde-apps/ksystemlog-15.08.49.9999:4/15.08::kde [4.14.3:4/4.14::gentoo] USE="handbook (-aqua) -debug {-test}" 0 KiB
[ebuild     U #] kde-apps/kde4-l10n-15.04.3:4/15.04::kde [4.14.3:4/4.14::gentoo] USE="handbook minimal (-aqua)" LINGUAS="en_GB -ar -bg -bs -ca -ca@valencia -cs -da -de -el -eo% -es -et -eu -fa -fi -fr -ga -gl -he -hi -hr -hu -ia -id -is -it -ja -kk -km -ko -lt -lv -mr -nb -nds -nl -nn -pa -pl -pt -pt_BR -ro -ru -sk -sl -sr -sv -tr -ug -uk -wa -zh_CN -zh_TW" 3,135 KiB
[ebuild     U *] kde-apps/libkcddb-15.08.49.9999:4/15.08::kde [4.14.3:4/4.14::gentoo] USE="handbook (-aqua) -debug -musicbrainz" 0 KiB
[ebuild     U *] kde-apps/libksane-15.08.49.9999:4/15.08::kde [4.14.3:4/4.14::gentoo] USE="(-aqua) -debug" 0 KiB
[ebuild     U *] kde-apps/konqueror-15.08.49.9999:4/15.08::kde [4.14.3:4/4.14::gentoo] USE="bookmarks handbook svg (-aqua) -debug" 0 KiB
[ebuild     U *] kde-apps/okular-15.08.49.9999:4/15.08::kde [4.14.3:4/4.14::gentoo] USE="crypt handbook jpeg pdf postscript tiff (-aqua) -chm -debug -djvu -dpi -ebook -mobi" 0 KiB
[blocks B      ] kde-apps/libkonq:4 ("kde-apps/libkonq:4" is blocking kde-apps/libkonq-5.9999)

Total: 34 packages (17 upgrades, 3 new, 14 in new slots, 13 uninstalls), Size of downloads: 6,763 KiB
Conflict: 14 blocks (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-apps/libkonq-15.08.49.9999:4/15.08::kde, ebuild scheduled for merge) pulled in by
    >=kde-apps/libkonq-4.14.3:4[aqua=] (>=kde-apps/libkonq-4.14.3:4[-aqua]) required by (kde-apps/keditbookmarks-15.08.49.9999:4/15.08::kde, ebuild scheduled for merge)
    >=kde-apps/libkonq-4.14.3:4[aqua=] (>=kde-apps/libkonq-4.14.3:4[-aqua]) required by (kde-apps/kfind-15.08.49.9999:4/15.08::kde, ebuild scheduled for merge)
    >=kde-apps/libkonq-4.14.3:4[aqua=] (>=kde-apps/libkonq-4.14.3:4[-aqua]) required by (kde-apps/plasma-apps-15.08.49.9999:4/15.08::kde, ebuild scheduled for merge)
    >=kde-apps/libkonq-4.14.3:4[aqua=] (>=kde-apps/libkonq-4.14.3:4[-aqua]) required by (kde-apps/konqueror-15.08.49.9999:4/15.08::kde, ebuild scheduled for merge)

  (kde-apps/libkonq-5.9999:5/5::kde, ebuild scheduled for merge) pulled in by
    >=kde-apps/libkonq-5.9999:5 required by (kde-apps/dolphin-15.08.49.9999:5/5::kde, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


Hmmm. Bug with some of the ebuilds (wouldn't be surprised as this is unreleased beta stuff just put in the overlay today) or is there another way to solve this which I miss?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7104
Location: Austria

PostPosted: Mon Jul 27, 2015 8:16 am    Post subject: Reply with quote

Ah you're probably first one to try those, thanks for the notice. dolphin is going to be kf5-based in this release so ebuild was copied over from 9999.

EDIT: Actually what happened is upstream is going to release dolphin:5 without having libkonq kf5-port in the same release...
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
davidm
Guru
Guru


Joined: 26 Apr 2009
Posts: 557
Location: US

PostPosted: Mon Jul 27, 2015 6:00 pm    Post subject: Reply with quote

genstorm wrote:
Ah you're probably first one to try those, thanks for the notice. dolphin is going to be kf5-based in this release so ebuild was copied over from 9999.

EDIT: Actually what happened is upstream is going to release dolphin:5 without having libkonq kf5-port in the same release...

Thanks genstorm. I went ahead and made a ebuild in my local overlay for kde-apps/dolphin and simply removed the offending rdepend line for libkonq. Since I already have libkonq:4 installed for other applications the hack should work and seems to do so at least until it gets fixed in the overlay.

I noticed another issue though relating to libkexiv2 in trying to install Dolphin with +thumbnailers:

Code:

emerge -pv1 kde-apps/dolphin kde-apps/okular

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U *] kde-apps/okular-15.08.49.9999:4/15.08::kde [15.04.3:4/15.04::kde] USE="crypt handbook jpeg pdf postscript tiff (-aqua) -chm -debug -djvu -dpi -ebook -mobi" 0 KiB
[ebuild  NS   *] kde-apps/libkexiv2-5.9999:5::kde [15.04.3:4/15.04::kde] USE="xmp -debug" 0 KiB
[ebuild  N    *] kde-apps/baloo-widgets-9999:5::kde  USE="-debug" 0 KiB
[ebuild  NS   *] kde-apps/libkdcraw-5.9999:5::kde [15.04.3:4/15.04::kde] USE="-debug" 0 KiB
[uninstall     ] kde-apps/libkdcraw-15.04.3:4/15.04::kde  USE="(-aqua) -debug"
[blocks b      ] kde-apps/libkdcraw:4 ("kde-apps/libkdcraw:4" is blocking kde-apps/libkdcraw-5.9999)
[ebuild  NS   *] kde-apps/thumbnailers-5.9999:5::kde [15.04.3:4/15.04::kde] USE="-debug" 0 KiB
[uninstall     ] kde-apps/thumbnailers-15.04.3:4/15.04::kde  USE="(-aqua) -debug"
[blocks b      ] kde-apps/thumbnailers:4 ("kde-apps/thumbnailers:4" is blocking kde-apps/thumbnailers-5.9999)
[ebuild  NS   *] kde-apps/ffmpegthumbs-5.9999:5::kde [15.04.3:4/15.04::kde] USE="-debug" 0 KiB
[uninstall     ] kde-apps/ffmpegthumbs-15.04.3:4/15.04::kde  USE="(-aqua) -debug"
[blocks b      ] kde-apps/ffmpegthumbs:4 ("kde-apps/ffmpegthumbs:4" is blocking kde-apps/ffmpegthumbs-5.9999)
[ebuild  NS   *] kde-apps/dolphin-15.08.49.9999:5::myoverlay [15.04.3:4/15.04::kde] USE="handbook semantic-desktop thumbnail -debug {-test}" 0 KiB
[uninstall     ] kde-apps/dolphin-15.04.3:4/15.04::kde  USE="handbook semantic-desktop thumbnail (-aqua) -debug"
[blocks b      ] kde-apps/dolphin:4 ("kde-apps/dolphin:4" is blocking kde-apps/dolphin-15.08.49.9999)
[blocks B      ] kde-apps/libkexiv2:4 ("kde-apps/libkexiv2:4" is blocking kde-apps/libkexiv2-5.9999)

Total: 7 packages (1 upgrade, 1 new, 5 in new slots, 4 uninstalls), Size of downloads: 0 KiB
Conflict: 5 blocks (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-apps/libkexiv2-5.9999:5/5::kde, ebuild scheduled for merge) pulled in by
    >=kde-apps/libkexiv2-5.9999:5 required by (kde-apps/thumbnailers-5.9999:5/5::kde, ebuild scheduled for merge)

  (kde-apps/libkexiv2-15.04.3:4/15.04::kde, installed) pulled in by
    >=kde-apps/libkexiv2-4.14.3:4[aqua=] (>=kde-apps/libkexiv2-4.14.3:4[-aqua]) required by (kde-apps/okular-15.08.49.9999:4/15.08::kde, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


I was able to get around it by unmerging libkexiv2:4 and emerging libkexiv2-5.9999:5/5. Then okular complained and caused a block in pulling in libkexiv2:4 so I went ahead and unmerged the okular:4 version and went to okular-5.9999. It all seems to be working now well enough including Dolphin. There is some weirdness with baloo ratings displayed (the stars) in Dolphin but baloo is a weird case since it's moving to a framework and also there was some weirdness with it before regarding how it displays in Breeze. It could be if I switch to Oxygen the ratings are actually there and now properly displayed. I haven't tested yet but I highly suspect this.

Also I think you help with the overlay? It's not a big deal but If so I also noticed this and figured I would mention it in case it is not just a transient error:

Code:

>>> Failed to emerge kde-apps/kde-wallpapers-15.08.49.9999, Log file:

>>>  '/var/tmp/portage/kde-apps/kde-wallpapers-15.08.49.9999/temp/build.log'

 * Messages for package kde-apps/kde-wallpapers-15.08.49.9999:

 * ERROR: kde-apps/kde-wallpapers-15.08.49.9999::kde failed (unpack phase):
 *   subversion: can't fetch to /usr/portage/distfiles/svn-src/kde-wallpapers-15.08.49.9999/kde-wallpapers from svn://anonsvn.kde.org/home/kde/branches/KDE/15.08/kde-wallpapers.
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_unpack
 *   environment, line 3733:  Called kde4-base_src_unpack
 *   environment, line 2851:  Called subversion_src_unpack
 *   environment, line 4054:  Called subversion_fetch
 *   environment, line 3948:  Called die
 * The specific snippet of code:
 *               ${ESVN_FETCH_CMD} ${options} "${repo_uri}" || die "${ESVN}: can't fetch to ${wc_path} from ${repo_uri}.";
 *
 * If you need support, post the output of `emerge --info '=kde-apps/kde-wallpapers-15.08.49.9999::kde'`,
 * the complete build log and the output of `emerge -pqv '=kde-apps/kde-wallpapers-15.08.49.9999::kde'`.
 * The complete build log is located at '/var/tmp/portage/kde-apps/kde-wallpapers-15.08.49.9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-apps/kde-wallpapers-15.08.49.9999/temp/environment'.
 * Working directory: '/usr/portage/distfiles/svn-src/kde-wallpapers-15.08.49.9999'
 * S: '/var/tmp/portage/kde-apps/kde-wallpapers-15.08.49.9999/work/kde-wallpapers-15.08.49.9999'

 * GNU info directory index is up-to-date.
 * After world updates, it is important to remove obsolete packages with
 * emerge --depclean. Refer to `man emerge` for more information.
 


Anyway thanks for your (and others) work on the overlay. I guess if I run into more issues I will just share them here in case a overlay developer sees it and it helps or should I file bugs for this bleeding edge stuff?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7104
Location: Austria

PostPosted: Mon Jul 27, 2015 6:32 pm    Post subject: Reply with quote

davidm wrote:
Thanks genstorm. I went ahead and made a ebuild in my local overlay for kde-apps/dolphin and simply removed the offending rdepend line for libkonq. Since I already have libkonq:4 installed for other applications the hack should work and seems to do so at least until it gets fixed in the overlay.

This is fixed now in overlay.

The necessary dependencies for kde-apps/dolphin[thumbnail] will not be part of 15.08. So the USE flag is still there, but in use.mask, same with gwenview[kipi,raw] for the exact reason that there will be conflicts such as yours with okular:4. Which btw is really good quality already even if pulled from git.

Generally, if you unmask these use flags, several meta ebuilds become blockers/incompatible.

davidm wrote:
Also I think you help with the overlay?

The pull request for 15.08.49.9999 that's causing you trouble was actually mine :)
kde-wallpapers might just branch later, but thanks for the heads up ;)

davidm wrote:
Anyway thanks for your (and others) work on the overlay. I guess if I run into more issues I will just share them here in case a overlay developer sees it and it helps or should I file bugs for this bleeding edge stuff?

Forum is probably the least frequented place to report bugs. You can open a bug in bugs.gentoo.org with [kde overlay] prefix in summary, however the most convenient way (provided you have a github account) might be to directly report an issue at the KDE team's github mirror: https://github.com/gentoo/kde Make sure you are always testing latest commit before filing.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
davidm
Guru
Guru


Joined: 26 Apr 2009
Posts: 557
Location: US

PostPosted: Thu Jul 30, 2015 12:32 am    Post subject: Reply with quote

Yes okular:5 is working nicely for me. Thank you for the github link. I had no idea that existed there. I already have a Gentoo Bugzilla account so I will probably just use that. I just wasn't sure if you all wanted to be bothered about this new stuff. I fixed akregator to pull the git logs for some kde projects and some mailing lists so hopefully I don't annoy you all too much with frivolous bug reports on packaging changes. :)

15.08 should be a good release with dolphin:5. It's working very well for me right now for production use. The (baloo generated) ratings aren't working and are all displaying 5 stars but I'm still investigating that to make sure it's not an error on my end or with my config. I know baloo is in a strange state anyway since it's going to be a framework.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7104
Location: Austria

PostPosted: Thu Jul 30, 2015 7:31 pm    Post subject: Reply with quote

Well, your findings have already helped fix bugs so keep the reports coming ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
davidm
Guru
Guru


Joined: 26 Apr 2009
Posts: 557
Location: US

PostPosted: Mon Aug 03, 2015 10:26 pm    Post subject: Reply with quote

Hmm.. Is anyone using the live Dolphin or 15.08.49.9999 packages (using :5) able to get the ratings to work (view -> additional information -> ratings and/or view -> panels -> information) ? Here I'm seeing it where it appears that all files have five stars whereas it used to work fine in :4. It does this in with both Breeze and Oxygen themes and icons. It also does the same thing in kde-apps/gwenview-15.08.49.9999.

I believe it is baloo-widgets responsible for the functionality.

Code:

[I] kde-frameworks/baloo [1]
     Available versions:  (5) (**)9999(5/9999){tbz2}
       {debug doc test}
     Installed versions:  9999(5/9999){tbz2}(03:57:11 PM 08/03/2015)(-debug -doc -test)
     Homepage:            http://www.kde.org/
     Description:         Framework for searching and managing metadata

[I] kde-apps/baloo-widgets [1]
     Available versions:  (5) {M}(~)15.07.80^m (**)15.08.49.9999 (**)9999{tbz2}
       {debug}
     Installed versions:  9999(5){tbz2}(03:58:12 PM 08/03/2015)(-debug)
     Homepage:            http://www.kde.org/
     Description:         Widget library for baloo

[I] kde-apps/dolphin
     Available versions: 
     (4)    4.14.3(4/4.14)^t{tbz2} {M}(~)15.04.3(4/15.04)^t{tbz2}[1]
     (5)    {M}(~)15.07.80^t[1] (**)15.08.49.9999^t{tbz2}[1] **9999^t[1]
       {aqua debug +handbook semantic-desktop test thumbnail}
     Installed versions:  15.08.49.9999(5)^t{tbz2}[1](04:03:25 PM 08/03/2015)(handbook semantic-desktop -debug -test -thumbnail)
     Homepage:            http://dolphin.kde.org http://www.kde.org/applications/system/dolphin
     Description:         Plasma filemanager focusing on usability

[I] kde-apps/gwenview
     Available versions: 
     (4)    4.14.3(4/4.14)^t{tbz2}
     (5)    {M}(~)15.04.3{tbz2}[1] {M}(~)15.07.80^m[1] (**)15.08.49.9999{tbz2}[1] **9999[1]
       {X aqua debug +handbook kipi raw semantic-desktop test}
     Installed versions:  15.08.49.9999(5){tbz2}[1](04:07:48 PM 08/03/2015)(X handbook semantic-desktop -debug -kipi -raw -test)
     Homepage:            http://www.kde.org/applications/graphics/gwenview/ http://gwenview.sourceforge.net/
     Description:         KDE image viewer


Code:

# ldd /usr/bin/dolphin | grep -i baloo
        libKF5BalooWidgets.so.5 => /usr/lib64/libKF5BalooWidgets.so.5 (0x00007f29d60c1000)
        libKF5Baloo.so.5 => /usr/lib64/libKF5Baloo.so.5 (0x00007f29d5b36000)
        libKF5BalooEngine.so.5 => /usr/lib64/libKF5BalooEngine.so.5 (0x00007f29cf52f000)


Code:

# ldd /usr/bin/dolphin | grep -i meta
        libKF5FileMetaData.so.3 => /usr/lib64/libKF5FileMetaData.so.3 (0x00007fb41cff2000)


Code:

# ldd /usr/bin/gwenview | grep -i baloo
        libKF5Baloo.so.5 => /usr/lib64/libKF5Baloo.so.5 (0x00007efd55b6b000)
        libKF5BalooEngine.so.5 => /usr/lib64/libKF5BalooEngine.so.5 (0x00007efd500ca000)


Code:

# ldd /usr/bin/gwenview | grep -i meta
        libKF5FileMetaData.so.3 => /usr/lib64/libKF5FileMetaData.so.3 (0x00007f10ff4b8000)


emerge --info

The core functionality is there as Dolphin is able to search files by ratings and such. Also:

Code:

kioclient5 list 'baloosearch://?query=rating>3'


does indeed list the actual files which were previously rated. The problem seems to be the widget isn't displaying it properly in Dolphin and Gwenview.

I thought I'd see if it is doing this for others too (or if it might be packaging related) before reporting a bug upstream so hopefully they can get it fixed before the next release.
Back to top
View user's profile Send private message
davidm
Guru
Guru


Joined: 26 Apr 2009
Posts: 557
Location: US

PostPosted: Tue Aug 04, 2015 11:18 pm    Post subject: Reply with quote

It looks like previous issue with ratings with baloo/dolphin/gwenview is probably due to the following bug:

https://bugs.kde.org/show_bug.cgi?id=339863
Back to top
View user's profile Send private message
davidm
Guru
Guru


Joined: 26 Apr 2009
Posts: 557
Location: US

PostPosted: Sat Aug 08, 2015 4:02 am    Post subject: Reply with quote

I believe kde-apps/kdepim-9999:5 might be missing a build dependency.

dev-libs/grantlee-5.0.0

It complained during configure that it was looking for grantlee5 and upon installing it now it appears to build fine.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7104
Location: Austria

PostPosted: Mon Aug 10, 2015 11:17 pm    Post subject: Reply with quote

davidm wrote:
It complained during configure that it was looking for grantlee5 and upon installing it now it appears to build fine.

Thanks, this was fixed.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum