Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge gentoo-sources Issues
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
fuzzyn00b
n00b
n00b


Joined: 29 Jul 2015
Posts: 3

PostPosted: Wed Jul 29, 2015 7:52 pm    Post subject: emerge gentoo-sources Issues Reply with quote

Hi

Gentoo newbie here. I am trying to install this for the first time in my life and i have the least idea of what i am doing(except following the tutorials, as much i can understand)

I am getting some errors when running 'emerge gentoo-sources' - http://pastebin.com/anyHL4J3

I see a couple of files to attach while seeking help. Attached two of them :
http://pastebin.com/bvGDEcyZ
http://pastebin.com/btBrfqpT

Tried finding similar issue on forums, but didn't get anywhere with that. Any help greatly appreciated.
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Wed Jul 29, 2015 7:55 pm    Post subject: Reply with quote

Welcome to the forums!

Code:
CFLAGS="-O2 -pipe --march=native"


Fix it to below string and try again.

Code:
CFLAGS="-O2 -pipe -march=native"
Back to top
View user's profile Send private message
fuzzyn00b
n00b
n00b


Joined: 29 Jul 2015
Posts: 3

PostPosted: Wed Jul 29, 2015 8:06 pm    Post subject: Reply with quote

Thank you for that. Silly mistake on my part
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Wed Jul 29, 2015 8:28 pm    Post subject: Reply with quote

You are welcome! Errare humanum est.
Back to top
View user's profile Send private message
fuzzyn00b
n00b
n00b


Joined: 29 Jul 2015
Posts: 3

PostPosted: Wed Jul 29, 2015 8:44 pm    Post subject: Further Issue regarding installation Reply with quote

'emerge genkernel' has hanged for a while now.

the log file shows :
File 'cpio-2.11.tar.bz2' is already locked by another fetcher

Tried "rm /var/tmp/* -r" and "rm tmp/* -r" with no luck
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Wed Jul 29, 2015 8:47 pm    Post subject: Reply with quote

There may be a lock file in /usr/portage or its subdirectories.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum