Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kernel panic - not syncing: No working init found [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
stu_rat
n00b
n00b


Joined: 17 Jan 2011
Posts: 50
Location: UK

PostPosted: Fri Jul 31, 2015 7:26 am    Post subject: Kernel panic - not syncing: No working init found [SOLVED] Reply with quote

New installation on a Samsung NC10 (Intel Atom processor). Manual kernel build.

A photograph of the error is here: https://drive.google.com/file/d/0B0JkugWV87y8U3g5OE9ZbkRGckU/view?usp=sharing

https://www.kernel.org/doc/Documentation/init.txt gives an architecture mismatch as a possible cause.

This is the stage3 file I used: stage3-i686-20150721.tar.bz2, which I think is correct for the Intel Atom processor.

Suggestions as to where to look next, please.


Last edited by stu_rat on Fri Jul 31, 2015 6:48 pm; edited 1 time in total
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Fri Jul 31, 2015 8:35 am    Post subject: Reply with quote

did you use gentoo-sources and enabled those gentoo specific / udev specific kernel settings?

you may use a genkernel kernel first and adapt it. or a kernel seed.

and did you specify root and other stuff for the kernel in the kernel line of your bootloader? I had similar errors after recovering from "ubuntu" deleting" my grub.config and the root cause was missing kernel flags after recovery.

you may need an initramfs too.

check filesystem support / hardware support too.
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Fri Jul 31, 2015 2:06 pm    Post subject: Reply with quote

There must be something missing in your kernel configuration. Can you pastebin it?
Back to top
View user's profile Send private message
stu_rat
n00b
n00b


Joined: 17 Jan 2011
Posts: 50
Location: UK

PostPosted: Fri Jul 31, 2015 3:07 pm    Post subject: Reply with quote

tw04l124 wrote:
did you use gentoo-sources and enabled those gentoo specific / udev specific kernel settings?
Yes

tw04l124 wrote:
and did you specify root and other stuff for the kernel in the kernel line of your bootloader?
I used Grub2, so it did all that for me. This is the relevant section from grub.cfg:
Code:
menuentry 'Gentoo GNU/Linux' --class gentoo --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-52131baf-0e78-418b-9c56-e6a30dc6f59d' {
   load_video
   insmod gzio
   insmod part_msdos
   insmod ext2
   set root='hd0,msdos1'
   if [ x$feature_platform_search_hint = xy ]; then
     search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1  438b939e-9f37-48f4-9c6b-8c8afa6
36482
   else
     search --no-floppy --fs-uuid --set=root 438b939e-9f37-48f4-9c6b-8c8afa636482
   fi
   echo   'Loading Linux 4.0.5-gentoo ...'
   linux   /vmlinuz-4.0.5-gentoo root=/dev/sda3 ro 
}


This is my fstab:
Code:
/dev/sda1      /boot      ext2      noauto,noatime   1 2
/dev/sda3      /      ext4      noatime      0 1
/dev/sda2      none      swap      sw      0 0


Quote:
check filesystem support / hardware support too.

Yes, both ext2 and ext4 enabled.

Thanks for the suggestions.
Back to top
View user's profile Send private message
stu_rat
n00b
n00b


Joined: 17 Jan 2011
Posts: 50
Location: UK

PostPosted: Fri Jul 31, 2015 3:15 pm    Post subject: Reply with quote

Buffoon wrote:
There must be something missing in your kernel configuration. Can you pastebin it?

https://bpaste.net/show/db150a6aacb2

Thanks.
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Fri Jul 31, 2015 6:02 pm    Post subject: Reply with quote

Code:
# CONFIG_BINFMT_ELF is not set
Back to top
View user's profile Send private message
stu_rat
n00b
n00b


Joined: 17 Jan 2011
Posts: 50
Location: UK

PostPosted: Fri Jul 31, 2015 6:47 pm    Post subject: Reply with quote

Buffoon wrote:
Code:
# CONFIG_BINFMT_ELF is not set
That's fixed it.

Thanks very much.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum