Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Buetooth not working?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
shimitar
Apprentice
Apprentice


Joined: 23 Nov 2003
Posts: 274
Location: Italy, Torino

PostPosted: Sun Aug 02, 2015 6:09 pm    Post subject: [SOLVED] Buetooth not working? Reply with quote

Hi!
i am having some issues using bluetooth on an ARM tablet (Asus TF700T with dock) where i have successfully ditched Android for Gentoo Linux.

I have installed bluez5 and blueman.

The service /etc/init.d/bluetooth does not start (it says "crashed") so i tried to start the daemon by hand, but i get the following error:
Code:

/usr/libexec/bluetooth/bluetoothd -nd -E
bluetoothd[9949]: Bluetooth daemon 5.25
bluetoothd[9949]: src/main.c:parse_config() parsing main.conf
bluetoothd[9949]: src/main.c:parse_config() Key file does not have key 'DiscoverableTimeout'
bluetoothd[9949]: src/main.c:parse_config() Key file does not have key 'PairableTimeout'
bluetoothd[9949]: src/main.c:parse_config() Key file does not have key 'AutoConnectTimeout'
bluetoothd[9949]: src/main.c:parse_config() name=tf700
bluetoothd[9949]: src/main.c:parse_config() Key file does not have key 'Class'
bluetoothd[9949]: src/main.c:parse_config() Key file does not have key 'DeviceID'
bluetoothd[9949]: src/main.c:parse_config() Key file does not have key 'ReverseServiceDiscovery'
bluetoothd[9949]: src/gatt.c:gatt_init() Starting GATT server
bluetoothd[9949]: Failed to access management interface
bluetoothd[9949]: Adapter handling initialization failed


The bluetooth adapter seems to be available:
Code:

tf700t ~ # hciconfig
hci0:   Type: BR/EDR  Bus: UART
   BD Address: 00:22:33:76:93:1F  ACL MTU: 1021:8  SCO MTU: 64:1
   DOWN
   RX bytes:509 acl:0 sco:0 events:20 errors:0
   TX bytes:106 acl:0 sco:0 commands:20 errors:0


And seems to be working:
Code:

tf700t ~ # hciconfig hci0 up
tf700t ~ # hciconfig
hci0:   Type: BR/EDR  Bus: UART
   BD Address: 00:22:33:76:93:1F  ACL MTU: 1021:8  SCO MTU: 64:1
   UP RUNNING
   RX bytes:1011 acl:0 sco:0 events:39 errors:0
   TX bytes:208 acl:0 sco:0 commands:39 errors:0


At this point, i can also scan:
Code:

tf700t ~ # hcitool scan
Scanning ...
   C8:14:79:01:E3:1B   SM-N9005


Which is my phone "discoverable".

Anybody has any idea why the bluetooth daemon does not start? This is preventing blueman to properly work...

(edit: if useful, in order for the bluetooth device to be available i need to issue the following command and keep it running as a daemon in the background:
Code:

brcm_patchram_plus --enable_hci --scopcm=0,2,0,0,0,0,0,0,0,0 --baudrate 3000000 --use_baudrate_for_download --patchram /lib/firmware/BCM4330B1_002.001.003.0967.0970.hcd --enable_lpm --no2bytes --tosleep=5000 /dev/ttyHS2

This is a tool and a firmware file provided by Nvidia, since this is a Tegra3 chipset)

thank you for any suggestion!
_________________
Willy Gardiol
willy@gardiol.org


Last edited by shimitar on Sun Aug 02, 2015 9:59 pm; edited 1 time in total
Back to top
View user's profile Send private message
shimitar
Apprentice
Apprentice


Joined: 23 Nov 2003
Posts: 274
Location: Italy, Torino

PostPosted: Sun Aug 02, 2015 9:58 pm    Post subject: Reply with quote

It seems the problem was using bluez5 with my older kernel. Bluez4 works!
_________________
Willy Gardiol
willy@gardiol.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum