Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ruby] Maj vers ruby 2.1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 739
Location: S.O. France

PostPosted: Thu Jul 30, 2015 5:15 pm    Post subject: [ruby] Maj vers ruby 2.1 Reply with quote

Aujourd'hui
Code:
Calculating dependencies... done!
[ebuild  NS    ] dev-lang/ruby-2.1.6-r1:2.1::gentoo [1.9.3_p551-r1:1.9::gentoo, 2.0.0_p645:2.0::gentoo] USE="berkdb gdbm ipv6 ncurses rdoc readline ssl -debug -doc -examples -rubytests -socks5 -xemacs" 9 165 KiB
[ebuild     U  ] dev-ruby/rubygems-2.2.5-r1::gentoo [2.2.5::gentoo] USE="-server {-test}" RUBY_TARGETS="ruby19 ruby20 ruby21%*" 0 KiB
[ebuild     U  ] virtual/rubygems-10::gentoo [9::gentoo] RUBY_TARGETS="ruby19 ruby20 ruby21%*" 0 KiB
[ebuild     U  ] dev-ruby/rake-0.9.6-r1::gentoo [0.9.6::gentoo] USE="-doc {-test}" RUBY_TARGETS="ruby19 ruby20 ruby21%*" 0 KiB
[ebuild     U  ] dev-ruby/json-1.8.2-r1::gentoo [1.8.0::gentoo] USE="-doc {-test}" RUBY_TARGETS="ruby19 ruby20 ruby21%* (-jruby%)" 149 KiB
[ebuild     U  ] dev-ruby/racc-1.4.11::gentoo [1.4.9::gentoo] USE="-doc {-test}" RUBY_TARGETS="ruby19 ruby20 ruby21%*" 111 KiB
[ebuild     U  ] dev-ruby/rdoc-4.0.1-r2::gentoo [4.0.1-r1::gentoo] USE="-doc {-test}" RUBY_TARGETS="ruby19 ruby20 ruby21%*" 0 KiB

Total: 8 packages (7 upgrades, 1 in new slot), Size of downloads: 9 435 KiB

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-ruby/rdoc-4.0.1-r2::gentoo[-test,ruby_targets_ruby21]
# required by dev-lang/ruby-2.1.6-r1::gentoo[rdoc]
# required by dev-ruby/racc-1.4.11::gentoo[ruby_targets_ruby21]
>=virtual/rubygems-10 ruby_targets_ruby21
# required by dev-lang/ruby-2.1.6-r1::gentoo
# required by virtual/rubygems-10::gentoo[ruby_targets_ruby21]
# required by dev-ruby/json-1.8.2-r1::gentoo
# required by dev-ruby/rdoc-4.0.1-r2::gentoo[ruby_targets_ruby21]
# required by dev-lang/ruby-1.9.3_p551-r1::gentoo[rdoc]
# required by dev-ruby/rubygems-2.2.5-r1::gentoo[ruby_targets_ruby19]
>=dev-ruby/rake-0.9.6-r1 ruby_targets_ruby21
.
.
.


Donc maintenant faut obligatoirement RUBY_TARGETS="ruby 19 ruby20 ruby21" dans le make.conf
C'est utile de garder les 3 versions ou je peux simplement mettre RUBY_TARGETS="ruby21"? et ainsi virer le reste.
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1699
Location: 127.0.0.1

PostPosted: Thu Jul 30, 2015 6:35 pm    Post subject: Reply with quote

Salut,

Quote:

Donc maintenant faut obligatoirement RUBY_TARGETS="ruby 19 ruby20 ruby21" dans le make.conf

J'ai eu le cas aujourd'hui, et à mon avis c'est un bug. Essaye de re-synchroniser dans quelques heures. Si çà en est pas un, çà craint.
Pour la petite histoire, lorsque j'ai eu cette sortie, je suis remonté jusqu'au paquet original installé qui faisait que ruby était envoyé dans le calcul des dépendances, j'ai désinstallé le paquet en question, et emerge -uDN world && emerge --depclean -ask.
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 739
Location: S.O. France

PostPosted: Thu Jul 30, 2015 7:18 pm    Post subject: Reply with quote

Je sais pas s'il s'agit d'un bug. J'attends quelques jours pour faire la maj voir si ca bouge sur le forum.
https://forums.gentoo.org/viewtopic-t-979626-view-next.html?sid=8716ef929a1aa2a4b04fcc0cf9286a09 (fin 2013)
https://bugs.gentoo.org/show_bug.cgi?id=518094#c8

J'avoue que j'ai de plus en plus de mal a comprendre la logique.
J'ai de plus en plus de paquets en ~amd64 suite à la décision de supprimer des ebuilds trop anciens.
Il y a 2 mois, j'avais ouvert un bug pour que des paquets qui dépendent de qt4 ne soient pas supprimés. On m'a gentiment fait comprendre que qt5 devait être stabilisé très rapidement et que, soit je passais à qt5, sois je créais mon overlay perso afin de bénéficier de ces anciennes versions.
Il a fallu que je passe à qt5 qui je viens de vérifier dépends de ruby...
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1699
Location: 127.0.0.1

PostPosted: Fri Jul 31, 2015 8:55 am    Post subject: Reply with quote

sebB wrote:
Il a fallu que je passe à qt5 qui je viens de vérifier dépends de ruby...

Çà je ne sais pas. Et à la limite çà ne me gêne pas.
Là où je pense qu'il y a bug, c'est que par défaut l'utilisateur ne doit pas avoir a (re)définir la variable RUBY_TARGETS dans le make.conf, puisqu'elle est censée être définie par le profil, de la même manière que la variable PYTHON_TARGETS d'ailleurs.

Quote:

$ grep -B 2 RUBY_TARGETS= "$(portageq get_repo_path / gentoo)"/profiles/base/make.defaults
# Manuel Rüger <mrueg@gentoo.org> (16 Mar 2014)
# Default Ruby build targets
RUBY_TARGETS="ruby19 ruby20"
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 739
Location: S.O. France

PostPosted: Fri Jul 31, 2015 1:57 pm    Post subject: Reply with quote

On est d'accords, mais je me posais la question si un changement avait eu lieu

Bug ouvert
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum