Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Nvidia Optimus fatal error no screens found
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
mirko28
n00b
n00b


Joined: 03 Aug 2015
Posts: 6
Location: Montenegro

PostPosted: Thu Aug 06, 2015 11:50 am    Post subject: Nvidia Optimus fatal error no screens found Reply with quote

I have installed nvidia-drivers and mode setting. These are error logs:

https://bpaste.net/show/57ebe18a65d0
https://bpaste.net/show/45bc8a632ec7
https://bpaste.net/show/0a5b25cf4e55
https://bpaste.net/show/a5e78b46e514

When I run startx the first output line is
Code:

xauth: file /root/.serverauth.16761 does not exist


Then it continues however till another error, this one is x specific:
Code:

Fatal server error:
(EE) no screens found (EE)


Here's xorg log file:
https://bpaste.net/show/ddb7d018ecaf

GPU model
Code:

$ lspci -nn | grep '\[03'
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
01:00.0 3D controller [0302]: NVIDIA Corporation GF117M [GeForce 610M/710M/820M / GT 620M/625M/630M/720M] [10de:1140] (rev a1)


It's GF 710M in fact.

Thanks, if you need something more let me know.
.
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Thu Aug 06, 2015 5:42 pm    Post subject: Reply with quote

is this a hybrid box?

afaik you need to get the intel card to work again and than the nvidia one. as it goes through the intel card...

did you check gentoo wiki for a general guide regarding your hardware?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43183
Location: 56N 3W

PostPosted: Thu Aug 06, 2015 6:04 pm    Post subject: Reply with quote

mirko28,

Code:
 * ERROR: x11-drivers/nvidia-drivers-352.21::gentoo failed (setup phase):
 *   Kernel sources need compiling first


This error says the the nvida-drivers tried to build against you kernel and failed.
Did you fix this, if not you don't yet have nvidia-drivers installed.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
mirko28
n00b
n00b


Joined: 03 Aug 2015
Posts: 6
Location: Montenegro

PostPosted: Fri Aug 07, 2015 10:51 am    Post subject: Reply with quote

tw04l124 wrote:
is this a hybrid box?

afaik you need to get the intel card to work again and than the nvidia one. as it goes through the intel card...

did you check gentoo wiki for a general guide regarding your hardware?


No I didn't. Is my xorg.conf ok?
Back to top
View user's profile Send private message
mirko28
n00b
n00b


Joined: 03 Aug 2015
Posts: 6
Location: Montenegro

PostPosted: Fri Aug 07, 2015 10:52 am    Post subject: Reply with quote

NeddySeagoon wrote:
mirko28,

Code:
 * ERROR: x11-drivers/nvidia-drivers-352.21::gentoo failed (setup phase):
 *   Kernel sources need compiling first


This error says the the nvida-drivers tried to build against you kernel and failed.
Did you fix this, if not you don't yet have nvidia-drivers installed.


I have fixed that later, so yes I have it properly installed.
Back to top
View user's profile Send private message
mirko28
n00b
n00b


Joined: 03 Aug 2015
Posts: 6
Location: Montenegro

PostPosted: Fri Aug 07, 2015 10:58 am    Post subject: Reply with quote

tw04l124 wrote:
is this a hybrid box?

afaik you need to get the intel card to work again and than the nvidia one. as it goes through the intel card...

did you check gentoo wiki for a general guide regarding your hardware?


I'm following this https://wiki.gentoo.org/wiki/NVIDIA_Driver_with_Optimus_Laptops , but I can't find this intel kernel options in genkernel menu.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43183
Location: 56N 3W

PostPosted: Fri Aug 07, 2015 5:17 pm    Post subject: Reply with quote

mirko28,

The kernel has changed. You need the Intel support under AGP or DRM ... maybe both.
There is no modeswitching option any more.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum