Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Failed emerge --ask sys-kernel/gentoo-sources
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Tetractys
n00b
n00b


Joined: 09 Oct 2011
Posts: 5
Location: Torino

PostPosted: Thu Aug 06, 2015 3:47 pm    Post subject: [SOLVED] Failed emerge --ask sys-kernel/gentoo-sources Reply with quote

Hi!
during the installation of kernek i'm stuck in failed command: emerge --ask sys-kernel/gentoo-sources

this is the output:

http://pastebin.com/XKekCHvv

Please, be sure to read it to the last line! further info there - thanks.

furthermore i'm not sure of this setting:

Code:
(chroot) thor-p / # eselect locale list
Available targets for the LANG variable:
  [1]   C
  [2]   en_US
  [3]   en_US.iso88591 *
  [4]   en_US.utf8
  [5]   POSIX
  [ ]   (free form)
(chroot) thor-p / #


i want my system in english with italian keyboard. after enter commands from the chrooted prompt this line appear:

Code:
setlocale: unsupported locale setting


Thank you in advance for any advice!


Last edited by Tetractys on Thu Aug 06, 2015 5:06 pm; edited 1 time in total
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3079
Location: Illinois, USA

PostPosted: Thu Aug 06, 2015 4:01 pm    Post subject: Reply with quote

Looks to me that you just had to type "yes" or "y" or just press enter (that's what I usually do). I didn't see any failure.

Regarding the locale, I can't help. I use en-US and en-GB and a standard US keyboard. Maybe this wiki article helps https://wiki.gentoo.org/wiki/Keyboard_layout_switching#OpenRC
It would appear that locale and keyboard are different settings.
Back to top
View user's profile Send private message
Tetractys
n00b
n00b


Joined: 09 Oct 2011
Posts: 5
Location: Torino

PostPosted: Thu Aug 06, 2015 4:21 pm    Post subject: Reply with quote

Thanks Tony for the prompt response.

I pressed enter. and this is the result:

http://pastebin.com/tNK9TRYG

i'am in chrooted environment on an xubuntu 15.10 linux host. Do you think the host locale can modify the chrooted locale setting? i did too (in chrooted env):

Code:
emerge locale set x
. /etc/profile
env-update && source /etc/profile


... really confused....
Back to top
View user's profile Send private message
Tetractys
n00b
n00b


Joined: 09 Oct 2011
Posts: 5
Location: Torino

PostPosted: Thu Aug 06, 2015 5:05 pm    Post subject: [solved] Reply with quote

For the locale: it_IT UTF-8 is the correct one! @Tony0945 Your suggestion has been illuminating thanks.

For the compilation

Code:
CFLAGS="-march=native -O2 -pipe"


was

Code:
CFLAGS="-march=native O2 -pipe"


and of course generated the error! O2 instead of -O2 ...

i'm a real noob. :oops:

Thank you for your patience!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum