Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
udev is blocking systemd and networkmanager installs
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
bristlecone
n00b
n00b


Joined: 07 Aug 2015
Posts: 2

PostPosted: Fri Aug 07, 2015 1:03 am    Post subject: udev is blocking systemd and networkmanager installs Reply with quote

Hi, I'm completely new to Gentoo (coming over from Mint after a few years on Linux) so apologies in advance if I have some trouble following. I'm having some problems installing Funtoo. The instructions for setting up WiFi on the Funtoo installation guide tell me to run the following:
Code:
emerge linux-firmware networkmanager


However, when I run that, I get these errors:
Code:
[blocks B      ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/eudev-1.5.3-r2)
[blocks B      ] sys-fs/eudev ("sys-fs/eudev" is blocking sys-apps/gentoo-systemd-integration-4, sys-apps/systemd-218-r3)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.


I've already manually unmerged both udev and eudev and I deselected both, but this error keeps coming up when I either emerge world or emerge linux-firmware and networkmanager. I've been Googling around for a while and I still don't know what's going wrong, so any help would be appreciated.

Full output:
Code:
(chroot) mint / # emerge --deselect sys-fs/eudev
>>> No matching atoms found in "world" favorites file...
(chroot) mint / # emerge --deselect virtual/udev
>>> No matching atoms found in "world" favorites file...
(chroot) mint / # emerge --unmerge sys-fs/eudev
 * This action can remove important packages! In order to be safer, use
 * `emerge -pv --depclean <atom>` to check for reverse dependencies before
 * removing packages.

--- Couldn't find 'sys-fs/eudev' to unmerge.

>>> No packages selected for removal by unmerge
(chroot) mint / # emerge --unmerge virtual/udev
 * This action can remove important packages! In order to be safer, use
 * `emerge -pv --depclean <atom>` to check for reverse dependencies before
 * removing packages.

--- Couldn't find 'virtual/udev' to unmerge.

>>> No packages selected for removal by unmerge
(chroot) mint / # emerge linux-firmware networkmanager
Calculating dependencies... done!
[ebuild  N     ] net-wireless/rfkill-0.5
[ebuild  N     ] net-wireless/wireless-regdb-20150605
[ebuild  N     ] dev-libs/libunistring-0.9.5  USE="-doc -static-libs"
[ebuild  N     ] sys-power/pm-quirks-20100619
[ebuild  N     ] dev-libs/libx86-1.1-r3  USE="-static-libs"
[ebuild  N     ] sys-kernel/linux-firmware-20150206  USE="-savedconfig"
[ebuild  N     ] dev-libs/gobject-introspection-common-1.42.0
[ebuild  N     ] app-arch/zip-3.0-r3  USE="bzip2 crypt unicode -natspec"
[ebuild  N     ] dev-lang/swig-2.0.9  USE="pcre -ccache -doc"
[ebuild  N     ] sys-libs/slang-2.2.4-r1  USE="pcre readline zlib -cjk -png -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-util/gtk-doc-am-1.24
[ebuild  N     ] dev-libs/nspr-4.10.8  USE="-debug" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] net-libs/libndp-1.4
[ebuild  N     ] dev-libs/nettle-2.7.1-r4  USE="gmp -doc (-neon) -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-libs/libatomic_ops-7.4.2
[ebuild  N     ] dev-libs/nss-3.19.2  USE="cacert nss-pem -utils" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-libs/boehm-gc-7.2f  USE="cxx threads -static-libs"
[ebuild  N     ] dev-scheme/guile-2.0.11-r1  USE="deprecated nls regex threads -debug -debug-malloc -emacs -networking -static"
[ebuild  N     ] dev-libs/libnl-3.2.25  USE="python -static-libs -utils" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_3 -python3_4"
[ebuild  N     ] dev-util/gdbus-codegen-2.44.1-r1000  PYTHON_ABIS="2.7 3.3 -2.6 -3.1 -3.2 -3.4 (-3.5)"
[ebuild  N     ] dev-libs/newt-0.52.15  USE="nls -gpm -tcl" PYTHON_TARGETS="python2_7"
[ebuild  N     ] dev-lang/spidermonkey-17.0.0-r4  USE="-debug -jit -minimal -static-libs {-test}"
[ebuild  N     ] sys-devel/autogen-5.18.4-r3  USE="-libopts -static-libs"
[ebuild  N     ] net-dialup/ppp-2.4.7  USE="ipv6 pam -activefilter -atm -dhcp -eap-tls -gtk -radius"
[ebuild  N     ] app-arch/libarchive-3.1.2-r1  USE="acl bzip2 e2fsprogs iconv lzma xattr zlib -expat -lzo -nettle -static-libs"
[ebuild  N     ] dev-util/cmake-3.2.2  USE="ncurses -doc -emacs -qt4 (-qt5) {-test}"
[ebuild  NS    ] app-text/docbook-xml-dtd-4.1.2-r6 [4.2-r2, 4.4-r2]
[ebuild  N     ] net-libs/libproxy-0.4.11-r2  USE="python -gnome -kde -mono -networkmanager -perl -spidermonkey {-test} -webkit" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7"
[ebuild  N     ] dev-libs/dbus-glib-0.102  USE="-debug -doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] net-dns/libidn-1.30  USE="nls -doc -emacs -java -mono -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] gnome-base/gsettings-desktop-schemas-3.14.2  USE="-introspection"
[ebuild  N     ] sys-auth/polkit-0.112-r3  USE="nls pam systemd -examples -gtk -introspection -jit -kde (-selinux)"
[ebuild  N     ] dev-libs/libtasn1-4.5  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] net-libs/gnutls-3.3.15  USE="crywrap cxx nls openssl zlib -dane -doc -examples -guile -pkcs11 -static-libs {-test}" ABI_X86="(64) -32 (-x32)" LINGUAS="-cs -de -en -fi -fr -it -ms -nl -pl -sv -uk -vi -zh_CN"
[ebuild  N     ] net-libs/glib-networking-2.42.1  USE="gnome libproxy ssl -smartcard {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] net-libs/libsoup-2.48.1  USE="ssl -debug -introspection -samba {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] sys-fs/eudev-1.5.3-r2  USE="gudev hwdb keymap kmod modutils openrc rule-generator static-libs -doc -introspection (-selinux) {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] virtual/udev-215
[ebuild  N     ] virtual/libgudev-215  USE="static-libs -introspection" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] net-wireless/crda-1.1.3-r1
[ebuild  N     ] net-wireless/wpa_supplicant-2.4-r3  USE="dbus hs2-0 readline ssl -ap -eap-sim -fasteap -gnutls -p2p (-ps3) -qt4 (-selinux) -smartcard -tdls -uncommon-eap-types -wimax -wps"
[ebuild  N     ] sys-apps/vbetool-1.1
[ebuild  N     ] sys-power/pm-utils-1.4.1-r6  USE="-alsa -debug -ntp" VIDEO_CARDS="-intel -radeon"
[ebuild  N     ] sys-power/upower-0.99.1  USE="deprecated -introspection -ios"
[ebuild  N     ] net-misc/networkmanager-1.0.2  USE="dhcpcd ncurses nss ppp resolvconf wifi -bluetooth -connection-sharing -consolekit -dhclient -gnutls -introspection -modemmanager -plugins_openconnect -plugins_openswan -plugins_openvpn -plugins_pptp -plugins_sstp -plugins_vpnc -policykit (-selinux) -teamd {-test} -vala -wext -zeroconf"
[blocks B      ] sys-fs/eudev ("sys-fs/eudev" is blocking sys-apps/gentoo-systemd-integration-4, sys-apps/systemd-218-r3)
[blocks B      ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/eudev-1.5.3-r2)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/systemd-218-r3::gentoo, installed) pulled in by
    sys-apps/systemd:0= required by (sys-auth/polkit-0.112-r3::gentoo, ebuild scheduled for merge)
    sys-apps/systemd:0= required by (sys-apps/dbus-1.8.16::gentoo, installed)
    sys-apps/systemd:0/2= required by (sys-apps/dbus-1.8.16::gentoo, installed)
    sys-apps/systemd required by @selected
    >=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-4::gentoo, installed)

  (sys-fs/eudev-1.5.3-r2::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/eudev-1.3 required by (virtual/udev-215::gentoo, ebuild scheduled for merge)
    >=sys-fs/eudev-1.3:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,static-libs?] (>=sys-fs/eudev-1.3:0/0[abi_x86_64(-),static-libs]) required by (virtual/libudev-215::gentoo, installed)
    >=sys-fs/eudev-1.5.3-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,gudev,introspection?,static-libs?] (>=sys-fs/eudev-1.5.3-r1:0/0[abi_x86_64(-),gudev,static-libs]) required by (virtual/libgudev-215::gentoo, ebuild scheduled for merge)

  (sys-apps/gentoo-systemd-integration-4::gentoo, installed) pulled in by
    sys-apps/gentoo-systemd-integration required by @selected
    sys-apps/gentoo-systemd-integration required by (sys-apps/systemd-218-r3::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 433
Location: Australia

PostPosted: Fri Aug 07, 2015 1:51 am    Post subject: Reply with quote

Funtoo != Gentoo there are considerable differences. Try http://forums.funtoo.org/ or the unsupported software section of these forums.
Back to top
View user's profile Send private message
bristlecone
n00b
n00b


Joined: 07 Aug 2015
Posts: 2

PostPosted: Fri Aug 07, 2015 2:20 am    Post subject: Reply with quote

ian.au: Thank you very much! I wasn't aware that there were large differences between the two. I'm going through the install process for normal Gentoo, and I was happy to see that one of the profiles included systemd, so I'm going to guess (and hope) that the rest of the installation goes smoothly.
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 433
Location: Australia

PostPosted: Fri Aug 07, 2015 2:25 am    Post subject: Reply with quote

Funtoo doesn't support systemd at all. It has shims that make Gnome work without it.
Gentoo has it as optional systemd support, if you want systemd install Gentoo.

Install Gentoo with Gentoo docs or Funtoo with Funtoo docs. You won't have a good time otherwise.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum