Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
64 Bit System, 64 Bit Browser, 32er Javaplugin?[capitulate]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2224
Location: Germany

PostPosted: Sun Aug 09, 2015 3:53 pm    Post subject: 64 Bit System, 64 Bit Browser, 32er Javaplugin?[capitulate] Reply with quote

So. Diverse Player nutzen kein Flash sondern Java. 64 Bit Java habe ich installiert. Funktioniert, nur nicht mit manchen Videoplayern.

Diverse Player wollen aber 32-Bit und das geht dann nicht.

Aktuell habe ich Oracle, weil ich zuerst dachte icedtea wäre der Ursprung des Problems.

Code:
 # eselect java-nsplugin list
Available 32-bit Java browser plugins
Available 64-bit Java browser plugins
  [1]   oracle-jre-bin-1.8  current


Code:
[I] www-plugins/nspluginwrapper
     Available versions:  1.4.4-r3
     Installed versions:  1.4.4-r3(04:34:58 14.04.2015)
     Homepage:            http://nspluginwrapper.org/
     Description:         Netscape Plugin Wrapper - Load 32bit plugins on 64bit browser


Das Wiki empfiehlt ja noch die alte Methode:

https://wiki.gentoo.org/wiki/Java wrote:
echo "app-emulation/emul-linux-x86-java nsplugin" >> /etc/portage/package.use
root #emerge emul-linux-x86-java


Das Useflag nsplugin habe ich aktiviert.

Code:
eix oracle-jre
[I] dev-java/oracle-jre-bin
     Available versions: 
     (1.7)  1.7.0.80^fs
     (1.8)  1.8.0.51^fs
       {X alsa +awt cups (+)fontconfig javafx jce nsplugin pax_kernel selinux}
     Installed versions:  1.8.0.51(1.8)^fs(19:55:03 08.08.2015)(alsa awt cups fontconfig nsplugin -javafx -jce -pax_kernel -selinux)
     Homepage:            http://www.oracle.com/technetwork/java/javase/
     Description:         Oracle's Java SE Runtime Environment


Lange Rede kurzer Sinn, was ersetzt im Multilib-Zeitalter emul-linux-x86-java?

Ein Workaround ist natürlich einfach den 32-Bit firefox-bin Browser zu verwenden.

Vielleicht habe ich aber auch was anders übersehen, aber das ist bisher der einzige unterschied zwischen den Systemen.


Last edited by ChrisJumper on Thu Aug 13, 2015 9:47 pm; edited 2 times in total
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2040
Location: My own world! I and Gentoo!

PostPosted: Sun Aug 09, 2015 3:54 pm    Post subject: Reply with quote

ABI_X86="32 64" ersetzt so ziemlich alle emul-linux-x86-* Pakete heutzutage ;)
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2224
Location: Germany

PostPosted: Sun Aug 09, 2015 4:09 pm    Post subject: Reply with quote

Quote:
# ABI_X86="32 64" emerge -av dev-java/oracle-jre-bin

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild Rf ] dev-java/oracle-jre-bin-1.8.0.51:1.8::gentoo USE="alsa awt cups fontconfig nsplugin -javafx -jce -pax_kernel (-selinux)" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB
Fetch Restriction: 1 package

Would you like to merge these packages? [Yes/No] yes

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) dev-java/oracle-jre-bin-1.8.0.51::gentoo
* jre-8u51-linux-x64.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ... [ ok ]
>>> Unpacking source...
>>> Unpacking jre-8u51-linux-x64.tar.gz to /var/tmp/portage/dev-java/oracle-jre-bin-1.8.0.51/work


Aber es installiert nicht zusätzlich die 32-Bit Version. Hmm. Mit ABI_X86="32" geht es auch nicht. Die E-Builds haben dafür wohl noch kein ABI Multilibflag.
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2224
Location: Germany

PostPosted: Thu Aug 13, 2015 9:45 pm    Post subject: Reply with quote

So ein Murks. Es ist wohl doch etwas anderes als Java. Denn der firefox-bin, funktioniert. Chromium 64-Bit

Code:
I] www-client/chromium
     Available versions:  44.0.2403.89^d ~45.0.2454.6^d ~45.0.2454.15^d ~45.0.2454.15-r1^d [M]~46.0.2467.2^d {cups custom-cflags gnome gnome-keyring hidpi hotwording kerberos neon pic +proprietary-codecs pulseaudio selinux +tcmalloc test LINGUAS="+am +ar +bg +bn +ca +cs +da +de +el +en_GB +es +es_LA +et +fa +fi +fil +fr +gu +he +hi +hr +hu +id +it +ja +kn +ko +lt +lv +ml +mr +ms +nb +nl +pl +pt_BR +pt_PT +ro +ru +sk +sl +sr +sv +sw +ta +te +th +tr +uk +vi +zh_CN +zh_TW"}
     Installed versions:  44.0.2403.89^d(00:18:55 31.07.2015)(cups gnome pic proprietary-codecs pulseaudio tcmalloc -custom-cflags -gnome-keyring -hidpi -hotwording -kerberos -neon -selinux -test LINGUAS="de -am -ar -bg -bn -ca -cs -da -el -en_GB -es -es_LA -et -fa -fi -fil -fr -gu -he -hi -hr -hu -id -it -ja -kn -ko -lt -lv -ml -mr -ms -nb -nl -pl -pt_BR -pt_PT -ro -ru -sk -sl -sr -sv -sw -ta -te -th -tr -uk -vi -zh_CN -zh_TW")
     Homepage:            http://chromium.org/
     Description:         Open-source version of Google Chrome web browser


Bei Chromium funktioniert der Player auch. Ich wechsle jetzt einfach vom firefox zu firefox-bin.

Ärgerliches Detail am Rande. Der neue firefox 40 und nutzen unter dem Stichwort Safe browsring, jeder der nicht gerne URLs aus dem privaten LAN an Google schickt sollte hier mal nachlesen.

Code:
browser.safebrowsing.downloads.remote.enabled
browser.safebrowsing.downloads.enabled


heise.de wrote:
Beim Download von ausführbaren Dateien befragt der Browser den Safe-Browsing-Service von Google, ob es sich bei der Software um Malware handelt.

Artikel: Firefox-40-warnt-vor-Malware-und-fehlenden-Add-on-Signaturen
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum