Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
K3B "mp3 audio decoder plugin not found" audio cd support
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
awalp
n00b
n00b


Joined: 29 May 2003
Posts: 71

PostPosted: Thu Aug 13, 2015 5:54 am    Post subject: K3B "mp3 audio decoder plugin not found" audio cd Reply with quote

When I launch k3b I get this error...
"MP3 Audio Decoder plugin not found"

This is the function of writing mp3s into an audio cd.

I'm trying to figure out how to fix this error.

I've rebuilt k3b with and without ffmpeg, libav, whatever combination, same error.


Code:
m17xr3 ~ # emerge -Dav k3b

 * IMPORTANT: 16 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   *] app-cdr/k3b-9999:5::kde  USE="dvd encode ffmpeg* flac handbook libav mad mp3 musepack sndfile sox* taglib vcd vorbis -debug -emovix {-test}" 0 KiB


Also, I'm using k3b-9999 because I'm running Plasma 5 / @kde-next-live overlay.
This error I believe has nothing to do with it being a live build.


----------------

What do I need to do to fix this and enable mp3 audio cd support?

I have practically every audio/media related USE flag in my make.conf

Code:
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=corei7-avx -O2 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
#USE="bindist mmx sse sse2"
PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"
MAKEOPTS="-j9"


USE_NO="-gnome -gtk -qt4"
        #USE_NO="-consolekit -gnome -gtk -qt4"
USE_CPU="sse mmx sse2 sse3 ssse3 sse4_1 sse4_2 smp"
USE_SYSTEM="truetype bzip2 dbus icu gpm samba smb cifs sambafs smbclient sddm usb"
USE_X="X nvidia opengl touchpad xinerama xnest vdpau"
USE_KDE="qt5 plasma wallpapers udev phonon semantic-desktop widgets upower"
#USE_KDE="semantic-desktop widgets"
  #USE_GNOME="gnome dbus gtk3 icu udisks eds"
USE_GNOME="-gnome -gtk"
USE_MEDIA="sndfile dvd dvb dvr dvdr cdr bluray blu-ray alsa jpeg gif png tiff a52 aac flac imagemagick ipod lame matroska svg theora wmf x264 x265 xvid avi jpeg2k twolame cdda vcd vorbis m$
USE_AUDIO="alsa mp3 mp4 ffmpeg musepack mpeg ogg quicktime midi schroedinger pulseaudio aacplus cdio wav taglib libav sox id3tag wavpack"
  #USE_AUDIO="alsa"
USE_MISC="yahoo spell samba rdesktop fuse bluetooth wimax vlc samba wifi pdf"

USE="$USE_NO $USE_CPU $USE_SYSTEM $USE_X $USE_KDE $USE_MEDIA $USE_GNOME $USE_AUDIO $USE_MISC"
  #USE="-gtk -gnome -qt4 qt5 kde dvd alsa cdr nvidia opengl"

VIDEO_CARDS="nvidia"
INPUT_DEVICES="evdev keyboard mouse synaptics"

LINGUAS="en de"
source /var/lib/layman/make.conf

GENTOO_MIRRORS="ftp://ftp.ussg.iu.edu/pub/linux/gentoo http://lug.mtu.edu/gentoo/ ftp://lug.mtu.edu/gentoo/ http://gentoo.cites.uiuc.edu/pub/gentoo/ ftp://gentoo.cites.uiuc.edu/pub/gentoo/"




BTW, I'm using the default non-desktop profile as both plasma & kde desktop profiles were pulling in KDE4.



------------------


Any ideas what's going on?
Is this a license issue and gentoo has mp3 disabled or what?


------------------

I do have one issue,
required dependency kdenlive is not merged (error with needing mlt version higher than available)

I'm not sure if I had to use keep-going to get k3b to build or whether I had different use flags.

Does kdenlive have anything to do with this mp3 decoder problem?
Back to top
View user's profile Send private message
Keruskerfuerst
Advocate
Advocate


Joined: 01 Feb 2006
Posts: 2288
Location: near Augsburg, Germany

PostPosted: Thu Aug 13, 2015 6:50 am    Post subject: Reply with quote

You need the mp3 decoding libraries.

https://packages.gentoo.org/

But i don´t see any libs here.

As I remember mp3 was invented by Fraunhofer Institute.
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Thu Aug 13, 2015 7:41 am    Post subject: Reply with quote

this is a duplicate of my post

https://forums.gentoo.org/viewtopic-t-1026484-highlight-.html

and it is a won t fix anyway.

same issue. i still have k3b on my box form kde-overlay.

kde overlay belongs to unsupported. k3b is broken in portage and from this overlay.
portage k3b can not handle proper m4a files
k3b from kde overlay can not handle m4a, mp3 ...

broken ffmpeg. won t fix.

when you want ot create audio cds, you can use gnomebaker from portage, that worked a few hours ago for myself. there are other ways also ...
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Thu Aug 13, 2015 8:10 am    Post subject: Reply with quote

Keruskerfuerst wrote:
You need the mp3 decoding libraries.

https://packages.gentoo.org/

But i don´t see any libs here.

As I remember mp3 was invented by Fraunhofer Institute.


libmad is not proper handled by kde overlay k3b. but its build form git. so he may report it to the kde devs, as k3b is buggy anyway and so many open bugs regarding k3b i gave up...

libmad => mp3 plugin for k3b ...
Back to top
View user's profile Send private message
awalp
n00b
n00b


Joined: 29 May 2003
Posts: 71

PostPosted: Fri Aug 14, 2015 3:27 am    Post subject: Reply with quote

tw04l124 wrote:
Keruskerfuerst wrote:
You need the mp3 decoding libraries.

https://packages.gentoo.org/

But i don´t see any libs here.

As I remember mp3 was invented by Fraunhofer Institute.


libmad is not proper handled by kde overlay k3b. but its build form git. so he may report it to the kde devs, as k3b is buggy anyway and so many open bugs regarding k3b i gave up...

libmad => mp3 plugin for k3b ...



I should have libmad installed as I am using the 'mad' use flag.

As for previous poster saying to just give up its not going to work... there has to be a reasonable explanation of this.
-- I tried to see if this is an issues in Arch Linux, k3b works fine (though I'm not sure of the actual version)

---------------

How else am I suppose to use K3B other than using k3b-9999.... I wish to use all qt5, plasma 5 and related applications.
Plasma 5 is not new, its been around for a while now and the relatively slow ported of applications to Plasma 5 is disappointing.
Back to top
View user's profile Send private message
Keruskerfuerst
Advocate
Advocate


Joined: 01 Feb 2006
Posts: 2288
Location: near Augsburg, Germany

PostPosted: Fri Aug 14, 2015 4:16 am    Post subject: Reply with quote

You can download the source code for mp3 decoding somewhere in the internet.

mp3 decoder source code
Back to top
View user's profile Send private message
awalp
n00b
n00b


Joined: 29 May 2003
Posts: 71

PostPosted: Fri Aug 14, 2015 1:50 pm    Post subject: Reply with quote

awalp wrote:
tw04l124 wrote:
Keruskerfuerst wrote:
You need the mp3 decoding libraries.

https://packages.gentoo.org/

But i don´t see any libs here.

As I remember mp3 was invented by Fraunhofer Institute.


libmad is not proper handled by kde overlay k3b. but its build form git. so he may report it to the kde devs, as k3b is buggy anyway and so many open bugs regarding k3b i gave up...

libmad => mp3 plugin for k3b ...



I should have libmad installed as I am using the 'mad' use flag.

As for previous poster saying to just give up its not going to work... there has to be a reasonable explanation of this.
-- I tried to see if this is an issues in Arch Linux, k3b works fine (though I'm not sure of the actual version)

---------------

How else am I suppose to use K3B other than using k3b-9999.... I wish to use all qt5, plasma 5 and related applications.
Plasma 5 is not new, its been around for a while now and the relatively slow ported of applications to Plasma 5 is disappointing.

Keruskerfuerst wrote:
You can download the source code for mp3 decoding somewhere in the internet.

mp3 decoder source code



Isn't that the job of Portage and setting the proper USE Flags?

Even if I did have to manually create an ebuild file, is there something missing from portage causing this?

So what I am hearing is Portage is installing libmad/mad but not including a plugin, even though the USE flags are set correctly and in all accounts should work?
-- Is there a dev or group handling the libmad portage section that I should contact about this issue?
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Fri Aug 14, 2015 5:39 pm    Post subject: Reply with quote

First of all you use Git code from kde overlay. so its unsupported. I wonder why its not moved to unsupported area.

And you compile from git? No wonder the app does not work. Why should it?

When you want to change that, you need to check the ebuild in question from kde-overlany and submit a bug at bugs.kde.org (i think thats the url)...

and why do you compare it with arch -linux.

does arch linux pull these days everything on a daily basis from git? i doubt, i used arch linux for quite a while and that was not git stuff in the arch repository...

you compare apples with bananas

arch repository VS git tree from kde development which is beeing made available with kde overlay, unsupported ebuilds, in the first place!

That stuff is unfixable. I wont bother again ever with unproven git code from any dev... They change on a daily basis stuff, so you just waste your time.


Quote:
To quote myself from the other topic, about the same issue:

portage ebuild: mad useflag for mp3
kde overlay ebuild: mp3 useflag for mp3
both utilize ffmpeg and / or libmad ... for that feature ...
Back to top
View user's profile Send private message
awalp
n00b
n00b


Joined: 29 May 2003
Posts: 71

PostPosted: Sat Aug 15, 2015 11:59 am    Post subject: Reply with quote

tw04l124 wrote:
First of all you use Git code from kde overlay. so its unsupported. I wonder why its not moved to unsupported area.

And you compile from git? No wonder the app does not work. Why should it?

When you want to change that, you need to check the ebuild in question from kde-overlany and submit a bug at bugs.kde.org (i think thats the url)...

and why do you compare it with arch -linux.

does arch linux pull these days everything on a daily basis from git? i doubt, i used arch linux for quite a while and that was not git stuff in the arch repository...

you compare apples with bananas

arch repository VS git tree from kde development which is beeing made available with kde overlay, unsupported ebuilds, in the first place!

That stuff is unfixable. I wont bother again ever with unproven git code from any dev... They change on a daily basis stuff, so you just waste your time.


Quote:
To quote myself from the other topic, about the same issue:

portage ebuild: mad useflag for mp3
kde overlay ebuild: mp3 useflag for mp3
both utilize ffmpeg and / or libmad ... for that feature ...



My point is this seems to be a common error and not related to k3b being -9999 but rather how gentoo is configured.

I'll try k3b-15.x and see if I have the same issue.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3622
Location: Germany

PostPosted: Sat Aug 15, 2015 3:26 pm    Post subject: Reply with quote

awalp wrote:
BTW, I'm using the default non-desktop profile as both plasma & kde desktop profiles were pulling in KDE4.

Hm, KDE4 is finely co installable with Plasma5

I use here
Code:
emerge -pv plasma-desktop k3b

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   *] kde-plasma/plasma-desktop-9999:5::kde  USE="evdev fontconfig qt4 -debug -gtk2 -gtk3 -handbook -legacy-systray -pulseaudio {-test} -touchpad" 0 KiB
[ebuild   R    ] app-cdr/k3b-2.0.3-r2:4::gentoo  USE="dvd encode ffmpeg flac mad mp3 sndfile sox taglib vcd vorbis (-aqua) -debug -emovix -handbook -libav -musepack" LINGUAS="de -ast -be -bg -bs -ca -ca@valencia -cs -csb -da -el -en_GB -eo -es -et -eu -fi -fr -ga -gl -he -hi -hne -hr -hu -is -it -ja -kk -km -ko -ku -lt -lv -mai -mr -ms -nb -nds -nl -nn -oc -pa -pl -pt -pt_BR -ro -ru -se -sk -sl -sr -sr@ijekavian -sr@ijekavianlatin -sr@latin -sv -th -tr -ug -uk -zh_CN -zh_TW" 0 KiB

Total: 2 packages (2 reinstalls), Size of downloads: 0 KiB
on a plasma5 desktop
k3b works fine and burn audio CDs from MP3

(excuse please my bad english)
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Sat Aug 15, 2015 5:05 pm    Post subject: Reply with quote

portage k3b: try m4a audio files, and you better use a rewriteable disc, as the audio gets gargage... gentoo bug was closed => upstream and i neiver reported it upstreams ..
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7693
Location: Pelotas, BR

PostPosted: Wed Nov 18, 2015 10:41 am    Post subject: Reply with quote

Moved from Multimedia to Duplicate Threads. Please see this thread.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum