Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Probleme mit Getty und systemd
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
xtrace
Tux's lil' helper
Tux's lil' helper


Joined: 17 May 2010
Posts: 75

PostPosted: Fri Aug 14, 2015 5:07 pm    Post subject: Probleme mit Getty und systemd Reply with quote

Hi,

anscheind scheint getty mit system nicht korrekt zu laufen.
Hatte das Problem schonmal jemand?

Quote:
# journalctl -b

Code:

Aug 15 18:52:10 empire agetty[5307]: /dev/ttyX: No such file or directory
Aug 15 18:52:20 empire systemd[1]: getty@ttyX.service has no holdoff time, scheduling restart.
Aug 15 18:52:20 empire systemd[1]: Stopping Getty on ttyX...
Aug 15 18:52:20 empire systemd[1]: Starting Getty on ttyX...
Aug 15 18:52:20 empire systemd[1]: Started Getty on ttyX.
Aug 15 18:52:20 empire agetty[5309]: /dev/ttyX: No such file or directory
Aug 15 18:52:30 empire systemd[1]: getty@ttyX.service has no holdoff time, scheduling restart.
Aug 15 18:52:30 empire systemd[1]: Stopping Getty on ttyX...
Aug 15 18:52:30 empire systemd[1]: Starting Getty on ttyX...
Aug 15 18:52:30 empire systemd[1]: Started Getty on ttyX.
Aug 15 18:52:30 empire agetty[5311]: /dev/ttyX: No such file or directory
Aug 15 18:52:40 empire systemd[1]: getty@ttyX.service has no holdoff time, scheduling restart.
Aug 15 18:52:40 empire systemd[1]: Stopping Getty on ttyX...
Aug 15 18:52:40 empire systemd[1]: Starting Getty on ttyX...
Aug 15 18:52:40 empire systemd[1]: Started Getty on ttyX.


Vielen Dank.
cu,
xtrace
Back to top
View user's profile Send private message
xtrace
Tux's lil' helper
Tux's lil' helper


Joined: 17 May 2010
Posts: 75

PostPosted: Tue Sep 08, 2015 6:07 am    Post subject: Reply with quote

Ich habe nun mit mknod /dev/ttyX -c 4 1 eine Geräte Datei erstellt. Leider ohne Erfolg.

Sonst noch jemand eine Idee woran das liegen kann?

VG
xtrace
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1559
Location: Schweiz

PostPosted: Tue Sep 08, 2015 8:19 am    Post subject: Reply with quote

Also wenn agetty sein Device nicht finden kann würde ich persönlich eher auf einen Fehler in der Kernel-Konfiguration tippen als in systemd/udev. Aber wo genau man da nachsehen müsste weiß ich jetzt auch nicht da mir sowas noch nie passiert ist und laut Google auch kaum jemand anderem.
_________________
GPG: 0x3FC78AEE51E5FB95


Last edited by schmidicom on Wed Sep 09, 2015 5:43 am; edited 1 time in total
Back to top
View user's profile Send private message
mrsteven
Veteran
Veteran


Joined: 04 Jul 2003
Posts: 1938

PostPosted: Tue Sep 08, 2015 6:03 pm    Post subject: Reply with quote

Wirklich wörtlich /dev/ttyX? Das sollte doch eher /dev/tty1, /dev/tty2 usw. sein. Bist du sicher, dass du das richtige service-file verwendest?
_________________
Unix philosophy: "Do one thing and do it well."
systemd: "Do everything and do it wrong."
Back to top
View user's profile Send private message
xtrace
Tux's lil' helper
Tux's lil' helper


Joined: 17 May 2010
Posts: 75

PostPosted: Tue Sep 08, 2015 6:12 pm    Post subject: Reply with quote

Hey,

ja. Da steht wirklich /dev/ttyX (wie im ersten Post zu sehen).
Komischerweise nimmt sich der Rechner immer parallel zum Fehler einige Gedenksekunden (die Festplattenlampe leuchtet dauerhaft und der Rechner wirkt wie eingefroren).

Ich habe im Kernel auch nochmal alles überprüft. Konnte keinen Fehler feststellen.

Gestartet habe ich folgenden serivce:

Quote:
systemctl start getty@tty{2,3,4,5,6}.service



VG
xtrace
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum