Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
new install will not boot [solved]
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1107
Location: Tri-Cities, WA USA

PostPosted: Wed Aug 19, 2015 12:03 am    Post subject: Reply with quote

ian.au wrote:
I think you'll have to wait until you reboot into your systemd system, my guess is you're booted with openrc right now (as systemd wasn't installed due to those Blocks and world is still updating?) easiest way to check is to see what's sitting on pid1 :wink:
Code:
ps -ax |less
If not
Code:
1 ?        Ss     0:08 /usr/lib/systemd/systemd
then none of the systemctl functionality is available yet.


thanks again.
- I recompolied my kernel with systemd enabled. I did not have this set.
I did not compile with OpenRC as ist was compiled before.

I still get and error with:
#hostnamectl set-hostname myhostname
Code:

# hostnamectl set-hostname azzerare
Failed to create bus connection: No such file or directory

No nic on ifconfig or ifcfg

Questions:
Should I remove OpenRC?

I am reading and following this guide: https://wiki.gentoo.org/wiki/Systemd


Code:

ps  -ax
 PID TTY      STAT   TIME COMMAND
    1 ?        Ss     0:01 init [3]
    2 ?        S      0:00 [kthreadd]
    3 ?        S      0:00 [ksoftirqd/0]
    5 ?        S<     0:00 [kworker/0:0H]
    7 ?        S      0:00 [rcu_sched]
    8 ?        S      0:00 [rcu_bh]
    9 ?        S      0:00 [migration/0]
   10 ?        S<     0:00 [khelper]
   11 ?        S      0:00 [kdevtmpfs]
   12 ?        S<     0:00 [netns]
   13 ?        S<     0:00 [perf]
   14 ?        S<     0:00 [writeback]
   15 ?        S<     0:00 [crypto]
   16 ?        S<     0:00 [bioset]
   17 ?        S<     0:00 [kblockd]
   18 ?        S<     0:00 [ata_sff]
   19 ?        S<     0:00 [md]
   20 ?        S      0:01 [kworker/0:1]
   21 ?        S<     0:00 [cfg80211]
   22 ?        S<     0:00 [rpciod]
   23 ?        S      0:00 [kswapd0]
   24 ?        S      0:00 [fsnotify_mark]
   25 ?        S<     0:00 [nfsiod]
   41 ?        S<     0:00 [acpi_thermal_pm]
   42 ?        S      0:00 [kworker/u4:1]
   44 ?        S<     0:00 [ttm_swap]
   45 ?        S<     0:00 [kworker/u5:0]
   46 ?        S<     0:00 [kloopd]
   47 ?        S      0:00 [scsi_eh_0]
   48 ?        S<     0:00 [scsi_tmf_0]
   49 ?        S      0:00 [scsi_eh_1]
   50 ?        S<     0:00 [scsi_tmf_1]
   51 ?        S      0:00 [scsi_eh_2]
   52 ?        S<     0:00 [scsi_tmf_2]
   53 ?        S      0:00 [scsi_eh_3]
   54 ?        S<     0:00 [scsi_tmf_3]
   58 ?        S<     0:00 [kpsmoused]
60 ?        S<     0:00 [ipv6_addrconf]
   61 ?        S<     0:00 [deferwq]
   62 ?        S      0:00 [kworker/u4:5]
   66 ?        S<     0:00 [kworker/0:1H]
   67 ?        S      0:00 [jbd2/sda3-8]
   68 ?        S<     0:00 [ext4-rsv-conver]
  256 ?        Ss     0:00 /usr/lib/systemd/systemd-udevd --daemon
  291 ?        S<     0:00 [hd-audio0]
  292 ?        S<     0:00 [hd-audio1]
  782 ?        S      0:00 supervising syslog-ng                                                                                                             $
  783 ?        Ss     0:00 /usr/sbin/syslog-ng --persist-file /var/lib/syslog-ng/syslog-ng.persist --cfgfile /etc/syslog-ng/syslog-ng.conf --pidfile /run/sys$
  807 ?        Ss     0:00 /usr/sbin/crond
  832 ?        Ss     0:00 /usr/sbin/sshd
  854 tty1     Ss     0:00 /bin/login --
  855 tty2     Ss+    0:00 /sbin/agetty 38400 tty2 linux
  856 tty3     Ss+    0:00 /sbin/agetty 38400 tty3 linux
  857 tty4     Ss+    0:00 /sbin/agetty 38400 tty4 linux
  858 tty5     Ss+    0:00 /sbin/agetty 38400 tty5 linux
  859 tty6     Ss+    0:00 /sbin/agetty 38400 tty6 linux
881 tty1     S      0:00 -bash
  885 tty1     S      0:00 su -
  886 tty1     S      0:00 -su
 1119 ?        S      0:00 [kworker/0:0]
 1120 ?        S      0:00 [kworker/0:2]
 1128 tty1     R+     0:00 ps -ax


_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 433
Location: Australia

PostPosted: Wed Aug 19, 2015 12:13 am    Post subject: Reply with quote

No, don't remove openrc. You need to keep that around. You just need to tell the system to boot the systemd init you've installed.

What do you have in /etc/default/grub? You need to change the init line there to boot systemd. That entry looks like:
Code:
# Boot with systemd instead of sysvinit (openrc)
GRUB_CMDLINE_LINUX="init=/usr/lib/systemd/systemd"
(This is part of the Grub2 instructions on the wiki page you are using, I think you've maybe missed this step?)
Back to top
View user's profile Send private message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1107
Location: Tri-Cities, WA USA

PostPosted: Wed Aug 19, 2015 12:40 am    Post subject: Reply with quote

ian.au wrote:
No, don't remove openrc. You need to keep that around. You just need to tell the system to boot the systemd init you've installed.

What do you have in /etc/default/grub? You need to change the init line there to boot systemd. That entry looks like:
Code:
# Boot with systemd instead of sysvinit (openrc)
GRUB_CMDLINE_LINUX="init=/usr/lib/systemd/systemd"
(This is part of the Grub2 instructions on the wiki page you are using, I think you've maybe missed this step?)


time to compile the kernel again :)

thanks!

Code:


GRUB_DISTRIBUTOR="Gentoo"

# Default menu entry
#GRUB_DEFAULT=0

# Boot the default entry this many seconds after the menu is displayed
#GRUB_TIMEOUT=5
#GRUB_TIMEOUT_STYLE=menu

# Append parameters to the linux kernel command line
#GRUB_CMDLINE_LINUX=""
#
# Examples:
#
# Boot with network interface renaming disabled
# GRUB_CMDLINE_LINUX="net.ifnames=0"
#
# Boot with systemd instead of sysvinit (openrc)
# GRUB_CMDLINE_LINUX="init=/usr/lib/systemd/systemd"

# Append parameters to the linux kernel command line for non-recovery entries
#GRUB_CMDLINE_LINUX_DEFAULT=""

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal.
# Note that you can use only modes which your graphic card supports via VBE.
# You can see them in real GRUB with the command `vbeinfo'.
#GRUB_GFXMODE=640x480
# Set to 'text' to force the Linux kernel to boot in normal text
# mode, 'keep' to preserve the graphics mode set using
# 'GRUB_GFXMODE', 'WIDTHxHEIGHT'['xDEPTH'] to set a particular
# graphics mode, or a sequence of these separated by commas or
# semicolons to try several modes in sequence.
#GRUB_GFXPAYLOAD_LINUX=

# Path to theme spec txt file.
# The starfield is by default provided with use truetype.
# NOTE: when enabling custom theme, ensure you have required font/etc.
#GRUB_THEME="/boot/grub/themes/starfield/theme.txt"

# Background image used on graphical terminal.
# Can be in various bitmap formats.
#GRUB_BACKGROUND="/boot/grub/mybackground.png"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to kernel
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY=true

# Uncomment to disable generation of the submenu and put all choices on
# the top-level menu.
# Besides the visual affect of no sub menu, this makes navigation of the
# menu easier for a user who can't see the screen.
#GRUB_DISABLE_SUBMENU=y

# Uncomment to play a tone when the main menu is displayed.
# This is useful, for example, to allow users who can't see the screen
# to know when they can make a choice on the menu.
#GRUB_INIT_TUNE="60 800 1"


_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 433
Location: Australia

PostPosted: Wed Aug 19, 2015 12:52 am    Post subject: Reply with quote

Quote:
GRUB_DISTRIBUTOR="Gentoo"

# Default menu entry
#GRUB_DEFAULT=0

# Boot the default entry this many seconds after the menu is displayed
#GRUB_TIMEOUT=5
#GRUB_TIMEOUT_STYLE=menu

# Append parameters to the linux kernel command line
#GRUB_CMDLINE_LINUX=""
#
# Examples:
#
# Boot with network interface renaming disabled
# GRUB_CMDLINE_LINUX="net.ifnames=0"
#
# Boot with systemd instead of sysvinit (openrc)
# GRUB_CMDLINE_LINUX="init=/usr/lib/systemd/systemd"

# Append parameters to the linux kernel command line for non-recovery entries
#GRUB_CMDLINE_LINUX_DEFAULT=""

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal.
# Note that you can use only modes which your graphic card supports via VBE.
# You can see them in real GRUB with the command `vbeinfo'.
#GRUB_GFXMODE=640x480
# Set to 'text' to force the Linux kernel to boot in normal text
# mode, 'keep' to preserve the graphics mode set using
# 'GRUB_GFXMODE', 'WIDTHxHEIGHT'['xDEPTH'] to set a particular
# graphics mode, or a sequence of these separated by commas or
# semicolons to try several modes in sequence.
#GRUB_GFXPAYLOAD_LINUX=

# Path to theme spec txt file.
# The starfield is by default provided with use truetype.
# NOTE: when enabling custom theme, ensure you have required font/etc.
#GRUB_THEME="/boot/grub/themes/starfield/theme.txt"

# Background image used on graphical terminal.
# Can be in various bitmap formats.
#GRUB_BACKGROUND="/boot/grub/mybackground.png"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to kernel
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY=true

# Uncomment to disable generation of the submenu and put all choices on
# the top-level menu.
# Besides the visual affect of no sub menu, this makes navigation of the
# menu easier for a user who can't see the screen.
#GRUB_DISABLE_SUBMENU=y

# Uncomment to play a tone when the main menu is displayed.
# This is useful, for example, to allow users who can't see the screen
# to know when they can make a choice on the menu.
#GRUB_INIT_TUNE="60 800 1"


You don't need to recompile the kernel? Why do you think that? Just change the line I marked above to read GRUB_CMDLINE_LINUX="init=/usr/lib/systemd/systemd" by removing the # in front of it.

With any luck (and I sincerely hope it for you) you should boot successfully into systemd once you changed this.
Back to top
View user's profile Send private message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1107
Location: Tri-Cities, WA USA

PostPosted: Wed Aug 19, 2015 1:41 am    Post subject: Reply with quote

ya, you sincerely hope so I stop presting you :) LOL
I just though I had to compile the kernel for openrc support as I did with systemd
yiour a good man ian

edit:
changed the /etc/default/grub setting

error
#systemctrl
Failed to get D-Bus connection: Operation not permitted

I'll keep at it.
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 433
Location: Australia

PostPosted: Wed Aug 19, 2015 1:55 am    Post subject: Reply with quote

Only partly :) If I recall correctly you've been trying to get this install up for some time. Your persistence is commendable, I think your falling into the trap of 'waiting until something looks familiar' here as opposed to really reading and following the instructions. The systemd approach is a bit of a new flavour, once set up though it tends to just work. Never remove openrc, leaving it there enables you to switch back if you have problems, just by amending that line in oops /etc/default/grub. Remember we are an openrc init with a systemd option the way this is structured.

After you amend your /etc/default/grub, you should rerun
Code:
grub2-mkconfig -o /boot/grub/grub.cfg
before you reboot so Grub knows about the change, and you should (hopefully) be good to go after rebooting.

Edit
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 433
Location: Australia

PostPosted: Wed Aug 19, 2015 2:00 am    Post subject: Reply with quote

Sorry, check those edits above - I'm updating an old grub legacy system at the moment and put in the legacy grub.conf without thinking.
Back to top
View user's profile Send private message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1107
Location: Tri-Cities, WA USA

PostPosted: Wed Aug 19, 2015 2:20 am    Post subject: Reply with quote

ian.au wrote:
Sorry, check those edits above - I'm updating an old grub legacy system at the moment and put in the legacy grub.conf without thinking.


got er done.

at least systemctl works.
now i can set up a nic

taking a break to walk the dog.

thanks. i post later
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 433
Location: Australia

PostPosted: Wed Aug 19, 2015 2:21 am    Post subject: Reply with quote

:D :D :D
Back to top
View user's profile Send private message
Box293
n00b
n00b


Joined: 12 May 2017
Posts: 9

PostPosted: Fri May 19, 2017 12:00 am    Post subject: Reply with quote

ian.au wrote:
You just need to tell the system to boot the systemd init you've installed.

What do you have in /etc/default/grub? You need to change the init line there to boot systemd. That entry looks like:
Code:
# Boot with systemd instead of sysvinit (openrc)
GRUB_CMDLINE_LINUX="init=/usr/lib/systemd/systemd"   


After you amend your /etc/default/grub, you should rerun
Code:
grub2-mkconfig -o /boot/grub/grub.cfg
before you reboot so Grub knows about the change, and you should (hopefully) be good to go after rebooting.


This fixed it for me, but I needed to run:
Code:
grub-mkconfig -o /boot/grub/grub.cfg
Back to top
View user's profile Send private message
ian.au
Guru
Guru


Joined: 07 Apr 2011
Posts: 433
Location: Australia

PostPosted: Fri May 19, 2017 12:17 am    Post subject: Reply with quote

Box293 wrote:
ian.au wrote:
You just need to tell the system to boot the systemd init you've installed.

What do you have in /etc/default/grub? You need to change the init line there to boot systemd. That entry looks like:
Code:
# Boot with systemd instead of sysvinit (openrc)
GRUB_CMDLINE_LINUX="init=/usr/lib/systemd/systemd"   


After you amend your /etc/default/grub, you should rerun
Code:
grub2-mkconfig -o /boot/grub/grub.cfg
before you reboot so Grub knows about the change, and you should (hopefully) be good to go after rebooting.


This fixed it for me, but I needed to run:
Code:
grub-mkconfig -o /boot/grub/grub.cfg


Yes, this post was from 2015 - the multislot default setting changed in 2016, so which command you use is now dependent on whether or not the multislot flag is set on sys-boot/grub per the following news update.

Quote:
2016-08-11-grub2_multislot_default
Title Grub2 multislot default setting is changing
Author William Hubbs <williamh@gentoo.org>
Author Ian Stakenvicius <axs@gentoo.org>
Posted 2016-08-11
Revision 1

The multislot use flag in sys-boot/grub-2.x is no longer enabled by
default.

When the flag is enabled, all upstream binaries and documentation are
renamed to "grub2" so as not to collide with grub-0. Now that the use
flag is no longer default-enabled, these names will revert back to
their upstream defaults. For example, grub2-mkconfig will become
grub-mkconfig, grub2-install will become grub-install, etc.

If you wish to retain the previous naming scheme, please make sure to
explicitly enable USE="multislot" on sys-boot/grub in the usual manner.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum