Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Booting failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
hurvajs77
n00b
n00b


Joined: 05 Apr 2010
Posts: 56

PostPosted: Tue Aug 18, 2015 9:55 am    Post subject: [SOLVED] Booting failed Reply with quote

Hi guys,
I've problem with boot - kernel 4.1.6 successfully compiled, but failed. I presume on udev may be... - you can see video on my YouTube there.

What is really little strage is this: if I you kernel from similar my computer, so boot is successful - with minor errors, EFI partition isn't mounted and mount failed because /dev/BOOT isn't devide, but success - video is here

There is UEFI, Gentoo and Windows 7. Two HDD and layout:
- sda contains Windows7 and EFI (/boot), /, /opt, /usr, /home, /tmp)
- sdb contains swap and /var only

Can you someone help me please? Thank you :-)


Last edited by hurvajs77 on Wed Sep 02, 2015 7:23 am; edited 1 time in total
Back to top
View user's profile Send private message
genoobish
n00b
n00b


Joined: 18 Feb 2015
Posts: 73

PostPosted: Tue Aug 18, 2015 11:22 am    Post subject: Reply with quote

what do you have in your /etc/fstab ?

from the comment above, mentioning /dev/BOOT, I think you forgot to add the entry for the /boot partition (or maybe for everytying) in your fstab.
Back to top
View user's profile Send private message
TheLexx
Tux's lil' helper
Tux's lil' helper


Joined: 04 Dec 2005
Posts: 115
Location: Austin Tx

PostPosted: Tue Aug 18, 2015 3:30 pm    Post subject: Reply with quote

Humm, before your computer locked up, the Linux kernel encountered an "oops" https://en.wikipedia.org/wiki/Linux_kernel_oops . This is a recoverable error that was encountered as your kernel runs. However whatever was the problem it was sever enough to print out the following error message.
Code:
fixing recursive fault but reboot is needed!


My guess is that what ever happened, OpenRC was not able to compensate for the fault.

I noticed that the lock-up/crash was late in the game. I can't tell if your computer was able to mount the HD as read/write before the lock-up. You stated that the drive did not mount, and I seam to think you are correct, however you might check anyway, just to be sure.

If it did mount and the kernel messages were saved to disk then it will be much easier to find-out what happened. Try looking into the /var/log/message to see if details of the failed boot attempt are contained within. I would grep for the recursive fault message inside the log file".

I have the live distro Finnix on HD and cd-rom for occasions like this. I prefer it because Finnix will not add append to the log file. Nor will Finnix open the filesystem as read/write until/unless you tell it to. You can grep the log regardless of whether you boot into Gentoo or Finnix.

If you use Finnix it is easier to figure out whether the drives were mounter or not during the failed boot attempt. If the filesystem was mounted read/write during the boot attempt, them they will not be cleanly unmounted. From Finnix use "fsck.ext4 -v -C 0 THE_FILE_SYSTEM". you will usually get a message saying that the journal was recovered, or the filesystem was cleanly unmounted. You might get the message that the mount count was reached, but you are only interested in whether fsck recovers the journal or not.

PS. If you setup root and /usr as separate partitions, you will need to use an initrd to mount /usr before the standard OpenRC starts it's work.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum