Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No Sound [AMD] FCH Azalia Controller (rev 01) [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
DancesWithWords
Guru
Guru


Joined: 29 Jun 2002
Posts: 341
Location: ottawa, canada

PostPosted: Tue Aug 18, 2015 10:08 pm    Post subject: No Sound [AMD] FCH Azalia Controller (rev 01) [SOLVED] Reply with quote

Trying to get this onboard soundcard to work.

lspic -k
http://pastebin.com/teCMETLB

alsamixer
cannot open mixer: No such device

cat /proc/asound/cards
0 [Generic ]: HDA-Intel - HD-Audio Generic
HD-Audio Generic at 0xfeb40000 irq 16

grep Codec /proc/asound/card*/codec*
Codec: Realtek ID 887

ls -la /proc/asound/
total 0
dr-xr-xr-x 5 root root 0 Aug 18 18:04 .
dr-xr-xr-x 162 root root 0 Aug 17 17:32 ..
dr-xr-xr-x 2 root root 0 Aug 18 18:04 card0
-r--r--r-- 1 root root 0 Aug 18 18:04 cards
-r--r--r-- 1 root root 0 Aug 18 18:04 devices
lrwxrwxrwx 1 root root 5 Aug 18 18:04 Generic -> card0
-r--r--r-- 1 root root 0 Aug 18 18:04 hwdep
dr-xr-xr-x 2 root root 0 Aug 18 18:04 oss
-r--r--r-- 1 root root 0 Aug 18 18:04 pcm
dr-xr-xr-x 2 root root 0 Aug 18 18:04 seq
-r--r--r-- 1 root root 0 Aug 18 18:04 timers
-r--r--r-- 1 root root 0 Aug 18 18:04 version


aplay -D default /mnt/mmedia/Music/ashanti/over.mp3
ALSA lib /var/tmp/portage/media-libs/alsa-lib-1.0.29/work/alsa-lib-1.0.29/src/pcm/pcm_dmix.c:1024:(snd_pcm_dmix_open) unable to open slave
aplay: main:722: audio open error: No such file or directory

uname -a
Linux bbox 3.18.16-gentoo #1 SMP Sun Aug 16 20:45:20 EDT 2015 x86_64 AMD A6-6400K APU with Radeon(tm) HD Graphics AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
DancesWithWords
Guru
Guru


Joined: 29 Jun 2002
Posts: 341
Location: ottawa, canada

PostPosted: Wed Aug 19, 2015 12:23 am    Post subject: Re: No Sound [AMD] FCH Azalia Controller (rev 01) [SOLVED] Reply with quote

DancesWithWords wrote:
Trying to get this onboard soundcard to work.

lspic -k
http://pastebin.com/teCMETLB

alsamixer
cannot open mixer: No such device

cat /proc/asound/cards
0 [Generic ]: HDA-Intel - HD-Audio Generic
HD-Audio Generic at 0xfeb40000 irq 16

grep Codec /proc/asound/card*/codec*
Codec: Realtek ID 887

ls -la /proc/asound/
total 0
dr-xr-xr-x 5 root root 0 Aug 18 18:04 .
dr-xr-xr-x 162 root root 0 Aug 17 17:32 ..
dr-xr-xr-x 2 root root 0 Aug 18 18:04 card0
-r--r--r-- 1 root root 0 Aug 18 18:04 cards
-r--r--r-- 1 root root 0 Aug 18 18:04 devices
lrwxrwxrwx 1 root root 5 Aug 18 18:04 Generic -> card0
-r--r--r-- 1 root root 0 Aug 18 18:04 hwdep
dr-xr-xr-x 2 root root 0 Aug 18 18:04 oss
-r--r--r-- 1 root root 0 Aug 18 18:04 pcm
dr-xr-xr-x 2 root root 0 Aug 18 18:04 seq
-r--r--r-- 1 root root 0 Aug 18 18:04 timers
-r--r--r-- 1 root root 0 Aug 18 18:04 version


aplay -D default /mnt/mmedia/Music/ashanti/over.mp3
ALSA lib /var/tmp/portage/media-libs/alsa-lib-1.0.29/work/alsa-lib-1.0.29/src/pcm/pcm_dmix.c:1024:(snd_pcm_dmix_open) unable to open slave
aplay: main:722: audio open error: No such file or directory

uname -a
Linux bbox 3.18.16-gentoo #1 SMP Sun Aug 16 20:45:20 EDT 2015 x86_64 AMD A6-6400K APU with Radeon(tm) HD Graphics AuthenticAMD GNU/Linux


Found my error. I was missing the following from my kernel .conf.

CONFIG_SND_HDA_CODEC_REALTEK=y

Sound is working in KDE, mplayer, youtube

Sound is not working VLC
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum