Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
FTP + Umlaute problem
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
kutte128
Apprentice
Apprentice


Joined: 18 May 2004
Posts: 173

PostPosted: Fri Aug 21, 2015 2:48 pm    Post subject: FTP + Umlaute problem Reply with quote

Hi,

ich folgendes Problem:
ich lade eine Datei mit Umlauten per FTP auf den Server.
FTP-Server ist pure-ftpd.

Aus einer "Datei mit ü.txt" wird dann eine "Datei mit ▒.txt"

Die üblichen Verdächtigen habe ich schon überprüft. Mein KiTTY steht auf UTF-8, locale auch:
Code:

 eselect locale list
Available targets for the LANG variable:
  [1]   C
  [2]   de_DE
  [3]   de_DE@euro
  [4]   de_DE.iso88591
  [5]   de_DE.iso885915@euro
  [6]   de_DE.utf8 *
  [7]   deutsch
  [8]   en_US
  [9]   en_US.iso88591
  [10]  en_US.utf8
  [11]  german
  [12]  POSIX

Im FTP-Client wird sie richtig angezeigt, allerdings kann ich z.B. nicht mit PHP darauf zugreifen, da sie nicht gefunden wird.
Wenn ich die Datei direkt über die Konsole anlege, stimmen auch die Umlaute aber im FTP-Client bekomme ich dann für diese Datei Unsinn angezeigt.
Stelle ich meinen FTP-Client auf UTF-8, zeigt er mir die auf der Konsole erstellte richtig an, die andere nicht, aber ein Upload mit Umlauten ist dann nicht mehr möglich.
Dateisystem ist Ext4

Wo könnte das Problem sein?

Es funktioniert übrigens, wenn ich den FTP-Client auf UTF-8 stelle. Ideal wäre es, wenn das auch mit "Auto" funktionieren würde

Grüße,
kutte128


Last edited by kutte128 on Fri Aug 21, 2015 4:57 pm; edited 1 time in total
Back to top
View user's profile Send private message
py-ro
Veteran
Veteran


Joined: 24 Sep 2002
Posts: 1733
Location: St. Wendel

PostPosted: Fri Aug 21, 2015 4:39 pm    Post subject: Reply with quote

Bring deinem FTP Server bei das richtige Encoding mitzuteilen, bei Proftpd könnte das hier helfen:

http://www.proftpd.org/docs/modules/mod_lang.html

Bye
Py
Back to top
View user's profile Send private message
kutte128
Apprentice
Apprentice


Joined: 18 May 2004
Posts: 173

PostPosted: Fri Aug 21, 2015 5:01 pm    Post subject: Reply with quote

hey, thx für die schnelle Antwort.

Mist, ich wollte noch reintippern dass ich ich pure-ftpd nutze. Ich habs mal oben ergänzt.

Für pure-ftpd gibts das ja auch mit -8 und -9, hat aber nichts gebracht.

Es scheint auch kein rfc2640 use-flag zu geben
Back to top
View user's profile Send private message
fenris_der_wolf
n00b
n00b


Joined: 17 Oct 2009
Posts: 7

PostPosted: Fri Aug 28, 2015 10:44 am    Post subject: Reply with quote

Versuch mal pure-ftpd mit USE="charconv" zu erstellen. Dann solltest Du in der Config-Datei (/etc/conf.d/pure-ftpd) die Option
Code:
CHARCONV="--fscharset <charset>"
setzen können. ( <charset> z.B. utf-8 )
Vieleicht hilft das ja...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum