Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Nvidia GT 630 does not work properly with any driver
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
deltamalloc
Apprentice
Apprentice


Joined: 18 Jan 2013
Posts: 279

PostPosted: Mon Aug 24, 2015 8:09 pm    Post subject: Nvidia GT 630 does not work properly with any driver Reply with quote

Using the proprietary nvidia driver with a GT 630 card, X will randomly crash hard, freezing the display, the mouse and the keyboard. ctrl+alt+backspace does not work.

I can ssh into the machin from a different system. There is nothing in dmesg, however in the X log, I have:

Code:

(EE) [mi] EQ overflowing.  Additional events will be discarded until existing events are processed.
(EE)
(EE) Backtrace:
(EE) 0: /usr/bin/X (xorg_backtrace+0x48) [0x5848b8]
(EE) 1: /usr/bin/X (mieqEnqueue+0x22b) [0x56675b]
(EE) 2: /usr/bin/X (QueuePointerEvents+0x52) [0x44ce72]
(EE) 3: /usr/lib64/xorg/modules/input/evdev_drv.so (0x7f80bcfb2000+0x5e37) [0x7f80bcfb7e37]
(EE) 4: /usr/lib64/xorg/modules/input/evdev_drv.so (0x7f80bcfb2000+0x6525) [0x7f80bcfb8525]
(EE) 5: /usr/bin/X (0x400000+0x72e78) [0x472e78]
(EE) 6: /usr/bin/X (0x400000+0x9be6a) [0x49be6a]
(EE) 7: /lib64/libc.so.6 (0x7f80c36aa000+0x34ef0) [0x7f80c36deef0]
(EE) 8: /lib64/libc.so.6 (nanosleep+0x10) [0x7f80c3763310]
(EE) 9: /lib64/libc.so.6 (usleep+0x34) [0x7f80c378ac54]
(EE) 10: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f80be082000+0x55682f) [0x7f80be5d882f]
(EE) 11: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f80be082000+0x556a42) [0x7f80be5d8a42]
(EE) 12: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f80be082000+0x55d3f8) [0x7f80be5df3f8]
(EE) 13: /usr/bin/X (_CallCallbacks+0x34) [0x43b244]
(EE) 14: /usr/bin/X (0x400000+0x318c6) [0x4318c6]
(EE) 15: /usr/bin/X (0x400000+0x3618e) [0x43618e]
(EE) 16: /usr/bin/X (0x400000+0x39f8a) [0x439f8a]
(EE) 17: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x7f80c36cbaa5]
(EE) 18: /usr/bin/X (0x400000+0x256de) [0x4256de]
(EE)
(EE) [mi] These backtraces from mieqEnqueue may point to a culprit higher up the stack.
(EE) [mi] mieq is *NOT* the cause.  It is a victim.
(EE) [mi] EQ overflow continuing.  100 events have been dropped.
(EE)
(EE) Backtrace:
(EE) 0: /usr/bin/X (xorg_backtrace+0x48) [0x5848b8]
(EE) 1: /usr/bin/X (QueuePointerEvents+0x52) [0x44ce72]
(EE) 2: /usr/lib64/xorg/modules/input/evdev_drv.so (0x7f80bcfb2000+0x5e37) [0x7f80bcfb7e37]
(EE) 3: /usr/lib64/xorg/modules/input/evdev_drv.so (0x7f80bcfb2000+0x6525) [0x7f80bcfb8525]
(EE) 4: /usr/bin/X (0x400000+0x72e78) [0x472e78]
(EE) 5: /usr/bin/X (0x400000+0x9be6a) [0x49be6a]
(EE) 6: /lib64/libc.so.6 (0x7f80c36aa000+0x34ef0) [0x7f80c36deef0]
(EE) 7: /lib64/libc.so.6 (nanosleep+0x10) [0x7f80c3763310]
(EE) 8: /lib64/libc.so.6 (usleep+0x34) [0x7f80c378ac54]
(EE) 9: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f80be082000+0x5568b6) [0x7f80be5d88b6]
(EE) 10: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f80be082000+0x556a42) [0x7f80be5d8a42]
(EE) 11: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f80be082000+0x55d3f8) [0x7f80be5df3f8]
(EE) 12: /usr/bin/X (_CallCallbacks+0x34) [0x43b244]
(EE) 13: /usr/bin/X (0x400000+0x318c6) [0x4318c6]
(EE) 14: /usr/bin/X (0x400000+0x3618e) [0x43618e]
(EE) 15: /usr/bin/X (0x400000+0x39f8a) [0x439f8a]
(EE) 16: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x7f80c36cbaa5]
(EE) 17: /usr/bin/X (0x400000+0x256de) [0x4256de]
(EE)
(EE) [mi] EQ overflow continuing.  200 events have been dropped.
(EE)
(EE) Backtrace:
(EE) 0: /usr/bin/X (xorg_backtrace+0x48) [0x5848b8]
(EE) 1: /usr/bin/X (QueuePointerEvents+0x52) [0x44ce72]
(EE) 2: /usr/lib64/xorg/modules/input/evdev_drv.so (0x7f80bcfb2000+0x5e37) [0x7f80bcfb7e37]
(EE) 3: /usr/lib64/xorg/modules/input/evdev_drv.so (0x7f80bcfb2000+0x6525) [0x7f80bcfb8525]
(EE) 4: /usr/bin/X (0x400000+0x72e78) [0x472e78]
(EE) 5: /usr/bin/X (0x400000+0x9be6a) [0x49be6a]
(EE) 6: /lib64/libc.so.6 (0x7f80c36aa000+0x34ef0) [0x7f80c36deef0]
(EE) 7: /lib64/libc.so.6 (nanosleep+0x10) [0x7f80c3763310]
(EE) 8: /lib64/libc.so.6 (usleep+0x34) [0x7f80c378ac54]
(EE) 9: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f80be082000+0x55682f) [0x7f80be5d882f]
(EE) 10: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f80be082000+0x556a42) [0x7f80be5d8a42]
(EE) 11: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f80be082000+0x55d3f8) [0x7f80be5df3f8]
(EE) 12: /usr/bin/X (_CallCallbacks+0x34) [0x43b244]
(EE) 13: /usr/bin/X (0x400000+0x318c6) [0x4318c6]
(EE) 14: /usr/bin/X (0x400000+0x3618e) [0x43618e]
(EE) 15: /usr/bin/X (0x400000+0x39f8a) [0x439f8a]
(EE) 16: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x7f80c36cbaa5]
(EE) 17: /usr/bin/X (0x400000+0x256de) [0x4256de]
(EE)
[107082.594] nvLock: client timed out, taking the lock
[107086.594] [mi] Increasing EQ size to 1024 to prevent dropped events.
[107086.595] [mi] EQ processing has resumed after 219 dropped events.
[107086.595] [mi] This may be caused my a misbehaving driver monopolizing the server's resources.


The same happens with nouveau as well, however, I don't have an X log of that, but the type of crash is exactly the same.

I don't have any consistent way to reproduce the crash, it most frequently will happen when starting video playback with mplayer, using VDPAU, however, it also happens when the screensaver has been running for some time.

I've checked memtest86, CPU stress tests and GPU stress tests (playing games). There is nothing wrong with the system. It seems VDPAU or something even more generic in the driver is badly broken, something which affects both drivers.

I've had this issue for a year or so, I do frequent updates, I've switched between nvidia and nouveau multiple times, it doesn't help at all, and the issue has never gone away with a kernel update or world update.
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Mon Aug 24, 2015 8:33 pm    Post subject: Reply with quote

I did a quick google on this. Hardware conflict seems to be the most likely reason.
Back to top
View user's profile Send private message
deltamalloc
Apprentice
Apprentice


Joined: 18 Jan 2013
Posts: 279

PostPosted: Mon Aug 24, 2015 8:56 pm    Post subject: Reply with quote

Buffoon wrote:
I did a quick google on this. Hardware conflict seems to be the most likely reason.


There is some really old stuff about this from two years ago, I hope this is still not a bug that has never been fixed.
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Mon Aug 24, 2015 9:03 pm    Post subject: Reply with quote

Hardware conflict and software bug are completely different things.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43178
Location: 56N 3W

PostPosted: Mon Aug 24, 2015 9:23 pm    Post subject: Reply with quote

deltamalloc,

Check that the graphics card power connectors are fitted properly and are not blackened and charred.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
deltamalloc
Apprentice
Apprentice


Joined: 18 Jan 2013
Posts: 279

PostPosted: Tue Aug 25, 2015 12:05 am    Post subject: Reply with quote

NeddySeagoon wrote:
deltamalloc,

Check that the graphics card power connectors are fitted properly and are not blackened and charred.


I have removed it and reseated it recently, it has no extra power connector. It is a low-end card.
Back to top
View user's profile Send private message
deltamalloc
Apprentice
Apprentice


Joined: 18 Jan 2013
Posts: 279

PostPosted: Tue Aug 25, 2015 12:07 am    Post subject: Reply with quote

Buffoon wrote:
Hardware conflict and software bug are completely different things.


What exactly do you mean by "hardware conflict" and how did you arrive at that being the cause?
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Tue Aug 25, 2015 8:36 pm    Post subject: Reply with quote

Did you checked if there is a new firmware for your card?

MY gpu for example has the memory bars misaglined and no nvidia-driver worked until i patched every kernel. They later added something to the binary nvidia-drivers which solved the issue. But that issue was over 2 years after purchase.


Did you checked the net with the manufacturer and the tpye of your card if any other linux user in any other distribution has such issues?
Usually you find something in ubuntu / arch linux wherever and can get your card working here too.

Sometimes using unsable ~gentoo sources + ~nvidia-drivers can solve the issue too.
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1368
Location: Montréal

PostPosted: Wed Aug 26, 2015 12:00 am    Post subject: Reply with quote

I have been using successfully the Uvesafb framebuffer on the Linux kernel side with the proprietary Nvidia driver of Xorg. I have been able to use successfully the Nouveau framebuffer on the kernel side with the Nouveau Xorg module. To use Nouveau I had to use the branch 4 of the Linux kernel. My NVIDIA Corporation GK208 [GeForce GT 730] is not supported by the branch 3.

In your situation, I think a good practice is to not mixe Nouveau and Nvidia installations. Just use one at a time. Uninstall all packages from the previous driver and reemerge all the Xorg packages can help when you pass from one driver to the other because, Nouveau and Nvidia do not use the same libraries. If some trace of the previous driver stay, it can make Xorg crash.
_________________
Paul
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum