Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Audioengine D1 USB DAC fails with 4.0.5 update
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
gwr
Apprentice
Apprentice


Joined: 19 Nov 2014
Posts: 194

PostPosted: Tue Aug 25, 2015 5:01 pm    Post subject: Audioengine D1 USB DAC fails with 4.0.5 update Reply with quote

I have been happily using my Audioengine D1 USB DAC for a couple of years now, but a recent kernel upgrade has caused it to fail to be probed, and I get the following dmsg output:

Code:
[19203.114906] usb 7-1: new full-speed USB device number 6 using uhci_hcd
[19203.551440] usb 7-1: New USB device found, idVendor=2912, idProduct=30c8
[19203.551446] usb 7-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[19203.551449] usb 7-1: Product: Audioengine D1
[19203.563430] usb 7-1: 1:1: cannot get freq at ep 0x1
[19203.569428] usb 7-1: 1:2: cannot get freq at ep 0x1
[19203.575424] usbhid 7-1:1.2: can't add hid device: -75
[19203.575435] usbhid: probe of 7-1:1.2 failed with error -75
[19203.580422] usbhid 7-1:1.3: can't add hid device: -75
[19203.580431] usbhid: probe of 7-1:1.3 failed with error -75
[19203.832308] usb 7-1: 1:2: cannot get freq at ep 0x1
[19203.840301] usb 7-1: 1:2: cannot get freq at ep 0x1


To my knowledge, I have not changed anything in my kernel settings. lsusb shows a device, but it, too, fails to probe it:

Code:
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 005: ID 046d:c019 Logitech, Inc. Optical Tilt Wheel Mouse
Bus 007 Device 004: ID 04fe:0006 PFU, Ltd
Bus 007 Device 003: ID 04fe:0008 PFU, Ltd
Bus 007 Device 006: ID 2912:30c8
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 002: ID 051d:0002 American Power Conversion Uninterruptible Power Supply
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 004: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


Does anyone have any knowledge of a regression in the 4 series of kernel? I can't seem to find anything specific.

Thanks!
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2541
Location: Near Toronto

PostPosted: Wed Aug 26, 2015 11:14 am    Post subject: Reply with quote

I don't have any fixes, but for what it's worth, the d1 works in 4.1.6 ...

Can you compare the .config files for the new kernel vs. the old one?
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
gwr
Apprentice
Apprentice


Joined: 19 Nov 2014
Posts: 194

PostPosted: Thu Aug 27, 2015 3:14 pm    Post subject: Reply with quote

albright wrote:
I don't have any fixes, but for what it's worth, the d1 works in 4.1.6 ...

Can you compare the .config files for the new kernel vs. the old one?


Thanks! I just updated to 4.1.6 and it works fine again. :-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum