Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Dell XPS installation Grub/General Questions
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
tuxtop
n00b
n00b


Joined: 28 Aug 2015
Posts: 15

PostPosted: Fri Aug 28, 2015 11:24 pm    Post subject: Dell XPS installation Grub/General Questions Reply with quote

Hi Gentoo-Community :D

I've been working with some Linux Servers (mainly CentOS and SuSE) and especially with apache, ssh and so on..
My experience in Linux as Desktop OS isn't that huge tough. Over the time i've tested some graphical-installer distros (Ubuntu, Mint..) but just recently installed gentoo on a vm and found it to be the distro fitting my needs the most.

After some reading i decided to buy a new Dell XPS 13inch i7 to use it with gentoo.
After I have spent some hours trying to get Gentoo (or to be more specific the uefi-boot :() running I'm still not getting it to work.

I mainly used these two articles for my install efforts
https://wiki.gentoo.org/wiki/Handbook:AMD64/en
https://wiki.gentoo.org/wiki/Dell_XPS_13_9343

I hope to find answers to some of my questions here :)

In the manual there are modules for the Kernel whose names i don't find in the makeconf, or the names slightly changed.
Am I interpreting this correct, that the manuals refer to an older kernel version and therefore some names changed? Is there a way to track those changes?

The XPS page states that they only use broadcom hw. Lucky me I discovored that mine has been equiped with an intel-wlan. As far as i see this drivers are default and therefore it shouldn't be a problem? (and i can skip steps for the broadcom-drivers?)

And now UEFI-newbie questions:

I used parted and made those partitions
Device/Number - Start -End - Size - File system - Name - Flags
/dev/sda1 - 1049kB - 3146kB - 2097kB - fat32 - grub - bios_grub
/dev/sda2 - 3146kB - 137MB - 134MB - fat16 - boot - boot, esp
/dev/sda3 - 137MB - 1137MB - 999MB - linux-swap(v1) - swap -
/dev/sda4 - 1137MB - 256GB - 255GB - ext4 - rootfs -


Grub-installer claims that it doesn't find the efi-folder which is present in /boot/efi



Help is very appreciated (can't wait to use my new notebook :))
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum