Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't resume after hibernation
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
lex82
Apprentice
Apprentice


Joined: 04 Jan 2006
Posts: 241
Location: Italy

PostPosted: Sun Aug 30, 2015 6:30 am    Post subject: Can't resume after hibernation Reply with quote

Hi guys,
I am getting around an issue with pm-utils and I can't find a solution to my problem. Suspension to RAM (S3) does work flawlessy but suspension to DISK does not. It does suspend correctly but when I turn on the computer again linux shows me it's resuming ("found resume image", "resuming"...) but then the monitor shuts down and the machine is locked. I cannot even get access to it with SSH!

pm-suspend.log (after issuing "pm-hibernate" from root with XDM disabled)

Code:
Initial commandline parameters:
Blacklisting 01grub.
Blacklisting 90clock.
dom 30 ago 2015, 08.08.56, CEST: Running hooks for hibernate.
Running hook /usr/lib64/pm-utils/sleep.d/00logging hibernate hibernate:
Linux titanus 4.0.5-gentoo #1 SMP Thu Aug 27 10:07:09 CEST 2015 x86_64 AMD FX(tm)-6300 Six-Core Processor AuthenticAMD GNU/Linux
Module                  Size  Used by
uvcvideo               72425  0
videobuf2_vmalloc   4486  1 uvcvideo
videobuf2_memops        1767  1 videobuf2_vmalloc
videobuf2_core         34396  1 uvcvideo
             total    used       free     shared    buffers     cached
Mem:     16285044    1180988   15104056       1384    96236     738888
-/+ buffers/cache:     345864   15939180
Swap:     33554428          0   33554428
/usr/lib64/pm-utils/sleep.d/00logging hibernate hibernate: success.

Running hook /usr/lib64/pm-utils/sleep.d/00powersave hibernate hibernate:
Blacklisting 01grub.
Blacklisting 90clock.
/usr/lib64/pm-utils/sleep.d/00powersave hibernate hibernate: success.

Running hook /usr/lib64/pm-utils/sleep.d/01grub hibernate hibernate:
/usr/lib64/pm-utils/sleep.d/01grub hibernate hibernate: disabled.

Running hook /usr/lib64/pm-utils/sleep.d/50unload_alx hibernate hibernate:
/usr/lib64/pm-utils/sleep.d/50unload_alx hibernate hibernate: success.

Running hook /usr/lib64/pm-utils/sleep.d/75modules hibernate hibernate:
/usr/lib64/pm-utils/sleep.d/75modules hibernate hibernate: success.

Running hook /usr/lib64/pm-utils/sleep.d/90clock hibernate hibernate:
/usr/lib64/pm-utils/sleep.d/90clock hibernate hibernate: disabled.

Running hook /usr/lib64/pm-utils/sleep.d/94cpufreq hibernate hibernate:
/usr/lib64/pm-utils/sleep.d/94cpufreq hibernate hibernate: success.

Running hook /usr/lib64/pm-utils/sleep.d/95led hibernate hibernate:
/usr/lib64/pm-utils/sleep.d/95led hibernate hibernate: not applicable.

Running hook /usr/lib64/pm-utils/sleep.d/98video-quirk-db-handler hibernate hibernate:
Kernel modesetting video driver detected, not using quirks.
/usr/lib64/pm-utils/sleep.d/98video-quirk-db-handler hibernate hibernate: success.

Running hook /usr/lib64/pm-utils/sleep.d/99video hibernate hibernate:
/usr/lib64/pm-utils/sleep.d/99video hibernate hibernate: success.

dom 30 ago 2015, 08.08.57, CEST: performing hibernate


The worst thing is that I can't even get a resume log so I don't know where to look for a fix.

Here is my kernel configuration: http://pastebin.com/5jcXtSGG
_________________
Bye,
Axel.
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7073
Location: almost Mile High in the USA

PostPosted: Sun Aug 30, 2015 4:00 pm    Post subject: Reply with quote

Likely some bug in swsuspend, probably due to hardware. What video card do you have, and will it suspend if you're not in graphics mode or have the graphics drivers unloaded? Using closed source or OSS drivers?

Since you don't have an Intel machine, so probably not interaction with RapidStart...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
lex82
Apprentice
Apprentice


Joined: 04 Jan 2006
Posts: 241
Location: Italy

PostPosted: Sun Aug 30, 2015 5:06 pm    Post subject: Reply with quote

eccerr0r wrote:
Likely some bug in swsuspend, probably due to hardware. What video card do you have, and will it suspend if you're not in graphics mode or have the graphics drivers unloaded? Using closed source or OSS drivers?

Since you don't have an Intel machine, so probably not interaction with RapidStart...


This is my HW configuration:

Code:
ASUStek Sabertooth 990FX/R2.0
AMD FX-6350 Black Edition
Kingston KHX1600C9D3K4/16GX
Sapphhire AMD Radeon R9 280X UEFI edition
Kingston SSD Now! 300 (256GB)
2x Western Digital 2TB
1x Samsung 500GB


lspci:

Code:
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (external gfx0 port B) (rev 02)
00:00.2 IOMMU: Advanced Micro Devices, Inc. [AMD/ATI] RD990 I/O Memory Management Unit (IOMMU)
00:02.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (PCI express gpp port B)
00:04.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (PCI express gpp port D)
00:05.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (PCI express gpp port E)
00:09.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (PCI express gpp port H)
00:0a.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (external gfx1 port A)
00:0b.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (NB-SB link)
00:0d.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] RD890 PCI to PCI bridge (external gfx1 port B)
00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode] (rev 40)
00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller (rev 42)
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) (rev 40)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 LPC host controller (rev 40)
00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge (rev 40)
00:14.5 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
00:15.0 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB700/SB800/SB900 PCI to PCI bridge (PCIE port 0)
00:15.1 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB700/SB800/SB900 PCI to PCI bridge (PCIE port 1)
00:15.2 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB900 PCI to PCI bridge (PCIE port 2)
00:15.3 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB900 PCI to PCI bridge (PCIE port 3)
00:16.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:16.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 0
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 1
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 2
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 3
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 4
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h Processor Function 5
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti XT [Radeon HD 7970/8970 OEM / R9 280X]
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti XT HDMI Audio [Radeon HD 7970 Series]
02:00.0 SATA controller: ASMedia Technology Inc. ASM1062 Serial ATA Controller (rev 01)
03:00.0 SATA controller: ASMedia Technology Inc. ASM1062 Serial ATA Controller (rev 01)
04:00.0 USB controller: ASMedia Technology Inc. ASM1042A USB 3.0 Host Controller
0a:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 09)
0b:00.0 USB controller: ASMedia Technology Inc. ASM1042A USB 3.0 Host Controller
0c:00.0 USB controller: ASMedia Technology Inc. ASM1042A USB 3.0 Host Controller


I am using the radeon open-source driver (VIDEO_CARDS="radeon radeonsi"). I disabled the "Fast boot" option in the UEFI BIOS (I know it causes some compatibility problems with linux) and also "CSM" and "Safe boot" are disabled.
_________________
Bye,
Axel.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum