Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved mysteriously] Kernel don't compile
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
AleksandrSS
n00b
n00b


Joined: 17 Jul 2015
Posts: 6

PostPosted: Mon Aug 31, 2015 11:54 am    Post subject: [Solved mysteriously] Kernel don't compile Reply with quote

Hi everybody.

I'm in the installing of a server with hardened-sources. At this moment, I can't compile the kernel.
I tried with the 4.1.6-hardened. When make reach this line:

CHK include/generated/compile.h
I get this error:
usr/Makefile:64: *** target pattern contains no '%'. Stop.
make: *** [usr] Error 2

The only way I found to solve this problem is unmerge the source and reemerge. This is not a comfortable way to to the things and take a lot of time. So I tried the unstable version of the sources, 4.1.6-hardened-r1. I get exactly the same problem. I tried to clean with "make clean" and:

usr/Makefile:64: *** target pattern contains no '%'. Stop.
Makefile:1271:recipe for target '_clean_usr' failed
make: *** [_clean_usr] Error 2

I didn't found in google any way to solve this problem and work for me. Any help? Thanks


Last edited by AleksandrSS on Thu Sep 03, 2015 6:13 pm; edited 1 time in total
Back to top
View user's profile Send private message
Keruskerfuerst
Advocate
Advocate


Joined: 01 Feb 2006
Posts: 2288
Location: near Augsburg, Germany

PostPosted: Mon Aug 31, 2015 3:56 pm    Post subject: Reply with quote

Seems to be a kernel bug.
Submit a report.
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Mon Aug 31, 2015 4:02 pm    Post subject: Reply with quote

You can use "make mrproper" to remove everything including the kernel .config.

In case the files in your kernel tree were maybe corrupted, use "equery check gentoo-sources" to find out which (if any) were modified since installing the package.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7071

PostPosted: Mon Aug 31, 2015 4:17 pm    Post subject: Re: Kernel don't compile Reply with quote

AleksandrSS wrote:
usr/Makefile:64: *** target pattern contains no '%'. Stop.
make: *** [usr] Error 2


Sorry, nobody can help you because nobody could know your problem as you didn't gave the error.

It's easy:
- Error 1 : cannot build the car
- Error 2 : cannot use the car

Knowing you cannot use the car is not of any help, you cannot use the car because you cannot build the car, what is important is "why i cannot build the car" : and the answer to this is just next to Error1.

Use pastebin or other similar website to gave the full log. Or copy/paste here 5-10 lines upto when you see Error 1 (some | grep -B10 "Error 1")
Back to top
View user's profile Send private message
Keruskerfuerst
Advocate
Advocate


Joined: 01 Feb 2006
Posts: 2288
Location: near Augsburg, Germany

PostPosted: Mon Aug 31, 2015 4:28 pm    Post subject: Reply with quote

No, it´s not:
1. can´t build the car
2. can´t use the car

It´s:
1. can´t build Gentoo
2. can´t use the computer

I think it´s clear now.
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3690
Location: Hamburg

PostPosted: Mon Aug 31, 2015 5:00 pm    Post subject: Reply with quote

what does
Code:
make mrproper; make defconfig; make
give ?
Back to top
View user's profile Send private message
cwr
Veteran
Veteran


Joined: 17 Dec 2005
Posts: 1969

PostPosted: Tue Sep 01, 2015 4:28 pm    Post subject: Reply with quote

What are the contents of line 64 of the Makefile giving the error?

Will
Back to top
View user's profile Send private message
AleksandrSS
n00b
n00b


Joined: 17 Jul 2015
Posts: 6

PostPosted: Thu Sep 03, 2015 4:19 pm    Post subject: Reply with quote

I return today to my house, installed 2 additional GB (I don't think this is related but is the only change I did) and try again to compile... and work fine.
No idea what happened, but thanks everybody.
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3690
Location: Hamburg

PostPosted: Thu Sep 03, 2015 4:55 pm    Post subject: Reply with quote

AleksandrSS wrote:
installed 2 additional GB (I don't think this is related but is the only change I did)
Did you run make with "-jX" with X>1 ?
Back to top
View user's profile Send private message
AleksandrSS
n00b
n00b


Joined: 17 Jul 2015
Posts: 6

PostPosted: Thu Sep 03, 2015 5:03 pm    Post subject: Reply with quote

toralf wrote:
Did you run make with "-jX" with X>1 ?


I tried with make -j2 (my usual make), make -j1 and make, any of them worked. And computer had 1 GB of RAM and 2GB of SWAP (Now it has 3GB of RAM and 2GB of SWAP)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum