Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[für mich gelöst] Kodi und PVR.
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Fri Sep 11, 2015 8:55 pm    Post subject: Reply with quote

Dafür würde mal deine kodi log datei helfen.
Vielleicht hilft es auch xbmc-addon-pvr zu deinstallieren? Das aber nur als schuß ins blaue...
Back to top
View user's profile Send private message
Amarok
n00b
n00b


Joined: 11 Nov 2003
Posts: 70

PostPosted: Fri Sep 11, 2015 9:20 pm    Post subject: Reply with quote

So alle nochmal neu und immer wieder das selbe. Werde morgen nochmals genau im log suchen.
Habe alles weg (emerge -C) und per Hand dann die restlichen Ordner (.kodi / /usr/share/kodi) entfernt.

auch vor dem aktivieres des plugins den m3u pfad eingefügt um da nen fehler auszuschliessen.

Warte nun noch auf ein Okay von Euch das es beu euch geklappt hat das ich weiss das der fehler hier bei mir irgendwo klappt.

Install klappt ja so weit nur nicht das aktivieren (und verwenden)
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Fri Sep 11, 2015 9:29 pm    Post subject: Reply with quote

Also zum einen, erst mal ganz großen Dank für die Anleitung, es hat alles prima geklappt.
Dann zum anderen, Kodi sagte, es kann nicht geladen oder aktiviert werden oder so etwas.
Und dann: Leckt mich doch einfach am Arsch. Wenn ihr euren Klump von Version zu Version schlechter machen wollt, dann steht euch das frei. Ich werde euch da keine Steine in den Weg legen.

emerge -C kodi und ich habe in dieser Beziehung keine Probleme mehr.

In diesem Sinne: Prost. Wenn irgendwelche Individuen glauben, man krault ihnen die Eier, nur weil es da irgendwas mit Open Source ist, dann liegen die bei mir falsch. Xbmc fand ich mal richtig gut. Erbärmlich was daraus geworden ist.
Back to top
View user's profile Send private message
Amarok
n00b
n00b


Joined: 11 Nov 2003
Posts: 70

PostPosted: Fri Sep 11, 2015 9:45 pm    Post subject: Reply with quote

@Klaus Meier

Kann deinen Frust verstehen. Mach das auch nur auf nen weitern NB den auf meine Arbeitstier läuft 14.1 weiter. da gehts ja.

Andererseits finde ich auch gerne die Lösungen. Und vielleicht kanns ja ein anderer wenn wir selbst nicht dahinter kommen.

Aufgefallen ist im log der Eintrag "PVMRmanager destroyed" . Das dürfte kommen nachdem ich das ADDON aktiviert habe und kodi beende um neu zu starten. Und ich hab den Verdacht da können wir an der Lösung nichts machen den das liegt gleube ich an Kodi selbst.
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Sat Sep 12, 2015 8:47 am    Post subject: Reply with quote

Klaus:
Ich mag Deine emotionale Ausgeglichenheit. :)

Zu Kodi:
Bei mir funktioniert jetzt seit neuesten das EPG nicht mehr. Im kodi.log tauchen permanent irgendwelche Datenbankfehler auf. Ich bin jetzt dabei MariaDB als Backend flott zu kriegen. Vielleicht bringt das ein paar Verbesserungen.

Zur Kodi-Qualität:
Es stimmt schon, dass das Ding relativ fragil ist. Und die Priorität liegt vermutlich auch nicht auf Linux. Das Ding gibt's schließlich für Mac, Windows, Android.

Momentan seh ich 2 größere Probleme:
  1. Die Add-On-Sources werden nicht zeitnah aktualisiert. Obwohl Kodi-15.1 jetzt als Stable deklariert wurde, läuft das Hauptrepository der xbmc-addon-pvr-Sourcen noch immer auf Helix. Und auch im Master ist die XBMC_API-Version noch immer auf 1.9.4. Kodi-15.1 verlangt die 1.9.6. Genau aus diesem Grund deaktiviert sich das Add-On beim Aufruf in Kodi. Zuständig sind 2 Personen für die PVR-Addons, soweit ich das bisher mitbekommen hab: Fernet Menta und Opdenkamp.
  2. Es fehlt irgendwie ein vernünftiges Overlay. Ein paar Sachen stehen in vdr-devel. Aber selbst dort fehlen viele VDR-Sachen. Dann hatte ich mal noch irgendein Multimedia-Overlay. Alles halbgare Sachen.


Ich hab gestern mal die Brecheisen-Methode versucht und einfach aus dem Autoconf-File alles rauszuschmeißen, was ich nicht brauch. Aber vermutlich hab ich da etwas zuviel gelöscht. Jedenfalls schlug das Bauen dann schon in der Configure-Phase fehl. Werd das heut noch mal etwas testen.
Back to top
View user's profile Send private message
Amarok
n00b
n00b


Joined: 11 Nov 2003
Posts: 70

PostPosted: Sat Sep 12, 2015 10:59 am    Post subject: Reply with quote

Das ist mal beruhigend. Es deaktiviert sich also tatsächlich bei Euch auch.

Ich für meinen Teil werde es auch vorerst auf 14.1 weiter laufen lassen und warten bis es besser wird.

Ich ja nur ärgerlich weil auf allen Androiden (aftv , tablets und RPIs ) dann schon 15.1 rennt und Gentoo plagt sich mit 14.1 herum.

Andersrum wuerd ich es vermutlich noch weniger moegen aber diese halben Sachen stoeren dann schon mal.
Back to top
View user's profile Send private message
frostwork
n00b
n00b


Joined: 11 Dec 2006
Posts: 64

PostPosted: Sun Sep 13, 2015 6:39 am    Post subject: Reply with quote

moin leuts,
ich benutze seit ewigkeiten die ebuilds aus dem recht schwer zu findenden
https://github.com/herrnst/gentoo-kodi-overlay
kodi-pvr-vdr-vnsi-9999 funzt zb ziemlich problemlos mit kodi-9999
("ziemlich" im sinne von segfault beim kodi schliessen, aber sonst alles gut).
falls ich noch irgendwie helfen kann, gerne im irc - bin hier eigentlich nie :}
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Sun Sep 13, 2015 9:24 am    Post subject: Reply with quote

Hmm, ich krieg's nicht mal compiliert:

kodi-pvr-vdr-vnsi-9999:
[ 75%] Building CXX object CMakeFiles/pvr.vdr.vnsi.dir/src/VNSIDemux.cpp.o
/usr/bin/x86_64-pc-linux-gnu-g++  -DBUILD_KODI_ADDON -DHAVE_GL -DTARGET_LINUX -DTARGET_POSIX -DUSE_DEMUX -D_LINUX -Dpvr_vdr_vnsi_EXPORTS  -DNDEBUG -march=atom -mcx16 -msahf -mmovbe -mno-aes -mno-pclmul -mno-popcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-bmi2 -mno-tbm -mno-avx -mno-avx2 -mno-sse4.2 -mno-sse4.1 -mno-lzcnt -mno-rtm -mno-hle -mno-rdrnd -mno-f16c -mno-fsgsbase -mno-rdseed -mno-prfchw -mno-adx -mfxsr -mno-xsave -mno-xsaveopt --param l1-cache-size=24 --param l1-cache-line-size=64 --param l2-cache-size=512 -mtune=atom -fstack-protector -std=gnu++11 -fPIC -I/usr/include/kodi -I/usr/include/platform    -o CMakeFiles/pvr.vdr.vnsi.dir/src/VNSIDemux.cpp.o -c /var/tmp/portage/media-plugins/kodi-pvr-vdr-vnsi-9999/work/kodi-pvr-vdr-vnsi-9999/src/VNSIDemux.cpp
CMakeFiles/pvr.vdr.vnsi.dir/build.make:62: recipe for target 'CMakeFiles/pvr.vdr.vnsi.dir/src/client.cpp.o' failed
make[2]: *** [CMakeFiles/pvr.vdr.vnsi.dir/src/client.cpp.o] Error 1
make[2]: *** Waiting for unfinished jobs....
/var/tmp/portage/media-plugins/kodi-pvr-vdr-vnsi-9999/work/kodi-pvr-vdr-vnsi-9999/src/VNSIData.cpp: In member function ‘PVR_ERROR cVNSIData::GetTimerInfo(unsigned int, PVR_TIMER&)’:
/var/tmp/portage/media-plugins/kodi-pvr-vdr-vnsi-9999/work/kodi-pvr-vdr-vnsi-9999/src/VNSIData.cpp:413:7: error: ‘PVR_TIMER’ has no member named ‘iTimerType’
   tag.iTimerType = PVR_TIMER_TYPE_NONE;
       ^
/var/tmp/portage/media-plugins/kodi-pvr-vdr-vnsi-9999/work/kodi-pvr-vdr-vnsi-9999/src/VNSIData.cpp:413:20: error: ‘PVR_TIMER_TYPE_NONE’ was not declared in this scope
   tag.iTimerType = PVR_TIMER_TYPE_NONE;
                    ^
/var/tmp/portage/media-plugins/kodi-pvr-vdr-vnsi-9999/work/kodi-pvr-vdr-vnsi-9999/src/VNSIData.cpp: In member function ‘bool cVNSIData::GetTimersList(ADDON_HANDLE)’:
/var/tmp/portage/media-plugins/kodi-pvr-vdr-vnsi-9999/work/kodi-pvr-vdr-vnsi-9999/src/VNSIData.cpp:467:11: error: ‘PVR_TIMER’ has no member named ‘iTimerType’
       tag.iTimerType = PVR_TIMER_TYPE_NONE;
           ^
/var/tmp/portage/media-plugins/kodi-pvr-vdr-vnsi-9999/work/kodi-pvr-vdr-vnsi-9999/src/VNSIData.cpp:467:24: error: ‘PVR_TIMER_TYPE_NONE’ was not declared in this scope
       tag.iTimerType = PVR_TIMER_TYPE_NONE;
                        ^
/var/tmp/portage/media-plugins/kodi-pvr-vdr-vnsi-9999/work/kodi-pvr-vdr-vnsi-9999/src/VNSIData.cpp: In member function ‘PVR_ERROR cVNSIData::AddTimer(const PVR_TIMER&)’:
/var/tmp/portage/media-plugins/kodi-pvr-vdr-vnsi-9999/work/kodi-pvr-vdr-vnsi-9999/src/VNSIData.cpp:554:43: error: ‘PVR_WEEKDAY_NONE’ was not declared in this scope
   if (!vrp.add_U32(timerinfo.iWeekdays != PVR_WEEKDAY_NONE ? timerinfo.firstDay : 0))   return PVR_ERROR_UNKNOWN;
                                           ^
/var/tmp/portage/media-plugins/kodi-pvr-vdr-vnsi-9999/work/kodi-pvr-vdr-vnsi-9999/src/VNSIData.cpp: In member function ‘PVR_ERROR cVNSIData::UpdateTimer(const PVR_TIMER&)’:
/var/tmp/portage/media-plugins/kodi-pvr-vdr-vnsi-9999/work/kodi-pvr-vdr-vnsi-9999/src/VNSIData.cpp:637:43: error: ‘PVR_WEEKDAY_NONE’ was not declared in this scope
   if (!vrp.add_U32(timerinfo.iWeekdays != PVR_WEEKDAY_NONE ? timerinfo.firstDay : 0))   return PVR_ERROR_UNKNOWN;
                                           ^
CMakeFiles/pvr.vdr.vnsi.dir/build.make:230: recipe for target 'CMakeFiles/pvr.vdr.vnsi.dir/src/VNSIData.cpp.o' failed
make[2]: *** [CMakeFiles/pvr.vdr.vnsi.dir/src/VNSIData.cpp.o] Error 1
make[2]: Leaving directory '/var/tmp/portage/media-plugins/kodi-pvr-vdr-vnsi-9999/work/kodi-pvr-vdr-vnsi-9999_build'
CMakeFiles/Makefile2:99: recipe for target 'CMakeFiles/pvr.vdr.vnsi.dir/all' failed
make[1]: *** [CMakeFiles/pvr.vdr.vnsi.dir/all] Error 2
make[1]: Leaving directory '/var/tmp/portage/media-plugins/kodi-pvr-vdr-vnsi-9999/work/kodi-pvr-vdr-vnsi-9999_build'
Makefile:149: recipe for target 'all' failed
make: *** [all] Error 2


Ich bin jetzt kurz davor, wieder zurück zur 14.2 zu gehen.
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Sun Sep 13, 2015 10:26 am    Post subject: Reply with quote

Also ich frage mich ständig, was das alles soll. Genau das war es ja auch, was mir Gnome vergrault hat. So auf den ersten Blick hat sich nichts getan. Und wenn, dann ist es eine Verschlechterung. Aber Hauptsache, alles ist inkompatibel. So wie bei Gnome die Themes und Extensions.

Gab es einen triftigen Grund, die Schnittstelle zu den Plugins so zu ändern, dass nun gar nichts mehr funktioniert? Und auch nach Wochen nicht zum Laufen gebracht wird?

Natürlich habe ich keinen Anspruch auf irgend etwas, aber ich will einfach nicht verstehen, warum manche Menschen Zeit und Energie verschwenden, um etwas zu verschlechtern. Gnome als leuchtendes Beispiel. Zum Glück ist Microsoft ja auf dem gleichen Trip. Ich habe in den letzten Wochen ernsthaft über einen Wechsel zu Windows nachgedacht. Aber die Idiotisierung der Software findet auch dort statt.
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Sun Sep 13, 2015 12:56 pm    Post subject: Reply with quote

@klaus: wenn man nicht direkt in der Entwicklung eines solchen Projekts beteiligt ist, sind solche Aussagen immer sehr einfach zu treffen. "Es funktioniert ja alles, also machen wir nix" => es gibt u.U. keine neuen Features. Ich vermute mal, dass sich die Entwickler schon gedanken gemacht haben, und die pluginAPI nicht mal so zum Spaß geändert haben, sondern weil sie etwas neues machen wollten.

@musv: probier mal
Code:
EGIT_BRANCH="Isengard" emerge <dein kodi plugin>


Ich habs noch nicht probiert, aber bei meinen ebuild war das auch. In den ebuilds aus diesem overlay steht als branch "Master" und der ist wohl nicht mit kodi-15.1 kompatibel. Der Isengard branch sollte aber gehen.
Das liegt an den ebuilds, und nicht an kodi, dass das nicht geht
Back to top
View user's profile Send private message
Amarok
n00b
n00b


Joined: 11 Nov 2003
Posts: 70

PostPosted: Sun Sep 13, 2015 6:37 pm    Post subject: Reply with quote

@frostwork

Danke so klappt das nun bei mir.

Nachdem ich nun mit Overlay alle hinbekommen habe das auch die 9999 er alle richtig installiert werden, klappt nun endlich alles


hab nun emerge kodi-pvr-iptvsimple installiert
wobei kodi-9999 und kodiplatform installiert wurde.
habe zuvor einige restdatein per hand gelöscht.

dann lief alles sauber durch

erster versuch iptv zu starten ohne konfig endete wieder mit disable vom plugin
eingabe der daten und nun rennt es soweit. epg mach ich dann spaeter da ich noch keinen sync habe.


also mal danke und nun echt ERLEDIGT
Back to top
View user's profile Send private message
Amarok
n00b
n00b


Joined: 11 Nov 2003
Posts: 70

PostPosted: Sun Sep 13, 2015 6:47 pm    Post subject: Reply with quote

aja ist nun die 16 alpha 3 von heute die hier läuft mit iptv-simple

Ach ja: @bluray das USE FLAG musste ich entfernen (-bluray) da da libs fehlten. Ich hab mir dann die Sucherei erstart und habs mal ausgeschalten.
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Mon Sep 14, 2015 4:30 pm    Post subject: Reply with quote

Mal 'ne weitere Rückmeldung:

1. Plan: Runterschmeißen der 15.1 mit Downgrade auf 14.2.
Hat nicht geklappt. Die 14.2 hat sich aus unerfindlichen Gründen nicht mehr compilieren lassen.

2. Idee: Kodi 15.1 mit den xbmc-addon-Geschichten und manueller Änderung der XBMC_PVR_API-Version von 1.9.4 auf 1.9.6
Ebenfalls fehlgeschlagen. VNSI hatte dabei die höchste Priorität.

3. Idee: Kodi-9999 (Isengard-Branch) aka Kodi-15.2-rc
Hat erstaunlicherweise geklappt. Aus dem Gentoo-Kodi-Overlay hab ich dann vom Masterbranch die Kodiplatform und Kodi-pvr-vdr-vnsi und Kodi-pvr-vdr-xvdr compiliert bekommen. Hat insofern den Seiteneffekt, dass ich die ganzen nicht benötigten PVR-Addons nicht mitcompilieren muss. Das kostet auf meinem HTPC 'ne Menge Zeit.

Bei XVDR hatte ich den Effekt, den ich in den letzten Tagen schon beobachtet hatte. Seit dem letzten Systemupdate klappte das EPG mit XVDR nicht mehr. Im VDR ging das noch wunderbar, aber Kodi weigerte sich wehement, das EPG zu verarbeiten.
kodi.log:
17:27:31 T:140596123514624   ERROR: SQL: Abort due to constraint violation
                                            Query: INSERT INTO channels (iUnique
Id, bIsRadio, bIsHidden, bIsUserSetIcon, bIsUserSetName, bIsLocked, sIconPath, s
ChannelName, bIsVirtual, bEPGEnabled, sEPGScraper, iLastWatched, iClientId, idEp
g) VALUES (40046423, 0, 0, 0, 0, 0, '/home/xbmc/senderlogos/n-joy.png', 'N-JOY',
 0, 1, 'client', 0, 762, 55)


VNSI funktioniert jetzt relativ stabil. Zwar sind die Umschaltzeiten länger als bei XVDR. Und auch gehen manche Pay-TV-Sender fast nicht mehr, z.B. ORF III HD (funktionierte mit XVDR mehr schlecht als recht). Aber dafür klappt Disney Junior HD, was den Hausfrieden mit dem Nachwuchs sichert.

Ach ja, IPTVSimple hab ich nicht compiliert bekommen. Das scheint wohl wirklich die 16.x zu benötigen. Aber gut, das wäre bei mir eh nur zum Probieren gewesen. Mit DSL 6000 will man kein IP-TV von HD-Sendern.

Fazit:
Derzeit funktionierende Kombination für Kodi mit Sat-TV - Kodi-15.2-rc (Portage) + VSNI-Addon (Gentoo-Kodi-Overlay):
Code:
EGIT_BRANCH="Isengard" USE="texturepacker" emerge kodi-9999
emerge kodi-pvr-vdr-vnsi
Back to top
View user's profile Send private message
Tyler_Durden
Apprentice
Apprentice


Joined: 27 Jul 2004
Posts: 189
Location: Germany

PostPosted: Mon Sep 14, 2015 6:32 pm    Post subject: Reply with quote

frostwork wrote:
moin leuts,
ich benutze seit ewigkeiten die ebuilds aus dem recht schwer zu findenden
https://github.com/herrnst/gentoo-kodi-overlay
kodi-pvr-vdr-vnsi-9999 funzt zb ziemlich problemlos mit kodi-9999
("ziemlich" im sinne von segfault beim kodi schliessen, aber sonst alles gut).
falls ich noch irgendwie helfen kann, gerne im irc - bin hier eigentlich nie :}


Das Overlay lässt sich übrigens so hinzufügen:
Code:
layman -o https://raw.github.com/herrnst/gentoo-kodi-overlay/master/overlay.xml -f -a gentoo-kodi-overlay

_________________
Gentoo 17.1 x86_64
Intel Core i7-6700K
Asus MAXIMUS VIII HERO
Asus Geforce GTX1080 Ti
Asus STRIX RAID DLX
32GB DDR4
Samsung SSD SM951-NVMe 256GB
8x Seagate Archive (SATA-RAID 64TB)
Digital Devices Cine S2 V6.5 DVB Adapter
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Mon Sep 14, 2015 7:32 pm    Post subject: Reply with quote

Hmm, ok. ich hab's jetzt nicht über layman gelöst sondern einfach so eingebunden:

Code:
cd /usr/portage/local/
git clone git://github.com/herrnst/gentoo-kodi-overlay


Und dann noch in die repos eingetragen:
/etc/portage/repos.conf/git.conf:
[gentoo-kodi-overlay]
priority = 50
location = /usr/portage/local/gentoo-kodi-overlay
sync-type = git
sync-uri = git://github.com/herrnst/gentoo-kodi-overlay
auto-sync = Yes


Damit geht's auch und wird auch aktualisiert bei emerge --sync
Back to top
View user's profile Send private message
d-fens
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jan 2004
Posts: 92

PostPosted: Tue Dec 08, 2015 11:54 pm    Post subject: Reply with quote

hi,

musste meine box neu aufsetzen und jetzt kodi 15.2 mit dem integrierten vnsi addon gibt folgenden Fehler
Code:
ERROR: PVR - Add-on 'VDR VNSI Client' is using an incompatible API version. XBMC minimum API version = '1.9.6', add-on API version '1.9.4'


das emergen von media-libs/kodiplatform-9999::gentoo-kodi-overlay steigt aber mit
Code:
By not providing "Findplatform.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "platform",
  but CMake did not find one.

  Could not find a package configuration file provided by "platform" with any
  of the following names:

    platformConfig.cmake
    platform-config.cmake

aus, also kann ich nichtmal media-plugins/kodi-pvr-vdr-vnsi-9999 emergen.

HÜLFE!
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Wed Dec 09, 2015 6:42 am    Post subject: Reply with quote

Vergiss die 15.2. Hab die probiert und auch nicht zum Laufen gebracht.

Ich hab dann die 16.1. Beta genommen (Jarvis). Und komischerweise geht da alles. Kodi compiliert. Die Kodi-Plugins (jetzt einzeln) kodi-pvr-vdr-xvdr, kodi-pvr-vdr-vnsi, kodi-pvr-iptvsimple lassen sich compilieren. XVDR hab ich noch nicht getestet. VNSI und IPTVSimple funktionieren aber.

Bei mir ist jetzt noch ein einziges Problem übrig: Die Pay-TV-Sender funktionieren mit VNSI erst beim 2. Booten. Ich hab keine Ahnung, warum das so ist und wie ich das korrigieren kann. Ist der Rechner erst mal "warm", d.h. wurde an dem Tag schon benutzt, dann klappt auch das Pay TV ohne Probleme.

Bin mir jetzt nicht ganz sicher, da ich kein Gentoo hier hab. Aber ich glaub, ich hab das Overlay für die Plugins verwendet. Und meine installierte Kodi-Version sollte das Ebuild kodi-9999 aus dem Portage sein.
Back to top
View user's profile Send private message
d-fens
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jan 2004
Posts: 92

PostPosted: Wed Dec 09, 2015 9:42 am    Post subject: Reply with quote

Ich habe versucht alles als 9999 zu installieren:

kodi selber geht, auch dev-libs/libplatform-9999 (pulse8) funktioniert.

Dann fehlen noch
Code:

[ebuild  N    ~] media-libs/kodiplatform-9999
[ebuild  N    ~] media-plugins/kodi-pvr-vdr-vnsi-9999
aus dem overlay, aber die kodiplatform bricht ab mit der oben genannten Fehlermeldung. Funktioniert kodiplatform-9999 denn für jemanden bzw wie fixe ich die cmake Fehler?


---
Edith sagt:

das libplatform-9999 ebuild legt die Files unter /usr/include/p8-platform/ ab, das 1.0.10 er ebuild korrekt unter /usr/include/platform/, dann gehts auch mit dem kompilieren :!:
Back to top
View user's profile Send private message
frostwork
n00b
n00b


Joined: 11 Dec 2006
Posts: 64

PostPosted: Wed Dec 09, 2015 6:12 pm    Post subject: Reply with quote

hi, hab mal was zusammengehackt:
https://github.com/kodi-pvr/pvr.vdr.vnsi/pull/43

solange das nicht in irgendeiner form im upstream landet (kann man sicher schöner machen :))
kann man auch wüst
die datei
/etc/portage/env/media-plugins/kodi-pvr-vdr-vnsi
mit folgendem einzeiler anlegen:
EGIT_REPO_URI="https://github.com/frostworx/pvr.vdr.vnsi.git"

baut brav durch hier und funktioniert so wie's aussieht :}
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Fri Dec 11, 2015 3:02 pm    Post subject: Reply with quote

d-fens:

Ich hab gestern Abend mal Kodi aktualisiert, d.h. von 16.0 beta1 auf 16.0 beta3. Dadurch musste ich auch die PVR-Addons gegen die neue Version bauen, d.h.
  • kodiplatform
  • kodi-pvr-vdr-vnsi
  • kodi-pvr-vdr-xvdr
  • kodi-pvr-iptvsimple


Compiliert alles problemlos durch und funktioniert. Alle Pakete inkl. Kodi hab ich aus dem Overlay genommen.

Update:
Ich muss meine Aussage revidieren. XVDR lässt sich in Kodi aktivieren, bringt aber 'ne Fehlermeldung beim Start, dass es nicht benutzt werden kann. Und bei VNSI sind Bild und Ton auf einmal asynchron. Das Bild hängt ca. 2 Sekunden hinterher.

Zum Vergleich hab ich VDR über Xineliboutput ausgeben lassen. Damit ist alles synchron.

Update 2:
Muss meine Revision wieder revidieren. Installiert hatte ich kodi-9999, was dann auch ordnungsgemäßig den Master-Branch klonte und mir schnurstracks die 17.0 alpha auf die Platte bügelte. Ich hab dann im Ebuild explizit den Jarvis-Branch angegeben, der mich dann zur 16.0 beta 4 brachte. Aber sowohl bei der 16.0 beta als auch bei der 17.0 ließen sich die o.g. Pakete ohne probleme compilieren. Und mit der 16.0 beta 4 funktioniert auch alles wieder wie gewohnt.
Back to top
View user's profile Send private message
tava
n00b
n00b


Joined: 15 Nov 2005
Posts: 16

PostPosted: Mon Dec 14, 2015 9:14 pm    Post subject: My working configuration Reply with quote

I will use this thread to summarize my experience and write down my working configuration. Maybe I can help someone.

XVDR: Just for information
The development of the XVDR add-on for Kodi is on-hold / was stopped. https://github.com/pipelka/vdr-plugin-xvdr/issues/131#issuecomment-164306481

My working configuration
  • VDR: Standard vdr version from the gentoo repository (media-video/vdr-2.2.0::gentoo)
  • VDR-VNSI: Live vdr-vnsiserver plugin from vdr-devel overlay (media-plugins/vdr-vnsiserver-9999)

    • Create a new overlay in /etc/portage/repos.conf/vdr-devel or use an application (layman) to register a new overlay to portage.
    • Umask the live ebuild 9999, otherwise version 1.2.0 will be installed or
    • Use the version 1.2.0 and modify the ebuild. Remove the dependency media-plugins/xbmc-addon-pvr from the ebuild (this kodi-plugin is not compatible and will create conflicts with the following setup)

  • Kodi: I have installed the latest stable Kodi version 15.2 from the gentoo repository (media-tv/kodi-15.2::gentoo)
  • Kodi-VNSI: Install the VNSI plugin for kodi

    • Install dev-libs/libplatform-1.0.10::gentoo. You have to install the version from the standard gentoo overlay - If you install this package as dependency from the kodi-pvr-vdr-vnsi plugin, a compile failure will be occured (see current thread, wrong file location). Afterwards you can remove the line dev-libs/libplatform from /var/lib/portage/world file to ensure depclean will removes this package if kodi-pvr-vdr-vnsi was removed
    • add a new overlay to portage /etc/portage/repos.conf/gentoo-kodi-overlay (https://github.com/herrnst/gentoo-kodi-overlay). This overlay is not existing within layman
    • synchronize portage
    • overwrites the configuration of the live ebuild media-plugins/kodi-pvr-vdr-vnsi-9999::gentoo-kodi-overlay within portage (add entry within /etc/portage/package.env and /etc/portage/env/kodi-vnsi.conf) or temporary within the live ebuild and set / overwrite the git branch from "master" to "Isengard" if you are using Kodi 15.2 like me
    • install media-plugins/kodi-pvr-vdr-vnsi-9999::gentoo-kodi-overlay
    • start Kodi, enable vnsi plugin, switch configuration to expert mode, go to tv, client specific settings, enable timeshift

  • Open a beer and enjoy
That was my setup. Maybe not perfect but it is working! I'm sure other setups will working, too.
Back to top
View user's profile Send private message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1124
Location: Baden / Germany

PostPosted: Sat Feb 06, 2016 10:58 am    Post subject: Reply with quote

Hallo Leute,

ich hab mir die Tage nen Raspi 2 gekauft und der läuft mit openelec out of the box per vnsi plugin aus dem openelec repository mit meinem yavdr zusammen.
Nur die alten mpeg2 Aufnahmen mag er nicht. Ich denke ich brauch noch die mpeg2 Lizenz für die GPU damit das geht.

Und auf dem Bürorechner (gentoo) wollte ich jetzt auch Kodi per vnsi anbinden.
Aber ich denke bevor ich mir das antue versuch ich lieber noch nen alten Raspi dafür zu nehmen.
Glücklicherweise hat mein Monitor noch nen HDMI Port frei.

Und um Klaus da noch zuzustimmen, ich denke XBMC/Kodi sollte eigentlich mit plugins direkt aus portage funktionieren oder langes Gebastel oder irgendwelche overlays.
Was macht das sonst für einen Sinn, sowas in portage zu haben?

Warum können die Betreiber solcher overlays ihr Zeugs nicht direkt in portage einkippen?
Wie immer das große Linuxproblem. Jeder bastelt im stillen Kämmerlein sein eigenes Zeugs :-(
_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Sun Feb 07, 2016 9:05 am    Post subject: Reply with quote

tazinblack wrote:
Und um Klaus da noch zuzustimmen, ich denke XBMC/Kodi sollte eigentlich mit plugins direkt aus portage funktionieren oder langes Gebastel oder irgendwelche overlays.
Was macht das sonst für einen Sinn, sowas in portage zu haben?

Warum können die Betreiber solcher overlays ihr Zeugs nicht direkt in portage einkippen?
Wie immer das große Linuxproblem. Jeder bastelt im stillen Kämmerlein sein eigenes Zeugs :-(

Es ist wohl eher das Problem, was auch bei KDE5 besteht. Die Änderungen sind zuviel und zu tiefgreifend, so dass die Addon-Entwickler nicht hinterherkommen.

Ich hab momentan die 16.0-beta4 laufen, die ganz gut funktioniert. Von der 17.0 würde ich noch abraten. Da war bei mir der Ton asynchron zum Bild (Ton 3 Sekunden hinterher).

Zu XVDR: Pipelka hat wohl schon sehr lange Zeit nichts mehr daran gemacht. Aber es gibt einen Fork (für Ubuntu), bei dem XVDR wieder funktionieren soll. Ich hatte noch nicht die Zeit, XVDR zum Laufen zu kriegen für die 16.0. Bei mir funktioniert momentan VNSI halbwegs brauchbar (hab immer noch das Pay-TV-Problem).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum