Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ati-drivers-14.12-r3 fails to compile
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
grimx
n00b
n00b


Joined: 15 Jun 2010
Posts: 63

PostPosted: Thu Sep 10, 2015 2:37 am    Post subject: ati-drivers-14.12-r3 fails to compile Reply with quote

My kernel : 4.0.5-gentoo x86_g4
My Graphics Card: Advanced Micro Devices, Inc. [AMD/ATI] RV730/M96 [Mobility Radeon HD 4650/5165]
My /etc/portage/make.conf:
VIDEO_CARDS="radeon r730 fglrx"

I've been following the fglrx on Gentoo Wiki.
When I run: emerge --ask --changed-use --deep world
x11-drivers/ati-drivers-14.12-r3 fails in compile phase.

Code:

* Messages for package x11-drivers/ati-drivers-14.12-r3:

 *
 * Please note that this driver only supports graphic cards based on
 * Evergreen chipset and newer.
 * This includes the AMD Radeon HD 5400+ series at this moment.
 *
 * If your card is older then use x11-drivers/xf86-video-ati
 * For migration informations please refer to:
 * https://www.gentoo.org/proj/en/desktop/x/x11/ati-migration-guide.xml
 * ERROR: x11-drivers/ati-drivers-14.12-r3::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=x11-drivers/ati-drivers-14.12-r3::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/ati-drivers-14.12-r3::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/ati-drivers-14.12-r3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/ati-drivers-14.12-r3/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-drivers/ati-drivers-14.12-r3/work/common/lib/modules/fglrx/build_mod/2.6.x'
 * S: '/var/tmp/portage/x11-drivers/ati-drivers-14.12-r3/work'

 * Regenerating GNU info directory index...
 * Processed 147 info files.
 * After world updates, it is important to remove obsolete packages with
 * emerge --depclean. Refer to `man emerge` for more information.



One side note:
I successfully installed the radeon drivers by following the Radeon Gentoo Wiki
before I started the install of the ati-drivers.
Mistake or not??
Back to top
View user's profile Send private message
grimx
n00b
n00b


Joined: 15 Jun 2010
Posts: 63

PostPosted: Thu Sep 10, 2015 3:57 am    Post subject: Reply with quote

Well I followed this guide to apply a patch:https://forums.gentoo.org/viewtopic-t-1020106-start-0-postdays-0-postorder-asc-highlight-.html
I rebooted into KDE and KWIN crashes and sets my Desktop Effects back to OpenGl-2.0 and Raster.

KDE Crash Handler shows:
Executable: kwin PID: 2980 Signal: Segmentation fault (11) Time: 09/09/15 09:48:43 PM
Back to top
View user's profile Send private message
grimx
n00b
n00b


Joined: 15 Jun 2010
Posts: 63

PostPosted: Thu Sep 10, 2015 4:59 am    Post subject: Reply with quote

glxinfo | grep render :
X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 155 (GLX)
Minor opcode of failed request: 19 (X_GLXQueryServerString)
Serial number of failed request: 12
Current serial number in output stream: 12
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum