Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
portage vs apt with firewall
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
froosh
n00b
n00b


Joined: 10 Jul 2014
Posts: 29

PostPosted: Thu Sep 10, 2015 3:32 am    Post subject: portage vs apt with firewall Reply with quote

Hi,

I'm not sure which group to ask this question to so I'll start here. I use gentoo as my main computer here at work and it works fine. I've been given a work laptop with using ubuntu and I cannot use apt to download any packages. I get an an error that stating:
Code:

Get:1 http://dl.google.com stable InRelease                                   
100% [1 InRelease gpgv 81.7 kB] [Waiting for headers] [Connecting to ppa.launchSplitting up /var/lib/apt/lists/partial/dIgn http://dl.google.com stable InRelease                                      e failed
E: GPG error: http://dl.google.com stable InRelease: Clearsigned file isn't valid, got 'NODATA' (does the network require authentication?)


Now, I understand this is a ubuntu error but all signs point to not receiving information due to the firewall here.

So my question is how does portage manage to work flawlessly on the same network? I haven't changed any of the defaults on either and both are using the same mirror (via a local University) on http or ftp.

Anyone experienced in both systems that could give me a guess?
Back to top
View user's profile Send private message
mrbassie
Guru
Guru


Joined: 31 May 2013
Posts: 535

PostPosted: Thu Sep 10, 2015 6:31 am    Post subject: Reply with quote

Try removing/commenting out http://dl.google.com from /etc/apt/sources.list and running apt-get update.
Back to top
View user's profile Send private message
froosh
n00b
n00b


Joined: 10 Jul 2014
Posts: 29

PostPosted: Thu Sep 10, 2015 7:43 pm    Post subject: Reply with quote

mrbassie wrote:
Try removing/commenting out http://dl.google.com from /etc/apt/sources.list and running apt-get update.


I just put a fresh debian install on without that mirror. It's still similar error:
Code:

: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://security.debian.org testing/updates InRelease: Clearsigned file isn't valid, got 'NODATA' (does the network require authentication?)


My guess is that it has something to do with my workplace firewall rules. I think if there's no rule in the firewall to allow incoming connections from the server, it keeps failing. I think firewalls call this type of rule "ESTABLISHED,RELATED" so that only incoming connections from a server that already has an outgoing connection will be allowed.

But I have no idea how portage manages to work. If there's a way to force apt to do the same thing as portage it would be helpful since I'm suppose to get this silly laptop working for other people who don't want to use Gentoo.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43072
Location: 56N 3W

PostPosted: Sat Sep 19, 2015 3:00 pm    Post subject: Reply with quote

Moved from Portage & Programming to Unsupported Software.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum