Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Konflikt beim Pakete Updaten
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
alexander_ro
Apprentice
Apprentice


Joined: 22 Nov 2014
Posts: 171

PostPosted: Sat Sep 12, 2015 10:07 am    Post subject: Konflikt beim Pakete Updaten Reply with quote

Hi Mädels ... Jungs ... :-)

Ich habe jetzt auf einem meiner Server das Debian durch Gentoo amd64 (Hardened) ersetzt. Beim updaten der installierten Pakete hatte ich eine ganze reihe von konflikten von denen ich die meisten lösen konnte. Nur bei dem folgenden komme ich nicht weiter. Kann mir vielleicht jemand von euch erklären wie ich das auflösen kann?

Code:

hulk / # emerge --ask --update --deep --with-bdeps=y --newuse world

 * IMPORTANT: 12 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS   ~] sys-libs/ncurses-5.9-r101 [5.9-r5] USE="unicode -gpm -tinfo" ABI_X86="(64) -32 (-x32)"
[blocks B      ] <sys-libs/ncurses-6:0 ("<sys-libs/ncurses-6:0" is blocking sys-libs/ncurses-5.9-r101)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-libs/ncurses-5.9-r101:5/5::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-libs/ncurses-5.2-r2 required by (app-shells/bash-4.3_p39:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by (sys-apps/util-linux-2.25.2-r2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by (dev-lang/python-2.7.9-r1:2.7/2.7::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by (sys-apps/texinfo-5.2:0/0::gentoo, installed)
    sys-libs/ncurses:5/5= required by (sys-apps/openrc-0.17:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7[unicode?] (>=sys-libs/ncurses-5.7-r7[unicode]) required by (sys-process/procps-3.3.9-r2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r5 required by (sys-boot/grub-2.02_beta2-r7:2/2::gentoo, installed)
    >=sys-libs/ncurses-5.9-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-libs/ncurses-5.9-r3[abi_x86_64(-)]) required by (sys-libs/readline-6.3_p8-r2:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by (sys-apps/less-478:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7 required by (sys-process/psmisc-22.21-r2:0/0::gentoo, installed)
    sys-libs/ncurses required by (app-admin/eselect-1.4.4:0/0::gentoo, installed)
    sys-libs/ncurses required by (sys-devel/gettext-0.19.4:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by (sys-devel/bc-1.06.95-r1:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by (sys-kernel/hardened-sources-4.1.6:4.1.6/4.1.6::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by (dev-lang/python-3.4.1:3.4/3.4::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2 required by (app-editors/vim-7.4.769:0/0::gentoo, installed)

  (sys-libs/ncurses-5.9-r5:0/5::gentoo, installed) pulled in by
    sys-libs/ncurses:0 required by @selected
    sys-libs/ncurses:0= required by (sys-apps/openrc-0.17:0/0::gentoo, installed)
    sys-libs/ncurses:0= required by (app-emulation/qemu-2.4.0-r1:0/0::gentoo, installed)
    sys-libs/ncurses:0/5= required by (app-emulation/qemu-2.4.0-r1:0/0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


Viele Grüße
Alexander
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6281

PostPosted: Sat Sep 12, 2015 5:17 pm    Post subject: Reply with quote

Eigentlich sollte ncurses-5.9-r101 das Keyword "amd64" und nicht "~amd64" haben.
Kann es sein, dass Du in /etc/protage/package.accept_keywords einen entsprechenden Eintrag für ncurses hast? Dann entferne ihn.
Back to top
View user's profile Send private message
alexander_ro
Apprentice
Apprentice


Joined: 22 Nov 2014
Posts: 171

PostPosted: Sun Sep 13, 2015 8:58 am    Post subject: Reply with quote

Ja stimmt nur wie das da hin kommt weiss ich nicht.

Code:

# required by sys-apps/openrc-0.17::gentoo
# required by @system
# required by @world (argument)
=sys-libs/ncurses-5.9-r101 ~amd64


[Edit]
Danke für die Hilfe wenn man das löscht dann funktioniert es ... :-)
[/Edit]
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3686
Location: Hamburg

PostPosted: Sat Sep 19, 2015 9:48 am    Post subject: Reply with quote

alexander_ro wrote:
Ja stimmt nur wie das da hin kommt weiss ich nicht.
Weil Du evtl.
Code:
--autounmask --autounmask-unrestricted-atoms --autounmask-write
in make.conf und einmal zu viel mit "Yes" geantwortet hast ? ;)
Back to top
View user's profile Send private message
alexander_ro
Apprentice
Apprentice


Joined: 22 Nov 2014
Posts: 171

PostPosted: Fri Sep 25, 2015 8:21 pm    Post subject: Reply with quote

Gut möglich aber in der make.conf habe ich es nicht. Ich glaube der hat das mal als Lösungsmöglichkeit vorgeschlagen und dann habe ich es als Parameter benutzt. Aber warum macht der dann das ~amd64 wenn es falsch ist?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum