Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] Blocks & Slots...
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1162
Location: Eppingen, Germany

PostPosted: Sun Sep 06, 2015 7:28 pm    Post subject: [gelöst] Blocks & Slots... Reply with quote

Hallo Gemeinde,

das Problem ha be ich nun schon ein paar Wochen. Einen Block konnte ich bisher auflösen, das hier ist aber hartnäckig übrig:

Code:
[blocks B      ] >=sys-apps/util-linux-2.23 (">=sys-apps/util-linux-2.23" is blocking sys-apps/sysvinit-2.88-r4)
[blocks B      ] <sys-apps/sysvinit-2.88-r6 ("<sys-apps/sysvinit-2.88-r6" is blocking sys-process/procps-3.3.9-r2)
[blocks B      ] sys-block/eject ("sys-block/eject" is blocking sys-apps/util-linux-2.25.2-r2)
[blocks B      ] <sys-apps/sysvinit-2.88-r7 ("<sys-apps/sysvinit-2.88-r7" is blocking sys-apps/util-linux-2.25.2-r2)
[blocks B      ] <=x11-libs/libfm-1.2.3 ("<=x11-libs/libfm-1.2.3" is hard blocking x11-libs/libfm-extra-1.2.3)

Total: 258 packages (135 upgrades, 19 downgrades, 11 new, 4 in new slots, 89 reinstalls), Size of downloads: 1.136.369 KiB
Conflict: 6 blocks (5 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-python/PyQt4:0

  (dev-python/PyQt4-4.11.1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-python/PyQt4[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),X] required by (app-portage/elogviewer-2.1-r2:0/0::gentoo, ebuild scheduled for merge)                                                                           
                                                                                                                                                                                                                                                                                                                           
    dev-python/PyQt4[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),svg] required by (dev-python/ipython-3.2.1:0/0::gentoo, ebuild scheduled for merge)                                                                               
                                                                                                                                                                                                                                                                                                                         
    >=dev-python/PyQt4-4.11[X,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/qscintilla-python-2.8.4:0/0::gentoo, ebuild scheduled for merge)                                                               
                                                                                                                                                                                                                                                                                                                                       
    >=dev-python/PyQt4-4.10[python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python2_7(-)?,-python_single_target_jython2_5(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),python_single_target_python3_3(+)?,python_single_target_python3_4(+)?,python_single_target_python2_7(+)?,X,help,sql,svg,webkit] required by (dev-util/eric-5.5.2:5/5::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                               

  (dev-python/PyQt4-4.11.1:0/0::gentoo, installed) pulled in by
    dev-python/PyQt4[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/python-poppler-qt4-0.18.1:0/0::gentoo, installed)                                                                                       
                                                                                                                                                                                                                                                                                                               

dev-python/sip:0

  (dev-python/sip-4.16.2:0/11::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/sip-4.16:=[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/PyQt4-4.11.1:0/0::gentoo, ebuild scheduled for merge)                                                                             
                                                                                                                                                                                                                                                                                                                           
    >=dev-python/sip-4.16:=[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/qscintilla-python-2.8.4:0/0::gentoo, ebuild scheduled for merge)                                                                 
                                                                                                                                                                                                                                                                                                                                     
    >=dev-python/sip-4.14.3[python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python2_7(-)?,-python_single_target_jython2_5(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),python_single_target_python3_3(+)?,python_single_target_python3_4(+)?,python_single_target_python2_7(+)?] required by (dev-util/eric-5.5.2:5/5::gentoo, ebuild scheduled for merge)                                                                           
                                                                                                                                                                                                                                                                                                                                                                                                                                                         

  (dev-python/sip-4.16.2:0/11::gentoo, installed) pulled in by
    >=dev-python/sip-4.16:0/11=[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/PyQt4-4.11.1:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                               
    >=dev-python/sip-4.16:=[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/PyQt4-4.11.1:0/0::gentoo, installed)                                                                                             
                                                                                                                                                                                                                                                                                                         
    >=dev-python/sip-4.9.1[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/python-poppler-qt4-0.18.1:0/0::gentoo, installed)                                                                                 
                                                                                                                                                                                                                                                                                                                     

dev-python/dbus-python:0

  (dev-python/dbus-python-1.2.0-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/dbus-python-0.80[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/PyQt4-4.11.1:0/0::gentoo, ebuild scheduled for merge)                                                                       
                                                                                                                                                                                                                                                                                                                                 

  (dev-python/dbus-python-1.2.0-r1:0/0::gentoo, installed) pulled in by
    >=dev-python/dbus-python-0.80[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/PyQt4-4.11.1:0/0::gentoo, installed)                                                                                       
                                                                                                                                                                                                                                                                                                               


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-block/eject-2.1.5-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    sys-block/eject required by (virtual/eject-0:0/0::gentoo, installed)

  (x11-libs/libfm-extra-1.2.3:0/4.3.0::gentoo, ebuild scheduled for merge) pulled in by
    ~x11-libs/libfm-extra-1.2.3 required by (x11-libs/libfm-1.2.3-r1:0/4.3.0::gentoo, ebuild scheduled for merge)
    x11-libs/libfm-extra required by (lxde-base/menu-cache-1.0.0-r1:0/2::gentoo, ebuild scheduled for merge)

  (sys-apps/sysvinit-2.88-r4:0/0::gentoo, ebuild scheduled for merge) pulled in by
    <=sys-apps/sysvinit-2.88-r4 required by (sys-power/apcupsd-3.14.12-r1:0/0::gentoo, installed)
    >=sys-apps/sysvinit-2.86-r6 required by (sys-apps/openrc-0.17:0/0::gentoo, installed)

  (sys-process/procps-3.3.9-r2:0/0::gentoo, installed) pulled in by
    sys-process/procps:0= required by (dev-db/mariadb-10.0.21:0/18::gentoo, ebuild scheduled for merge)
    sys-process/procps required by @system

  (sys-apps/util-linux-2.25.2-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/util-linux-2.13 required by (www-plugins/nspluginwrapper-1.4.4-r3:0/0::gentoo, installed)
    sys-apps/util-linux required by (app-text/xmlto-0.0.26:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.25:0= required by (sys-apps/systemd-219_p112:0/2::gentoo, ebuild scheduled for merge)
    sys-apps/util-linux required by (app-text/build-docbook-catalog-1.19.1:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.24.1-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-apps/util-linux-2.24.1-r3[abi_x86_32(-),abi_x86_64(-)]) required by (media-sound/lash-0.5.4-r2:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.19 required by (dev-libs/rasqal-0.9.29:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.22 required by (virtual/eject-0:0/0::gentoo, installed)
    sys-apps/util-linux required by @system
    >=sys-apps/util-linux-2.16 required by (dev-libs/apr-1.5.2:1/1::gentoo, installed)
    sys-apps/util-linux required by (sys-apps/gptfdisk-0.8.10:0/0::gentoo, installed)
    sys-apps/util-linux required by (app-admin/apache-tools-2.2.31:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/util-linux-2.20 required by (net-fs/autofs-5.0.7-r4:0/0::gentoo, installed)
    sys-apps/util-linux required by (app-admin/testdisk-7.0-r2:0/0::gentoo, installed)
    sys-apps/util-linux required by (sys-apps/udevil-0.4.3:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.20 required by (sys-block/gparted-0.22.0:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.20.1-r2 required by (sys-fs/udisks-2.1.4:2/2::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (sys-fs/lvm2-2.02.109:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.24.1-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-apps/util-linux-2.24.1-r3[abi_x86_32(-),abi_x86_64(-)]) required by (x11-libs/libSM-1.2.2-r1:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.20 required by (dev-python/pymountboot-0.2.2:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/util-linux-2.12-r4 required by (app-backup/rsnapshot-1.3.1-r2:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (sys-fs/e2fsprogs-1.42.13:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/util-linux-2.20.1-r2 required by (sys-fs/udisks-1.0.5-r1:0/0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following packages are causing rebuilds:

  (dev-libs/libgcrypt-1.6.3-r4:0/20::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (media-libs/libmtp-1.1.8:0/9::gentoo, ebuild scheduled for merge)
    (dev-libs/libxslt-1.1.28-r4:0/0::gentoo, ebuild scheduled for merge)
    (app-crypt/libsecret-0.18.2:0/0::gentoo, ebuild scheduled for merge)
    (media-video/vlc-2.1.5-r1:0/5-7::gentoo, ebuild scheduled for merge)
    (app-crypt/gcr-3.14.0:0/1::gentoo, ebuild scheduled for merge)
    (gnome-base/gnome-keyring-3.14.0:0/0::gentoo, ebuild scheduled for merge)
  (dev-util/mdds-0.12.1:0/0.12.1::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (dev-libs/libixion-0.9.0:0/0.10::gentoo, ebuild scheduled for merge)
  (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (dev-libs/libixion-0.9.0:0/0.10::gentoo, ebuild scheduled for merge)
    (dev-libs/liborcus-0.7.1:0/0::gentoo, ebuild scheduled for merge)
    (kde-base/kdepimlibs-4.14.8:4/4.14::gentoo, ebuild scheduled for merge)
    (dev-libs/librevenge-0.0.2:0/0::gentoo, ebuild scheduled for merge)
    (media-gfx/hugin-2014.0.0:0/0::gentoo, ebuild scheduled for merge)
    (app-text/libwps-0.3.1:0/0::gentoo, ebuild scheduled for merge)
    (www-plugins/gnash-0.8.10_p20131019:0/0::gentoo, ebuild scheduled for merge)


Das bekomme ich nicht weg.... Hat vielleicht jemand einen Tip für mich? BTW bei mir ist Python 3.3 und 3.4 auf dem System. In der Make.conf habe ich aber keine Targets gesetzt. Sollte dann nicht nur ein dreier-Python aus dem Profil vorhanden sein?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org


Last edited by uhai on Wed Sep 16, 2015 7:00 pm; edited 1 time in total
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6293

PostPosted: Sun Sep 06, 2015 8:46 pm    Post subject: Reply with quote

Unmerge eject (das gehört jetzt zu util-linux).
Danach kann er vermutlich util-linux upgraden, und dann auch sysvinit.
Das mit libfm verstehe ich nicht: Ggf. musst Du manuell emerge -1 libfm ausführen.

Zu Python: Solange Du kein emerge --depclean oder zumindest emerge --clean ausführst, werden ältere Slots nicht entfernt, egal ob sie benötigt werden oder nicht.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3672
Location: Germany

PostPosted: Sun Sep 06, 2015 8:59 pm    Post subject: Reply with quote

uhai wrote:
Code:
[blocks B      ] <=x11-libs/libfm-1.2.3 ("<=x11-libs/libfm-1.2.3" is hard blocking x11-libs/libfm-extra-1.2.3)

Hier sollte vermutlich vorheriges unmergen der alten noch installierten Version helfen.
Siehe dazu zb auch im https://forums.gentoo.org/viewtopic-p-7788736.html#7788736
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1162
Location: Eppingen, Germany

PostPosted: Mon Sep 07, 2015 1:01 am    Post subject: Reply with quote

@Josef.95:
Das hat hingehauen. Vielen Dank auch für den Link.

@mv:
Das hat leider nicht hin. Ich habe sys-block/eject und virtual/eject mit emerge --unmerge entfernt. Beide tauchen aber wieder auf:

Code:
eix eject                                            ──(Mo,Sep07)─┘
* sys-block/eject
     Available versions:  2.1.5-r2 {nls}
     Homepage:            http://eject.sourceforge.net/
     Description:         A command to eject a disc from the CD-ROM drive

* sys-block/eject-bsd
     Available versions:  ~*1.5
     Homepage:            http://www.freshports.org/sysutils/eject/
     Description:         eject command for FreeBSD systems

* virtual/eject
     Available versions:  0
     Description:         Virtual for the eject command


Das sieht dann so aus:
Code:
[blocks B      ] >=sys-apps/util-linux-2.23 (">=sys-apps/util-linux-2.23" is blocking sys-apps/sysvinit-2.88-r4)
[blocks B      ] <sys-apps/sysvinit-2.88-r6 ("<sys-apps/sysvinit-2.88-r6" is blocking sys-process/procps-3.3.9-r2)
[blocks B      ] sys-block/eject ("sys-block/eject" is blocking sys-apps/util-linux-2.25.2-r2)
[blocks B      ] <sys-apps/sysvinit-2.88-r7 ("<sys-apps/sysvinit-2.88-r7" is blocking sys-apps/util-linux-2.25.2-r2)

Code:

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/util-linux-2.25.2-r2:0/0::gentoo, installed) pulled in by
    >=sys-apps/util-linux-2.13 required by (www-plugins/nspluginwrapper-1.4.4-r3:0/0::gentoo, installed)
    sys-apps/util-linux required by (app-text/xmlto-0.0.26:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.25:0= required by (sys-apps/systemd-219_p112:0/2::gentoo, ebuild scheduled for merge)
    sys-apps/util-linux required by (app-text/build-docbook-catalog-1.19.1:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.24.1-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-apps/util-linux-2.24.1-r3[abi_x86_32(-),abi_x86_64(-)]) required by (media-sound/lash-0.5.4-r2:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.19 required by (dev-libs/rasqal-0.9.29:0/0::gentoo, installed)
    sys-apps/util-linux required by @system
    >=sys-apps/util-linux-2.16 required by (dev-libs/apr-1.5.2:1/1::gentoo, installed)
    sys-apps/util-linux required by (sys-apps/gptfdisk-0.8.10:0/0::gentoo, installed)
    sys-apps/util-linux required by (app-admin/apache-tools-2.2.31:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/util-linux-2.20 required by (net-fs/autofs-5.0.7-r4:0/0::gentoo, installed)
    sys-apps/util-linux required by (app-admin/testdisk-7.0-r2:0/0::gentoo, installed)
    sys-apps/util-linux required by (sys-apps/udevil-0.4.3:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.20 required by (sys-block/gparted-0.22.0:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.20.1-r2 required by (sys-fs/udisks-2.1.4:2/2::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (sys-fs/lvm2-2.02.109:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.24.1-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-apps/util-linux-2.24.1-r3[abi_x86_32(-),abi_x86_64(-)]) required by (x11-libs/libSM-1.2.2-r1:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.20 required by (dev-python/pymountboot-0.2.2:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/util-linux-2.12-r4 required by (app-backup/rsnapshot-1.3.1-r2:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.22 required by (virtual/eject-0:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/util-linux-2.16 required by (sys-fs/e2fsprogs-1.42.13:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/util-linux-2.20.1-r2 required by (sys-fs/udisks-1.0.5-r1:0/0::gentoo, installed)

  (sys-block/eject-2.1.5-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    sys-block/eject required by (virtual/eject-0:0/0::gentoo, ebuild scheduled for merge)

  (sys-apps/sysvinit-2.88-r4:0/0::gentoo, ebuild scheduled for merge) pulled in by
    <=sys-apps/sysvinit-2.88-r4 required by (sys-power/apcupsd-3.14.12-r1:0/0::gentoo, installed)
    >=sys-apps/sysvinit-2.86-r6 required by (sys-apps/openrc-0.17:0/0::gentoo, installed)

  (sys-process/procps-3.3.9-r2:0/0::gentoo, installed) pulled in by
    sys-process/procps:0= required by (dev-db/mariadb-10.0.21:0/18::gentoo, ebuild scheduled for merge)
    sys-process/procps required by @system


uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6293

PostPosted: Mon Sep 07, 2015 12:27 pm    Post subject: Reply with quote

uhai wrote:
Ich habe sys-block/eject und virtual/eject mit emerge --unmerge entfernt. Beide tauchen aber wieder auf:

Dann ist dies das Problem. Maskiere sys-block/eject und finde so heraus, was (fälschlicherweise) unbedingt sys-block/eject haben will. Dieses Paket musst Du ebenfalls unmerge, maskieren, oder ggf. manuell upgraden.
virual/eject ist kein Problem: Diess virtual is auch mit >=sys-apps/util-linux-2.22 zufrieden.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1162
Location: Eppingen, Germany

PostPosted: Mon Sep 07, 2015 7:53 pm    Post subject: Reply with quote

Die Ausgabe kann ich nicht deuten:

Code:
[blocks B      ] >=sys-apps/util-linux-2.23 (">=sys-apps/util-linux-2.23" is blocking sys-apps/sysvinit-2.88-r4)
[blocks B      ] <sys-apps/sysvinit-2.88-r6 ("<sys-apps/sysvinit-2.88-r6" is blocking sys-process/procps-3.3.9-r2)
[blocks B      ] <sys-apps/sysvinit-2.88-r7 ("<sys-apps/sysvinit-2.88-r7" is blocking sys-apps/util-linux-2.25.2-r2)

Total: 255 packages (134 upgrades, 19 downgrades, 10 new, 4 in new slots, 88 reinstalls), Size of downloads: 1.136.249 KiB
Conflict: 4 blocks (3 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-python/PyQt4:0

  (dev-python/PyQt4-4.11.1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-python/PyQt4[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),X] required by (app-portage/elogviewer-2.1-r2:0/0::gentoo, ebuild scheduled for merge)                                                                           
                                                                                                                                                                                                                                                                                                                           
    dev-python/PyQt4[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),svg] required by (dev-python/ipython-3.2.1:0/0::gentoo, ebuild scheduled for merge)                                                                               
                                                                                                                                                                                                                                                                                                                         
    >=dev-python/PyQt4-4.11[X,python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/qscintilla-python-2.8.4:0/0::gentoo, ebuild scheduled for merge)                                                               
                                                                                                                                                                                                                                                                                                                                       
    >=dev-python/PyQt4-4.10[python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python2_7(-)?,-python_single_target_jython2_5(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),python_single_target_python3_3(+)?,python_single_target_python3_4(+)?,python_single_target_python2_7(+)?,X,help,sql,svg,webkit] required by (dev-util/eric-5.5.2:5/5::gentoo, ebuild scheduled for merge)
                                                                                                                                                                                                                                                                                                                                                                                                                                                                               

  (dev-python/PyQt4-4.11.1:0/0::gentoo, installed) pulled in by
    dev-python/PyQt4[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/python-poppler-qt4-0.18.1:0/0::gentoo, installed)                                                                                       
                                                                                                                                                                                                                                                                                                               

dev-python/sip:0

  (dev-python/sip-4.16.2:0/11::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/sip-4.16:=[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/PyQt4-4.11.1:0/0::gentoo, ebuild scheduled for merge)                                                                             
                                                                                                                                                                                                                                                                                                                           
    >=dev-python/sip-4.16:=[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/qscintilla-python-2.8.4:0/0::gentoo, ebuild scheduled for merge)                                                                 
                                                                                                                                                                                                                                                                                                                                     
    >=dev-python/sip-4.14.3[python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python2_7(-)?,-python_single_target_jython2_5(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),python_single_target_python3_3(+)?,python_single_target_python3_4(+)?,python_single_target_python2_7(+)?] required by (dev-util/eric-5.5.2:5/5::gentoo, ebuild scheduled for merge)                                                                           
                                                                                                                                                                                                                                                                                                                                                                                                                                                         

  (dev-python/sip-4.16.2:0/11::gentoo, installed) pulled in by
    >=dev-python/sip-4.16:0/11=[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/PyQt4-4.11.1:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                               
    >=dev-python/sip-4.16:=[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/PyQt4-4.11.1:0/0::gentoo, installed)                                                                                             
                                                                                                                                                                                                                                                                                                         
    >=dev-python/sip-4.9.1[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/python-poppler-qt4-0.18.1:0/0::gentoo, installed)                                                                                 
                                                                                                                                                                                                                                                                                                                     

dev-python/dbus-python:0

  (dev-python/dbus-python-1.2.0-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/dbus-python-0.80[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/PyQt4-4.11.1:0/0::gentoo, ebuild scheduled for merge)                                                                       
                                                                                                                                                                                                                                                                                                                                 

  (dev-python/dbus-python-1.2.0-r1:0/0::gentoo, installed) pulled in by
    >=dev-python/dbus-python-0.80[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/PyQt4-4.11.1:0/0::gentoo, installed)                                                                                       
                                                                                                                                                                                                                                                                                                               


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/util-linux-2.25.2-r2:0/0::gentoo, installed) pulled in by
    >=sys-apps/util-linux-2.13 required by (www-plugins/nspluginwrapper-1.4.4-r3:0/0::gentoo, installed)
    sys-apps/util-linux required by (app-text/xmlto-0.0.26:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.25:0= required by (sys-apps/systemd-219_p112:0/2::gentoo, ebuild scheduled for merge)
    sys-apps/util-linux required by (app-text/build-docbook-catalog-1.19.1:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.24.1-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-apps/util-linux-2.24.1-r3[abi_x86_32(-),abi_x86_64(-)]) required by (media-sound/lash-0.5.4-r2:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.19 required by (dev-libs/rasqal-0.9.29:0/0::gentoo, installed)
    sys-apps/util-linux required by @system
    >=sys-apps/util-linux-2.16 required by (dev-libs/apr-1.5.2:1/1::gentoo, installed)
    sys-apps/util-linux required by (sys-apps/gptfdisk-0.8.10:0/0::gentoo, installed)
    sys-apps/util-linux required by (app-admin/apache-tools-2.2.31:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/util-linux-2.20 required by (net-fs/autofs-5.0.7-r4:0/0::gentoo, installed)
    sys-apps/util-linux required by (app-admin/testdisk-7.0-r2:0/0::gentoo, installed)
    sys-apps/util-linux required by (sys-apps/udevil-0.4.3:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.20 required by (sys-block/gparted-0.22.0:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.20.1-r2 required by (sys-fs/udisks-2.1.4:2/2::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (sys-fs/lvm2-2.02.109:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.24.1-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-apps/util-linux-2.24.1-r3[abi_x86_32(-),abi_x86_64(-)]) required by (x11-libs/libSM-1.2.2-r1:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.20 required by (dev-python/pymountboot-0.2.2:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/util-linux-2.12-r4 required by (app-backup/rsnapshot-1.3.1-r2:0/0::gentoo, installed)
    >=sys-apps/util-linux-2.22 required by (virtual/eject-0:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/util-linux-2.16 required by (sys-fs/e2fsprogs-1.42.13:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/util-linux-2.20.1-r2 required by (sys-fs/udisks-1.0.5-r1:0/0::gentoo, installed)

  (sys-process/procps-3.3.9-r2:0/0::gentoo, installed) pulled in by
    sys-process/procps:0= required by (dev-db/mariadb-10.0.21:0/18::gentoo, ebuild scheduled for merge)
    sys-process/procps required by @system

  (sys-apps/sysvinit-2.88-r4:0/0::gentoo, ebuild scheduled for merge) pulled in by
    <=sys-apps/sysvinit-2.88-r4 required by (sys-power/apcupsd-3.14.12-r1:0/0::gentoo, installed)
    >=sys-apps/sysvinit-2.86-r6 required by (sys-apps/openrc-0.17:0/0::gentoo, installed)

_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3672
Location: Germany

PostPosted: Mon Sep 07, 2015 9:22 pm    Post subject: Reply with quote

uhai wrote:
Code:
[...]
  (sys-apps/sysvinit-2.88-r4:0/0::gentoo, ebuild scheduled for merge) pulled in by
    <=sys-apps/sysvinit-2.88-r4 required by (sys-power/apcupsd-3.14.12-r1:0/0::gentoo, installed)
    >=sys-apps/sysvinit-2.86-r6 required by (sys-apps/openrc-0.17:0/0::gentoo, installed)

Hm, das haut so nicht hin.
Laut
apcupsd-3.14.12-r1.ebuild:
DEPEND="
        ||      ( >=sys-apps/util-linux-2.23[tty-helpers(-)]
                  <=sys-apps/sysvinit-2.88-r4
                  sys-freebsd/freebsd-ubin
                )

sollte sich dieser Konflikt lösen lassen indem sys-apps/util-linux mit USE=tty-helpers gebaut wird,
dann sollte apcupsd-3.14.12-r1
auch mit der von openrc-0.17 geforderten >=sys-apps/sysvinit-2.86-r6 Version zusammen installierbar sein.

Fazit: Prüfe mal mit welchen USE-Flags sys-apps/util-linux installiert ist bzw nun gebaut werden würde.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1162
Location: Eppingen, Germany

PostPosted: Tue Sep 08, 2015 3:44 am    Post subject: Reply with quote

Code:
eix sys-apps/util-linux                                                                         ──(Mo,Sep07)─┘
[I] sys-apps/util-linux
     Available versions:  2.24.1-r2 2.24.1-r3 ~2.24.2 ~2.25.1 ~2.25.1-r1 ~2.25.2 ~2.25.2-r1 2.25.2-r2 ~2.26 ~2.26.1 ~2.26.1-r1 ~2.26.2 **9999 {bash-completion caps +cramfs cytune fdformat ncurses nls pam python selinux slang static-libs +suid systemd test tty-helpers udev unicode ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32" PYTHON_SINGLE_TARGET="python2_7 python3_3 python3_4" PYTHON_TARGETS="python2_7 python3_3 python3_4"}                                           
     Installed versions:  2.25.2-r2(02:38:50 07.09.2015)(cramfs ncurses nls pam python suid systemd tty-helpers udev unicode -caps -fdformat -selinux -slang -static-libs -test ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_4 -python3_3")           
     Homepage:            https://www.kernel.org/pub/linux/utils/util-linux/
     Description:         Various useful Linux utilities



USE=tty-helpers ist gesetzt,oder sehe ich das falsch?
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3672
Location: Germany

PostPosted: Tue Sep 08, 2015 8:11 am    Post subject: Reply with quote

Hm ja, in der eix Ausgabe ist ersichtlich wie bzw mit welchen Flags das Paket aktuell installiert ist,
es ist aber nicht ersichtlich wie es beim neu bauen installiert werden würde.
Wenn in der package.use das tty-helpers USE-Flag nicht mehr gesetzt ist, dann ist das in der eix Ausgabe nicht ersichtlich (solange es nicht tatsächlich so gebaut/installiert ist).

Schau für sowas am besten direkt in der Ausgabe des Paketmanagers (portage/emerge), denn der entscheidet letztendlich wie gebaut/installiert werden würde.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1162
Location: Eppingen, Germany

PostPosted: Tue Sep 08, 2015 6:35 pm    Post subject: Reply with quote

In der package.use ist tty-helpers gesetzt....

Mehr hat mich verblüfft, dass sich kein Package über das fehlende eject beschwert hat.

Code:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] sys-apps/util-linux-2.25.2-r2::gentoo  USE="cramfs ncurses nls pam python suid systemd tty-helpers udev unicode -caps -fdformat (-selinux) -slang -static-libs {-test}" ABI_X86="32 (64) (-x32)" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_4 -python3_3" 0 KiB         

Total: 1 package (1 reinstall), Size of downloads: 0 KiB

Would you like to merge these packages? [Yes/No] n


Wird also mit tty-helpers gebaut, oder?

Jetzt habe ich beim portage-Update portage auf einmal in zwei Slots:
Code:
emerge --oneshot portage                                                                        ──(Di,Sep08)─┘
WARNING: One or more repositories have missing repo_name entries:

        /usr/local/portage/overlay/profiles/repo_name

NOTE: Each repo_name entry should be a plain text file containing a
unique name for the repository on the first line.


Calculating dependencies... done!
[ebuild     U  ] sys-apps/portage-2.2.20.1 [2.2.20] PYTHON_TARGETS="python3_4* -python3_3*"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-apps/portage:0

  (sys-apps/portage-2.2.20.1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/portage (Argument)

  (sys-apps/portage-2.2.20:0/0::gentoo, installed) pulled in by
    >=sys-apps/portage-2.2.8-r1[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (app-portage/portpeek-2.1.18:0/0::gentoo, installed)                                                                                     
                                                                                                                                                                                                                                                                                                                 
    sys-apps/portage[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_pypy(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_pypy(-)] required by (app-admin/webapp-config-1.53-r2:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                 
    sys-apps/portage[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_pypy(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_pypy(-)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed)


Muss ich jetzt tatsächlich maskieren?
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3672
Location: Germany

PostPosted: Wed Sep 09, 2015 1:04 am    Post subject: Reply with quote

Hm ja, die Flags von util-linux sollten soweit passen, daran sollte es dann also nicht liegen.

So direkt nur portage zu aktualisieren geht vermutlich nicht so einfach, da sich zwischenzeitlich scheinbar auch die PYTHON_TARGETS geändert haben, dessen Deps so noch nicht mit aufgelöst werden können.

Hm schwierig, ich denke so kommen wir hier ohne weitere Info kaum weiter. Magst du mal die komplette ungekürzte Ausgabe von
Code:
emerge -avuDN @world --backtrack=300
zb via Pastebin-Service bereitstellen? (und dazu am besten auch die aktuelle emerge --info)
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1162
Location: Eppingen, Germany

PostPosted: Wed Sep 09, 2015 6:12 pm    Post subject: Reply with quote

guckst Du hier:

emerge -avuDN @world --backtrack=300
https://bpaste.net/show/0408bccb1186

und hier:
emerge --info
https://bpaste.net/show/ce6de8d8f2de

Danke für Eure Hilfe....

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3672
Location: Germany

PostPosted: Wed Sep 09, 2015 9:47 pm    Post subject: Reply with quote

Ah prima, das schaut doch schon ein wenig übersichtlicher aus :)

Schau mal warum bei den Qt Libs ein Downgrade von 4.8.7 auf 4.8.6 vorgenommen werden soll. Meist versucht portage hier alternativ ein Downgrade vorzunehmen, wenn zb eine nun zusätzliche benötigte Lib (oder auch eine schon installierte) nicht in der passenden Version mit freigeschaltet ist.

Gleiches bei dem
[ebuild UD~] sys-apps/systemd-219_p112:0/2::gentoo [220-r2:0/2::gentoo]
Downgrade.
Womöglich passen in deiner package.accept_keywords die freigeschalteten Versionen nicht mehr?
=systemd-220-r2 (deine aktuell installierte Version) gibt es nicht mehr im Tree - portage wird wahrscheinlich auch hier ein Downgrade vornehmen wollen sofern keine neuere Version freigeschaltet ist.
Ich denke wenn die beiden Downgrades (systemd und die Qt Libs aus Slot 4) verhindert bzw passend freigeschaltet werden sieht das ganze wahrscheinlich schon besser aus.

Um alle Qt Libs freizuschalten könntest du in der package.accept_keywords testweise etwas wie dev-qt/* nutzen.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1162
Location: Eppingen, Germany

PostPosted: Sat Sep 12, 2015 12:24 pm    Post subject: Reply with quote

Fast alles gut :-) :

Code:
Calculating dependencies... done!
[nomerge       ] lxqt-base/lxqt-meta-0.9.0-r2::gentoo  USE="filemanager icons lightdm lximage oxygen policykit -admin -minimal -powermanagement -sddm -ssh-askpass"                                                                                                           
[ebuild  N    ~]  sys-auth/consolekit-1.0.0::gentoo  USE="acl pam policykit -cgroups -debug -doc (-selinux) {-test}" 12 KiB
[nomerge       ] app-misc/freemind-1.0.1-r1::gentoo  USE="doc pdf svg -groovy -latex"
[nomerge       ]  dev-java/batik-1.8-r1:1.8::gentoo  USE="python -doc -tcl"
[nomerge       ]   dev-java/xmlgraphics-commons-2.0.1:2::gentoo  USE="-doc -examples -source {-test}"
[ebuild     U  ]    dev-java/commons-logging-1.2::gentoo [1.1.1::gentoo] USE="-avalon-framework -avalon-logkit -doc -log4j -servletapi -source {-test}" 0 KiB                                                                                                                 
[nomerge       ] dev-db/mysql-workbench-6.3.3::gentoo  USE="-debug -doc -gnome-keyring" PYTHON_TARGETS="python2_7"
[ebuild   R    ]  sci-libs/gdal-1.11.1-r3::gentoo  USE="aux_xml gif java jpeg jpeg2k mysql png python sqlite threads -armadillo -curl -debug -doc -fits -geos -gml -hdf5 -mdb -netcdf -odbc -ogdi -opencl -pdf -perl -postgres (-ruby) -spatialite -xls" PYTHON_TARGETS="python2_7 python3_4* -python3_3*" 0 KiB                                                                                                     
[ebuild   R    ] dev-util/eric-5.5.2:5::gentoo  LINGUAS="de -cs -en -es -fr -it -pt -ru -tr -zh_CN" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_4* -python3_3*" 0 KiB                                                           
[ebuild     U  ] dev-vcs/subversion-1.8.14::gentoo [1.8.13-r1::gentoo] USE="apache2 berkdb ctypes-python doc dso extras http java nls perl python -debug -gnome-keyring -kde -ruby -sasl {-test} -vim-syntax" PYTHON_TARGETS="python2_7" 0 KiB                               
[nomerge       ] dev-util/eric-5.5.2:5::gentoo  LINGUAS="de -cs -en -es -fr -it -pt -ru -tr -zh_CN" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_4* -python3_3*"                                                                 
[ebuild   R    ]  dev-python/qscintilla-python-2.8.4::gentoo  USE="-debug" PYTHON_TARGETS="python2_7 python3_4* -python3_3*" 0 KiB
[nomerge       ] sys-apps/util-linux-2.27::gentoo  USE="cramfs ncurses nls pam python suid systemd tty-helpers udev unicode -caps -fdformat (-selinux) -slang -static-libs {-test}" ABI_X86="32 (64) (-x32)" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_4 -python3_3"
[ebuild     U  ]  sys-libs/pam-1.2.1::gentoo [1.1.8-r2::gentoo] USE="berkdb cracklib nls pie%* -audit -debug -nis (-selinux) {-test} -vim-syntax" ABI_X86="32 (64) (-x32)" 0 KiB                                                                                             
[nomerge       ] app-misc/freemind-1.0.1-r1::gentoo  USE="doc pdf svg -groovy -latex"
[nomerge       ]  dev-java/fop-2.0-r1::gentoo  USE="(-doc) -examples -source {-test}"
[nomerge       ]   dev-java/batik-1.8-r1:1.8::gentoo  USE="python -doc -tcl"
[ebuild     U  ]    dev-java/xalan-2.7.2::gentoo [2.7.1::gentoo] USE="-doc -source" 0 KiB
[ebuild     U  ]     dev-java/xalan-serializer-2.7.2::gentoo [2.7.1::gentoo] USE="-doc -source" 0 KiB
[nomerge       ] dev-java/batik-1.8-r1:1.8::gentoo  USE="python -doc -tcl"
[nomerge       ]  dev-java/rhino-1.7.2-r2:1.6::gentoo  USE="-doc -examples -source"
[nomerge       ]   dev-java/xml-xmlbeans-1.0.4_pre20041217:1::gentoo  USE="-doc -source"
[nomerge       ]    dev-java/jaxen-1.1.1:1.1::gentoo  USE="-doc -examples -source {-test}"
[nomerge       ]     dev-java/dom4j-1.6.1-r4:1::gentoo  USE="-doc -source {-test}"
[ebuild     U  ]      dev-java/xpp2-2.1.10-r2::gentoo [2.1.10-r1::gentoo] USE="-doc -source {-test%}" 0 KiB
[nomerge       ] virtual/dev-manager-0::gentoo
[ebuild  N     ]  sys-fs/static-dev-0.1::gentoo  0 KiB

Total: 11 packages (6 upgrades, 2 new, 3 reinstalls), Size of downloads: 12 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

sys-apps/systemd:0

  (sys-apps/systemd-226:0/2::gentoo, ebuild scheduled for merge) conflicts with
    >=sys-apps/systemd-212-r5:0/2[abi_x86_32(-),abi_x86_64(-),gudev(-),introspection(-)] required by (virtual/libgudev-215-r3:0/0::gentoo, installed)                                                                                                                         
                                                                                       

xfce-base/libxfce4ui:0

  (xfce-base/libxfce4ui-4.12.1-r2:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=xfce-base/libxfce4ui-4.11.1:=[gtk3(+)] required by (uhai0.5.0-r1:0/0::gentoo, installed)
                                           
    >=xfce-base/libxfce4ui-4.11.1:0/0=[gtk3(+)] required by (xfce-base/garcon-0.5.0-r1:0/0::gentoo, installed)
                                               


Would you like to merge these packages? [Yes/No]


Die Java-Teile finden die VM nicht, eselect java funktioniert nicht.... Wie kann ich dem System die richtige JavaVM geben? In den Settings von lxqt ist jdk-home mit /opt/sun-jre-bin-1.6.0.45 angeben. Das sollte eigenetlich stimmen....

systemd habe ich vorher separat upgedatet. Problemlos. virtual/libgudev sollte ich doch dann auch hochziehen d.d. keyword setzen, oder??

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6293

PostPosted: Sat Sep 12, 2015 5:09 pm    Post subject: Reply with quote

uhai wrote:
virtual/libgudev sollte ich doch dann auch hochziehen d.d. keyword setzen, oder??

Nicht nur das, sondern das Gleiche auch für dev-libs/libgudev: Letzteres ist nicht mehr im aktuellen systemd enthalten. Du verfügst derzeit also über kein libgudev, und das ist der Grund, weshalb virtual/libgudev Dein systemd downgraden will: In älteren systemd Versionen war libgudev noch enthalten, und das aktuelle dev-libs/libgudev hat noch keine stabile Version.

(Eigentlich ist es ein portage-Fehler, dass portage diese Keyword nicht selbst vorschlägt; vielleicht ist der Wert für --backtrack noch nicht hoch genug.)
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1162
Location: Eppingen, Germany

PostPosted: Sat Sep 12, 2015 7:59 pm    Post subject: Reply with quote

Mit libgudev bin ich zwischenzeitlich fertig. Jetzt hab ichs noch mit:

Code:
>>> Emerging (1 of 2) dev-python/qscintilla-python-2.8.4::gentoo
 * QScintilla-gpl-2.8.4.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                             [ ok ]
>>> Unpacking source...
>>> Unpacking QScintilla-gpl-2.8.4.tar.gz to /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work
>>> Source unpacked in /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work
>>> Preparing source in /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python ...
 * Will copy sources from /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python
 * python3_4: copying to /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python-python3_4
 * python2_7: copying to /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python-python2_7
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python ...
 * python3_4: running run_in_build_dir configuration
/usr/bin/python3.4 configure.py --destdir=/usr/lib64/python3.4/site-packages/PyQt4 --sip-incdir=/usr/include/python3.4 --pyqt-sipdir=/usr/share/sip --qsci-sipdir=/usr/share/sip --pyqt=PyQt4 --no-timestamp
Error: Unable to create the C++ code.
Configuring QScintilla 2.8.4...
QScintilla 2.8.4 is being used.
The QScintilla .sip files will be installed in /usr/share/sip.
The QScintilla module will be installed in
/usr/lib64/python3.4/site-packages/PyQt4.
PyQt 4.11.4 is being used.
Qt 4.8.7 is being used.
sip 4.16.9 is being used.
The sip executable is /usr/bin/sip.
The QScintilla module is being built with 'protected' redefined as 'public'.
The QScintilla API file will be installed in /usr/share/qt4/qsci/api/python.
Generating the C++ source for the Qsci module...
 * ERROR: dev-python/qscintilla-python-2.8.4::gentoo failed (configure phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_configure
 *   environment, line 3199:  Called python_foreach_impl 'run_in_build_dir' 'configuration'
 *   environment, line 2715:  Called multibuild_foreach_variant '_python_multibuild_wrapper' 'run_in_build_dir' 'configuration'
 *   environment, line 1908:  Called _multibuild_run '_python_multibuild_wrapper' 'run_in_build_dir' 'configuration'
 *   environment, line 1906:  Called _python_multibuild_wrapper 'run_in_build_dir' 'configuration'
 *   environment, line  452:  Called run_in_build_dir 'configuration'
 *   environment, line 3181:  Called configuration
 *   environment, line 3196:  Called die
 * The specific snippet of code:
 *           "${myconf[@]}" || die;
 *
 * If you need support, post the output of `emerge --info '=dev-python/qscintilla-python-2.8.4::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-python/qscintilla-python-2.8.4::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-python/qscintilla-python-2.8.4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/qscintilla-python-2.8.4/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python-python3_4'
 * S: '/var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python'

>>> Failed to emerge dev-python/qscintilla-python-2.8.4, Log file:

>>>  '/var/tmp/portage/dev-python/qscintilla-python-2.8.4/temp/build.log'

python-updater hat zwar etwas reinstalliert, aber das Problem habe ich noch immer. Und die Sache mit der java-vm, die nicht gefunden wird.....

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3672
Location: Germany

PostPosted: Sun Sep 13, 2015 2:49 pm    Post subject: Reply with quote

Hm, teste mal bitte ob ein rebuild folgender Pakete hilft
Code:
emerge -av1 dev-python/sip x11-libs/qscintilla PyQt4 qscintilla-python
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1162
Location: Eppingen, Germany

PostPosted: Sun Sep 13, 2015 9:04 pm    Post subject: Reply with quote

Code:
[ebuild   R   ~] dev-python/sip-4.16.9:0/11::gentoo  USE="-debug -doc" PYTHON_TARGETS="python2_7 python3_3 python3_4" 0 KiB
[ebuild   R    ] x11-libs/qscintilla-2.8.4-r1:0/11::gentoo  USE="-designer -doc" 0 KiB
[ebuild   R   ~] dev-python/PyQt4-4.11.4::gentoo  USE="X dbus declarative doc examples help opengl phonon sql svg webkit -debug -designer -kde -multimedia -script -scripttools -testlib -xmlpatterns" PYTHON_TARGETS="python2_7 python3_3 python3_4" 0 KiB                         
[ebuild   R    ] dev-python/qscintilla-python-2.8.4::gentoo  USE="-debug" PYTHON_TARGETS="python2_7 python3_4* -python3_3*" 0 KiB

Total: 4 packages (4 reinstalls), Size of downloads: 0 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-python/qscintilla-python:0

  (dev-python/qscintilla-python-2.8.4:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-python/qscintilla-python (Argument)

  (dev-python/qscintilla-python-2.8.4:0/0::gentoo, installed) pulled in by
    >=dev-python/qscintilla-python-2.7.1[python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python2_7(-)?,-python_single_target_jython2_5(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),python_single_target_python3_3(+)?,python_single_target_python3_4(+)?,python_single_target_python2_7(+)?] required by (dev-util/eric-5.5.2:5/5::gentoo, installed)


Nur qscintilla-python wird mit PYTHON-TARGETS -python3_3 gebaut???

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3672
Location: Germany

PostPosted: Sun Sep 13, 2015 10:06 pm    Post subject: Reply with quote

Hm, hast da eventuell selbst (abweichend vom Profil) PYTHON_TARGETS für einzelne Pakete zb via package.use gesetzt?
Schau mal via
Code:
grep -Ri python /etc/portage/ /etc/make.conf
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1162
Location: Eppingen, Germany

PostPosted: Mon Sep 14, 2015 3:43 am    Post subject: Reply with quote

Nein, in make.conf und package.use sind keined PYTHON-TARGETS gesetzt....

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3672
Location: Germany

PostPosted: Mon Sep 14, 2015 3:58 pm    Post subject: Reply with quote

Hm, dann sind wahrscheinlich bei einigen installierten Paketen die vor einigen Monaten geänderten PYTHON_TARGETS noch nicht wirklich gebaut.
Schau mal wie weit du mit einem
Code:
emerge -avuDU @world --backtrack=300 --keep-going
kommst.

(Zu den Java Paketen kann ich nichts beitragen - damit kenne ich mich nicht aus).
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1162
Location: Eppingen, Germany

PostPosted: Mon Sep 14, 2015 7:34 pm    Post subject: Reply with quote

Bricht immer noch ab...

Code:
 emerge -avuDU @world --backtrack=300 --keep-going                                                                                                                                     ──(Mo,Sep14)─┘
!!! Error while reading repo config file: While reading from '/etc/portage/repos.conf/layman.conf' [line  7]: option 'sync-uri' in section 'layman' already exists
WARNING: One or more repositories have missing repo_name entries:

        /usr/local/portage/overlay/profiles/repo_name

NOTE: Each repo_name entry should be a plain text file containing a
unique name for the repository on the first line.



These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-python/qscintilla-python-2.8.4::gentoo  USE="-debug" PYTHON_TARGETS="python2_7 python3_4* -python3_3*" 0 KiB
[ebuild   R    ] dev-util/eric-5.5.2:5::gentoo  LINGUAS="de -cs -en -es -fr -it -pt -ru -tr -zh_CN" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_4* -python3_3*" 0 KiB

Total: 2 packages (2 reinstalls), Size of downloads: 0 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

xfce-base/libxfce4ui:0

  (xfce-base/libxfce4ui-4.12.1-r2:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=xfce-base/libxfce4ui-4.11.1:=[gtk3(+)] required by (xfce-base/garcon-0.5.0-r2:0/0::gentoo, installed)
                                           
    >=xfce-base/libxfce4ui-4.11.1:0/0=[gtk3(+)] required by (xfce-base/garcon-0.5.0-r2:0/0::gentoo, installed)
                                               


Would you like to merge these packages? [Yes/No] y

>>> Verifying ebuild manifests

>>> Emerging (1 of 2) dev-python/qscintilla-python-2.8.4::gentoo
 * QScintilla-gpl-2.8.4.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                         [ ok ]
>>> Unpacking source...
>>> Unpacking QScintilla-gpl-2.8.4.tar.gz to /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work
>>> Source unpacked in /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work
>>> Preparing source in /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python ...
 * Will copy sources from /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python
>>> Source prepared.
 * python3_4: copying to /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python-python3_4
 * python2_7: copying to /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python-python2_7
>>> Configuring source in /var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python ...
 * python3_4: running run_in_build_dir configuration
/usr/bin/python3.4 configure.py --destdir=/usr/lib64/python3.4/site-packages/PyQt4 --sip-incdir=/usr/include/python3.4 --pyqt-sipdir=/usr/share/sip --qsci-sipdir=/usr/share/sip --pyqt=PyQt4 --no-timestamp
Error: Unable to create the C++ code.
Configuring QScintilla 2.8.4...
QScintilla 2.8.4 is being used.
The QScintilla .sip files will be installed in /usr/share/sip.
The QScintilla module will be installed in
/usr/lib64/python3.4/site-packages/PyQt4.
PyQt 4.11.4 is being used.
Qt 4.8.7 is being used.
sip 4.16.9 is being used.
The sip executable is /usr/bin/sip.
The QScintilla module is being built with 'protected' redefined as 'public'.
The QScintilla API file will be installed in /usr/share/qt4/qsci/api/python.
Generating the C++ source for the Qsci module...
 * ERROR: dev-python/qscintilla-python-2.8.4::gentoo failed (configure phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_configure
 *   environment, line 3199:  Called python_foreach_impl 'run_in_build_dir' 'configuration'
 *   environment, line 2715:  Called multibuild_foreach_variant '_python_multibuild_wrapper' 'run_in_build_dir' 'configuration'
 *   environment, line 1908:  Called _multibuild_run '_python_multibuild_wrapper' 'run_in_build_dir' 'configuration'
 *   environment, line 1906:  Called _python_multibuild_wrapper 'run_in_build_dir' 'configuration'
 *   environment, line  452:  Called run_in_build_dir 'configuration'
 *   environment, line 3181:  Called configuration
 *   environment, line 3196:  Called die
 * The specific snippet of code:
 *           "${myconf[@]}" || die;
 *
 * If you need support, post the output of `emerge --info '=dev-python/qscintilla-python-2.8.4::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-python/qscintilla-python-2.8.4::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-python/qscintilla-python-2.8.4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/qscintilla-python-2.8.4/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python-python3_4'
 * S: '/var/tmp/portage/dev-python/qscintilla-python-2.8.4/work/QScintilla-gpl-2.8.4/Python'

>>> Failed to emerge dev-python/qscintilla-python-2.8.4, Log file:

>>>  '/var/tmp/portage/dev-python/qscintilla-python-2.8.4/temp/build.log'
*** Resuming merge...

These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 KiB
 * emerge --keep-going: dev-util/eric-5.5.2 dropped because it requires >=dev-
 * python/qscintilla-python-2.7.1[python_targets_python3_4(-),python_targets_p
 * ython2_7(-),-python_single_target_jython2_5(-),-python_single_target_jython
 * 2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),python_
 * single_target_python2_7(+)], >=dev-python/qscintilla-python-2.7.1[python_ta
 * rgets_python3_4(-),python_targets_python2_7(-),-python_single_target_jython
 * 2_5(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-py
 * thon_single_target_pypy3(-),python_single_target_python2_7(+)]
 *
 * The following 2 packages have failed to build, install, or execute
 * postinst:
 *
 *  (dev-python/qscintilla-python-2.8.4:0/0::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-python/qscintilla-python-2.8.4/temp/build.log'
 *  (dev-util/eric-5.5.2:5/5::gentoo, ebuild scheduled for merge)

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3672
Location: Germany

PostPosted: Mon Sep 14, 2015 9:45 pm    Post subject: Reply with quote

Ah ja, ich kann den Abbruch mit =qscintilla-python-2.8.4 bestätigen (was vermutlich an Qt-(~)4.8.7, sip und PyQt aus testing liegt). Stable und testing mischen ist hier wohl nicht angebracht.
Versuche es mit ~x11-libs/qscintilla-2.9 und ~dev-python/qscintilla-python-2.9
die sollten problemlos bauen.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1162
Location: Eppingen, Germany

PostPosted: Tue Sep 15, 2015 5:51 am    Post subject: Reply with quote

ok, das hat auch geklappt.

Jetzt ist nur noch dieser Punkt seltsam:

Code:
 emerge -auDNtv --backtrack=300 world                                       ──(Di,Sep15)─┘
!!! Error while reading repo config file: While reading from '/etc/portage/repos.conf/layman.conf' [line  7]: option 'sync-uri' in section 'layman' already exists
WARNING: One or more repositories have missing repo_name entries:

        /usr/local/portage/overlay/profiles/repo_name

NOTE: Each repo_name entry should be a plain text file containing a
unique name for the repository on the first line.



These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

xfce-base/libxfce4ui:0

  (xfce-base/libxfce4ui-4.12.1-r2:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=xfce-base/libxfce4ui-4.11.1:=[gtk3(+)] required by (xfce-base/garcon-0.5.0-r2:0/0::gentoo, installed)
                                           
    >=xfce-base/libxfce4ui-4.11.1:0/0=[gtk3(+)] required by (xfce-base/garcon-0.5.0-r2:0/0::gentoo, installed)
                                               


Nothing to merge; quitting.


euse -i gtk3:
Code:
[- c    ] gtk3
    xfce-base/libxfce4ui: Enable gtk3 support
              4.10.0 [gentoo]
        [+ B] 4.12.1-r2 [gentoo]



Da müsste ich jetzt gtk3 setzen, oder? Brauche ich das Paket eigentlich für lxqt? Oder ist das ein Kellerleiche...?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3672
Location: Germany

PostPosted: Tue Sep 15, 2015 9:27 am    Post subject: Reply with quote

uhai wrote:
Da müsste ich jetzt gtk3 setzen, oder?

Ja, oder das gtk3 Flag für dieses Paket nicht deaktivieren, denn normal ist es im ebuild schon per default aktiv gesetzt.

Code:
grep IUSE `equery w libxfce4ui-4.12.1-r2`
IUSE="debug +gtk3 startup-notification"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum