Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Intel Corporation Centrino Ultimate-N 6300[SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 933

PostPosted: Sat Sep 19, 2015 2:42 pm    Post subject: Intel Corporation Centrino Ultimate-N 6300[SOLVED] Reply with quote

Hi All:

I have the above mentioned chipset in my laptop and never paid much attention to it, it just worked and seemed to work fine. lately I started noticing that the speed, as reported by conky, is always 1Mbps even if the link is at 100%.

So I checked it with iwlist and conky is reporting correctly.

I've done some speed tests to my local ISP's ftp server and am getting about 2MBper second over the wireless and then over our GPON. Problem is, when I do this conky reports the wifi at 1Mbps.

I went to the router to check and it says I'm connected at 36Mbps.

So why is iwlist reporting only 1Mbps?

Not even sure how to try and troubleshoot this. I have the latest intel sys-firmware/iwl6000-ucode-9.221.4.1 installed and everything seems to work.
Its just strange.

Our fiber connection is supposed to be 30Mbps.

Looking for ideas on how to get the reporting from iwlist sorted out.

Cheers,
John


Last edited by jserink on Sat Oct 10, 2015 1:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
Keruskerfuerst
Advocate
Advocate


Joined: 01 Feb 2006
Posts: 2288
Location: near Augsburg, Germany

PostPosted: Tue Sep 29, 2015 5:42 am    Post subject: Reply with quote

LAN or WLAN connection?
Back to top
View user's profile Send private message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 933

PostPosted: Wed Sep 30, 2015 2:09 am    Post subject: Reply with quote

WLAN.
Back to top
View user's profile Send private message
snkmoorthy
Guru
Guru


Joined: 19 Nov 2002
Posts: 376

PostPosted: Wed Sep 30, 2015 10:21 am    Post subject: Reply with quote

just out of curiosity - what does Bit Rate field from
Quote:
iwconfig
say?
Also make sure the ucode is getting loaded by the module, by grepping in
Quote:
dmesg

Also check power management state on the card.
Back to top
View user's profile Send private message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 933

PostPosted: Sun Oct 04, 2015 10:45 am    Post subject: Reply with quote

Ok was going to try snkmoorthy's suggestion and look at iwconfig to check things out tonight and glanced over at conky and it says 6.5Mbps?
WTF?

I check iwlist and iwconfig and both show 6.5Mbps.

Right, connect to ftp.singnet.com.sg to their speedtest directory and download a 100M test file and it comes in at:
100000000 bytes received in 15.6 secs (6.3e+03 Kbytes/sec)
The card did NOT bump up to a faster speed, its fixed at 6.5Mbps. Somehting is fishy here, it used to go up and down based on the load.

jserinki7 jserink # iwconfig
enp0s25 no wireless extensions.

lo no wireless extensions.

wlp3s0 IEEE 802.11abgn ESSID:"JohnandGrace2"
Mode:Managed Frequency:2.452 GHz Access Point: 16:0C:C3:E8:0A:38
Bit Rate=6.5 Mb/s Tx-Power=15 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=56/70 Signal level=-54 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:19 Missed beacon:0

There it is, weird. Will change APs.
jserinki7 jserink # iwconfig
enp0s25 no wireless extensions.

lo no wireless extensions.

wlp3s0 IEEE 802.11abgn ESSID:"JohnandGrace"
Mode:Managed Frequency:2.437 GHz Access Point: 00:80:48:50:C7:41
Bit Rate=6.5 Mb/s Tx-Power=15 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=56/70 Signal level=-54 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:1440 Missed beacon:0

ftp was slightly slower through this AP as it goes through an older homeplug system to connect tot he router. The first AP is the actual GPON router.

And now, we get to the end of snkmoorthy's email about ucode and...
jserinki7 jserink # dmesg | grep "ucode"
[ 12.213031] iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-6000-6.ucode failed with error -2
[ 12.213056] iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-6000-5.ucode failed with error -2

Ahh.....now it clear.

Ok, got to work on this now.

Cheers,
John
Back to top
View user's profile Send private message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 933

PostPosted: Sun Oct 04, 2015 11:12 am    Post subject: Reply with quote

Ok, plot thickens...there is not problem, from my syslog:
Oct 04 18:02:27 [kernel] [ 12.213031] iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-6000-6.ucode failed with error -2
Oct 04 18:02:27 [kernel] [ 12.213056] iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-6000-5.ucode failed with error -2
Oct 04 18:02:27 [kernel] [ 12.216438] dcdbas dcdbas: Dell Systems Management Base Driver (version 5.6.0-3.2)
Oct 04 18:02:27 [kernel] [ 12.262254] iwlwifi 0000:03:00.0: loaded firmware version 9.221.4.1 build 25532 op_mode iwldvm
.
.
.
Oct 04 18:02:27 [kernel] [ 13.011307] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUG disabled
Oct 04 18:02:27 [kernel] [ 13.011318] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUGFS disabled
Oct 04 18:02:27 [kernel] [ 13.011327] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TRACING disabled
Oct 04 18:02:27 [kernel] [ 13.011337] iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Ultimate-N 6300 AGN, REV=0x74
Oct 04 18:02:27 [kernel] [ 13.011460] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
.
.
.
Oct 04 18:02:27 [kernel] [ 13.087585] intel_rapl: Found RAPL domain package
Oct 04 18:02:27 [kernel] [ 13.087596] intel_rapl: Found RAPL domain core
Oct 04 18:02:27 [kernel] [ 13.087602] intel_rapl: Found RAPL domain uncore
.
.
Oct 04 18:02:27 [kernel] [ 13.243042] iwlwifi 0000:03:00.0 wlp3s0: renamed from wlan0
.
.
Oct 04 18:02:27 [kernel] [ 13.914799] cfg80211: World regulatory domain updated:
Oct 04 18:02:27 [kernel] [ 13.914800] cfg80211: DFS Master region: unset
Oct 04 18:02:27 [kernel] [ 13.914801] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
Oct 04 18:02:27 [kernel] [ 13.914803] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
Oct 04 18:02:27 [kernel] [ 13.914804] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
Oct 04 18:02:27 [kernel] [ 13.914805] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
Oct 04 18:02:27 [kernel] [ 13.914807] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
Oct 04 18:02:27 [kernel] [ 13.914810] cfg80211: (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
Oct 04 18:02:27 [kernel] [ 13.914811] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
Oct 04 18:02:27 [kernel] [ 13.914813] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
.
.



Oct 04 18:11:32 [kernel] [ 569.484683] NET: Registered protocol family 4
Oct 04 18:11:32 [kernel] [ 569.493616] NET: Registered protocol family 5
Oct 04 18:11:32 [kernel] [ 569.568696] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
Oct 04 18:11:32 [kernel] [ 569.575217] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
Oct 04 18:11:32 [kernel] [ 569.793944] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
Oct 04 18:11:32 [kernel] [ 569.800422] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
Oct 04 18:11:32 [kernel] [ 569.893838] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
Oct 04 18:11:41 [dhcpcd] dhcpcd not running
Oct 04 18:11:41 [kernel] [ 578.862297] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
Oct 04 18:11:41 [kernel] [ 578.868863] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
Oct 04 18:11:42 [kernel] [ 579.087770] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
Oct 04 18:11:42 [kernel] [ 579.094250] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
Oct 04 18:11:42 [kernel] [ 579.191016] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
Oct 04 18:11:42 [dhcpcd] dhcpcd not running
Oct 04 18:11:42 [kernel] [ 579.246444] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
Oct 04 18:11:42 [kernel] [ 579.252952] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
Oct 04 18:11:42 [kernel] [ 579.471098] iwlwifi 0000:03:00.0: L1 Enabled - LTR Disabled
Oct 04 18:11:42 [kernel] [ 579.477574] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
Oct 04 18:11:42 [kernel] [ 579.573138] IPv6: ADDRCONF(NETDEV_UP): wlp3s0: link is not ready
Oct 04 18:11:44 [kernel] [ 581.871709] NET: Registered protocol family 17
Oct 04 18:11:48 [kernel] [ 585.022084] wlp3s0: authenticate with 16:0c:c3:e8:0a:38
Oct 04 18:11:48 [kernel] [ 585.070090] wlp3s0: send auth to 16:0c:c3:e8:0a:38 (try 1/3)
Oct 04 18:11:48 [kernel] [ 585.071800] wlp3s0: authenticated
Oct 04 18:11:48 [kernel] [ 585.071851] wlp3s0: associating with AP with corrupt beacon and probe response
Oct 04 18:11:48 [kernel] [ 585.072769] wlp3s0: associate with 16:0c:c3:e8:0a:38 (try 1/3)
Oct 04 18:11:48 [kernel] [ 585.076703] wlp3s0: RX AssocResp from 16:0c:c3:e8:0a:38 (capab=0x431 status=0 aid=17)
Oct 04 18:11:48 [kernel] [ 585.080879] wlp3s0: associated
Oct 04 18:11:48 [kernel] [ 585.080939] IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link becomes ready
Oct 04 18:11:48 [kernel] [ 585.081060] cfg80211: Calling CRDA for country: SG
Oct 04 18:11:48 [kernel] [ 585.087616] cfg80211: Regulatory domain changed to country: SG
Oct 04 18:11:48 [kernel] [ 585.087620] cfg80211: DFS Master region: unset
Oct 04 18:11:48 [kernel] [ 585.087624] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
Oct 04 18:11:48 [kernel] [ 585.087630] cfg80211: (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
Oct 04 18:11:48 [kernel] [ 585.087636] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 1700 mBm), (N/A)
Oct 04 18:11:48 [kernel] [ 585.087642] cfg80211: (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2400 mBm), (0 s)
Oct 04 18:11:48 [kernel] [ 585.087647] cfg80211: (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2400 mBm), (0 s)
Oct 04 18:11:48 [kernel] [ 585.087652] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 3000 mBm), (N/A)
Oct 04 18:11:49 [dhcpcd] DUID 00:01:00:01:1a:78:eb:9e:24:77:03:04:61:50
Oct 04 18:11:49 [dhcpcd] wlp3s0: IAID 03:04:61:50
Oct 04 18:11:50 [dhcpcd] wlp3s0: soliciting a DHCP lease
Oct 04 18:11:50 [dhcpcd] wlp3s0: soliciting an IPv6 router
Oct 04 18:11:53 [dhcpcd] wlp3s0: offered 192.168.0.142 from 192.168.0.254
Oct 04 18:11:53 [dhcpcd] wlp3s0: leased 192.168.0.142 for 14400 seconds
Oct 04 18:11:53 [dhcpcd] wlp3s0: adding route to 192.168.0.0/24
Oct 04 18:11:53 [dhcpcd] wlp3s0: adding default route via 192.168.0.254
Oct 04 18:11:53 [dhcpcd] forked to background, child pid 13698
Oct 04 18:12:02 [dhcpcd] wlp3s0: no IPv6 Routers available


So, it appears the correct FW is loading.

And the power management is off from here:
jserinki7 jserink # iwconfig
enp0s25 no wireless extensions.

lo no wireless extensions.

wlp3s0 IEEE 802.11abgn ESSID:"JohnandGrace"
Mode:Managed Frequency:2.437 GHz Access Point: 00:80:48:50:C7:41
Bit Rate=6.5 Mb/s Tx-Power=15 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=56/70 Signal level=-54 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:64743 Missed beacon:0

But the card is LOCKED at 6.5Mbps...or so it says. Previous days it was locked at 1Mbps.

This is 'very' weird.

Cheers,
john
Back to top
View user's profile Send private message
snkmoorthy
Guru
Guru


Joined: 19 Nov 2002
Posts: 376

PostPosted: Mon Oct 05, 2015 5:49 am    Post subject: Reply with quote

Can you try a live distro on USB, install linux firmware or keep the ucode file handy load the iwlwifi driver and connect to your AP and check the speeds. This is to rule out any current kernel config issues.

Before that, do you have another WiFi card and try to do more than 6.5Mbps - to confirm card/driver issue and rule out AP issues.(Check AP for b/g/n settings) and Android smart phones have simple WiFi scanner showing frequency bands https://play.google.com/store/apps/details?id=com.farproc.wifi.analyzer&hl=en check if you are getting squeezed by other WiFi signals.

iwlwifi module has 11n_disable option, try loading with that and see if you can go to atleast 54Mbps
Back to top
View user's profile Send private message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 933

PostPosted: Fri Oct 09, 2015 1:14 pm    Post subject: Reply with quote

The plot thickens everyone, check this out:
jserinki7 jserink # iwconfig wlp3s0 rate 54M
jserinki7 jserink # iwconfig wlp3s0
wlp3s0 IEEE 802.11abgn ESSID:"JohnandGrace2"
Mode:Managed Frequency:2.452 GHz Access Point: 16:0C:C3:E8:0A:38
Bit Rate=1 Mb/s Tx-Power=15 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=69/70 Signal level=-41 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:45 Missed beacon:0

jserinki7 jserink # iw dev wlp3s0 link
Connected to 16:0c:c3:e8:0a:38 (on wlp3s0)
SSID: JohnandGrace2
freq: 2452
RX: 125276140 bytes (101615 packets)
TX: 1696379 bytes (14662 packets)
signal: -51 dBm
tx bitrate: 54.0 MBit/s

bss flags: short-preamble short-slot-time
dtim period: 1
beacon int: 100
jserinki7 jserink #


That's right, you're seeing that correctly. iwconfig sets the WLAN to 54M and does not report an error and then reports a bit rate of 1Mbps. but iw reports a bit rate of 54M?

jserinki7 jserink # iwlist wlp3s0 rate
wlp3s0 unknown bit-rate information.
Current Bit Rate:1 Mb/s

iwlist also reports 1Mbps but iw:
jserinki7 jserink # iw dev wlp3s0 link
Connected to 16:0c:c3:e8:0a:38 (on wlp3s0)
SSID: JohnandGrace2
freq: 2452
RX: 125764981 bytes (104605 packets)
TX: 1755633 bytes (14898 packets)
signal: -51 dBm
tx bitrate: 54.0 MBit/s

bss flags: short-preamble short-slot-time
dtim period: 1
beacon int: 100

Is reporting 54Mbps....

So, what's with iwconfig and iwlist?

Conky appears to use one of those two to get the wireless information because it reports 1Mbps.

Cheers,
john
Back to top
View user's profile Send private message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 933

PostPosted: Sat Oct 10, 2015 1:37 pm    Post subject: Fixed Reply with quote

Ok, first things first....
Added the following line to /etc/sudoers
jserink ALL=(ALL) NOPASSWD: /usr/sbin/iw

replaced this line in my .conkyrc file:
#${color yellow}Bitrate: $color${wireless_bitrate wlp3s0}

with this line:
${color yellow}Bitrate: $color${texeci 15 sudo iw dev wlp3s0 link | grep 'tx bitrate: ' | cut -c14-24}

Problem solved.

Cheers,
john
Back to top
View user's profile Send private message
snkmoorthy
Guru
Guru


Joined: 19 Nov 2002
Posts: 376

PostPosted: Fri Oct 23, 2015 2:38 am    Post subject: Reply with quote

I have a 6200 Intel card, once I upgraded the kernel to 4.0.5 the reported speed is 1Mbps(never changes). With my older kernel 3.18 speeds are reported normally(1Mbps - 144Mbps)
'iwconfig' and 'i3status' report the wrong 1Mbps speed, iw bitrate seems correct.

So a question to the original poster, are you on kernel version 4?
Back to top
View user's profile Send private message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 933

PostPosted: Fri Oct 23, 2015 3:04 am    Post subject: Reply with quote

snkmoorthy wrote:
I have a 6200 Intel card, once I upgraded the kernel to 4.0.5 the reported speed is 1Mbps(never changes). With my older kernel 3.18 speeds are reported normally(1Mbps - 144Mbps)
'iwconfig' and 'i3status' report the wrong 1Mbps speed, iw bitrate seems correct.

So a question to the original poster, are you on kernel version 4?


jserinki7 jserink # uname -a
Linux jserinki7 4.0.5-gentoo #3 SMP PREEMPT Sun Oct 4 19:31:33 SGT 2015 x86_64 Intel(R) Core(TM) i7-2720QM CPU @ 2.20GHz GenuineIntel GNU/Linux
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum