Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kernel compile generating duplicate modules? [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
huelter
n00b
n00b


Joined: 16 Sep 2015
Posts: 14

PostPosted: Mon Sep 21, 2015 1:50 am    Post subject: Kernel compile generating duplicate modules? [solved] Reply with quote

I've been trying to add support for my sound card as a module on the kernel:

Code:
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)
   Subsystem: Acer Incorporated [ALI] NM10/ICH7 Family High Definition Audio Controller


Code:
#
# HD-Audio
#
CONFIG_SND_HDA=m
CONFIG_SND_HDA_INTEL=m
CONFIG_SND_HDA_DSP_LOADER=y
CONFIG_SND_HDA_PREALLOC_SIZE=64
CONFIG_SND_HDA_HWDEP=y
CONFIG_SND_HDA_RECONFIG=y
CONFIG_SND_HDA_INPUT_BEEP=y
CONFIG_SND_HDA_INPUT_BEEP_MODE=1
# CONFIG_SND_HDA_INPUT_JACK is not set
CONFIG_SND_HDA_PATCH_LOADER=y
CONFIG_SND_HDA_CODEC_REALTEK=m
CONFIG_SND_HDA_CODEC_ANALOG=m
CONFIG_SND_HDA_CODEC_SIGMATEL=m
CONFIG_SND_HDA_CODEC_VIA=m
CONFIG_SND_HDA_CODEC_HDMI=m
CONFIG_SND_HDA_I915=y
CONFIG_SND_HDA_CODEC_CIRRUS=m
CONFIG_SND_HDA_CODEC_CONEXANT=m
CONFIG_SND_HDA_CODEC_CA0110=m
CONFIG_SND_HDA_CODEC_CA0132=m
CONFIG_SND_HDA_CODEC_CA0132_DSP=y
CONFIG_SND_HDA_CODEC_CMEDIA=m
CONFIG_SND_HDA_CODEC_SI3054=m
CONFIG_SND_HDA_GENERIC=m
CONFIG_SND_HDA_POWER_SAVE_DEFAULT=0
# CONFIG_SND_USB is not set
# CONFIG_SND_SOC is not set
# CONFIG_SOUND_PRIME is not set



But everytime I reboot, dmesg outputs:
Code:
[    6.878454] snd_hwdep: exports duplicate symbol snd_hwdep_new (owned by kernel)
[    6.892219] snd_hwdep: exports duplicate symbol snd_hwdep_new (owned by kernel)


modprobe -a snd_hda_intel doesn't load the module and adds another duplicate symbol message on dmesg.

I'm building kernel 4.0.5 x86, always cleaning first with:
Code:
make clean && make -j3 && make modules_install && make install && reboot


Last edited by huelter on Tue Sep 22, 2015 5:53 am; edited 1 time in total
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Mon Sep 21, 2015 2:01 am    Post subject: Reply with quote

You are not running the kernel you think you are. See uname -a, is the date and time what you expect?
Back to top
View user's profile Send private message
huelter
n00b
n00b


Joined: 16 Sep 2015
Posts: 14

PostPosted: Mon Sep 21, 2015 2:03 am    Post subject: Reply with quote

Yes, running the expected kernel.

Code:
Linux note-acer 4.0.5-gentoo #1 SMP Fri Sep 18 19:49:38 i686 Genuine Intel(R) CPU T2080 @ 1.73GHz GenuineIntel GNU/Linux


Also, /usr/src has only the 4.0.5 kernel and its symlink as usual.
Back to top
View user's profile Send private message
huelter
n00b
n00b


Joined: 16 Sep 2015
Posts: 14

PostPosted: Tue Sep 22, 2015 5:52 am    Post subject: Reply with quote

Downloading latest kernel (4.2.0-rc1) and recompiling solved the issue.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum