Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] grub2-mkconfig fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
elsni
n00b
n00b


Joined: 21 Sep 2004
Posts: 56
Location: Lübeck/Germany

PostPosted: Fri Sep 25, 2015 10:28 am    Post subject: [solved] grub2-mkconfig fails Reply with quote

Hi,

on a fresh gentoo installation according to the gentoo handbook grub2-mkconfig fails.

What I did:

grub2-mkconfig -o /boot/grub/grub.cfg

What I got:

/usr/sbin/grub2-mkconfig: line 232: /boot/grub/grub.cfg.new: No such file or directory

Since I dont know grub2 at all, I need some help, found nothing about this error.
Thanks!


Last edited by elsni on Sun Sep 27, 2015 9:14 pm; edited 1 time in total
Back to top
View user's profile Send private message
kikko
Apprentice
Apprentice


Joined: 29 Apr 2014
Posts: 260
Location: Milan, IT

PostPosted: Fri Sep 25, 2015 12:26 pm    Post subject: Re: [noob] grub2-mkconfig fails Reply with quote

Hi elsni
elsni wrote:
Code:
/usr/sbin/grub2-mkconfig: line 232: /boot/grub/grub.cfg.new: No such file or directory

there seems to be something missing... /boot is a separate partition (it must be mounted before run /usr/sbin/grub2-mkconfig)
Could you check that directory?
Regards
Back to top
View user's profile Send private message
elsni
n00b
n00b


Joined: 21 Sep 2004
Posts: 56
Location: Lübeck/Germany

PostPosted: Sun Sep 27, 2015 10:44 am    Post subject: Re: [noob] grub2-mkconfig fails Reply with quote

kikko wrote:
/boot is a separate partition (it must be mounted before run /usr/sbin/grub2-mkconfig)
Could you check that directory?

Yes, boot is mounted to /dev/sda2, contains genkernel, initramfs and system.map but no grub subdirectory.
Maybe something went wrong with emerge grub?
What can I do, I guess creating /boot/grub is not enough, since there is no grub.cfg.new in it.
Back to top
View user's profile Send private message
kikko
Apprentice
Apprentice


Joined: 29 Apr 2014
Posts: 260
Location: Milan, IT

PostPosted: Sun Sep 27, 2015 12:38 pm    Post subject: Reply with quote

Hi elsni
simply emerging grub doesn't install anything in /boot... in order to copy files in your boot partition, you should run the following (as root)
Code:
mount /boot #this just to make sure that /boot is mounted, if you have 'noauto' in /etc/fstab
grub2-install /dev/sda
the complete procedure for BIOS/MBR/GPT/Whatever is in the wiki
Regards
Back to top
View user's profile Send private message
elsni
n00b
n00b


Joined: 21 Sep 2004
Posts: 56
Location: Lübeck/Germany

PostPosted: Sun Sep 27, 2015 1:03 pm    Post subject: Reply with quote

shame on me I overlooked the line

grub2-install /dev/sda

in the manual 8O

Thank you so much!
Back to top
View user's profile Send private message
kikko
Apprentice
Apprentice


Joined: 29 Apr 2014
Posts: 260
Location: Milan, IT

PostPosted: Sun Sep 27, 2015 1:11 pm    Post subject: Reply with quote

Nice to hear that elsni :)
So you can substitute the [noob] tag in the title with a [solved] one ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum